Subject: RE: [SPIRITS] Some Thoughts On Protocol Requirements

From: "Roy, Radhika R, ALCOO" <[email-masked]>
Date: Thu, 29 Mar 2001 09:26:57 -0500

Folks:

It might be interesting to see the enclosed draft.

Radhika R. Roy

Technology Consultant
AT&T
Room 3D-2C09
200 S. Laurel Avenue
Middletown, NJ 07748
+1 732 420 1580
[email-masked]

-----Original Message-----
From: Bruce Chapman [mailto:[email-masked]]
Sent: Thursday, March 29, 2001 12:47 AM
To: [email-masked]
Subject: Re: [SPIRITS] Some Thoughts On Protocol Requirements

Alec summarized ...

> 2. SIP seems to be a "natural" transport vehicle for SPIRITS
> parameters ("We based PINT on SIP - it works for
> us, so you may need to give some details on why it doesn't work for
> SPIRITS. . . we didn't have to re-invent a
> worldwide infrastructure" - LC).
> 

As pointed out in my earlier emails, the B interface has some unusual
characteristics. 

I dont think we can just assume therefore that because SIP worked for PINT,
it will work for SPIRITS where (for ICW service at least) the thousands of
SERVERs are vagrants. (my term, it has no fixed abode, it may be old
fashioned, it is possibly antisocial, it is certainly unmanaged, it probably
won't have trusted relationship with anything (crytographically speaking)
(unless we build one), its platforms may have worn thin, you don't know its
whereabouts, and it may just disappear without warning)

This doesn't mean that SIP wont work, it just means that we need to explore
all the implications of having many vagrant SERVERs, and factor this into
our choice of transport protocol.

Someone convince me please.

regards

Bruce

-------------------------------------------------------
Bruce Chapman, Software Systems Architect,
NEC New Zealand
LEVEL 6
CORNER TARANAKI AND MANNERS STREETS
WELLINGTON
PHONE: 64  4  381-6279
FAX:   64  4  381-1110
EMAIL: [email-masked]
--------------------------------------------------------

_______________________________________________
SPIRITS mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/spirits

---

From: Alec Brusilovsky <[email-masked]>
Date: Thu, 29 Mar 2001 14:25:24 -0600

Group,

We have a good discussion here.
One comment, though. To preserve bandwidth for those of us who are on a slow
dial-up, please next time post a pointer to the document, instead of a document
itself.

Thanks,
Alec

"Roy, Radhika R, ALCOO" wrote:

>   ------------------------------------------------------------
>                                    Name: draft-deason-sip-soap-00.txt
>    draft-deason-sip-soap-00.txt    Type: Plain Text (text/plain)
>                                Encoding: quoted-printable