Subject: [SPIRITS] Looking for IN->SIP interface /interworking

From: arun kumar <[email-masked]>
Date: Thu, 13 Dec 2001 08:32:33 -0800 (PST)

Hi

I am working on putting an interface between the
Softswitch(IN CS-2 based call control)and the SIP
based application server. I have seen lots of
RFC/Drafts talking about SIP/IN interworking. But all
of them talk about accessing the IN services from SIP
based networks.
Can I find any RFC/draft/document or any other info
which talks about accessing the SIP based services
from IN based call model(BCM) which is already
implemented in my case. Any document/RFC which talks
about mapping the IN PICs with SIP. Is there any
implementation available?

thanks
AKS

__________________________________________________
Do You Yahoo!?
Check out Yahoo! Shopping and Yahoo! Auctions for all of
your unique holiday gifts! Buy at http://shopping.yahoo.com
or bid at http://auctions.yahoo.com
_______________________________________________
SPIRITS mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/spirits

---

From: Bobby Sardana <[email-masked]>
Date: Thu, 13 Dec 2001 19:21:55 -0800

You will have to map the BCM events to the SIP INVITEs to access the SIP
application server. Since SIP services can be generic - no specific
state/call model, I doubt if there exists a one-to-one mapping between
the BCM events and the a generic SIP service.

There is a call-flow draft that can provide you tons of examples.

regards,

Bobby Sardana.
[email-masked]

---

From: Hui-Lan Lu <[email-masked]>
Date: Tue, 18 Dec 2001 15:45:04 -0500

> implementation available?

Vijay Gurbani was the first to address IN call model and SIP mapping.
His initial draft has been discussed in the SIN (SIP/IN interworking)
design team and accepted as the basis of the team's framework document.
Presently, Vijay and his co-authors are revising the document. They
expect to have the revised version available to the team for review
soon. I should say that SIP-INAP interworking is also within the
"charter" of the SIN design team even though it is so far barely
started. If you are interested in the SIN work and joining the design
team, please contact me.

Hui-Lan Lu