Subject: [SPIRITS] Re: [Sip] Requirements on Reason information. New I-D

From: Vijay Gurbani <[email-masked]>
Date: Wed, 20 Mar 2002 07:41:30 -0800 (PST)

Sean Olson wrote:
>This is a very slippery slope. Although it is
>just as problematic, I would prefer the use of
>the Server: header for this task. The less the
>PSTN pollutes the SIP protocol, the better.

Sean:

In principal, I agree with you a 100%.  However,
reality is that for better or for worse, in the near
tearm, SIP will have accomodate other networks.  

Usage of the Reason header in conjunction with
interworking with foreign networks is sufficiently
"off the beaten" path so that folks implementing
baseline SIP do not have to worry about it if they do
not want to.

In any case, I do not want to start a war on the
merits or demerits of SIP interworking with other
protocols; just want to point out that the Reason
header could be used successfully in those cases.

Regards,

- vijay

=====
- vijay
--
Vijay K. Gurbani
[email-masked]

__________________________________________________
Do You Yahoo!?
Yahoo! Sports - live college hoops coverage
http://sports.yahoo.com/
_______________________________________________
SPIRITS mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/spirits

---

From: Sean Olson <[email-masked]>
Date: Wed, 20 Mar 2002 07:50:13 -0800 (PST)

I understand the problem you want to solve. I have
no issue with interworking with other networks. 
My main issue is attempting to *identify* the network
you are interworking with via the Reason: header.
This is the slippery slope I want to avoid. It 
quickly becomes very nasty in more complex topologies
where you may dip into the PSTN-space more than once.

/sean

--- Vijay Gurbani <[email-masked]> wrote:
> Sip mailing list 
> https://www1.ietf.org/mailman/listinfo/sip
> This list is for NEW development of the core SIP
> Protocol
> Use [email-masked] for questions
> on current sip
> Use [email-masked] for new developments on the
> application of sip

=====
Sean Olson <[email-masked]>