Subject: Re: [SPIRITS] Daniel Moreno's I-D on Mobility Management

From: [email-masked]
Date: Mon, 20 May 2002 19:14:17 +0200

Vijay, all,

When we wrote part of the SPIRITS requirements I-Ds. we considered that we should try to add to
SPIRITS only SS7-IP type of services which could not be easily provided at the moment. Therefore, we
considered SMS and GPRS out of scope.

The reason why the SMS (and other not circuit switched "calls") were specifically not included in
SPIRITS requirements is that IP services for them can be already provided.  An SMS sent to a
specific number can be screened by the SMSC node and handled using SMTP (a well known protocol) to
an IP server (and vice versa an IP server can send an SMS). This is heavily used by mobile operators
for many services (like SMS voting, SMS alerts, etc.).

GPRS sessions go, via a GGSN to the Internet. So IP services can be provided there (and also the IMS
domain in UMTS release 5 is devoted to IP services over the Packet Subsystem of UMTS) and using
SPIRITS for this is a loser option.

Thus a server in the IP domain can use SPIRITS to receive call events (and interact which voice
applications), SMTP to send/receive SMS, and other protocols to interact with GPRS sessions.

If there is a specific service case for SMS/GPRS which requires CAMEL triggering to a SPIRITS (and
can not be done via other existing and feasible technologies), I agree that the initial scope of
SPIRITS can be revisited.

Best regards,

Jorge

"Vijay K. Gurbani" <[email-masked]>@lists.bell-labs.com con fecha 20/05/2002 16:19:32

Enviado por:   [email-masked]

Asunto:   Re: [SPIRITS] Daniel Moreno's I-D on Mobility Management

[email-masked] wrote:

> Vijay:
> The problem I see is that you haven't defined the way to communicate
> that event (sending an SMS) to
> the SPIRITS client, because that's a "type of call" not considered in
> the SPIRITS protocol
> requirements.

Ah, I see what you mean.  It's not a question of technical merit, rather
semantics; namely, is SMS a "call" per se.

> I mentioned about CAMEL because it allows notifying such events, but
> SPIRITS is not
> going to use them, unless we change the protocol definition.

In the SPIRITS requirements I-D, section 3 (towards the end of the
section) discusses this:

  A particular Wireless IN standard development being considered here
  is CAMEL phase 3, standardised by the Third Generation Partnertship
  group (3GPP). The relevant service and architectural considerations
  and protocol requirements are presented later in this document. As
  far as the architecture is concerned, certain wireless events are
  generated by Home Location Register (HLR), which may, but does not
  have to, be part of the Mobile Switching Center (MSC) (a wireless
  equivalnet of the SSP). These events are communicated to Service
  Control, at which point they use the same mechanism for invoking
  SPIRITS services that the IN would.

Thus, it would appear that CAMEL events are just as applicable to
SPIRITS.  Furthermore, a lot of location services will happen out-
side the context of a call, so I would hate to tie ourselves to
services within the context of a call only.

Thanks.

- vijay

_______________________________________________
SPIRITS mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/spirits

_______________________________________________
SPIRITS mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/spirits

---

From: "Vijay K. Gurbani" <[email-masked]>
Date: Mon, 20 May 2002 15:32:22 -0500

> Vijay, all,
[...]
Jorge:

Thanks for the prompt response.  I agree with your email, but I see
SMS as great SPIRITS service, and I will try to explain why I think
so below.

> Therefore, we considered SMS and GPRS out of scope.
> 
> The reason why the SMS (and other not circuit switched "calls") were 
> specifically not included in SPIRITS requirements is that IP services 
> for them can be already provided.  An SMS sent to a specific number can 
> be screened by the SMSC node and handled using SMTP (a well known 
> protocol) to an IP server (and vice versa an IP server can send an SMS). 
> This is heavily used by mobile operators for many services (like SMS 
> voting, SMS alerts, etc.).

You have an excellent point there; but given where we are today in terms
of IM standardization and acceptence, it may be a good idea to revisit
the SMS service in terms of SPIRITS.  I can think of at least two
reasons why a SIP-based solution for SMS->SIP IM is desirable:

1) SIP-based application service providers will find a SIP-based IM
extremely attractive since their entire infrastructure is based on
SIP (e.g. SUBS/NOT, etc.).  To that extent, a SIP message arriving
from the wireless PSTN fits better then a SMTP message.  Their end
users are using SIP UAs anyway to subscribe to/get notification for
events.
2) As you point out, SMTP is a well accepted way to do this, but is it
the only way?  If the messaging protocol we have chosen (namely, SIP)
provides an integrated method do deliver short messages, why not use
it?

> Thus a server in the IP domain can use SPIRITS to receive call events 
> (and interact which voice applications), SMTP to send/receive SMS, and 
> other protocols to interact with GPRS sessions.

I would not argue as forcefully about GPRS as I am about SMS because I
really think that SMS is a good SPIRITS service.  Unlike SMTP, which
may get queued and not read till later, an Internet subscriber wishing
to get SMS over SIP IM is really expressing a preference to see the
instant messages (SMS content) in hard real time.

I am not advocating scrapping SMTP out of SMSC; to me SIP-IM SMS is a
different service.  Users who want information in real time (and have
SIP ASPs) can use the SIP based solution; others can continue using
SMTP.

> If there is a specific service case for SMS/GPRS which requires CAMEL 
> triggering to a SPIRITS (and can not be done via other existing and 
> feasible technologies), I agree that the initial scope of SPIRITS can 
> be revisited.

I don't think that we even need to revisit the scope of SPIRITS; your
protocol requirement I-D already has it all in!  Section 3 of your
I-D already talks about using SPIRITS for wireless networks,
specifically CAMEL phase 3, being standardized by 3GPP.

I hope you see how important SIP-based IM could be to SMS as a SPIRITS
service.  Please let me know what you think.

Best regards,

- vijay
-- 
Vijay K. Gurbani  vkg@{lucent.com,research.bell-labs.com,acm.org}
Wireless Networks Group/Internet Software and Services
Lucent Technologies/Bell Labs Innovations, 2000 Lucent Lane, Rm 6G-440
Naperville, Illinois 60566     Voice: +1 630 224 0216