Subject: [SPIRITS] HELP

From: michal slater <[email-masked]>
Date: Thu, 18 Jul 2002 00:06:23 -0700 (PDT)

hi all,

One simple query. Generally the services sit at the SCF. But with this SPIRITS Protocol

where does actually the SPIRITS Services reside. If they are not residing at the SCF then

what actually the SCF role? Just acts as a supporter to the SPIRITS Services.

thanks

Slater

---------------------------------
Do You Yahoo!?
Yahoo! Autos - Get free new car price quotes

---

From: Alec Brusilovsky <[email-masked]>
Date: Fri, 19 Jul 2002 07:58:43 -0500

Michael and all,

SPIRITS Client is pretty much collocated with SCP-SCF. It's
functionality includes: subscription to the DP after
receiving properly made SUBSCRIBE, formatting appropriate
NOTIFY responses, decoding XML data into ASN.1 and encoding
ASN.1 subscribed parameters into XML.
It does not do much more, unless I am still jet lagged and
forgot something.

Regards,
Alec

michal slater wrote:

> -----------------------------------------------------------
> Do You Yahoo!?

---

From: "Vijay K. Gurbani" <[email-masked]>
Date: Fri, 19 Jul 2002 12:26:36 -0500

Just a quick followup; the whole idea of SPIRITS is that the service
of interest resides in the Internet.  The SCF (through the SPIRITS
client) basically transforms the whole PSTN into a gigantic UA.  Thus,
Internet SIP endpoints can subscribe to and receive notifications from
this PSTN UA as well as treat it as a peer UA if they get an INVITE
from it.

-- 
Vijay K. Gurbani  vkg@{lucent.com,research.bell-labs.com,acm.org}
Wireless Networks Group/Internet Software and Services
Lucent Technologies/Bell Labs Innovations, 2000 Lucent Lane, Rm 6G-440
Naperville, Illinois 60566     Voice: +1 630 224 0216

_______________________________________________
SPIRITS mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/spirits