Subject: [spring] Conclusion from WG poll on dataplane solution for compressing segment routing over IPv6

From: "Joel M. Halpern" <[email-masked]>
Date: Mon, 6 Sep 2021 13:26:50 -0400

Our thanks to the working group members for speaking up clearly.  There 
is a rough (quite clear) consensus for standardizing one dataplane 
solution to compressing segment routing over IPv6.

As chairs, there are some related observations we need to make.
There appears to be significant interest in using the framework in the 
CSID draft for addressing the above.

However, before we issue a call for adoption on that, the chairs would 
like to understand how the working group wants to solve a technical 
problem.  The CSID draft contains two dataplane solutions.  The above 
rough consensus is for one dataplane solution.  Does the working group 
want to choose one?  Do the authors want to suggest that one of the two 
is the one we should standardize, and get working group agreement?
Should we adopt the document, with a note indicating the problem, and 
solve the problem afterwards?  (That itself does not solve the problem, 
it merely kicks it down the road.) Do folks see another means to avoid 
putting the WG in conflict with itself?

As a loosely related side node, the chairs will also observe that we do 
not see an obstacle to informational or experimental publication of 
other solutions, as long as there is sufficient energy in the working 
group to deal with those.  Also, only documents for which there is at 
least one implementation will be progressed this way.

Thank you,
Bruno, Jim, and Joel

---

From: Tony Li <[email-masked]>
Date: Tue, 7 Sep 2021 15:58:40 -0700

Dear chairs & WG,

> Our thanks to the working group members for speaking up clearly.  There is a rough (quite clear) consensus for standardizing one dataplane solution to compressing segment routing over IPv6.

I’m very pleased that we’ve found the courage to say that we want to make a decision.

> There appears to be significant interest in using the framework in the CSID draft for addressing the above.

I concur that there is interest in CSID.  However, as we have not yet done a consensus check to select the specific proposal, I hope that this is not your assertion that CSID is the result. This is a major decision by the WG and it does deserve a formal and explicit check.

> However, before we issue a call for adoption on that, the chairs would like to understand how the working group wants to solve a technical problem.  The CSID draft contains two dataplane solutions.  The above rough consensus is for one dataplane solution.  Does the working group want to choose one?  Do the authors want to suggest that one of the two is the one we should standardize, and get working group agreement?
> Should we adopt the document, with a note indicating the problem, and solve the problem afterwards?  (That itself does not solve the problem, it merely kicks it down the road.) Do folks see another means to avoid putting the WG in conflict with itself?

If the authors of the CSID proposal, or any proposal, would like to revise their proposals before we make a selection, this would seem to be an opportune time.

Tony

---

From: "Weiqiang Cheng" <[email-masked]>
Date: Wed, 8 Sep 2021 11:25:10 +0800

Dear Chairs,

Many thanks for your hard working. 

We are happy to see that the CSID draft has significant interest to be
adopted as a WG document. 

Regarding the dataplane, the authors believe that the CSID draft contains
only one dataplane solution with two different flavors[1]: NEXT-CSID-FLAVOR
and REPLACE-CSID-FLAVOR, rather than two dataplane solutions.

Both the flavors are defined based on the SRv6 data plane(one data plane),
and the SIDs with these two flavors can be encoded in a single SRH just like
we can encode PSP Flavor SIDs and USD flavor SIDs together in a SRH.

The inter-op test of CSIDs had been done almost one year ago[2], and
everything was OK. 

Furthermore, the mechanism defined in the draft has been stable and mature.

With the consensus, the authors hope WG can consider to adopt the CSID
draft.

Best regards,
Weiqiang
on behalf of CSID authors

[1]. https://datatracker.ietf.org/doc/html/rfc8986#section-4.16
[2].
https://datatracker.ietf.org/doc/html/draft-filsfilscheng-spring-srv6-srh-co
mpression-02#section-11

-----邮件原件-----
发件人: spring [mailto:[email-masked]] 代表 Joel M. Halpern
发送时间: 2021年9月7日 01:27
收件人: [email-masked]
主题: [spring] Conclusion from WG poll on dataplane solution for compressing
segment routing over IPv6

Thank you,
Bruno, Jim, and Joel

_______________________________________________
spring mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/spring

---

From: "Henderickx, Wim (Nokia - BE/Antwerp)" <[email-masked]>
Date: Wed, 8 Sep 2021 03:53:05 +0000

Joel and chairs thx for having us move forward here. On the q if CSID is 1 dataplane or 2 dataplane, in my view there is 2 dataplanes inside the CSID proposal and I am advocating that in case CSID moves fwd we pick 1 of them, not both.

From: spring <[email-masked]> on behalf of Joel M. Halpern <[email-masked]>
Date: Monday, 6 September 2021 at 19:27
To: [email-masked] <[email-masked]>
Subject: [spring] Conclusion from WG poll on dataplane solution for compressing segment routing over IPv6
Our thanks to the working group members for speaking up clearly.  There
is a rough (quite clear) consensus for standardizing one dataplane
solution to compressing segment routing over IPv6.

Thank you,
Bruno, Jim, and Joel

---

From: <[email-masked]>
Date: Wed, 8 Sep 2021 14:39:46 +0800 (CST)

In my opinion, C-SID just presents 1 solution in dataplane, even it has 2 flavors, but they share the same framework and process. Before we accept it it is not important to prefer which flavor.

Best regards，

Aihua

原始邮件

发件人：Henderickx,Wim(Nokia-BE/Antwerp)
收件人：Joel M. Halpern;[email-masked];
日 期 ：2021年09月08日 11:53
主 题 ：Re: [spring] Conclusion from WG poll on dataplane solution for compressing segment routing over IPv6

 

 

 
 Thank you,
 Bruno, Jim, and Joel

---

From: Robert Raszuk <[email-masked]>
Date: Wed, 8 Sep 2021 11:49:41 +0200

Hi Tony,

May I ask if the "check" you are recommending is to be done only based on
reading a few drafts or maybe also something else ?

I personally think that while reading the specs may give some hints as to
how the solution is supposed to work the real crux of the matter is in
details of hardware implementations and various design choices made there.

So to me if this WG is to make some choices (which I am not sure if it
should or is capable of specifically in regards to hardware impact of any
solution) much more useful is to document actual shipping and deployed
implementations and support it with actual data from the field (both
production deployment as well as early field trials).

Data presented so far clearly indicates that CSID data plane with two
flavors has most vendor and operational experience behind it.

Meanwhile let's see if the below two drafts will be adopted as WG doc:

https://datatracker.ietf.org/doc/html/draft-srcompdt-spring-compression-requirement

https://datatracker.ietf.org/doc/html/draft-srcompdt-spring-compression-analysis

If they will IMHO this will be good technical as well as formal input to
the choice to be made.

Many thx,

Robert

On Wed, Sep 8, 2021 at 12:58 AM Tony Li <[email-masked]> wrote:

> is a rough (quite clear) consensus for standardizing one dataplane solution
> to compressing segment routing over IPv6.
>
>
> I concur that there is interest in CSID.  However, as we have not yet done
> a consensus check to select the specific proposal, I hope that this is not
> your assertion that CSID is the result. This is a major decision by the WG
> and it does deserve a formal and explicit check.
>
>
> problem.  The CSID draft contains two dataplane solutions.  The above rough
> consensus is for one dataplane solution.  Does the working group want to
> choose one?  Do the authors want to suggest that one of the two is the one
> we should standardize, and get working group agreement?
> solve the problem afterwards?  (That itself does not solve the problem, it
> merely kicks it down the road.) Do folks see another means to avoid putting
> the WG in conflict with itself?
>
>
> If the authors of the CSID proposal, or any proposal, would like to revise
> their proposals before we make a selection, this would seem to be an
> opportune time.
>
> Tony
>

---

From: "Henderickx, Wim (Nokia - BE/Antwerp)" <[email-masked]>
Date: Fri, 10 Sep 2021 04:26:05 +0000

Maybe just to clarify my statement. in my view we can adopt CSID and discuss the matter of 1 versus 2 data-planes during the WG and see how to move forward from here. At least we can make progress on this matter.

From: spring <[email-masked]> on behalf of Henderickx, Wim (Nokia - BE/Antwerp) <[email-masked]>
Date: Wednesday, 8 September 2021 at 05:53
To: Joel M. Halpern <[email-masked]>, [email-masked] <[email-masked]>
Subject: Re: [spring] Conclusion from WG poll on dataplane solution for compressing segment routing over IPv6
Joel and chairs thx for having us move forward here. On the q if CSID is 1 dataplane or 2 dataplane, in my view there is 2 dataplanes inside the CSID proposal and I am advocating that in case CSID moves fwd we pick 1 of them, not both.

Thank you,
Bruno, Jim, and Joel

---

From: "Darren Dukes (ddukes)" <[email-masked]>
Date: Fri, 10 Sep 2021 18:48:17 +0000

Hello Joel and chairs.

I agree with the CSID authors observations below.
I think we can make excellent progress now that the WG has settled on one solution, let’s adopt the CSID draft and direct our energy toward it as a WG document.

Thanks
  Darren

On 2021-09-07, 11:25 PM, "spring" <[email-masked]> wrote:

Dear Chairs,

Best regards,
Weiqiang

-----邮件原件-----
发件人: spring [mailto:[email-masked]] 代表 Joel M. Halpern
发送时间: 2021年9月7日 01:27
收件人: [email-masked]
主题: [spring] Conclusion from WG poll on dataplane solution for compressing

Thank you,
Bruno, Jim, and Joel

---

From: Greg Mirsky <[email-masked]>
Date: Fri, 10 Sep 2021 12:52:14 -0700

Hi Joel et al.
in evaluating a draft during a WG AP I am looking for three questions:

   - Is the document written reasonably well to clearly convey the problem
   and proposed solution?
   - Does the problem statement reflect a real existing challenge, an issue
   that needs to be solved?
   - Is the proposed solution technically viable?

Reading the CSID draft (draft-filsfilscheng-spring-srv6-srh-compression
<https://datatracker.ietf.org/doc/draft-filsfilscheng-spring-srv6-srh-compression/>)
I could positively answer the first two questions. While deciding on the
third question, I've got sense that the document describes two different
behaviors in the data plane, two ways to encode variable-length SIDs in the
SRH extension header. I agree that it can be resolved through either the
authors selecting one solution, or the WG working on that. Personally, I
encourage the authors to do that.

Regards,
Greg

---

From: "Chengli (Cheng Li)" <[email-masked]>
Date: Sat, 11 Sep 2021 01:52:23 +0000

Hi Chairs,

After a long-time discussion and many contributions have been made to the topic,  I believe we have get the point that we should step forward to adopt the CSID draft, therefore, I fully agree with the CSID authors' POV.

Many thanks for your work, it MUST be difficult for you :)
But I still believe that we can address the tough tasks very soon as long as we can still move forward.

Thank you again for the excellent work and respect,
Cheng

-----Original Message-----
From: spring [mailto:[email-masked]] On Behalf Of Weiqiang Cheng
Sent: Wednesday, September 8, 2021 11:25 AM
To: 'Joel M. Halpern' <[email-masked]>; [email-masked]
Subject: Re: [spring] Conclusion from WG poll on dataplane solution for compressing segment routing over IPv6

Dear Chairs,

We are happy to see that the CSID draft has significant interest to be adopted as a WG document. 

Regarding the dataplane, the authors believe that the CSID draft contains only one dataplane solution with two different flavors[1]: NEXT-CSID-FLAVOR and REPLACE-CSID-FLAVOR, rather than two dataplane solutions.

Both the flavors are defined based on the SRv6 data plane(one data plane), and the SIDs with these two flavors can be encoded in a single SRH just like we can encode PSP Flavor SIDs and USD flavor SIDs together in a SRH.

The inter-op test of CSIDs had been done almost one year ago[2], and everything was OK. 

With the consensus, the authors hope WG can consider to adopt the CSID draft.

Best regards,
Weiqiang

-----邮件原件-----
发件人: spring [mailto:[email-masked]] 代表 Joel M. Halpern
发送时间: 2021年9月7日 01:27
收件人: [email-masked]
主题: [spring] Conclusion from WG poll on dataplane solution for compressing segment routing over IPv6

As a loosely related side node, the chairs will also observe that we do not see an obstacle to informational or experimental publication of other solutions, as long as there is sufficient energy in the working group to deal with those.  Also, only documents for which there is at least one implementation will be progressed this way.

Thank you,
Bruno, Jim, and Joel

---

From: <[email-masked]>
Date: Mon, 13 Sep 2021 20:30:17 +0800 (CST)

Dear Chairs & Weiqiang,

As I presented before, the CSID draft is just only one solution with two different flavors. Even there are some others, the CSID has the most supporters and has finished multi-vendor interworking test and field test, including my company ZTE. Especially, CSID is the most compatible the standard SRv6 dataplane. It's benificial for SRv6 industry if the WG could adopt the CSID draft.

Best regards,

Aihua

原始邮件

发件人：WeiqiangCheng
收件人：'Joel M. Halpern';[email-masked];
日 期 ：2021年09月08日 11:25
主 题 ：Re: [spring] Conclusion from WG poll on dataplane solution for compressing segment routing over IPv6

Dear Chairs,

Best regards,
Weiqiang

-----邮件原件-----
发件人: spring [mailto:[email-masked]] 代表 Joel M. Halpern
发送时间: 2021年9月7日 01:27
收件人: [email-masked]
主题: [spring] Conclusion from WG poll on dataplane solution for compressing

Thank you,
Bruno, Jim, and Joel

---

From: Gyan Mishra <[email-masked]>
Date: Sat, 18 Sep 2021 16:36:31 -0400

Dear Chairs & WG

As the authors have described the C-SID draft is a single solution for the
SRv6 data plane  compression solution with two different endpoint flavors
for SRv6 PGM Endpoint behaviors End and End.x, called NEXT-C-SID &
REPLACE-C-SID, similar to existing SRv6 PGM endpoint flavors PSP, USP, USD.

C-SID is a combination of the two drafts below:

C-SID
https://datatracker.ietf.org/doc/draft-filsfilscheng-spring-srv6-srh-compression/

Combination of the two drafts below:

G-SID - Generalized SID
https://datatracker.ietf.org/doc/html/draft-cl-spring-generalized-srv6-for-cmpr-03

G-SID is renamed to C-SID and G-SRv6 compression sub path is renamed to
C-SID Sequence in REPLACE-C-SID endpoint flavor in the above C-SID draft.

G-SID container concept and breaks out the common locator part of the SRv6
SID and trailing bits for the encapsulation header savings.
G-SID draft section 8 shows interoperability  status applied to the C-SID
draft.

SRv6 uSID micro-segment
https://datatracker.ietf.org/doc/html/draft-filsfils-spring-net-pgm-extension-srv6-usid-10

uSID is renamed to NEXT-C-SID endpoint flavor in the above C-SID draft.

uSID Micro-segment introduces a LIB and GIB local uSID and Global uSID
concept of IDs within a container.

C-SID draft  introduces a new endpoint flavor option which is a combination
of the two drafts above called NEXT-AND-REPLCE-CSID which provides the best
efficiency in encapsulation size with increased complexity.

Kind Regards

Gyan

On Mon, Sep 13, 2021 at 8:30 AM <[email-masked]> wrote:

>
> Dear Chairs & Weiqiang,
>
> As I presented before, the CSID draft is just only one solution with two
> different flavors. Even there are some others, the CSID has the most
> supporters and has finished multi-vendor interworking test and field test,
> including my company ZTE. Especially, CSID is the most compatible the
> standard SRv6 dataplane. It's benificial for SRv6 industry if the WG could
> adopt the CSID draft.
>
>
> Best regards,
>
> Aihua
>
>
> 原始邮件
> *发件人：*WeiqiangCheng
> *收件人：*'Joel M. Halpern';[email-masked];
> *日 期 ：*2021年09月08日 11:25
> *主 题 ：**Re: [spring] Conclusion from WG poll on dataplane solution for
> compressing segment routing over IPv6*
> Dear Chairs,
>
-- 

<http://www.verizon.com/>

*Gyan Mishra*

*Network Solutions A**rchitect *

*Email [email-masked] <[email-masked]>*

*M 301 502-1347*

---

From: Lizhenbin <[email-masked]>
Date: Fri, 24 Sep 2021 08:04:29 +0000

Hi Chairs,

Many thanks for your hard work for progressing the SRv6 compression work!
After several round polls in WG, we believe that we have reached the consensus that CSID draft should be adopted as a WG document. 
In addition, the CSID co-authors have explained clearly that the CSID is one data plane solution with different flavors.

IMHO, we need to move the work forward. With the consensus, we believe it is the right time to issue a WG adoption call for the CSID draft.
As we know very well, the adoption does not mean the ending point, but the starting point for the WG to concentrate efforts and go on to 
refine the solutions.

Best Regards,
Robin

-----Original Message-----
From: spring [mailto:[email-masked]] On Behalf Of Weiqiang Cheng
Sent: Wednesday, September 8, 2021 11:25 AM
To: 'Joel M. Halpern' <[email-masked]>; [email-masked]
Subject: Re: [spring] Conclusion from WG poll on dataplane solution for compressing segment routing over IPv6

Dear Chairs,

Best regards,
Weiqiang

-----邮件原件-----
发件人: spring [mailto:[email-masked]] 代表 Joel M. Halpern
发送时间: 2021年9月7日 01:27
收件人: [email-masked]
主题: [spring] Conclusion from WG poll on dataplane solution for compressing segment routing over IPv6

Thank you,
Bruno, Jim, and Joel

---

From: "Zafar Ali (zali)" <[email-masked]>
Date: Fri, 24 Sep 2021 12:41:08 +0000

Hi, 

I agree with the chairs that there is (quite clear) consensus for standardizing one dataplane solution, and that there is significant interest in using the framework in the CSID draft for addressing the compression requirements.

My view is that we move towards WG adoption of the document, and note any concern raised by WG members during the poll so that the WG can solve it afterwards.

Thanks
 
Regards … Zafar 

On 9/24/21, 4:05 AM, "spring on behalf of Lizhenbin" <[email-masked] on behalf of [email-masked]> wrote:

    Hi Chairs,

    Best Regards,
    Robin

    -----Original Message-----
    From: spring [mailto:[email-masked]] On Behalf Of Weiqiang Cheng
    Sent: Wednesday, September 8, 2021 11:25 AM
    To: 'Joel M. Halpern' <[email-masked]>; [email-masked]
    Subject: Re: [spring] Conclusion from WG poll on dataplane solution for compressing segment routing over IPv6

    Dear Chairs,

    Best regards,
    Weiqiang

    -----邮件原件-----
    发件人: spring [mailto:[email-masked]] 代表 Joel M. Halpern
    发送时间: 2021年9月7日 01:27
    收件人: [email-masked]
    主题: [spring] Conclusion from WG poll on dataplane solution for compressing segment routing over IPv6

    Thank you,
    Bruno, Jim, and Joel