Subject: Re: [spring] Conclusion from WG poll on dataplane solution for compressing segment routing over IPv6

From: zhen han <[email-masked]>
Date: Sun, 12 Sep 2021 08:53:08 +0800

Hi Chairs，

I fully agree with the CSID authors opinions below.

It is definitely not a easy topic as it take such a long time to get a
consensus version.
Thank the authors for their hard working！
I agree that 2 flavors are not equal to 2 dataplane，different flavors are
all based on the same SRv6 dataplane（one dateplane）.
The current version could be called as one solution.

Considering the huge progress we have achieved，it seems 100% ready to step
forward ASAP.

Best Regards，
Zhen HAN (Fiberhome)

*发件人：* Weiqiang Cheng <[email-masked]>
*发送时间：* 2021-09-08 11:25
*收件人：* 'Joel M. Halpern' <[email-masked]>; [email-masked]
*主题：* Re: [spring] Conclusion from WG poll on dataplane solution for
compressing segment routing over IPv6
Dear Chairs,

Many thanks for your hard working.

We are happy to see that the CSID draft has significant interest to be
adopted as a WG document.

Regarding the dataplane, the authors believe that the CSID draft contains
only one dataplane solution with two different flavors[1]: NEXT-CSID-FLAVOR
and REPLACE-CSID-FLAVOR, rather than two dataplane solutions.

Both the flavors are defined based on the SRv6 data plane(one data plane),
and the SIDs with these two flavors can be encoded in a single SRH just like
we can encode PSP Flavor SIDs and USD flavor SIDs together in a SRH.

The inter-op test of CSIDs had been done almost one year ago[2], and
everything was OK.

Furthermore, the mechanism defined in the draft has been stable and mature.

With the consensus, the authors hope WG can consider to adopt the CSID
draft.

Best regards,
Weiqiang
on behalf of CSID authors

[1]. https://datatracker.ietf.org/doc/html/rfc8986#section-4.16
[2].
https://datatracker.ietf.org/doc/html/draft-filsfilscheng-spring-srv6-srh-co
mpression-02#section-11

-----邮件原件-----
发件人: spring [mailto:[email-masked]] 代表 Joel M. Halpern
发送时间: 2021年9月7日 01:27
收件人: [email-masked]
主题: [spring] Conclusion from WG poll on dataplane solution for compressing
segment routing over IPv6

Our thanks to the working group members for speaking up clearly.  There
is a rough (quite clear) consensus for standardizing one dataplane
solution to compressing segment routing over IPv6.

As chairs, there are some related observations we need to make.
There appears to be significant interest in using the framework in the
CSID draft for addressing the above.

However, before we issue a call for adoption on that, the chairs would
like to understand how the working group wants to solve a technical
problem.  The CSID draft contains two dataplane solutions.  The above
rough consensus is for one dataplane solution.  Does the working group
want to choose one?  Do the authors want to suggest that one of the two
is the one we should standardize, and get working group agreement?
Should we adopt the document, with a note indicating the problem, and
solve the problem afterwards?  (That itself does not solve the problem,
it merely kicks it down the road.) Do folks see another means to avoid
putting the WG in conflict with itself?

As a loosely related side node, the chairs will also observe that we do
not see an obstacle to informational or experimental publication of
other solutions, as long as there is sufficient energy in the working
group to deal with those.  Also, only documents for which there is at
least one implementation will be progressed this way.

Thank you,
Bruno, Jim, and Joel

_______________________________________________
spring mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/spring

_______________________________________________
spring mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/spring

---

From: Lihao <[email-masked]>
Date: Tue, 14 Sep 2021 08:31:06 +0000

Hi Chairs&Weiqiang

Many thanks to DT's excellent contributions!

As an equipment vendor, I believe that CSID is a single data plane solution from the perspective of implementation.

Two flavors carry different functions, but follow the same processing principles.

it will be good if WG could adopt the CSID draft

-----邮件原件-----
发件人: spring [mailto:[email-masked]] 代表 Weiqiang Cheng
发送时间: 2021年9月8日 11:25
收件人: 'Joel M. Halpern' <[email-masked]>; [email-masked]
主题: Re: [spring] Conclusion from WG poll on dataplane solution for compressing segment routing over IPv6

Dear Chairs,

We are happy to see that the CSID draft has significant interest to be adopted as a WG document.

Regarding the dataplane, the authors believe that the CSID draft contains only one dataplane solution with two different flavors[1]: NEXT-CSID-FLAVOR and REPLACE-CSID-FLAVOR, rather than two dataplane solutions.

Both the flavors are defined based on the SRv6 data plane(one data plane), and the SIDs with these two flavors can be encoded in a single SRH just like we can encode PSP Flavor SIDs and USD flavor SIDs together in a SRH.

The inter-op test of CSIDs had been done almost one year ago[2], and everything was OK.

With the consensus, the authors hope WG can consider to adopt the CSID draft.

Best regards,
Weiqiang

-----邮件原件-----
发件人: spring [mailto:[email-masked]] 代表 Joel M. Halpern
发送时间: 2021年9月7日 01:27
收件人: [email-masked]
主题: [spring] Conclusion from WG poll on dataplane solution for compressing segment routing over IPv6

Our thanks to the working group members for speaking up clearly.  There is a rough (quite clear) consensus for standardizing one dataplane solution to compressing segment routing over IPv6.

As chairs, there are some related observations we need to make.
There appears to be significant interest in using the framework in the CSID draft for addressing the above.

However, before we issue a call for adoption on that, the chairs would like to understand how the working group wants to solve a technical problem.  The CSID draft contains two dataplane solutions.  The above rough consensus is for one dataplane solution.  Does the working group want to choose one?  Do the authors want to suggest that one of the two is the one we should standardize, and get working group agreement?
Should we adopt the document, with a note indicating the problem, and solve the problem afterwards?  (That itself does not solve the problem, it merely kicks it down the road.) Do folks see another means to avoid putting the WG in conflict with itself?

As a loosely related side node, the chairs will also observe that we do not see an obstacle to informational or experimental publication of other solutions, as long as there is sufficient energy in the working group to deal with those.  Also, only documents for which there is at least one implementation will be progressed this way.

Thank you,
Bruno, Jim, and Joel

_______________________________________________
spring mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/spring
-------------------------------------------------------------------------------------------------------------------------------------
本邮件及其附件含有新华三集团的保密信息，仅限于发送给上面地址中列出
的个人或群组。禁止任何其他人以任何形式使用（包括但不限于全部或部分地泄露、复制、
或散发）本邮件中的信息。如果您错收了本邮件，请您立即电话或邮件通知发件人并删除本
邮件！
This e-mail and its attachments contain confidential information from New H3C, which is
intended only for the person or entity whose address is listed above. Any use of the
information contained herein in any way (including, but not limited to, total or partial
disclosure, reproduction, or dissemination) by persons other than the intended
recipient(s) is prohibited. If you receive this e-mail in error, please notify the sender
by phone or email immediately and delete it!

---

From: Qiuyuanxiang <[email-masked]>
Date: Tue, 14 Sep 2021 09:01:32 +0000

Dear Chairs & Weiqiang,
 The CSID draft just contains one data plane solution with two different flavors. H3C has participated in the inter-op test of CSID with multiple vendors, also proves that this is a good solution.
 We hope WG can adopt the CSID draft.

Best regards,
Yuanxiang

-----邮件原件-----
发件人: spring [mailto:[email-masked]] 代表 Weiqiang Cheng
发送时间: 2021年9月8日 11:25
收件人: 'Joel M. Halpern' <[email-masked]>; [email-masked]
主题: Re: [spring] Conclusion from WG poll on dataplane solution for compressing segment routing over IPv6

Dear Chairs,

Best regards,
Weiqiang

-----邮件原件-----
发件人: spring [mailto:[email-masked]] 代表 Joel M. Halpern
发送时间: 2021年9月7日 01:27
收件人: [email-masked]
主题: [spring] Conclusion from WG poll on dataplane solution for compressing segment routing over IPv6

Thank you,
Bruno, Jim, and Joel

---

From: linchangwang <[email-masked]>
Date: Wed, 15 Sep 2021 15:28:53 +0000

Dear Chairs & Weiqiang,

Support WG adoption of these two documents.

The design team has done a great job.
The multi-vendor interworking test of CSIDs had been done , including my company New H3C.
The CSID satisfies all the requirements, it will be great if we can have CSID standardized.

Best regards,
Changwang lin

-----邮件原件-----
发件人: spring [mailto:[email-masked]] 代表 Weiqiang Cheng
发送时间: 2021年9月8日 11:25
收件人: 'Joel M. Halpern'; [email-masked]
主题: Re: [spring] Conclusion from WG poll on dataplane solution for compressing segment routing over IPv6

Dear Chairs,

Best regards,
Weiqiang

-----邮件原件-----
发件人: spring [mailto:[email-masked]] 代表 Joel M. Halpern
发送时间: 2021年9月7日 01:27
收件人: [email-masked]
主题: [spring] Conclusion from WG poll on dataplane solution for compressing

Thank you,
Bruno, Jim, and Joel