Subject: [spring] https://datatracker.ietf.org/doc/html/draft-filsfilscheng-spring-srv6-srh-compression-02#section-4.1.1

From: Gyan Mishra <[email-masked]>
Date: Sun, 19 Sep 2021 15:33:21 -0400

Dear Authors

After having a few discussions on threads related to the SRv6 compression
analysis draft results, as well as WG coming to consensus on a single SRv6
compression solution, a few critical questions have come up related to
C-SID draft that requires clarification by the authors.

The C-SID draft has 3 compression solutions below and is a combination of
the two drafts below which introduces 2 of the 3 compression solutions with
the  C-SID draft introduction of yet a 3rd compression solution.

Which of the 3 C-SID draft compression solutions was included as part of
the DT analysis draft results and conclusion?

This is a critical question that needs to be answered for clarification on
the C-SID draft solution.

As the WG has consensus on a single solution we need to have clarification
from the authors which of the 3 compression solutions was included in the
analysis.

The three solutions are very different and all would yield different
analysis results.

I understand the authors have called the each solution a endpoint flavor
which I see from the IANA codepoint allocations, however each flavor is a
different solution.

https://www.iana.org/assignments/segment-routing/segment-routing.xhtml

So the WG as stated would like a single solution so now we need feedback
from the authors which of the three solutions or endpoint flavors was part
of the DT analysis draft that the authors would like to put forward as the
single compression solution.

C-SID is a combination of the two drafts below:

Combination of the two drafts below:

G-SID - Generalized SID “REPLACE-C-SID”
https://datatracker.ietf.org/doc/html/draft-cl-spring-generalized-srv6-for-cmpr-03

SRv6 uSID micro-segment “ NEXT-C-SID”
https://datatracker.ietf.org/doc/html/draft-filsfils-spring-net-pgm-extension-srv6-usid-10

Kind Regards

Gyan
-- 

<http://www.verizon.com/>

*Gyan Mishra*

*Network Solutions A**rchitect *

*Email [email-masked] <[email-masked]>*

*M 301 502-1347*

---

From: Gyan Mishra <[email-masked]>
Date: Fri, 24 Sep 2021 09:55:36 -0400

Dear Spring Authors

Please respond to this question the WG has related to which of the three
SRv6 forwarding mechanisms called  flavors was inclusive of the compression
analysis draft.

The Analysis draft is ambiguous as to which SRv6 forwarding plane flavor
was part of the analysis.

This is a critical question that has come up by the WG and Chairs, and
answering this question will help pave the way to an adoption call for
C-SID.

Kind Regards

Gyan

*Gyan Mishra*

*M 301 502-1347*

---

From: "Darren Dukes (ddukes)" <[email-masked]>
Date: Fri, 24 Sep 2021 14:10:27 +0000

Hi Gyan, as a DT member, I can answer your analysis draft question.
Consistent with the requirement document, proposals were analyzed with 16-bit and 32-bit SID lengths, though several supported additional options.
The CSID draft recommended NEXT-C-SID use for 16-bit C-SIDs, and REPLACE-C-SID use for 32-bit C-SIDs. The design team followed this recommendation in its analysis, though the CSID draft notes all flavors support both 16-bit and 32-bit C-SID length.
Darren

On 2021-09-19, 3:34 PM, "spring" <[email-masked]> wrote:

Dear Authors

After having a few discussions on threads related to the SRv6 compression analysis draft results, as well as WG coming to consensus on a single SRv6 compression solution, a few critical questions have come up related to C-SID draft that requires clarification by the authors.

The C-SID draft has 3 compression solutions below and is a combination of the two drafts below which introduces 2 of the 3 compression solutions with the  C-SID draft introduction of yet a 3rd compression solution.

Which of the 3 C-SID draft compression solutions was included as part of the DT analysis draft results and conclusion?

This is a critical question that needs to be answered for clarification on the C-SID draft solution.

As the WG has consensus on a single solution we need to have clarification from the authors which of the 3 compression solutions was included in the analysis.

The three solutions are very different and all would yield different analysis results.

I understand the authors have called the each solution a endpoint flavor which I see from the IANA codepoint allocations, however each flavor is a different solution.

So the WG as stated would like a single solution so now we need feedback from the authors which of the three solutions or endpoint flavors was part of the DT analysis draft that the authors would like to put forward as the single compression solution.

Kind Regards

Gyan
--

[http://ss7.vzw.com/is/image/VerizonWireless/vz-logo-email]<http://www.verizon.com/>

Gyan Mishra

Network Solutions Architect

Email [email-masked]<mailto:[email-masked]>

M 301 502-1347

---

From: Robert Raszuk <[email-masked]>
Date: Fri, 24 Sep 2021 16:25:24 +0200

> all flavors support both 16-bit and 32-bit C-SID length.

Just for the record IMO there are real production networks which would
benefit also from 8-bit or 12-bit C-SIDs. So I am of the opinion that those
would be a very useful additions.

The real reason for vSID draft was an observation that one side will not
fit all and each network may be optimal with different length. So I am not
sure that going with 16 or 32 bits is best we can do.

Sure it is much less then 128 - no question. But it is almost same size as
MPLS label - so we could just advertise domain wide 20 bit as a C-SID and
leave data plane alone :).

Thx,
R,

On Fri, Sep 24, 2021 at 4:10 PM Darren Dukes (ddukes) <[email-masked]>
wrote:

> Consistent with the requirement document, proposals were analyzed with
> 16-bit and 32-bit SID lengths, though several supported additional options.
>
> The CSID draft recommended NEXT-C-SID use for 16-bit C-SIDs, and
> REPLACE-C-SID use for 32-bit C-SIDs. The design team followed this
> recommendation in its analysis, though the CSID draft notes all flavors
> support both 16-bit and 32-bit C-SID length.
>
> Darren
>
>
>
>
>
> *Network Solutions Architect *
>

---

From: Gyan Mishra <[email-masked]>
Date: Fri, 24 Sep 2021 10:53:27 -0400

Thank you Darren!

Few comments.

I do see many early allocation for C-SID for various endpoint behaviors.

I was trying to find out where in the CSID draft that is stated.  Please
provide the section.

“CSID draft recommended NEXT-C-SID use for 16-bit C-SIDs, and REPLACE-C-SID
use for 32-bit C-SIDs. “

Just based on the CSID draft SRv6 forwarding plane flavors, SID formatting,
 the NEXT-C-SID used a 16-bit combined NF -Locator/Function uSID variant
where the REPLACE-C-SID uses a 32-bit combined NF-Locator/Function.

I did not see explicit verbiage as to one flavor or the other for 16 or 32
bit SID.

I believe this  information is important to be included in the analysis
draft as well.

Section 6 talks about CSID length, Block length and GIB/LIB usage but does
not specify explicitly what you are stating.

As the WG has clearly stated that they would like a single solution,
however CSID is inclusive of 2 SRv6 forwarding compression solutions not
one from the two drafts - uSID & G-SID.

So that would have to be hashed out by the WG taking into account the
 interoperability issue that is the key point of contention to having
multiple solutions from an operators perspective.

Kind Regards

Gyan

-- 

*Gyan Mishra*

*M 301 502-1347*

---

From: James Guichard <[email-masked]>
Date: Fri, 24 Sep 2021 15:05:28 +0000

Hi Gyan,

[Chair hat off ...]

You asked where in the CSID document it states "CSID draft recommended NEXT-C-SID use for 16-bit C-SIDs, and REPLACE-C-SID use for 32-bit C-SIDs. "

Please see:

6<https://datatracker.ietf.org/doc/html/draft-filsfilscheng-spring-srv6-srh-compression-02#section-6>.  C-SID and Block Length

6.1<https://datatracker.ietf.org/doc/html/draft-filsfilscheng-spring-srv6-srh-compression-02#section-6.1>.  C-SID Length

   The NEXT-C-SID flavor supports both 16- and 32-bit C-SID lengths.  A
   C-SID length of 16-bit is recommended.

   The REPLACE-C-SID flavor supports both 16- and 32-bit C-SID lengths.
   A C-SID length of 32-bit is recommended.

Jim

From: Gyan Mishra <[email-masked]>
Sent: Friday, September 24, 2021 10:53 AM
To: Darren Dukes (ddukes) <[email-masked]>
Cc: SPRING WG <[email-masked]>; [email-masked]; [email-masked]
Subject: Re: [spring] https://datatracker.ietf.org/doc/html/draft-filsfilscheng-spring-srv6-srh-compression-02#section-4.1.1

Thank you Darren!

Few comments.

https://www.iana.org/assignments/segment-routing/segment-routing.xhtml<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.iana.org%2Fassignments%2Fsegment-routing%2Fsegment-routing.xhtml&data=04%7C01%7Cjames.n.guichard%40futurewei.com%7C02af79e38912473c50e108d97f6b41be%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637680920918409649%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=eWX%2Bhuyl9obuOYLLxQs%2FoH4t7lllEfacUp5C0c5QgNg%3D&reserved=0>

I was trying to find out where in the CSID draft that is stated.  Please provide the section.

"CSID draft recommended NEXT-C-SID use for 16-bit C-SIDs, and REPLACE-C-SID use for 32-bit C-SIDs. "

Just based on the CSID draft SRv6 forwarding plane flavors, SID formatting,  the NEXT-C-SID used a 16-bit combined NF -Locator/Function uSID variant where the REPLACE-C-SID uses a 32-bit combined NF-Locator/Function.

I did not see explicit verbiage as to one flavor or the other for 16 or 32 bit SID.

I believe this  information is important to be included in the analysis draft as well.

Section 6 talks about CSID length, Block length and GIB/LIB usage but does not specify explicitly what you are stating.

As the WG has clearly stated that they would like a single solution, however CSID is inclusive of 2 SRv6 forwarding compression solutions not one from the two drafts - uSID & G-SID.

So that would have to be hashed out by the WG taking into account the  interoperability issue that is the key point of contention to having multiple solutions from an operators perspective.

Kind Regards

Gyan

On Fri, Sep 24, 2021 at 10:10 AM Darren Dukes (ddukes) <[email-masked]<mailto:[email-masked]>> wrote:
Hi Gyan, as a DT member, I can answer your analysis draft question.
Consistent with the requirement document, proposals were analyzed with 16-bit and 32-bit SID lengths, though several supported additional options.
The CSID draft recommended NEXT-C-SID use for 16-bit C-SIDs, and REPLACE-C-SID use for 32-bit C-SIDs. The design team followed this recommendation in its analysis, though the CSID draft notes all flavors support both 16-bit and 32-bit C-SID length.
Darren

On 2021-09-19, 3:34 PM, "spring" <[email-masked]<mailto:[email-masked]>> wrote:

Dear Authors

https://www.iana.org/assignments/segment-routing/segment-routing.xhtml<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.iana.org%2Fassignments%2Fsegment-routing%2Fsegment-routing.xhtml&data=04%7C01%7Cjames.n.guichard%40futurewei.com%7C02af79e38912473c50e108d97f6b41be%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637680920918419645%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=QYAGkTnNs0Bfb768auk2U%2BzykfOw%2BPmF609Dj6gwlIQ%3D&reserved=0>

G-SID - Generalized SID "REPLACE-C-SID"
https://datatracker.ietf.org/doc/html/draft-cl-spring-generalized-srv6-for-cmpr-03<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fhtml%2Fdraft-cl-spring-generalized-srv6-for-cmpr-03&data=04%7C01%7Cjames.n.guichard%40futurewei.com%7C02af79e38912473c50e108d97f6b41be%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637680920918419645%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=xQXCNLDdSC4XXjdZXrLM05BxJ11M4cSZPtI2pSGURAA%3D&reserved=0>

SRv6 uSID micro-segment " NEXT-C-SID"
https://datatracker.ietf.org/doc/html/draft-filsfils-spring-net-pgm-extension-srv6-usid-10<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fhtml%2Fdraft-filsfils-spring-net-pgm-extension-srv6-usid-10&data=04%7C01%7Cjames.n.guichard%40futurewei.com%7C02af79e38912473c50e108d97f6b41be%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637680920918429635%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=6CispEy1z1jsNI5LzPsbMA3aIlsImAZ4dgWZFrIneYk%3D&reserved=0>

Kind Regards

Gyan
--

[http://ss7.vzw.com/is/image/VerizonWireless/vz-logo-email]<https://nam11.safelinks.protection.outlook.com/?url=http%3A%2F%2Fwww.verizon.com%2F&data=04%7C01%7Cjames.n.guichard%40futurewei.com%7C02af79e38912473c50e108d97f6b41be%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637680920918429635%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=1ByliHlPrZzPB60cwrVTmTOwT2q%2B4%2BUBNDdLA4CC5%2Bs%3D&reserved=0>

Gyan Mishra

M 301 502-1347

--

[http://ss7.vzw.com/is/image/VerizonWireless/vz-logo-email]<https://nam11.safelinks.protection.outlook.com/?url=http%3A%2F%2Fwww.verizon.com%2F&data=04%7C01%7Cjames.n.guichard%40futurewei.com%7C02af79e38912473c50e108d97f6b41be%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637680920918439634%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=uXz1BTmNxaOSWuBsAtojA8XcK8oFv27Ptx63%2FU0vSLE%3D&reserved=0>

Gyan Mishra

M 301 502-1347

---

From: Gyan Mishra <[email-masked]>
Date: Fri, 24 Sep 2021 11:57:54 -0400

Sorry I missed that.

Thank you!!

On Fri, Sep 24, 2021 at 11:05 AM James Guichard <
[email-masked]> wrote:

> Hi Gyan,
>
>
>
> [Chair hat off …]
>
>
>
> You asked where in the CSID document it states “CSID draft recommended
> NEXT-C-SID use for 16-bit C-SIDs, and REPLACE-C-SID use for 32-bit C-SIDs. “
>
>
>
> Please see:
>
>
>
> *6
> <https://datatracker.ietf.org/doc/html/draft-filsfilscheng-spring-srv6-srh-compression-02#section-6>.
> C-SID and Block Length*
>
>
>
> *6.1
> <https://datatracker.ietf.org/doc/html/draft-filsfilscheng-spring-srv6-srh-compression-02#section-6.1>.
> C-SID Length*
>
>
>
> *From:* Gyan Mishra <[email-masked]>
> *Sent:* Friday, September 24, 2021 10:53 AM
> *To:* Darren Dukes (ddukes) <[email-masked]>
> *Cc:* SPRING WG <[email-masked]>;
> [email-masked];
> [email-masked]
> *Subject:* Re: [spring]
> https://datatracker.ietf.org/doc/html/draft-filsfilscheng-spring-srv6-srh-compression-02#section-4.1.1
>
>
>
> Thank you Darren!
>
>
>
> Few comments.
>
>
>
> <https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.iana.org%2Fassignments%2Fsegment-routing%2Fsegment-routing.xhtml&data=04%7C01%7Cjames.n.guichard%40futurewei.com%7C02af79e38912473c50e108d97f6b41be%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637680920918409649%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=eWX%2Bhuyl9obuOYLLxQs%2FoH4t7lllEfacUp5C0c5QgNg%3D&reserved=0>
>
>
>
> “CSID draft recommended NEXT-C-SID use for 16-bit C-SIDs, and
> REPLACE-C-SID use for 32-bit C-SIDs. “
>
>
>
> Just based on the CSID draft SRv6 forwarding plane flavors, SID
> formatting,  the NEXT-C-SID used a 16-bit combined NF -Locator/Function
> uSID variant where the REPLACE-C-SID uses a 32-bit combined
> NF-Locator/Function.
>
>
>
> <https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.iana.org%2Fassignments%2Fsegment-routing%2Fsegment-routing.xhtml&data=04%7C01%7Cjames.n.guichard%40futurewei.com%7C02af79e38912473c50e108d97f6b41be%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637680920918419645%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=QYAGkTnNs0Bfb768auk2U%2BzykfOw%2BPmF609Dj6gwlIQ%3D&reserved=0>
>
>
>
> <https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fhtml%2Fdraft-cl-spring-generalized-srv6-for-cmpr-03&data=04%7C01%7Cjames.n.guichard%40futurewei.com%7C02af79e38912473c50e108d97f6b41be%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637680920918419645%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=xQXCNLDdSC4XXjdZXrLM05BxJ11M4cSZPtI2pSGURAA%3D&reserved=0>
>
>
>
> <https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fhtml%2Fdraft-filsfils-spring-net-pgm-extension-srv6-usid-10&data=04%7C01%7Cjames.n.guichard%40futurewei.com%7C02af79e38912473c50e108d97f6b41be%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637680920918429635%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=6CispEy1z1jsNI5LzPsbMA3aIlsImAZ4dgWZFrIneYk%3D&reserved=0>
>
>
>
> Kind Regards
>
>
>
> Gyan
>
> --
>
>
> <https://nam11.safelinks.protection.outlook.com/?url=http%3A%2F%2Fwww.verizon.com%2F&data=04%7C01%7Cjames.n.guichard%40futurewei.com%7C02af79e38912473c50e108d97f6b41be%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637680920918429635%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=1ByliHlPrZzPB60cwrVTmTOwT2q%2B4%2BUBNDdLA4CC5%2Bs%3D&reserved=0>
>
> *Gyan Mishra*
>
> <https://nam11.safelinks.protection.outlook.com/?url=http%3A%2F%2Fwww.verizon.com%2F&data=04%7C01%7Cjames.n.guichard%40futurewei.com%7C02af79e38912473c50e108d97f6b41be%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637680920918439634%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=uXz1BTmNxaOSWuBsAtojA8XcK8oFv27Ptx63%2FU0vSLE%3D&reserved=0>
>
> *Gyan Mishra*
>
-- 

*Gyan Mishra*

*M 301 502-1347*

---

From: Ron Bonica <[email-masked]>
Date: Fri, 24 Sep 2021 17:30:15 +0000

Gyan,

You raise a very good point. In the analysis document, Tables 1 through 6 and Tables 12 through 15 each contain only one column for the CSID. They do not indicate whether the number in that column were calculated using the NEXT-C-SID, REPLACE-C-SID, or NEXT-AND-REPLACE-C-SID. (That is, the do not indicate whether they were calculated using uSID, G-SID, or a combination of both).

Each of these tables should be modified, so that the CSID column is replaced by three columns (NEXT-C-SID, REPLACE-C-SID, and NEXT-AND-REPLACE-C-SID).

If the numbers in these columns are different from one another, this may inform our discussion about whether NEXT-C-SID, REPLACE-C-SID, and NEXT-AND-REPLACE-C-SID are different behaviors or different flavors of a behavior.

                                                                               Ron

Juniper Business Use Only
From: spring <[email-masked]> On Behalf Of Gyan Mishra
Sent: Friday, September 24, 2021 9:56 AM
To: SPRING WG <[email-masked]>; [email-masked]; [email-masked]
Subject: Re: [spring] draft-filsfilscheng-spring-srv6-srh-compression-02#section-4.1.1

[External Email. Be cautious of content]

Dear Spring Authors

Please respond to this question the WG has related to which of the three SRv6 forwarding mechanisms called  flavors was inclusive of the compression analysis draft.

The Analysis draft is ambiguous as to which SRv6 forwarding plane flavor was part of the analysis.

This is a critical question that has come up by the WG and Chairs, and answering this question will help pave the way to an adoption call for C-SID.

Kind Regards

Gyan

On Sun, Sep 19, 2021 at 3:33 PM Gyan Mishra <[email-masked]<mailto:[email-masked]>> wrote:
Dear Authors

https://www.iana.org/assignments/segment-routing/segment-routing.xhtml<https://urldefense.com/v3/__https:/www.iana.org/assignments/segment-routing/segment-routing.xhtml__;!!NEt6yMaO-gk!XJMCrXOtpr7xttMYGJp3u6tAqsuXrjU7AVELZIzIUxBfFYjzkcL6axEYZR-kW_YB$>

G-SID - Generalized SID "REPLACE-C-SID"
https://datatracker.ietf.org/doc/html/draft-cl-spring-generalized-srv6-for-cmpr-03<https://urldefense.com/v3/__https:/datatracker.ietf.org/doc/html/draft-cl-spring-generalized-srv6-for-cmpr-03__;!!NEt6yMaO-gk!XJMCrXOtpr7xttMYGJp3u6tAqsuXrjU7AVELZIzIUxBfFYjzkcL6axEYZXk5kUTn$>

SRv6 uSID micro-segment " NEXT-C-SID"
https://datatracker.ietf.org/doc/html/draft-filsfils-spring-net-pgm-extension-srv6-usid-10<https://urldefense.com/v3/__https:/datatracker.ietf.org/doc/html/draft-filsfils-spring-net-pgm-extension-srv6-usid-10__;!!NEt6yMaO-gk!XJMCrXOtpr7xttMYGJp3u6tAqsuXrjU7AVELZIzIUxBfFYjzkcL6axEYZWozRCLY$>

Kind Regards

Gyan
--

[http://ss7.vzw.com/is/image/VerizonWireless/vz-logo-email]<https://urldefense.com/v3/__http:/www.verizon.com/__;!!NEt6yMaO-gk!XJMCrXOtpr7xttMYGJp3u6tAqsuXrjU7AVELZIzIUxBfFYjzkcL6axEYZVS6oNsY$>

Gyan Mishra

M 301 502-1347

--

[http://ss7.vzw.com/is/image/VerizonWireless/vz-logo-email]<https://urldefense.com/v3/__http:/www.verizon.com/__;!!NEt6yMaO-gk!XJMCrXOtpr7xttMYGJp3u6tAqsuXrjU7AVELZIzIUxBfFYjzkcL6axEYZVS6oNsY$>

Gyan Mishra

M 301 502-1347

---

From: "Darren Dukes (ddukes)" <[email-masked]>
Date: Fri, 24 Sep 2021 18:15:59 +0000

Section 6.1

On 2021-09-24, 10:53 AM, "Gyan Mishra" <[email-masked]> wrote:

Thank you Darren!

Few comments.

“CSID draft recommended NEXT-C-SID use for 16-bit C-SIDs, and REPLACE-C-SID use for 32-bit C-SIDs. “

Kind Regards

Gyan

Dear Authors

Kind Regards

Gyan
--

Gyan Mishra

M 301 502-1347

--

Gyan Mishra

M 301 502-1347

---

From: Gyan Mishra <[email-masked]>
Date: Fri, 24 Sep 2021 14:46:24 -0400

Hi Darren

Was there any preference by the DT members or authors on the REPLACE-SID /
 G-SID draft solution recommended for 32 bit SID over the NEXT-SID / uSID
draft solution recommended for 16-bit SID, which of the two solutions works
best for both 16 bit or 32 bit or even different bit boundaries for example
MPLS 20 bit label or go even smaller 8 or 12 bit we mentioned by Robert.

Kind Regards

Gyan

-- 

*Gyan Mishra*

*M 301 502-1347*

---

From: "Darren Dukes (ddukes)" <[email-masked]>
Date: Mon, 27 Sep 2021 17:22:48 +0000

Was: Re: [spring] draft-filsfilscheng-spring-srv6-srh-compression-02#section-4.1.1

I’m sending this note to redirect this question to the srcomp DT for an editorial fix, when the team meets next.

For the DT:
Each proposal, introduced in section 1, discusses how it supports 16-bit and 32-bit SIDs. However, Gyan’s question indicates this could be more clearly stated in the analysis draft to help readers less familiar with a proposal.  As such, section 1 can be improved accordingly.

Darren

On 2021-09-24, 1:32 PM, "spring" <[email-masked]> wrote:

Gyan,

                                                                               Ron

Dear Spring Authors

Kind Regards

Gyan

Kind Regards

Gyan
--

Gyan Mishra

M 301 502-1347

--

Gyan Mishra

M 301 502-1347