Subject: Re: [Srcomp] Addressing requirement

From: "Darren Dukes (ddukes)" <[email-masked]>
Date: Wed, 3 Mar 2021 04:02:08 +0000

Hi team, we've discussed this in the past and had nearly concluded on the text from the backlog.  I believe we are better off sticking with a version of it or dropping the requirement all together.  As it is, no proposal considered is requiring specific address types or values.

https://mailarchive.ietf.org/arch/msg/srcomp/w6Xcul19QZuOcyf07Jp6yDdNRW8/

4.1.  Address Planning
   Description: The compression mechanism MUST support flexible IPv6
   address planning, and MUST NOT rely on specific address type and
   address value.  Also, It MUST support deployment by using GUA from
   different address blocks.

   Rationale: The address planning of the network may vary based on the
   addressing scheme of the operator, so the solution MUST support a
   flexible addressing scheme.  Operators need to deploy the solution
   based on their own address planning.

   Metric: A solution requiring a specific addressing scheme may not be
   compliant

Darren

On 2021-02-25, 12:43 PM, "Srcomp" <[email-masked]> wrote:

Folks,

The following is a reworking of the addressing requirement.

                                       Ron

Short Name: Addressing

Description: The compression mechanism MUST support any addressing plan and it MUST NOT require the excessive address space consumption.

Rationale: Network operators require addressing plan flexibility. They may be forced to adopt an addressing plan by corporate organization, mergers or government mandates.

Metric: The compression mechanism MUST work and provide adequate compression in any of the following addressing plans:

-          All locators are drawn from a single GUA /48

-          All locators are drawn from a single ULA /48

-          All locators except for the last is drawn from a single GUA or ULA /48. The final locator is drawn from a multicast prefix

-          Each locator is drawn from a different GUA /32

-          Each locator is drawn from a different GUA /16

-          Each locator is drawn from a different GUA /8

In all case, each node MUST allocate no more that a /60 to its locators.

Juniper Business Use Only

---

From: "Chengli (Cheng Li)" <[email-masked]>
Date: Wed, 3 Mar 2021 06:43:21 +0000

Agree. The weird thing is that we seem to discuss again and again like we never discuss before, but actually we have done the work.

It may be a good timing to finish the rest requirement items.
I guess they are less than 5,  may be 3. Let's do it tonight or one more meeting. Hopefully!

Thanks,
Cheng

From: Srcomp [mailto:[email-masked]] On Behalf Of Darren Dukes (ddukes)
Sent: Wednesday, March 3, 2021 12:02 PM
To: Ron Bonica <rbonica=[email-masked]>; [email-masked]
Subject: Re: [Srcomp] Addressing requirement

4.1.  Address Planning

Darren

On 2021-02-25, 12:43 PM, "Srcomp" <[email-masked]<mailto:[email-masked]>> wrote:

Folks,

                                       Ron

Short Name: Addressing

---

From: Ron Bonica <[email-masked]>
Date: Wed, 3 Mar 2021 11:20:04 +0000

Darren,

As you might expect, I strongly disagree.

Can you offer some technical reason why the proposed text should not be included?

Is the only reason that you have succeeded in keeping it in the parking lot until now?

Ron

Sent from my iPhone

On Mar 2, 2021, at 11:02 PM, Darren Dukes (ddukes) <ddukes=[email-masked]> wrote:

[External Email. Be cautious of content]

4.1.  Address Planning

Darren

Folks,

                                       Ron

Short Name: Addressing

---

From: Ron Bonica <[email-masked]>
Date: Wed, 3 Mar 2021 11:25:31 +0000

Actually, it comes up on the agenda again and again, but is never discussed. It is put in the backlog in favor of easier requirements.

Now we are at the end of the backlog. It is time to discuss the difficult ones

Ron

Sent from my iPhone

On Mar 3, 2021, at 1:43 AM, Chengli (Cheng Li) <[email-masked]> wrote:

It may be a good timing to finish the rest requirement items.
I guess they are less than 5,  may be 3. Let’s do it tonight or one more meeting. Hopefully!

Thanks,
Cheng

https://mailarchive.ietf.org/arch/msg/srcomp/w6Xcul19QZuOcyf07Jp6yDdNRW8/<https://urldefense.com/v3/__https://mailarchive.ietf.org/arch/msg/srcomp/w6Xcul19QZuOcyf07Jp6yDdNRW8/__;!!NEt6yMaO-gk!S3_VAtfhKVT7_GuDTfc8uiAoiRV49thxvBlFUhCi-hVh3R3NZBd4vDlmXEjTNxtd$>

4.1.  Address Planning

Darren

Folks,

                                       Ron

Short Name: Addressing

---

From: "Darren Dukes (ddukes)" <[email-masked]>
Date: Wed, 3 Mar 2021 12:03:07 +0000

The text I quoted is the proposed text from the parking lot/backlog document.

Darren

On 2021-03-03, 6:20 AM, "Ron Bonica" <rbonica=[email-masked]> wrote:

Darren,

Ron
Sent from my iPhone

4.1.  Address Planning

Darren

Folks,

                                       Ron

Short Name: Addressing