Subject: [Srcomp] Analysis Text: Operational

From: "Darren Dukes (ddukes)" <[email-masked]>
Date: Tue, 23 Mar 2021 02:48:52 +0000

Following up on last week’s actions, I’ve attached the proposed text for Operational Requirements

3.3.  Operational Requirements

3.3.1.  Lossless Compression

   A path traversed using a compressed SID list MUST always be the same
   as the path traversed using the uncompressed SID list if no
   compression was applied.

   +-------------+------+------------------+-------------------+-------+
   |             | CSID | CRH              | VSID              | UIDSR |
   +-------------+------+------------------+-------------------+-------+
   | Lossless    | Yes  | No Heterogeneous | No Heterogeneous  |       |
   | Compression |      | SID lists        | SID lists require |       |
   |             |      | require binding  | binding SIDs      |       |
   |             |      | SIDs             |                   |       |
   +-------------+------+------------------+-------------------+-------+

   Conclusion: CSID provides lossless compression for all deployments.

3.4.  Scalability Requirements

   The compression proposal MUST be capable of representing 65000
   adjacency segments per node.

   The compression proposal MUST be capable of representing 1 million
   prefix segments per SID numbering space.

   The compression proposal MUST be capable of representing 1 million
   services per node.

       +-------------------------------+------+-----+------+-------+
       |                               | CSID | CRH | VSID | UIDSR |
       +-------------------------------+------+-----+------+-------+
       | Adjacency Segment Scale 65000 | Yes  | Yes | Yes  |       |
       | Prefix Segment Scale 1000000  | Yes  | Yes | Yes  |       |
       | Service Scale 1000000         | Yes  | Yes | Yes  |       |
       +-------------------------------+------+-----+------+-------+

   Conclusion: All proposals support 16-bit and 32-bit variants to
   support large scale deployments

---

From: Ron Bonica <[email-masked]>
Date: Tue, 23 Mar 2021 14:11:48 +0000

Darren,

I strongly disagree with your analysis of CRH in Section 3.3.1. The corresponding metric says:

  *   Information present in the pre-compression segment list MUST also be present in the post-compression SID list.

It doesn't say that compression mechanism can't achieve this in one corner case using a binding SID. You say that it is not compliant because it requires a binding SID. This doesn't follow.

                                                                                                          Ron

Juniper Business Use Only
From: Srcomp <[email-masked]> On Behalf Of Darren Dukes (ddukes)
Sent: Monday, March 22, 2021 10:49 PM
To: [email-masked]
Subject: [Srcomp] Analysis Text: Operational

[External Email. Be cautious of content]

Following up on last week's actions, I've attached the proposed text for Operational Requirements