Subject: [Srcomp] Draft meeting minutes: 3/03/2021

From: Ron Bonica <[email-masked]>
Date: Wed, 3 Mar 2021 22:15:39 +0000

Attendees: Weiqiang, Chongfeng, Ron, Cheng, Darren, Peng, Wim (for part of the meeting)

RESOLVED
--------------

  *   Move Point to Multipoint Requirement (provided below) to the appendix for disputed requirements
  *   Move the PS/BCP requirement (provided below) to the main body of the document
  *   The group will meet at 1300 UTC on Friday with the following goals
     *   Finalize the addressing plane requirement, if agreement is not reached by email before then. See Action items.
     *   Finalize the parsing requirement
     *   Finalize the document so that we are ready for a call for adoption after IETF 110

DISCUSSED
---------------

  *   All present agreed on the text of the flexible addressing requirement (provided below). See Action Items.
  *   We are close to agreement on the parsing requirement. The remaining point of contention is regarding the final sentence of the metric, regarding debugging.
  *   Ron will take minutes going forward

ACTION ITEMS
---------------------

  *   All who were not present for the discussion regarding the flexible addressing requirement should read the text provided below and indicate whether they are OK with the text.
  *   All to review and comment on the use-cases that Darren proposed for the analysis document

REFERENCED REQUIREMENTS
------------------------------------------

Short Name: Point to Multipoint

Description: The compression mechanism SHOULD support point-to-multipoint SR paths.

Rationale: Many VPN services require point-to-multipoint SR paths.

Metric: A compliant proposal can encode a multicast address in the ultimate segment of the segment list.

PS or BCP Compliance

Description: The compression mechanism SHOULD comply with any proposed standard or BCP. If it does not comply with any PS or BCP it SHOULD update the related document.

Rationale: Compliance with existing standards makes the internet more robust.

Metric: A solution that complies with PS or BCP, or updates PS or BCP satisfies this requirement. The PS or BCP document may be updated at any time before the publication of the document specifying the compression mechanism.

Address Planning

Description: Network operators require addressing plan flexibility, The compression mechanism MUST support flexible IPv6 address planning, it MUST support deployment by using GUA from different address blocks.

Rationale: The address planning of the network may vary based on the addressing scheme of the operator, so the solution MUST support a flexible addressing scheme. Operators need to deploy the solution based on their own address planning.

Metric: The compression proposal supports locators drawn from different prefixes with the solutions analysis indicating efficiency.

Juniper Business Use Only

---

From: "Darren Dukes (ddukes)" <[email-masked]>
Date: Fri, 5 Mar 2021 12:39:11 +0000

Clarification on the addressing requirement:  Those present discussed the text and agreed to send it to the list for review.

Darren

On 2021-03-03, 5:16 PM, "Srcomp" <[email-masked]> wrote:

RESOLVED
--------------

-          Move Point to Multipoint Requirement (provided below) to the appendix for disputed requirements

-          Move the PS/BCP requirement (provided below) to the main body of the document

-          The group will meet at 1300 UTC on Friday with the following goals

o   Finalize the addressing plane requirement, if agreement is not reached by email before then. See Action items.

o   Finalize the parsing requirement

o   Finalize the document so that we are ready for a call for adoption after IETF 110

DISCUSSED
---------------

-          All present agreed on the text of the flexible addressing requirement (provided below). See Action Items.

-          We are close to agreement on the parsing requirement. The remaining point of contention is regarding the final sentence of the metric, regarding debugging.

-          Ron will take minutes going forward

ACTION ITEMS
---------------------

-          All who were not present for the discussion regarding the flexible addressing requirement should read the text provided below and indicate whether they are OK with the text.

-          All to review and comment on the use-cases that Darren proposed for the analysis document

REFERENCED REQUIREMENTS

PS or BCP Compliance

Address Planning