Subject: [Srcomp] New CSID Entities

From: Ron Bonica <[email-masked]>
Date: Mon, 29 Mar 2021 20:59:42 +0000

Darren,

In the analysis document, we say:

"CSID - [I-D.filsfilscheng-spring-srv6-srh-comp-sl-enc] - Describes two new SRv6 SIDs, a combination of SIDs from [I-D.filsfils-spring-net-pgm-extension-srv6-usid] and  [I-D.cl-spring-generalized-srv6-for-cmpr]".

In draft-filsfilscheng-spring-srv6-srh-comp-sl-enc, the authors say:

"This section defines several options to achieve compressed Segment List encoding, in the form of two new flavors for the END, END.X and  END.T behaviors of [I-D.ietf-spring-srv6-network-programming].  These    flavors could also be combined with behaviors defined in other  documents."

What are we defining? New SIDs or new flavors for END and END.T.

Does CSID provide compression for paths containing only END.X segments? If so, how does the compression work?

                                                                                                                   Ron

Juniper Business Use Only

---

From: "Darren Dukes (ddukes)" <[email-masked]>
Date: Wed, 31 Mar 2021 02:23:38 +0000

Hi Ron, please see inline [DD]

On 2021-03-29, 5:00 PM, "Srcomp" <[email-masked]> wrote:

Darren,

“CSID - [I-D.filsfilscheng-spring-srv6-srh-comp-sl-enc] - Describes two new SRv6 SIDs, a combination of SIDs from [I-D.filsfils-spring-net-pgm-extension-srv6-usid] and  [I-D.cl-spring-generalized-srv6-for-cmpr]”.

“This section defines several options to achieve compressed Segment List encoding, in the form of two new flavors for the END, END.X and  END.T behaviors of [I-D.ietf-spring-srv6-network-programming].  These    flavors could also be combined with behaviors defined in other  documents.”

[DD] The draft defines new SID behaviors, those behaviors are flavors of END, END.X, END.T.

[DD] Yes it does, section 5.2 indicates how local C-SID “may identify a cross-connect to a direct neighbor over a specific interface or a VPN context.”

Darren

                                                                                                                   Ron

---

From: Ron Bonica <[email-masked]>
Date: Wed, 31 Mar 2021 17:45:32 +0000

Darren,

If [I-D.filsfilscheng-spring-srv6-srh-comp-sl-enc] describes new SID behaviors, the text in the analysis draft should read:

  *   "CSID - [I-D.filsfilscheng-spring-srv6-srh-comp-sl-enc] - Requires three new SRv6 SID *behaviors*,  NEXT-C-SID, REPLACE-C-SID, and NEXT-AND-REPLACE- C-SID.

However, you may be creating a new SID, also. In Section 3.1 of RFC 8986, you say that a SID has a locator, function and arguments. The arguments are processed on the node that instantiates the SID. In Sections 4.1 and 4.2 of [I-D.filsfilscheng-spring-srv6-srh-comp-sl-enc], you say that a SID contains:

  *   A locator block (B)
  *   A NF (but you never tell us what NF stands for)
  *   Arguments

The NF contains:

  *   A locator node
  *   A function

The argument carries the remaining C-SIDs in the current C-SID container.

If that is the case, where are the arguments that are processed on each node along the path. For example, assume that the SR-path consists of END.X segments only. Where are the arguments that identify the outbound interface. Shouldn't they be included in NF?

                                                                                                                            Ron

Juniper Business Use Only
From: Darren Dukes (ddukes) <ddukes=[email-masked]>
Sent: Tuesday, March 30, 2021 10:24 PM
To: Ron Bonica <[email-masked]>; srcomp <[email-masked]>
Subject: Re: New CSID Entities

[External Email. Be cautious of content]

On 2021-03-29, 5:00 PM, "Srcomp" <[email-masked]<mailto:[email-masked]>> wrote:

Darren,

[DD] Yes it does, section 5.2 indicates how local C-SID "may identify a cross-connect to a direct neighbor over a specific interface or a VPN context."

Darren

                                                                                                                   Ron