Subject: [Srcomp] Draft meeting minutes: 3/15/2021

From: Ron Bonica <[email-masked]>
Date: Thu, 18 Mar 2021 17:29:30 +0000

Attendees: Weiqiang, Wim, Ron, Cheng, Darren, Peng

RESOLVED
--------------

  *   Requirements Document
     *   Complete, unless there are comments from the WG
     *   The appendix will remain
     *   Items in the appendix will be discussed in the analysis document
     *   Weiqiang will notify the WG

  *   DT will focus on the analysis document until the it concludes

DISCUSSED
---------------

  *   Analysis Document: Compression Requirements
     *   Discussed the reference topology
        *   Not clear whether each subdomain is a Autonomous System, ISIS level or OSPF Area
        *   Not clear whether we need two ASBRs border or a single ABR
        *   At least for the purposes of calculating encapsulation overhead
     *   Encapsulation Header Size
        *   Concluded that independent variables are SRv6BlockSize, SIDSize, and Number of Segments. Dependent variable is compression efficiency
        *   For the time being, we will express all of this in an Excel spreadsheet.
        *   We will reformat it into the document when we agree on the numbers

ACTION ITEMS
---------------------

  *   Weiqiang will notify the WG of the status of the Requirements Document (See resolved items)
  *   Ron to generate the above mentioned Excel spread sheet
     *   Ron to generate numbers for CRH-16 and CRH-32
     *   Darren to generate numbers for CSID-16 and CSID-32
     *   PSF to generate numbers for USID-16 and USID-32
     *   Somebody (???) to generate numbers for VSID
     *   All to check each other's numbers

Juniper Business Use Only

---

From: "Chengli (Cheng Li)" <[email-masked]>
Date: Fri, 19 Mar 2021 08:12:55 +0000

Hi Ron,

I guess I will work with Darren to generate the C-SID result? I did not hear this decision in last meeting, sorry for my late.
Also, we provided a VSID analysis data in an email several weeks ago, I guess we may can generate the result based on that.

BTW, many thanks for the sheets! C-SID and V-SID results can be filled in that.

Thanks,
Cheng

From: Srcomp [mailto:[email-masked]] On Behalf Of Ron Bonica
Sent: Friday, March 19, 2021 1:30 AM
To: [email-masked]
Subject: [Srcomp] Draft meeting minutes: 3/15/2021

RESOLVED
--------------

-          Requirements Document
o   Complete, unless there are comments from the WG
o   The appendix will remain
o   Items in the appendix will be discussed in the analysis document
o   Weiqiang will notify the WG

-          DT will focus on the analysis document until the it concludes

DISCUSSED
---------------
-          Analysis Document: Compression Requirements
o   Discussed the reference topology
?  Not clear whether each subdomain is a Autonomous System, ISIS level or OSPF Area
?  Not clear whether we need two ASBRs border or a single ABR
?  At least for the purposes of calculating encapsulation overhead
o   Encapsulation Header Size
?  Concluded that independent variables are SRv6BlockSize, SIDSize, and Number of Segments. Dependent variable is compression efficiency
?  For the time being, we will express all of this in an Excel spreadsheet.
?  We will reformat it into the document when we agree on the numbers

ACTION ITEMS
---------------------
-          Weiqiang will notify the WG of the status of the Requirements Document (See resolved items)
-          Ron to generate the above mentioned Excel spread sheet
o   Ron to generate numbers for CRH-16 and CRH-32
o   Darren to generate numbers for CSID-16 and CSID-32
o   PSF to generate numbers for USID-16 and USID-32
o   Somebody (???) to generate numbers for VSID
o   All to check each other's numbers

---

From: Ron Bonica <[email-masked]>
Date: Sun, 21 Mar 2021 22:22:12 +0000

Chengli,

I can also generate VSID results. If we are lucky, we will get the same answers 😉

I think that we should also invite Bruno into this exercise, as VSID is the only compression mechanism without a proponent on the design team.

Weiqiang, what do you think?

                                                                               Ron

Juniper Business Use Only
From: Chengli (Cheng Li) <[email-masked]>
Sent: Friday, March 19, 2021 4:13 AM
To: Ron Bonica <[email-masked]>; [email-masked]
Subject: RE: Draft meeting minutes: 3/15/2021

[External Email. Be cautious of content]

Hi Ron,

Thanks,
Cheng

From: Srcomp [mailto:[email-masked]] On Behalf Of Ron Bonica
Sent: Friday, March 19, 2021 1:30 AM
To: [email-masked]<mailto:[email-masked]>
Subject: [Srcomp] Draft meeting minutes: 3/15/2021

RESOLVED
--------------

  *   Requirements Document

DISCUSSED
---------------

ACTION ITEMS
---------------------

     *   All to check each other’s numbers

---

From: "Chengli (Cheng Li)" <[email-masked]>
Date: Tue, 23 Mar 2021 08:24:58 +0000

Cool. Multiple analysis are good, and they will converge into one finally. So please feel free to generate VSID results.

We will generate vSID and C-SID results as well. Let me discuss with Bruno about vSID, but I guess he will be happy if more people to generate the results.

Thanks,
Cheng

From: Ron Bonica [mailto:[email-masked]]
Sent: Monday, March 22, 2021 6:22 AM
To: Chengli (Cheng Li) <[email-masked]>; [email-masked]
Subject: RE: Draft meeting minutes: 3/15/2021

Chengli,

                                                                               Ron

Juniper Business Use Only
From: Chengli (Cheng Li) <[email-masked]<mailto:[email-masked]>>
Sent: Friday, March 19, 2021 4:13 AM
To: Ron Bonica <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Subject: RE: Draft meeting minutes: 3/15/2021

Hi Ron,

Thanks,
Cheng

RESOLVED
--------------

-          Requirements Document

DISCUSSED
---------------
-          Analysis Document: Compression Requirements
o   Discussed the reference topology
§  Not clear whether each subdomain is a Autonomous System, ISIS level or OSPF Area
§  Not clear whether we need two ASBRs border or a single ABR
§  At least for the purposes of calculating encapsulation overhead
o   Encapsulation Header Size
§  Concluded that independent variables are SRv6BlockSize, SIDSize, and Number of Segments. Dependent variable is compression efficiency
§  For the time being, we will express all of this in an Excel spreadsheet.
§  We will reformat it into the document when we agree on the numbers

ACTION ITEMS
---------------------
o   All to check each other’s numbers