Subject: [Srcomp] Compression analysis data from Feb 11 analysis

From: "Darren Dukes (ddukes)" <[email-masked]>
Date: Wed, 24 Mar 2021 01:41:29 +0000

Hey team, I’ve included the analysis data used in the February 11th analysis text for 1, 2 and 3 sub-domains with varying segment list lengths, along with the python functions that generated it.

I reviewed the VSID data with Cheng last night.
I omitted the CRH data, but I can add it back in.  It matched Ron’s CRH length in 1 sub domain.

Darren

---

From: Ron Bonica <[email-masked]>
Date: Mon, 29 Mar 2021 21:32:25 +0000

Darren,

In  E_NEXT(B, NF, Dn, Sn, Vn), are you making the following assumptions?

  *   That srv6 domain blocks are swapped only at domain boundaries
  *   That all CSID, including the VPN SID, are encoded in 16bits

                                                                              Ron

Juniper Business Use Only
From: Srcomp <[email-masked]> On Behalf Of Darren Dukes (ddukes)
Sent: Tuesday, March 23, 2021 9:41 PM
To: [email-masked]
Subject: [Srcomp] Compression analysis data from Feb 11 analysis

[External Email. Be cautious of content]

Hey team, I've included the analysis data used in the February 11th analysis text for 1, 2 and 3 sub-domains with varying segment list lengths, along with the python functions that generated it.

I reviewed the VSID data with Cheng last night.
I omitted the CRH data, but I can add it back in.  It matched Ron's CRH length in 1 sub domain.

Darren

---

From: "Darren Dukes (ddukes)" <[email-masked]>
Date: Wed, 31 Mar 2021 02:23:42 +0000

Hi Ron,

It assumes blocks differ per sub-domain (though they don’t have to).
It assumes all SIDs are encoded as 16 bits, including the VPN SID.

Darren

On 2021-03-29, 5:32 PM, "Ron Bonica" <rbonica=[email-masked]> wrote:

Darren,

-          That srv6 domain blocks are swapped only at domain boundaries

-          That all CSID, including the VPN SID, are encoded in 16bits

                                                                              Ron

Darren

---

From: Ron Bonica <[email-masked]>
Date: Wed, 31 Mar 2021 17:48:47 +0000

Darren,

I don't think that it is safe to assume that blocks won't differ within a sub-domain.

Let's discuss this at the next meeting.

                                         Ron

Juniper Business Use Only
From: Darren Dukes (ddukes) <ddukes=[email-masked]>
Sent: Tuesday, March 30, 2021 10:24 PM
To: Ron Bonica <[email-masked]>; [email-masked]
Subject: Re: Compression analysis data from Feb 11 analysis

Hi Ron,

It assumes blocks differ per sub-domain (though they don't have to).
It assumes all SIDs are encoded as 16 bits, including the VPN SID.

Darren

On 2021-03-29, 5:32 PM, "Ron Bonica" <rbonica=[email-masked]<mailto:rbonica=[email-masked]>> wrote:

Darren,

                                                                              Ron

Juniper Business Use Only
From: Srcomp <[email-masked]<mailto:[email-masked]>> On Behalf Of Darren Dukes (ddukes)
Sent: Tuesday, March 23, 2021 9:41 PM
To: [email-masked]<mailto:[email-masked]>
Subject: [Srcomp] Compression analysis data from Feb 11 analysis

Darren