Subject: RE: Using DNS for SSM

From: Sunny Schoch <[email-masked]>
Date: Wed, 14 Feb 2001 11:58:22 -0800

> I don't see the rationale for making the source the primary 
> key and the
> channels the secondary keys.  I think apps will more likely know the
> channel (DNS name) and want a listing of servers.
This method does not prevent multicast providers from configuring multiple A
records if they have multiple servers for one channel.  Users only need to
know the channel name and DNS server will resolve to one of the A records.
 
> Have you considered using some variation of SRV records so 
> that you can
> specify port numbers per server?  Depending on how you do it, 
> this would
> eliminate the need for a magic ".mcast." in the hostname.
No, we haven't considered that.  We'll look into it more.

Thanks!
Sunny

> 
> > Jeff Schoch [email-masked]
> > Operations Engineering 703-689-7716
> 
> S
> 
>      |          |         Stephen Sprunk, K5SSS, CCIE #3723
>     :|:        :|:        Network Design Consultant, GSOLE
>    :|||:      :|||:       New office: RCDN2 in Richardson, TX
> .:|||||||:..:|||||||:.    Email: [email-masked]
> 
>

---

From: Jon Crowcroft <[email-masked]>
Date: Wed, 14 Feb 2001 22:25:38 +0000

simpler

use ipv6 a records

then we are future proof.

In message <[email-masked]>, Sunny Sc

 >>> .:|||||||:..:|||||||:.    Email: [email-masked]

 cheers

   jon