Subject: [ssm] IGMP v3 packets

From: [email-masked]
Date: Mon, 23 Feb 2004 16:39:14 +0530

Hi
 
I want to refer IGMPv3 Report and Query captured packets. Packet format
is fine. I got that from RFC. But I wish to see an example of V3 Report
and Query packet. Especially when number of group records and number
source records are greater than 1.

It will be of great help for me if you could send me captured packets.

Thanks
 
Asawari Teredesai
~~~~~~~~~~~~~~~~~~~~~~~~~~~
Systems Engineer (T & I)
Wipro Technologies,
Madivala - III, Bangalore
Phone : 550 2001 Extn. 4129
~~~~~~~~~~~~~~~~~~~~~~~~~~~

---

From: Hitoshi Asaeda <[email-masked]>
Date: Mon, 23 Feb 2004 13:40:05 +0100 (MET)

> source records are greater than 1.

An attached log file was made by tcpdump on my machine (NetBSD).
("**** ****" are the address of my host and router.)

Description:
1. Host-X made an include mode join with 3 sources for one multicast
   addr
   IN (192.168.{27.108,30.249,61.65}, 232.1.1.1)
2. Host-X made an exclude mode join with 2 sources for one multicast
   addr
   EX (192.168.{29.96,32.236}, 232.1.1.2)
(Robustness value is 2 for each)
3. Host-X received a general query from Router-X
4. Host-x responded to report both of IN and EX status.

Hope this helps.
--
Hitoshi Asaeda
12:38:57.315665 Host-X > IGMP.MCAST.NET: igmp v3 report, 1 group record(s) [tos 0xc0]  [ttl 1]
			 46c0 0034 6190 0000 0102 5fcf **** ****
			 e000 0016 9404 0000 2200 3658 0000 0001
			 0500 0003 e801 0101 c0a8 1b6c c0a8 1ef9
			 c0a8 3d41
12:38:58.180050 Host-X > IGMP.MCAST.NET: igmp v3 report, 1 group record(s) [tos 0xc0]  [ttl 1]
			 46c0 0034 6192 0000 0102 5fcd **** ****
			 e000 0016 9404 0000 2200 3658 0000 0001
			 0500 0003 e801 0101 c0a8 1b6c c0a8 1ef9
			 c0a8 3d41
12:39:09.052062 Host-X > IGMP.MCAST.NET: igmp v3 report, 1 group record(s) [tos 0xc0]  [ttl 1]
			 46c0 0030 6193 0000 0102 5fd0 **** ****
			 e000 0016 9404 0000 2200 315b 0000 0001
			 0400 0002 e801 0102 c0a8 1d60 c0a8 20ec
12:39:09.380082 Host-X > IGMP.MCAST.NET: igmp v3 report, 1 group record(s) [tos 0xc0]  [ttl 1]
			 46c0 0030 6194 0000 0102 5fcf **** ****
			 e000 0016 9404 0000 2200 315b 0000 0001
			 0400 0002 e801 0102 c0a8 1d60 c0a8 20ec
12:39:15.119926 Router-X > ALL-SYSTEMS.MCAST.NET: igmp query v3 [tos 0xc0]  [ttl 1]
			 45c0 0020 0008 0000 0102 5689 **** ****
			 e000 0001 1164 ec9b 0000 0000 0200 0000
			 0000 0000 0000 0000 0000 0000 0000
12:39:21.180055 Host-X > IGMP.MCAST.NET: igmp v3 report, 2 group record(s) [tos 0xc0]  [ttl 1]
			 46c0 0044 6197 0000 0102 5fb8 **** ****
			 e000 0016 9404 0000 2200 8fb3 0000 0002
			 0100 0003 e801 0101 c0a8 1b6c c0a8 1ef9
			 c0a8 3d41 0200 0002 e801 0102 c0a8 1d60
			 c0a8 20ec

---

From: Hitoshi Asaeda <[email-masked]>
Date: Mon, 23 Feb 2004 13:40:05 +0100 (MET)

Description:

Hope this helps.