Subject: Re: [stir] A 4474 that will work through SBCs (generally/potentially)

From: Torrey Searle <[email-masked]>
Date: Sun, 9 Jun 2013 13:05:49 +0200

>I'm not sure I understand the logic here.
>Why would we trust a "not-evil" bit coming in from SS7/ISUP?
>Why wouldn't all pink carriers just start setting that bit?

In the case of

SIP->SS7->SIP

Wouldn't it be interesting for the Calling SIP party to put a signed hash

of the called/calling number into A sip header, copy that into the SS7
User-To-User

Header and then put it back into a SIP header on the destination sip leg?

That way the Destination SIP network only needs to trust the originating sip

network and not any intermediate SS7 networks.

Regards,
Torrey

---

From: "DOLLY, MARTIN C" <[email-masked]>
Date: Sun, 9 Jun 2013 13:11:46 +0000

How many octets?

From: [email-masked] [mailto:[email-masked]] On Behalf Of Torrey Searle
Sent: Sunday, June 09, 2013 7:06 AM
To: [email-masked]
Subject: Re: [stir] A 4474 that will work through SBCs (generally/potentially)

In the case of

SIP->SS7->SIP

of the called/calling number into A sip header, copy that into the SS7 User-To-User

Regards,
Torrey

---

From: Torrey Searle <[email-masked]>
Date: Sun, 9 Jun 2013 15:55:26 +0200

The only restriction is that length is encoded in one byte.  So that means
255 bytes of data.  As binary data is allowed, base64 encoding isn't needed
either.

Torrey

On Sun, Jun 9, 2013 at 3:11 PM, DOLLY, MARTIN C <[email-masked]> wrote:

>  How many octets?****
>
> ** **
>
> *From:* [email-masked] [mailto:[email-masked]] *On Behalf
> Of *Torrey Searle
> *Sent:* Sunday, June 09, 2013 7:06 AM
> *To:* [email-masked]
> *Subject:* Re: [stir] A 4474 that will work through SBCs
> (generally/potentially)****
>
> ** **
>
> >I'm not sure I understand the logic here.****
>
> >Why would we trust a "not-evil" bit coming in from SS7/ISUP?****
>
> ****
> In the case of****
> ****
> ****
> of the called/calling number into A sip header, copy that into the SS7 User-To-User****
>
> ****
> ****
> Torrey****

---

From: "DOLLY, MARTIN C" <[email-masked]>
Date: Sun, 9 Jun 2013 13:59:49 +0000

Answer the question... I wrote the ISUP standard

From: Torrey Searle [mailto:[email-masked]]
Sent: Sunday, June 09, 2013 9:55 AM
To: DOLLY, MARTIN C
Cc: [email-masked]
Subject: Re: [stir] A 4474 that will work through SBCs (generally/potentially)

The only restriction is that length is encoded in one byte.  So that means 255 bytes of data.  As binary data is allowed, base64 encoding isn't needed either.
Torrey

On Sun, Jun 9, 2013 at 3:11 PM, DOLLY, MARTIN C <[email-masked]<mailto:[email-masked]>> wrote:
How many octets?

From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of Torrey Searle
Sent: Sunday, June 09, 2013 7:06 AM
To: [email-masked]<mailto:[email-masked]>
Subject: Re: [stir] A 4474 that will work through SBCs (generally/potentially)

In the case of

SIP->SS7->SIP

Regards,
Torrey

---

From: Richard Barnes <[email-masked]>
Date: Mon, 10 Jun 2013 12:38:10 -0400

The ante for RSA signatures is 256 bytes, for ECDSA signatures 32-48 bytes.
 A SHA-256 digest is 32 bytes long.  So (1) RSA probably isn't feasible,
and (2) with EC, you're talking 64-96 bytes.

On Sun, Jun 9, 2013 at 9:59 AM, DOLLY, MARTIN C <[email-masked]> wrote:

>  Answer the question… I wrote the ISUP standard****
>
> ** **
>
> *From:* Torrey Searle [mailto:[email-masked]]
> *Sent:* Sunday, June 09, 2013 9:55 AM
> *To:* DOLLY, MARTIN C
> *Cc:* [email-masked]
>
> either.****
> On Sun, Jun 9, 2013 at 3:11 PM, DOLLY, MARTIN C <[email-masked]> wrote:***
> *
>
> How many octets?****
>
>  ****
>
> >Why wouldn't all pink carriers just start setting that bit?****
>
> In the case of****
>
> SIP->SS7->SIP  ****
>
> Wouldn't it be interesting for the Calling SIP party to put a signed hash****
>
> That way the Destination SIP network only needs to trust the originating sip****
>
> network and not any intermediate SS7 networks.****
>
> Regards,
> Torrey****
>
>    ** **
>
> _______________________________________________
> stir mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/stir
>
>

---

From: Stephen Farrell <[email-masked]>
Date: Mon, 10 Jun 2013 17:47:57 +0100

> and (2) with EC, you're talking 64-96 bytes.

...and (2) comes with IPR fun/FUD of course. RSA and EC also have
slightly different performance characteristics that sometimes (but
maybe not here) need to be considered.

Just noting that since I'm not sure if this community are familiar
with those issues -  participants in the putative wg will need to
consider stuff like that while thinking about what alg(s) to have
as a MUST implement. (Which is down the road some way I guess.)

S.

---

From: Hadriel Kaplan <[email-masked]>
Date: Mon, 10 Jun 2013 12:59:19 -0400

I was under the impression the User-to-user param didn't often survive very far on SS7, not beyond the local carrier.  True?

-hadriel