Subject: [stir] "Doctor" problem

From: "Anton Tveretin" <[email-masked]>
Date: Mon, 24 Jun 2013 22:59:54 +0600

Hello All,
Let me recall. A doctor makes a call from home, but she wants this call to 
appear as it is coming from her office.
If she is able to connect to office's SP (proxy or B2BUA) and authenticate, 
there will be no problem at all. Just IP-based routing.
But I think this is not the thing that is discussed. The credentials could 
be unavailable (esp. it is a SIM rather than password). But in this case, 
there will be just 2 identities (say doctor@home and doctor@office). The 
fact the person is the same does not matter. So we speak of something like a 
power of attorney granted by doctor@office to doctor@home. So consider the 
following:
1. Should this permission be dispathed from office SP to home SP 
immediately, or requsted on demand? Which methods (and protocols) to use?
In the former case, something  like e-mail or fax could be used (or leave 
this unspecified). In the latter case, real-time is unavoidable.
2. Should home SP route this call through office SP or not? If yes, how? Are 
there reasons for charging?
3. Should P-A-I be doctor@home or doctor@office? If former, would any entity 
consider this call spoofed?
Regards,
Anton

---

From: Brian Rosen <[email-masked]>
Date: Mon, 24 Jun 2013 14:04:11 -0400

What we have been discussing is inline below
On Jun 24, 2013, at 12:59 PM, Anton Tveretin <[email-masked]> wrote:

> Hello All,
> Let me recall. A doctor makes a call from home, but she wants this call to appear as it is coming from her office.
> If she is able to connect to office's SP (proxy or B2BUA) and authenticate, there will be no problem at all. Just IP-based routing.
> But I think this is not the thing that is discussed. The credentials could be unavailable (esp. it is a SIM rather than password). But in this case, there will be just 2 identities (say doctor@home and doctor@office). The fact the person is the same does not matter. So we speak of something like a power of attorney granted by doctor@office to doctor@home. So consider the following:
> 1. Should this permission be dispathed from office SP to home SP immediately, or requsted on demand?
Permission in advance
> Which methods (and protocols) to use?
Details to be decided, but generally, it's like another delegation - the SP office delegates the right to use the TN to SP Home

> In the former case, something  like e-mail or fax could be used (or leave this unspecified). In the latter case, real-time is unavoidable.
I think we should have a protocol for the delegation, but it's not clear that we absolutely need one

> 2. Should home SP route this call through office SP or not? If yes, how? Are there reasons for charging?
No

> 3. Should P-A-I be doctor@home or doctor@office? If former, would any entity consider this call spoofed?
Not clear we will specify.  We're not standardizing the SIP protocol for this operation, we're specifying the mechanism for assuring source identity.  Somewhat depends on the details of where the info for asserting identity & signing comes from.

> Regards,
> Anton 
> _______________________________________________
> stir mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/stir