Subject: [stir] Ben Campbell's Yes on draft-ietf-stir-rph-05: (with COMMENT)

From: Ben Campbell <[email-masked]>
Date: Thu, 17 May 2018 15:42:33 -0700

Ben Campbell has entered the following ballot position for
draft-ietf-stir-rph-05: Yes

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-stir-rph/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

Thank you for addressing my first discussion point and comments. I still have a
concern on the second discuss point:

§7.2:
   o  The verification of the signature MUST include means of verifying
      that the signer is authoritative for the signed content of the
      resource priority namespace in the PASSporT."

The authors explained via email that they expect this to depend on some ATIS
work. I understand that such work is in progress, but has not reached the point
of being citable. I don't want to see this document blocked on that work, so I
cleared my discuss. However, I still think it would be a good idea to add some
scoping text early in the document to the effect that this mechanism is
intended for environments where some means of verifying that the signer is
authoritative is available. (In addition to keeping the normative text in §7.2)

---

From: "Das, Subir" <[email-masked]>
Date: Fri, 18 May 2018 14:09:21 +0000

Hello Ben,
Thanks for clearing your  discuss. On the following point, we will add some texts in next version. 

_Subir 

§7.2:

The authors explained via email that they expect this to depend on some ATIS work. I understand that such work is in progress, but has not reached the point of being citable. I don't want to see this document blocked on that work, so I cleared my discuss. However, I still think it would be a good idea to add some scoping text early in the document to the effect that this mechanism is intended for environments where some means of verifying that the signer is authoritative is available. (In addition to keeping the normative text in §7.2)

-----Original Message-----
From: Ben Campbell <[email-masked]> 
Sent: Thursday, May 17, 2018 6:43 PM
To: The IESG <[email-masked]>
Cc: [email-masked]; Russ Housley <[email-masked]>; [email-masked]; [email-masked]; [email-masked]
Subject: Ben Campbell's Yes on draft-ietf-stir-rph-05: (with COMMENT)

When responding, please keep the subject line intact and reply to all email addresses included in the To and CC lines. (Feel free to cut this introductory paragraph, however.)

Thank you for addressing my first discussion point and comments. I still have a concern on the second discuss point:

§7.2:

The authors explained via email that they expect this to depend on some ATIS work. I understand that such work is in progress, but has not reached the point of being citable. I don't want to see this document blocked on that work, so I cleared my discuss. However, I still think it would be a good idea to add some scoping text early in the document to the effect that this mechanism is intended for environments where some means of verifying that the signer is authoritative is available. (In addition to keeping the normative text in §7.2)