Subject: [storm] New SAM3/4/5 features for iSCSI

From: "Knight, Frederick" <[email-masked]>
Date: Fri, 12 Jun 2009 12:57:28 -0400

Here is a list of differences (additions) I've found between SAM-2 and
SAM-5.  I didn't list the stuff that's been removed (like linked
commands):

1	Command Priority
2	Status Qualifier (2 bytes of additional returned status)
3	Variable length sense data (explicit in SAM5, not in SAM2) -
investigate more
4	First Burst Enable (already part of iSCSI)
5	Terminate Data Transfer service (not a TMF)
6	QUERY TASK TMF (including task progress response)
7	QUERY TASK SET TMF
8	I_T Nexus Loss response
9	Transport Reset operation
10	I_T NEXUS RESET TMF
11	QUERY ASYNCHRONOUS EVENT TMF

This seems like a good starting point for a high level list of what
needs to be added.  Are there any other things people have found?

	Fred Knight

---

From: "David Harrington" <[email-masked]>
Date: Mon, 15 Jun 2009 13:07:22 -0400

Are we going to SAM-4 or SAM-5?

I think the charter said SAM-4.

dbh 

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] 
> On Behalf Of Knight, Frederick
> Sent: Friday, June 12, 2009 12:57 PM
> To: [email-masked]
> Subject: [storm] New SAM3/4/5 features for iSCSI
> 
> _______________________________________________
> storm mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/storm
>

---

From: <[email-masked]>
Date: Mon, 15 Jun 2009 14:44:02 -0400

David (H)

The charter now says "at least SAM-4"; we need to pick up at least
some of SAM-5.  The explanation is (from my message on T10 and T11
document access):

> An important specific example is that part of the iSCSI update
> work to SAM-4 is to specify a number of new task management
> functions, including QUERY TASK.  It turns out that T10 has made
> a minor, but important, change to QUERY TASK in their ongoing
> SAM-5 work and hence the appropriate base document for this iSCSI
> work appears to be revision 1 of SAM-5, which is publicly
> accessible. 

Thanks,
--David (B)

> On Behalf Of David Harrington
> Sent: Monday, June 15, 2009 1:07 PM
> To: 'Knight, Frederick'; [email-masked]
> Subject: Re: [storm] New SAM3/4/5 features for iSCSI
>

---

From: "David Harrington" <[email-masked]>
Date: Mon, 15 Jun 2009 15:15:54 -0400

Hmmm, the charter text is now somewhat ambiguous as to scope. SAM-5 is
a moving target. I hope that doesn't bite us.

dbh 

> From: [email-masked] [mailto:[email-masked]] 
> Sent: Monday, June 15, 2009 2:44 PM
> To: [email-masked]; [email-masked]
> Cc: [email-masked]
> Subject: RE: [storm] New SAM3/4/5 features for iSCSI
> 
> David (H)
> 
> > > Here is a list of differences (additions) I've found between
SAM-2
> > and

---

From: "Knight, Frederick" <[email-masked]>
Date: Mon, 15 Jun 2009 20:21:43 -0400

To create something that is already known to be out of date at the time
it is written seems to me to be short sighted.  At some point, we will
have to draw a line, and not incorporate anything new from SAM-5, but
for now at least, I feel we should use SAM-5 as our base.

Specifically:
 http://www.t10.org/cgi-bin/ac.pl?t=f&f=sam5r01.pdf and
 http://www.t10.org/cgi-bin/ac.pl?t=f&f=sam5r02.pdf  (not posted yet).

r01 actually has an error being corrected in r02 (the QUERY TASK
addition was mistakely put in the QUERY TASK SET section instead of the
QUERY TASK function).

	Fred Knight

-----Original Message-----
From: David Harrington [mailto:[email-masked]] 
Sent: Monday, June 15, 2009 1:07 PM
To: Knight, Frederick; [email-masked]
Subject: RE: [storm] New SAM3/4/5 features for iSCSI

dbh 

> From: [email-masked] [mailto:[email-masked]] On Behalf

> Of Knight, Frederick

---

From: <[email-masked]>
Date: Mon, 15 Jun 2009 20:38:53 -0400

I agree with the concern - my hope is that we can pick a specific
version of SAM-5 and stick with it.

Thanks,
--David

> Sent: Monday, June 15, 2009 3:16 PM
> To: Black, David; [email-masked]

---

From: David Peterson <[email-masked]>
Date: Mon, 15 Jun 2009 19:53:23 -0600

Not referring to SAM-5 would be a mistake. I agree with David, stamp a version of SAM-5 at the end of the iSCSI update and we're good.

...Dave

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Monday, June 15, 2009 7:39 PM
To: [email-masked]; [email-masked]
Subject: Re: [storm] New SAM3/4/5 features for iSCSI

Thanks,
--David

---

From: "Paul Koning" <[email-masked]>
Date: Tue, 16 Jun 2009 15:53:18 -0400

You can't have normative references to Internet Drafts.  So by the same
reasoning there shouldn't be normative references to other drafts,
either.

If SAM-5 is an approved standard by the time we're ready to close the
spec, it is reasonable to refer to it; if not, then it seems improper
even though it's tempting.

	paul 

> Of [email-masked]
> Sent: Monday, June 15, 2009 8:39 PM

---

From: "Knight, Frederick" <[email-masked]>
Date: Tue, 16 Jun 2009 16:19:47 -0400

It is valid in ANSI (T10/T11/T13) to have references to standards under
development. 

But that is not IETF.  I do not know if there is a formal IETF rule
about referencing other standards that are still under development.

SAM-5 is targeting a completion date of January 2010.  Our iSCSI dates
are after that (or they will be once the charter gets approved), so
there should be no issue referencing SAM-5.  We just have to make sure
our schedules stay in sync, and there are multiple of us involved in
both areas (T10 - SAM-5, and IETF - Storm) to do that.

	Fred Knight

-----Original Message-----
From: Paul Koning [mailto:[email-masked]] 
Sent: Tuesday, June 16, 2009 3:53 PM
To: [email-masked]; [email-masked]; [email-masked]
Subject: Re: [storm] New SAM3/4/5 features for iSCSI

	paul 

> > > > From: [email-masked] [mailto:[email-masked]] On 
> > > > Behalf Of David Harrington

---

From: <[email-masked]>
Date: Tue, 16 Jun 2009 19:38:28 -0400

> It is valid in ANSI (T10/T11/T13) to have references to standards
under

Not only is it valid, it's even implemented (!) - see Annex D.8 in
any draft of SPC-4 (there are versions in SPC-3 and prior standards).
This could also be how to nail down the version of SAM-5 - ask T10
to allocate a Version Descriptor Code in that Annex of SPC-4 and
have the iSCSI update draft require use of that code if any of the
new task management functions are supported.

The place where the analogy to "other drafts" breaks down is that
T10 imposes a fairly high consistency and completeness bar on
proposals before incorporating them into working drafts of standards
and is cautious about allowing use of Version Descriptor codes
(values not in the table are not to be used, even though they can
be calculated).  The "other drafts" analogy clearly applies to
T10 (and T11) proposals that have not been incorporated into working
drafts of standards.

Thanks,
--David

> From: Knight, Frederick [mailto:[email-masked]] 
> Sent: Tuesday, June 16, 2009 4:20 PM
> To: Paul Koning; Black, David; [email-masked]; [email-masked]
> > From: [email-masked] 
> [mailto:[email-masked]] On Behalf
> 
> > Of [email-masked]
> > > Hmmm, the charter text is now somewhat ambiguous as to 
> scope. SAM-5
> > is