Subject: [storm] I-D Action:draft-ietf-storm-rdmap-ext-00.txt

From: [email-masked]
Date: Mon, 07 Mar 2011 16:30:02 -0800

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the STORage Maintenance Working Group of the IETF.

	Title           : RDMA Protocol Extensions
	Author(s)       : H. Shah, et al.
	Filename        : draft-ietf-storm-rdmap-ext-00.txt
	Pages           : 29
	Date            : 2011-03-07

This document specifies extensions to the IETF Remote Direct Memory
Access Protocol (RDMAP [RFC5040]). RDMAP provides read and write
services directly to applications and enables data to be transferred
directly into Upper Layer Protocol (ULP) Buffers without
intermediate data copies. The extensions specified in this document
provide the following capabilities and/or improvements: Atomic
Operations and Immediate Data.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-ietf-storm-rdmap-ext-00.txt

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

Below is the data which will enable a MIME compliant mail reader
implementation to automatically retrieve the ASCII version of the
Internet-Draft.

---

From: <[email-masked]>
Date: Tue, 8 Mar 2011 10:31:43 -0500

The RDMA extensions draft (see below) was approved and posted due to a combination of pilot error on my part and a favor to the authors because they submitted it right at the -00 cutoff deadline (hint: that's not a particularly good idea, because if something goes wrong, there's no opportunity to correct and resubmit).

This draft is **NOT** an official storm WG draft (at least, not right now) - the authors would like the storm WG to consider adopting it as a work item.  The draft is certainly within the potential scope of the WG as it updates another one of the RDMA protocols originally produced by the rddp WG - a revised version of the MPA peer connect draft should appear this week, and will be sent onward to the ADs for review, IETF Last Call, etc.

WG consideration of this RDMAP extension draft *will be* coupled with a determination of what to do about the iSER work item.  The iSER draft has expired through no fault of the author - Mike Ko has been diligent in updating the iSER draft, but everyone else with an interest in iSER appears to have vanished from the storm WG mailing list.  Let me be clear - if there is no interest in iSER changes to reflect what's actually been implemented, that work *will be* abandoned.  For those who want to refresh their memory about what's in that draft, a copy of the expired draft can be found at:

	http://www.watersprings.org/pub/id/draft-ietf-storm-iser-01.txt

Comments to the list on both drafts are encouraged.

Thanks,
--David (storm WG co-chair).
----------------------------------------------------
David L. Black, Distinguished Engineer
EMC Corporation, 176 South St., Hopkinton, MA  01748
+1 (508) 293-7953             FAX: +1 (508) 293-7786
[email-masked]        Mobile: +1 (978) 394-7754
----------------------------------------------------

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of Internet-
> [email-masked]
> Sent: Monday, March 07, 2011 7:30 PM
> To: [email-masked]
> Cc: [email-masked]
> Subject: I-D Action:draft-ietf-storm-rdmap-ext-00.txt
> 
> This document specifies extensions to the IETF Remote Direct Memory Access Protocol (RDMAP
> [RFC5040]). RDMAP provides read and write services directly to applications and enables data to be
> transferred directly into Upper Layer Protocol (ULP) Buffers without intermediate data copies. The
> extensions specified in this document provide the following capabilities and/or improvements: Atomic
> Below is the data which will enable a MIME compliant mail reader implementation to automatically
> retrieve the ASCII version of the Internet-Draft.