Subject: Re: [Stox] AD evaluation: draft-ietf-stox-im-10

From: Peter Saint-Andre - &yet <[email-masked]>
Date: Mon, 02 Feb 2015 09:23:04 -0700

Hi Alissa, thanks for the review. Comments inline.

On 1/31/15 5:09 PM, Alissa Cooper wrote:
> I have reviewed this draft in preparation for IETF LC, along with the
> -chat and -groupchat drafts. Overall the document appears in good
> shape. I have a comment I’d like to discuss before proceeding to IETF
> LC, along with an editorial nit to be addressed with any LC
> comments.
>
> You will note some commonality across my comments on all three
> drafts. In general, these drafts could do a better job of precisely
> specifying what is minimally required (normatively) for
> interoperability, versus what is optional or likely to differ between
> implementations. I think if at least the syntax mappings are
> normatively specified that should be sufficient, but the authors and
> WG might want to consider doing another pass at these documents to
> see if they could be more clear about which protocol exchanges the
> various gateways must support for STOX to work at all, versus which
> ones are suggested or optional.
>
> Comment:
>
> To achieve minimal interoperability, I think the syntax mappings in
> Section 4 need to be MUST-level requirements rather than SHOULD. Or,
> if there are cases envisioned in which different implementations
> might map the elements differently, those should be explained. But I
> assume there are not.

That seems reasonable.

Would you like the authors to complete this review and cleanup (with 
revised I-Ds for all three documents) before IETF Last Call?

> Nit:
>
> If GRUUs are generally not human-readable in use, I would suggest
> changing the ones in Section 4 to random identifiers.

Good point. Will fix.

Peter

-- 
Peter Saint-Andre
https://andyet.com/

---

From: Peter Saint-Andre - &yet <[email-masked]>
Date: Thu, 05 Feb 2015 13:51:01 -0700

> LC, along with an editorial nit to be addressed with any LC

Hi Alissa, we've updated all three drafts to address your comments. Let 
us know if there's anything else you need from the authors in order to 
proceed.

Thanks!

Peter

-- 
Peter Saint-Andre
https://andyet.com/

---

From: Alissa Cooper <[email-masked]>
Date: Thu, 5 Feb 2015 15:57:13 -0800

Thanks. It will likely take me a few days to go through the responses.

On Feb 5, 2015, at 12:51 PM, Peter Saint-Andre - &yet <[email-masked]> wrote:

> Hi Alissa, we've updated all three drafts to address your comments. Let us know if there's anything else you need from the authors in order to proceed.
> 
> Thanks!
> 
> Peter
> 
> -- 
> Peter Saint-Andre
> https://andyet.com/

---

From: Alissa Cooper <[email-masked]>
Date: Mon, 9 Feb 2015 15:44:08 -0800

The new draft addresses all of my issues, thanks. I’d like to see how the discussion with Ben resolves before issuing an IETF LC.

Alissa

On Feb 2, 2015, at 8:23 AM, Peter Saint-Andre - &yet <[email-masked]> wrote:

> Would you like the authors to complete this review and cleanup (with revised I-Ds for all three documents) before IETF Last Call?
> 
>> Nit:
>>

---

From: Peter Saint-Andre - &yet <[email-masked]>
Date: Wed, 11 Feb 2015 19:52:14 -0700

> The new draft addresses all of my issues, thanks. I’d like to see how the discussion with Ben resolves before issuing an IETF LC.

Agreed. If the text I've proposed seems acceptable, I can submit -12 
with the relevant fixes.

Peter