Subject: Re: [straw] Working group adoption of draft-kaplan-straw-b2bua-taxonomy-00 - REMINDER

From: Christer Holmberg <[email-masked]>
Date: Wed, 12 Sep 2012 14:22:10 +0200

(As co-chair)

Hi,

Note, that today is the "deadline" for indicating support/objection for WG adoption of draft-kaplan-straw-b2bua-taxonomy-00.

So far only a couple of individuals have indicated support for adopting the draft. None has objected.

Regards,

Christer

Ps. As individual, I support adopting the draft.

From: [email-masked] [mailto:[email-masked]] On Behalf Of Christer Holmberg
Sent: 5. syyskuuta 2012 14:14
To: [email-masked]
Subject: [straw] Working group adoption of draft-kaplan-straw-b2bua-taxonomy-00

Hi,

As mentioned last week, our first scheduled delivery in the charter is

a taxonomy document defining role-types of B2BUAs.

We believe that having a common understanding and agreement of the

different B2BUA roles is essential for our other deliverables.

The only proposal on the table is: http://www.ietf.org/id/draft-kaplan-straw-b2bua-taxonomy-00.txt

Last week we did ask whether someone else is planning to submit a draft for the

same delivery, but nobody has indicated an intention to do so.

Therefore, we would now like to ask the WG for adoption of

draft-kaplan-straw-b2bua-taxonomy-00, and to make it the base for our

delivery.

Please indicate your support of, or objection to, this proposal on the

list by Wednesday 12^th September.

Regards,

Christer & Victor (as chairs)

---

From: "DOLLY, MARTIN C" <[email-masked]>
Date: Wed, 12 Sep 2012 12:29:30 +0000

I support adopting the draft as a WG document

From: [email-masked] [mailto:[email-masked]] On Behalf Of Christer Holmberg
Sent: Wednesday, September 12, 2012 8:22 AM
To: [email-masked]
Subject: Re: [straw] Working group adoption of draft-kaplan-straw-b2bua-taxonomy-00 - REMINDER

(As co-chair)

Hi,

Regards,

Christer

From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]] On Behalf Of Christer Holmberg
Sent: 5. syyskuuta 2012 14:14
To: [email-masked]<mailto:[email-masked]>
Subject: [straw] Working group adoption of draft-kaplan-straw-b2bua-taxonomy-00

Hi,

delivery.

Regards,

---

From: <[email-masked]>
Date: Wed, 12 Sep 2012 15:02:57 +0200

+1

Roland

________________________________
Von: [email-masked] [mailto:[email-masked]] Im Auftrag von DOLLY, MARTIN C
Gesendet: Mittwoch, 12. September 2012 14:30
An: Christer Holmberg; [email-masked]
Betreff: Re: [straw] Working group adoption of draft-kaplan-straw-b2bua-taxonomy-00 - REMINDER

(As co-chair)

Hi,

Regards,

Christer

Hi,

delivery.

Regards,

---

From: James Polk <[email-masked]>
Date: Wed, 12 Sep 2012 15:47:20 -0500

At 07:22 AM 9/12/2012, Christer Holmberg wrote:
>Content-Language: en-US
>Content-Type: multipart/alternative;
> 
>boundary="_000_7F2072F1E0DE894DA4B517B93C6A0585340A53BB74ESESSCMS0356e_"
>
>(As co-chair)
>
>Hi,
>
>Note, that today is the "deadline" for indicating support/objection 
>for WG adoption of draft-kaplan-straw-b2bua-taxonomy-00.
>

But... someone did ask an important question (Sept 6th at 19:28 GMT) 
about the relationship between these different B2BUAs and the work in 
INSIPID that no one has answered, so barring that - I'm not in favor 
of adopting this draft yet.

James

>The only proposal on the table is: 
><http://www.ietf.org/id/draft-kaplan-straw-b2bua-taxonomy-00.txt>http://www.ietf.org/id/draft-kaplan-straw-b2bua-taxonomy-00.txt
>
>_______________________________________________
>straw mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/straw

---

From: Mary Barnes <[email-masked]>
Date: Wed, 12 Sep 2012 16:17:28 -0500

On Wed, Sep 12, 2012 at 3:47 PM, James Polk <[email-masked]> wrote:

>> boundary="_000_**7F2072F1E0DE894DA4B517B93C6A05**
>> 85340A53BB74ESESSCMS0356e_"
>>
>>
>> (As co-chair)
>>
>> Hi,
>>
>> Note, that today is the "deadline" for indicating support/objection for
>> WG adoption of draft-kaplan-straw-b2bua-**taxonomy-00.
>>
> But... someone did ask an important question (Sept 6th at 19:28 GMT) about
> the relationship between these different B2BUAs and the work in INSIPID
> that no one has answered, so barring that - I'm not in favor of adopting
> this draft yet.
>

[MB]   I was not entirely clear on your question/comment.  Are you asking
if the INSIPID documents need to consider each type of B2BUA (as the
current docs don't go into any detail on different types of B2BUAs) and use
this document as an informational reference? If that's the question, I
think that's a question for INSIPID WG.  Or are you asking if the
deliverables in STRAW must consider the new header defined by INSIPID?  If
it's the latter, I don't think that has any impact on this document which
is only defining taxonomies and not identifying explicitly how any specific
headers should be handled.

Note, I've addressed this response to Hadriel as well since he is an author
of this doc, as well as the INSIPID WG requirements document, so his
perspective might be helpful.[/MB]

>> From: [email-masked] [mailto:[email-masked]**] On Behalf
>> Of Christer Holmberg
>> Subject: [straw] Working group adoption of draft-kaplan-straw-b2bua-**
>> taxonomy-00
>>
>> Hi,
>>
>> The only proposal on the table is: <http://www.ietf.org/id/draft-**
>> kaplan-straw-b2bua-taxonomy-**00.txt<http://www.ietf.org/id/draft-kaplan-straw-b2bua-taxonomy-00.txt>
>> >http://www.ietf.org/id/**draft-kaplan-straw-b2bua-**taxonomy-00.txt<http://www.ietf.org/id/draft-kaplan-straw-b2bua-taxonomy-00.txt>
>>
>>
>> draft-kaplan-straw-b2bua-**taxonomy-00, and to make it the base for our
>> delivery.
>>
>> ______________________________**_________________
>> straw mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/**listinfo/straw<https://www.ietf.org/mailman/listinfo/straw>
>>
>
> ______________________________**_________________
> straw mailing list
> [email-masked]
> https://www.ietf.org/mailman/**listinfo/straw<https://www.ietf.org/mailman/listinfo/straw>
>

---

From: "Yanqiang (Michael)" <[email-masked]>
Date: Thu, 13 Sep 2012 03:25:59 +0000

I support the adoption.

Michael

> From: DOLLY, MARTIN C [mailto:[email-masked]] 
> Sent: Wednesday, September 12, 2012 8:29 PM
> To: Christer Holmberg; [email-masked]

> Note, that today is the “deadline” for indicating support/objection for WG adoption of draft-kaplan-straw-b2bua-taxonomy-00.

---

From: Christer Holmberg <[email-masked]>
Date: Thu, 13 Sep 2012 09:29:48 +0200

Hi James,

The idea is to have a general document, which describes different B2BUA roles. 

If INSIPID sees value in referencing such document, I don't see anything preventing that.

Regards,

Christer

________________________________________
From: James Polk [[email-masked]]
Sent: Wednesday, September 12, 2012 11:47 PM
To: Christer Holmberg; [email-masked]
Subject: Re: [straw] Working group adoption of  draft-kaplan-straw-b2bua-taxonomy-00 - REMINDER

James

---

From: James Polk <[email-masked]>
Date: Thu, 13 Sep 2012 16:15:51 -0500

Christer

I think you're misunderstanding my issue.

I think that INSIPID now doesn't have a choice in explicitly stating 
*which* B2BUA is involved in which scenario for each requirement or 
use-case, possibly (more like probably) greatly complicating the work 
in that WG. I think STRAW is redefining what a B2BUA is into several 
different types of B2BUAs - for the whole community to _have_ to 
account for in any explanation within any draft or RFC going forward.

IOW, with this draft, it will no longer be appropriate to can any 
entity or actor simply a B2BUA, except in the most general terms 
where no real detail exists to give more granular context.

And since INSIPID is all about defining something that will survive 
through any version of a B2BUA - the impact on INSIPID's work is more 
complicated, and no one from that WG has had a chance to digest or 
comment on the impact.

James

At 02:29 AM 9/13/2012, Christer Holmberg wrote:
>Subject: Re: [straw] Working group adoption 
>of  draft-kaplan-straw-b2bua-taxonomy-00 - REMINDER
>
> ><http://www.ietf.org/id/draft-kaplan-straw-b2bua-taxonomy-00.txt>ht 
> tp://www.ietf.org/id/draft-kaplan-straw-b2bua-taxonomy-00.txt
> >

---

From: Mary Barnes <[email-masked]>
Date: Thu, 13 Sep 2012 16:26:34 -0500

Comments below [MB].

Mary

On Thu, Sep 13, 2012 at 4:15 PM, James Polk <[email-masked]> wrote:

> use-case, possibly (more like probably) greatly complicating the work in
> that WG. I think STRAW is redefining what a B2BUA is into several different
> types of B2BUAs - for the whole community to _have_ to account for in any
> explanation within any draft or RFC going forward.
>
[MB] That was what I was asking yesterday, in which case that's a
discussion for the INSIPID WG and shouldn't impact whether STRAW adopts
this document.  However, I don't think STRAW is redefining what a B2BUA is.
Rather, the objective of this document is to characterize the different
"flavors" of B2BUAs that are already deployed.  The idea behind the STRAW
workgroup is to describe desired behaviors that will improve
interoperability.[/MB]

>
> IOW, with this draft, it will no longer be appropriate to can any entity
> or actor simply a B2BUA, except in the most general terms where no real
> detail exists to give more granular context.

[MB] This sentence doesn't parse. [/MB]

> complicated, and no one from that WG has had a chance to digest or comment
> on the impact.
>
[MB] As I stated in my email yesterday (which I also sent to Hadriel),
 Hadriel is an author of the WG requirements document in INSIPID and this
document, so it would be good to hear his perspective. [/MB]

>> ______________________________**__________
>> Subject: Re: [straw] Working group adoption of  draft-kaplan-straw-b2bua-
>> **taxonomy-00 - REMINDER
>>
>> >for WG adoption of draft-kaplan-straw-b2bua-**taxonomy-00.
>> >
>> >From: [email-masked] [mailto:[email-masked]**] On
>> >Behalf Of Christer Holmberg
>> >Subject: [straw] Working group adoption of
>> >draft-kaplan-straw-b2bua-**taxonomy-00
>> >
>> >Hi,
>> >
>> ><http://www.ietf.org/id/**draft-kaplan-straw-b2bua-**taxonomy-00.txt<http://www.ietf.org/id/draft-kaplan-straw-b2bua-taxonomy-00.txt>>ht
>> tp://www.ietf.org/id/draft-**kaplan-straw-b2bua-taxonomy-**00.txt<http://www.ietf.org/id/draft-kaplan-straw-b2bua-taxonomy-00.txt>
>>
>> >
>> >_____________________________**__________________
>> >straw mailing list
>> >[email-masked]

---

From: James Polk <[email-masked]>
Date: Thu, 13 Sep 2012 16:42:24 -0500

At 04:26 PM 9/13/2012, Mary Barnes wrote:
>Comments below [MB].
>
>Mary
>
>On Thu, Sep 13, 2012 at 4:15 PM, James Polk 
><<mailto:[email-masked]>[email-masked]> wrote:
>Christer
>
>use-case, possibly (more like probably) greatly complicating the 
>work in that WG. I think STRAW is redefining what a B2BUA is into 
>several different types of B2BUAs - for the whole community to 
>_have_ to account for in any explanation within any draft or RFC going forward.
>
>discussion for the INSIPID WG and shouldn't impact whether STRAW 
>adopts this document.  However, I don't think STRAW is redefining 
>what a B2BUA is. Rather, the objective of this document is to 
>characterize the different "flavors" of B2BUAs that are already 
>deployed.  The idea behind the STRAW workgroup is to describe 
>desired behaviors that will improve interoperability.[/MB]
>

s/can/call

does that help?

James

>through any version of a B2BUA - the impact on INSIPID's work is 
>more complicated, and no one from that WG has had a chance to digest 
>or comment on the impact.
>
>[MB] As I stated in my email yesterday (which I also sent to 
>Hadriel),  Hadriel is an author of the WG requirements document in 
>INSIPID and this document, so it would be good to hear his perspective. [/MB]
>
>James
>
>
>From: James Polk [<mailto:[email-masked]>[email-masked]]
>To: Christer Holmberg; <mailto:[email-masked]>[email-masked]
> >From: <mailto:[email-masked]>[email-masked] 
> [mailto:[email-masked]] On
> >To: <mailto:[email-masked]>[email-masked]
> >draft-kaplan-straw-b2bua-taxonomy-00
> >
> >Hi,
> >
> ><<http://www.ietf.org/id/draft-kaplan-straw-b2bua-taxonomy-00.txt>h 
> ttp://www.ietf.org/id/draft-kaplan-straw-b2bua-taxonomy-00.txt>ht 
> tp://<http://www.ietf.org/id/draft-kaplan-straw-b2bua-taxonomy-00.txt>www.ietf.org/id/draft-kaplan-straw-b2bua-taxonomy-00.txt
>
> >
> ><mailto:[email-masked]>[email-masked]
><mailto:[email-masked]>[email-masked]
><mailto:[email-masked]>[email-masked]

---

From: Mary Barnes <[email-masked]>
Date: Thu, 13 Sep 2012 17:14:01 -0500

On Thu, Sep 13, 2012 at 4:42 PM, James Polk <[email-masked]> wrote:

>> On Thu, Sep 13, 2012 at 4:15 PM, James Polk <<mailto:[email-masked]>
>> [email-masked] <[email-masked]>> wrote:
>> Christer
>>
[MB2] Yes it does.  I don't necessarily think that is the case (i.e., that
we can no longer use the general B2BUA term).  You do have a higher level
point (which is maybe what you were getting at initially) as to whether
STRAW must consider and document the handling of the new header defined by
INSIPID.  If you read the STRAW charter, it implies such - i.e., "specific
functions covered are expected to relate to already-published RFCs or
existing RAI area work".
In this case, folks from INSIPID would want to make sure that the WG
deliverables in STRAW that identify the headers that must be preserved
include the INSIPID header.   But, as usual, I don't think there is lack of
an overlap of participation that this is a problem. And, related to this
thread, that doesn't impact this document under discussion which only
defines topologies and doesn't identify any handling of headers.
Personally, I think having STRAW work underway at the same time as INSIPID
will only improve interoperability for the INSIPID header.   Without,
STRAW, you'd be assuming that each type of B2BUA would do the right thing
and preserve the header.
[/MB2]

>> From: James Polk [<mailto:[email-masked]>[email-masked]<[email-masked]>
>> ]
>>
>> To: Christer Holmberg; <mailto:[email-masked]>straw@**ietf.org<[email-masked]>
>>
>> >From: <mailto:[email-masked]**>[email-masked] [mailto:
>> [email-masked]**] On
>>
>> >To: <mailto:[email-masked]>straw@**ietf.org <[email-masked]>
>>
>> ><<http://www.ietf.org/id/**draft-kaplan-straw-b2bua-**taxonomy-00.txt<http://www.ietf.org/id/draft-kaplan-straw-b2bua-taxonomy-00.txt>>h
>> ttp://www.ietf.org/id/draft-**kaplan-straw-b2bua-taxonomy-**00.txt<http://www.ietf.org/id/draft-kaplan-straw-b2bua-taxonomy-00.txt>>ht
>> tp://<http://www.ietf.org/id/**draft-kaplan-straw-b2bua-**taxonomy-00.txt<http://www.ietf.org/id/draft-kaplan-straw-b2bua-taxonomy-00.txt>
>> >www.ietf.org/**id/draft-kaplan-straw-b2bua-**taxonomy-00.txt<http://www.ietf.org/id/draft-kaplan-straw-b2bua-taxonomy-00.txt>
>>
>>
>> >
>> ><mailto:[email-masked]>straw@**ietf.org <[email-masked]>
>>
>> <mailto:[email-masked]>straw@**ietf.org <[email-masked]>
>>
>> <mailto:[email-masked]>straw@**ietf.org <[email-masked]>
>>

---

From: "DRAGE, Keith (Keith)" <[email-masked]>
Date: Fri, 14 Sep 2012 13:01:19 +0200

My read is that INSIPID defines a SIP protocol mechanism.

For protocol mechanisms already in existence, STRAW will give some idea of what elements in the taxonomy can be expected to support in terms of transparency to SIP protocol mechanisms.

For new protocol mechanisms, that responsibility will probably default to the working group defining the new protocol mechanism.

My hope is that the former case applies to INSIPID.

INSIPID will however need to take account of B2BUAs generically, and we are already in a discussion of what is in scope and what is not in scope.

Keith

________________________________
From: [email-masked] [mailto:[email-masked]] On Behalf Of Mary Barnes
Sent: 13 September 2012 23:14
To: James Polk
Cc: [email-masked]; Christer Holmberg
Subject: Re: [straw] Working group adoption of draft-kaplan-straw-b2bua-taxonomy-00 - REMINDER

On Thu, Sep 13, 2012 at 4:42 PM, James Polk <[email-masked]<mailto:[email-masked]>> wrote:
At 04:26 PM 9/13/2012, Mary Barnes wrote:
Comments below [MB].

Mary
On Thu, Sep 13, 2012 at 4:15 PM, James Polk <<mailto:[email-masked]<mailto:[email-masked]>>[email-masked]<mailto:[email-masked]>> wrote:
Christer

I think that INSIPID now doesn't have a choice in explicitly stating *which* B2BUA is involved in which scenario for each requirement or use-case, possibly (more like probably) greatly complicating the work in that WG. I think STRAW is redefining what a B2BUA is into several different types of B2BUAs - for the whole community to _have_ to account for in any explanation within any draft or RFC going forward.

[MB] That was what I was asking yesterday, in which case that's a discussion for the INSIPID WG and shouldn't impact whether STRAW adopts this document.  However, I don't think STRAW is redefining what a B2BUA is. Rather, the objective of this document is to characterize the different "flavors" of B2BUAs that are already deployed.  The idea behind the STRAW workgroup is to describe desired behaviors that will improve interoperability.[/MB]

IOW, with this draft, it will no longer be appropriate to can any entity or actor simply a B2BUA, except in the most general terms where no real detail exists to give more granular context.

s/can/call

does that help?
[MB2] Yes it does.  I don't necessarily think that is the case (i.e., that we can no longer use the general B2BUA term).  You do have a higher level point (which is maybe what you were getting at initially) as to whether STRAW must consider and document the handling of the new header defined by INSIPID.  If you read the STRAW charter, it implies such - i.e., "specific functions covered are expected to relate to already-published RFCs or existing RAI area work".
In this case, folks from INSIPID would want to make sure that the WG deliverables in STRAW that identify the headers that must be preserved include the INSIPID header.   But, as usual, I don't think there is lack of an overlap of participation that this is a problem. And, related to this thread, that doesn't impact this document under discussion which only defines topologies and doesn't identify any handling of headers.   Personally, I think having STRAW work underway at the same time as INSIPID will only improve interoperability for the INSIPID header.   Without, STRAW, you'd be assuming that each type of B2BUA would do the right thing and preserve the header.
[/MB2]

James

And since INSIPID is all about defining something that will survive through any version of a B2BUA - the impact on INSIPID's work is more complicated, and no one from that WG has had a chance to digest or comment on the impact.

[MB] As I stated in my email yesterday (which I also sent to Hadriel),  Hadriel is an author of the WG requirements document in INSIPID and this document, so it would be good to hear his perspective. [/MB]

James

Regards,

Christer

________________________________________
From: James Polk [<mailto:[email-masked]<mailto:[email-masked]>>[email-masked]<mailto:[email-masked]>]

Sent: Wednesday, September 12, 2012 11:47 PM
To: Christer Holmberg; <mailto:[email-masked]<mailto:[email-masked]>>[email-masked]<mailto:[email-masked]>

James

>From: <mailto:[email-masked]<mailto:[email-masked]>>[email-masked]<mailto:[email-masked]> [mailto:[email-masked]<mailto:[email-masked]>] On

>To: <mailto:[email-masked]<mailto:[email-masked]>>[email-masked]<mailto:[email-masked]>

><<http://www.ietf.org/id/draft-kaplan-straw-b2bua-taxonomy-00.txt>h ttp://www.ietf.org/id/draft-kaplan-straw-b2bua-taxonomy-00.txt<http://www.ietf.org/id/draft-kaplan-straw-b2bua-taxonomy-00.txt>>ht tp://<http://www.ietf.org/id/draft-kaplan-straw-b2bua-taxonomy-00.txt>www.ietf.org/id/draft-kaplan-straw-b2bua-taxonomy-00.txt<http://www.ietf.org/id/draft-kaplan-straw-b2bua-taxonomy-00.txt>

><mailto:[email-masked]<mailto:[email-masked]>>[email-masked]<mailto:[email-masked]>

_______________________________________________
straw mailing list
<mailto:[email-masked]<mailto:[email-masked]>>[email-masked]<mailto:[email-masked]>

_______________________________________________
straw mailing list
<mailto:[email-masked]<mailto:[email-masked]>>[email-masked]<mailto:[email-masked]>

_______________________________________________
straw mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/straw

---

From: Christer Holmberg <[email-masked]>
Date: Fri, 14 Sep 2012 15:10:12 +0200

(As co-chair)

Hi James,

We can still use the general B2BUA term. There is no requirement that other WGs must start to reference the specific B2BUA roles described in STRAW. We have a deliverable to describe the roles in STRAW, which we will need our other STRAW deliverables.

(Other WGs may of course reference the roles if they choose to.)

So, based on the feedback on the list, the chairs' suggestion would be to request adoption of the document as base for our delivery. And, as we all know, adopting a draft as base for a delivery does not mean we agree to all the text in the draft.

Now, if you want to remove the whole deliverable from the charter, that is a separate discussion. The current poll, however, is about adopting a draft for an agreed deliverable.

Last, in the case of INSIPID, I thought the whole idea was to specify a mechanism that is not impacted by B2BUAs.

Regards,

Christer

From: Mary Barnes [mailto:[email-masked]]
Sent: 14. syyskuuta 2012 1:14
To: James Polk
Cc: [email-masked]; Christer Holmberg
Subject: Re: [straw] Working group adoption of draft-kaplan-straw-b2bua-taxonomy-00 - REMINDER

Mary

s/can/call

does that help?

James

James

Regards,

Christer

James

---

From: James Polk <[email-masked]>
Date: Fri, 14 Sep 2012 14:42:36 -0500

At 06:01 AM 9/14/2012, DRAGE, Keith (Keith) wrote:
>For protocol mechanisms already in existence, STRAW will give some 
>idea of what elements in the taxonomy can be expected to support in 
>terms of transparency to SIP protocol mechanisms.
>
>For new protocol mechanisms, that responsibility will probably 
>default to the working group defining the new protocol mechanism.
>

Christer & Mary

I believe most of my angst about adopting the draft is the uneasiness 
and uncertainty about this last line above that Keith expressed.

I'm concerned about INSIPID docs needed to move on the whim (word 
used mostly in jest) of a lateral WG. IOW - INSIPID docs will 
absolutely now have to define what a generic B2BUA is *because* of 
STRAW and readers of STRAW docs down the road. That's a fact IMO. Of 
more concern is whether or not INSIPID docs will have to articulate 
which type of B2BUA STRAW docs define whenever INSIPID docs use the 
initialism "B2BUA", including having to investigate whether or not 
how INSIPID docs use the term will be universally true for all 
instances or examples of _any_type_of_ B2BUA that STRAW happens to refer to.

On the other hand, if INSIPID doesn't have to account for what STRAW 
defines, given that the two WGs are working at the same time, and not 
all INSIPID participants are participants of STRAW - I have far less 
issues with this taxonomy draft being adopted in STRAW.

Bottom line - I don't want any author or editor of an INSIPID doc and 
work until a meeting, submit a draft at or near the deadline, and at 
the meeting have someone (or everyone) in the room say when they're 
presenting "you (generically) obviously haven't paid attention to 
what's happening in STRAW. Your preso is useless" and therefore cause 
an unnecessary delay to the INSIPID timelines.

James

>
>INSIPID will however need to take account of B2BUAs generically, and 
>we are already in a discussion of what is in scope and what is not in scope.
>
>Keith
>
>
>
>----------
>Subject: Re: [straw] Working group adoption of 
>draft-kaplan-straw-b2bua-taxonomy-00 - REMINDER
>
>
>On Thu, Sep 13, 2012 at 4:42 PM, James Polk 
>[MB2] Yes it does.  I don't necessarily think that is the case 
>(i.e., that we can no longer use the general B2BUA term).  You do 
>have a higher level point (which is maybe what you were getting at 
>initially) as to whether STRAW must consider and document the 
>handling of the new header defined by INSIPID.  If you read the 
>STRAW charter, it implies such - i.e., "specific functions covered 
>are expected to relate to already-published RFCs or existing RAI area work".
>deliverables in STRAW that identify the headers that must be 
>preserved include the INSIPID header.   But, as usual, I don't think 
>there is lack of an overlap of participation that this is a problem. 
>And, related to this thread, that doesn't impact this document under 
>discussion which only defines topologies and doesn't identify any 
>handling of headers.   Personally, I think having STRAW work 
>underway at the same time as INSIPID will only improve 
>interoperability for the INSIPID header.   Without, STRAW, you'd be 
>assuming that each type of B2BUA would do the right thing and 
>preserve the header.
>[/MB2]
>
>James
>
>
>
>To: Christer Holmberg; 
><mailto:[email-masked]><mailto:[email-masked]>[email-masked]
>
> >From: 
> <mailto:[email-masked]><mailto:[email-masked]>[email-masked] 
> >To: <mailto:[email-masked]><mailto:[email-masked]>[email-masked]
>
> ><<<http://www.ietf.org/id/draft-kaplan-straw-b2bua-taxonomy-00.txt> 
> http://www.ietf.org/id/draft-kaplan-straw-b2bua-taxonomy-00.txt>h 
> ttp://<http://www.ietf.org/id/draft-kaplan-straw-b2bua-taxonomy-00.txt>www.ietf.org/id/draft-kaplan-straw-b2bua-taxonomy-00.txt>ht 
> tp://<<http://www.ietf.org/id/draft-kaplan-straw-b2bua-taxonomy-00.txt>http://www.ietf.org/id/draft-kaplan-straw-b2bua-taxonomy-00.txt>www.ietf.org/id/draft-kaplan-straw-b2bua-taxonomy-00.txt
>
>
> >
> ><mailto:[email-masked]><mailto:[email-masked]>[email-masked]
>
><mailto:[email-masked]><mailto:[email-masked]>[email-masked]
>
><mailto:[email-masked]><mailto:[email-masked]>[email-masked]
>

---

From: Gonzalo Camarillo <[email-masked]>
Date: Tue, 18 Sep 2012 13:07:09 +0300

Hi James,

thanks for your cross-WG comments. It is always useful to have people
looking at different parts of the RAI area.

As you know, the actual scope of the INSIPID WG has been a central point
in the discussions (that took place in DISPATCH) that led to the
chartering of INSIPID and in the INSIPID session at the last IETF. One
of the reasons for having a fairly narrow scope was not to have to deal
with complex scenarios where different types of B2BUAs interact among
them in complicated ways.

>From the INSIPID charter:

> This group will focus on a document that will specify a SIP
> identifier that has the same aim as the From-tag, To-tag and Call-ID
> conjunction, but is less likely to be mangled by intermediaries.

So, answering your question, the limited-scope work that INSIPID is
undertaking will not be affected by this taxonomy document.

Of course, as you point out, the situation would be different if we were
to charter a WG with a wider scope at some point in time.

Cheers,

Gonzalo