Subject: [straw] Open issue in loop-detection too (not traceroute)

From: Hadriel Kaplan <[email-masked]>
Date: Wed, 19 Jun 2013 04:43:24 -0400

Howdy,
Apparently there is an open issue in the loop-detection draft as well, which I kinda forgot about.  I blame my co-author Victor for me having forgotten this though, since he submitted the most recent draft version because I was taking too long.  So it's really his fault for being so diligent. :)

Anyway… the open issue is in section 4:
   [Note: should we require all B2BUAs to perform Via-header loop-
   detection as well, even if they themselves don't forward on the Via
   headers?]

One of the WG chairs (I won't say who, but it's not Victor) asked me to also put my 2-cents in for my preference, to get the ball rolling towards discussion and consensus.  But personally, I don't have a strong opinion whether this should be required or not.  I can see some arguments either way.  It would be nice to detect loops sooner/faster than max-forwards would, for the cases where it could be detected.  On the other hand in the looping cases I've seen the via-header check would never have stopped them - the scenarios for detecting a loop using via-header checking are more limited in full B2BUA deployments.  And implementing Via-header loop-detection is a lot more work, extremely difficult if not impossible in some systems, and might impact performance on systems, so having this as a MUST statement means vendors might weasel their way out of the whole RFC. (the philosophy here being that the RFCs in STRAW are only as enforceable as the power of purchasers of systems to ask their vendors to do them, because they make sense to do)

I guess we could hedge and do a "SHOULD" or "RECOMMENDED".  But that's really just a cop-out.  A wise Jedi master once said: Do or do not, there is no try.

-hadriel

On Apr 18, 2013, at 10:17 AM, [email-masked] wrote:

> The IETF datatracker status page for this draft is:
> https://datatracker.ietf.org/doc/draft-ietf-straw-b2bua-loop-detection
> 
> There's also a htmlized version available at:
> http://tools.ietf.org/html/draft-ietf-straw-b2bua-loop-detection-00

---

From: Christer Holmberg <[email-masked]>
Date: Wed, 19 Jun 2013 10:54:09 +0000

> One of the WG chairs (I won't say who, but it's not Victor) asked me to also put my 2-cents in for my preference,

It's good that you didn't mention WHICH WG, because otherwise it would have been pretty obvious who you were talking about ;)

Regards,

Christer

---

From: Victor Pascual Avila <[email-masked]>
Date: Thu, 27 Jun 2013 09:47:39 +0200

I agree with the comments below

-Victor

On Wed, Jun 19, 2013 at 10:43 AM, Hadriel Kaplan
<[email-masked]> wrote:
> _______________________________________________
> straw mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/straw

---

From: Christer Holmberg <[email-masked]>
Date: Thu, 27 Jun 2013 11:08:42 +0000

(As co-chair)

Hi,

Nobody has objected to Hadriel's suggestion on closing the open issue.

So, my suggestion is that the authors submit a new version of the draft, implementing the suggested solution to the open issue, and we will then initiate WGLC.

Regards,

Christer

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Hadriel Kaplan
Sent: 19. kesäkuuta 2013 11:43
To: [email-masked]
Subject: [straw] Open issue in loop-detection too (not traceroute)

Howdy,

Anyway. the open issue is in section 4:
   [Note: should we require all B2BUAs to perform Via-header loop-
   detection as well, even if they themselves don't forward on the Via
   headers?]

-hadriel