Subject: [straw] Fwd: New Version Notification for draft-kaplan-straw-sip-traceroute-01.txt

From: Hadriel Kaplan <[email-masked]>
Date: Sat, 15 Jun 2013 15:25:52 -0400

Howdy,
based on the feedback from the last meeting, I've updated the traceroute draft.

-hadriel

Begin forwarded message:

> From: [email-masked]
> Subject: New Version Notification for draft-kaplan-straw-sip-traceroute-01.txt
> Date: June 15, 2013 3:24:22 PM EDT
> To: Hadriel Kaplan <[email-masked]>
> 
> 
> A new version of I-D, draft-kaplan-straw-sip-traceroute-01.txt
> has been successfully submitted by Hadriel Kaplan and posted to the
> IETF repository.
> 
> Filename:	 draft-kaplan-straw-sip-traceroute
> Revision:	 01
> Title:		 A Media-based Traceroute Function for the Session Initiation Protocol (SIP)
> Creation date:	 2013-06-15
> Group:		 Individual Submission
> Number of pages: 6
> URL:             http://www.ietf.org/internet-drafts/draft-kaplan-straw-sip-traceroute-01.txt
> Status:          http://datatracker.ietf.org/doc/draft-kaplan-straw-sip-traceroute
> Htmlized:        http://tools.ietf.org/html/draft-kaplan-straw-sip-traceroute-01
> Diff:            http://www.ietf.org/rfcdiff?url2=draft-kaplan-straw-sip-traceroute-01
> 
> Abstract:
>   SIP already provides the ability to perform hop-by-hop traceroute
>   for SIP messages using the Max-Forwards header field, in order to
>   determine the reachability path of requests to a target.  A
>   mechanism for media-loopback calls has also been defined separately,
>   which enables test calls to be generated which result in media being
>   looped back to the originator.  This document describes a means of
>   performing hop-by-hop traceroute-style test calls using the media-
>   loopback mechanism, in order to test the media path when SIP
>   sessions go through media-relaying B2BUAs.
>

---

From: "Schwarz, Albrecht (Albrecht)" <[email-masked]>
Date: Sun, 16 Jun 2013 05:12:46 +0000

Hi Hadriel,
fyi, some high-level comments to the taxonomy draft from perspective of decomposed SBCs (according H.248 model)
http://ftp3.itu.int/av-arch/avc-site/2013-2016/1306_Osl/AVD-4391.zip 

Regards,
Albrecht

---

From: Christer Holmberg <[email-masked]>
Date: Sun, 16 Jun 2013 09:03:49 +0000

(As co-chair)

Hi Albrecht,

I do appreciate the fact that you have taken a look at the draft, and studied its applicability from a SG16 perspective.

In the conclusion part, you ask whether there is a need to provide feedback to STRAW.

Keep in mind that the WGLC for the draft has finished, and that publication has been requested by the chairs.

Now, that does not prevent us from taking the draft back to the WG, and do changes, but in order for that to happen there normally has to be some issues that need to be changed/addressed in order to publish the document as an RFC.

Regards,

Christer

-----Alkuperäinen viesti-----
Lähettäjä: [email-masked] [mailto:[email-masked]] Puolesta Schwarz, Albrecht (Albrecht)
Lähetetty: 16. kesäkuuta 2013 8:13
Vastaanottaja: Hadriel Kaplan; <[email-masked]>
Aihe: [straw] draft-ietf-straw-b2bua-taxonomy: decomposed gateway model and media plane b2bua types

Hi Hadriel,
fyi, some high-level comments to the taxonomy draft from perspective of decomposed SBCs (according H.248 model) http://ftp3.itu.int/av-arch/avc-site/2013-2016/1306_Osl/AVD-4391.zip 

Regards,
Albrecht
_______________________________________________
straw mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/straw

---

From: "Schwarz, Albrecht (Albrecht)" <[email-masked]>
Date: Wed, 19 Jun 2013 11:19:54 +0000

Hello Christer, Hadriel,

I don't want to delay the publication.

Don't see any principle issue, too.

In case of a future revision of this RFC, then it might be beneficial to try to add a term definition for B2BUA (because the whole taxonomy is actually based on this term).

2nd I suppose a difference between B2BUA vs PROXY, hence might be worth as well to point out differences.

Personally, I could see following resolution proposal (based on ITU terms):

Background: the subject as such was studied in Y.1251 (http://www.itu.int/rec/dologin_pub.asp?lang=e&id=T-REC-Y.1251-200208-I!!PDF-E&type=items ).

Possible definition of term "B2BUA":

B2BUA:  provides a service interworking function (according clause 3.2/ITU-T Y.1251) with following limitations,

1.       network planes: only IP control and IP user plane;

2.       protocol stack: same protocol at each side of the service interworking function.
NOTE 1: hence, a B2BUA is not a proxy.

Proxy (derived from ITU-T Y.2902): A system authorized to work on behalf of another system including responding to protocol requests.
NOTE 1: hence, a proxy does not provide any interworking function (neither service interworking nor network interworking).
NOTE 2: a proxy as network element is an intermediary node in the sense of identical protocol stacks at incoming and outgoing interfaces of the proxy.

SIP B2BUA:   provides a B2BUA function with for the SIP, i.e., a service interworking function (according clause 3.2/ITU-T Y.1251) in the IP control plane.
NOTE: the service interworking function may include as well the interworking of the protocol stack for SIP transport (e.g., SIP-over-UDP/IP4 to SIP-over-SCTP/IPv6 interworking).

... and then subsequent, derived term definitions for

media plane B2BUA

back-to-back IP host

etc

Just some thoughts,

Albrecht

-----Original Message-----
From: Christer Holmberg [mailto:[email-masked]]
Sent: Sonntag, 16. Juni 2013 11:04
To: Schwarz, Albrecht (Albrecht); Hadriel Kaplan; <[email-masked]>
Subject: VS: [straw] draft-ietf-straw-b2bua-taxonomy: decomposed gateway model and media plane b2bua types

(As co-chair)

Hi Albrecht,

Regards,

Christer

-----Alkuperäinen viesti-----

Lähettäjä: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]] Puolesta Schwarz, Albrecht (Albrecht)

Vastaanottaja: Hadriel Kaplan; <[email-masked]<mailto:[email-masked]>>

Hi Hadriel,

Regards,

Albrecht

straw mailing list

[email-masked]<mailto:[email-masked]>