Subject: [straw] straw-sip-traceroute: 205?

From: Christer Holmberg <[email-masked]>
Date: Mon, 9 Sep 2013 11:13:25 +0000

(As co-chair)

Hi,

Hadriel has submitted the following draft in DISPATCH:

http://tools.ietf.org/id/draft-kaplan-dispatch-sip-205-response-00.txt

The draft defines a new SIP response code, 205, and Hadriel has also suggested the response code to be used in the STRAW trace-route delivery:

http://tools.ietf.org/html/draft-ietf-straw-sip-traceroute-00

The 205 draft has not been adopted yet, but the chairs would still like to ask the STRAW community whether it thinks that we can make a working assumption decision that we will use the 205 mechanism (assuming it gets done) in the trace-route delivery, or whether we should use some other mechanism.

If we choose 205, the trace-route draft will obviously have a dependency on the 205 draft, and we'll have to wait for it to get done.

And, as we don't know whether 205 will ever become an RFC, or how it will eventually look like, we can always re-visit any decision we make.

So, the question to the community is:

Do you think that:

a)      We shall base the trace-route delivery on using the SIP 205 response.

b)      We shall base the trace-route delivery on another mechanism - AND I am also elaborating on how such mechanism would look like.

c)      I have read all the relevant drafts, and the e-mail discussions, but I still think it is too early to make a working assumption, even if it later can be re-visited, at this point - AND I am also elaborating on why I think so.

Regards,

Christer & Victor

(STRAW Chairs)

---

From: Brett Tate <[email-masked]>
Date: Tue, 10 Sep 2013 13:13:03 +0000

> b) We shall base the trace-route delivery on another 
> mechanism - AND I am also elaborating on how such 
> mechanism would look like.
> c) I have read all the relevant drafts, and the e-mail 
> discussions, but I still think it is too early to make a
> working assumption, even if it later can be re-visited, at
> this point - AND I am also elaborating on why I think so.

Based upon the choices, I think c).  This is because the 205 solution relies upon a second part of the solution which would basically need to be adequate enough to work without requiring the 205.  For instance if the second part is the Reason header, I don't see a reason why it would work within a 205 response but not a 200 response.  Thus I think that the second part of the solution is the real solution although the 205 provides a little extra information (similar to History-Info).

NOTE: The 205 response is generic enough to allow the otherwise final location to return a 205 response when not the "intended target".

However with that said, I don't have a strong opinion about draft-ietf-straw-sip-traceroute actually using or not using the 205.  

Thanks,
Brett

---

From: Christer Holmberg <[email-masked]>
Date: Tue, 10 Sep 2013 17:56:54 +0000

(As co-chair)

Hi Brett,

Thanks for your input!

In order to try to "narrow down" the options, would it be fair to say that you see a way forward on using EITHER 200 or 205, depending on how the "second part" will look like?

Regards,

Christer

-----Original Message-----
From: Brett Tate [mailto:[email-masked]] 
Sent: Tuesday, September 10, 2013 3:13 PM
To: Christer Holmberg; [email-masked]
Subject: RE: straw-sip-traceroute: 205?

> b) We shall base the trace-route delivery on another mechanism - AND I 
> am also elaborating on how such mechanism would look like.
> c) I have read all the relevant drafts, and the e-mail discussions, 
> but I still think it is too early to make a working assumption, even 
> if it later can be re-visited, at this point - AND I am also 
> elaborating on why I think so.

Thanks,
Brett

---

From: Brett Tate <[email-masked]>
Date: Tue, 10 Sep 2013 18:06:40 +0000

> In order to try to "narrow down" the options, would it 
> be fair to say that you see a way forward on using 
> EITHER 200 or 205, depending on how the "second part" 
> will look like?

Yes.

> Based upon the choices, I think c).  This is because the 205 solution
> relies upon a second part of the solution which would basically need to
> be adequate enough to work without requiring the 205.  For instance if
> the second part is the Reason header, I don't see a reason why it would
> work within a 205 response but not a 200 response.  Thus I think that
> the second part of the solution is the real solution although the 205
> provides a little extra information (similar to History-Info).
> 
> NOTE: The 205 response is generic enough to allow the otherwise final
> location to return a 205 response when not the "intended target".
> 
> However with that said, I don't have a strong opinion about draft-ietf-
> straw-sip-traceroute actually using or not using the 205.
> 
> Thanks,
> Brett

---

From: Victor Pascual Avila <[email-masked]>
Date: Wed, 11 Sep 2013 17:48:27 +0200

Thanks Brett!

Does anyone else have an opinion on this?

-Victor

---

From: Paul Kyzivat <[email-masked]>
Date: Wed, 11 Sep 2013 12:49:01 -0400

> Does anyone else have an opinion on this?

Was I the proposer of this? I think so.

It seemed like a good idea initially. But as we talk about it, coming up 
with good criteria for choosing 205 rather than 200 seems quite hard.

I am satisfied with using Reason with 200 for the purpose at hand.

	Thanks,
	Paul

> _______________________________________________
> straw mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/straw
>

---

From: Victor Pascual Avila <[email-masked]>
Date: Sun, 15 Sep 2013 11:21:00 +0200

> I am satisfied with using Reason with 200 for the purpose at hand.

I agree

-Victor (as individual)

>>>>> b) We shall base the trace-route delivery on another mechanism - AND
>>>>
>>>> I
>>>>>

---

From: Hadriel Kaplan <[email-masked]>
Date: Mon, 16 Sep 2013 12:04:33 -0400

The 205 response code by itself won't be enough - it's too likely to get mapped to a 200 before reaching the UAC.  The Reason header might be enough by itself.  The rationale for doing the 205 was discussed in the original thread back in July.   See here:
http://www.ietf.org/mail-archive/web/straw/current/msg00147.html

-hadriel

On Sep 9, 2013, at 7:13 AM, Christer Holmberg <[email-masked]> wrote:

> If we choose 205, the trace-route draft will obviously have a dependency on the 205 draft, and we’ll have to wait for it to get done.
>  
> And, as we don’t know whether 205 will ever become an RFC, or how it will eventually look like, we can always re-visit any decision we make.
>

---

From: Hadriel Kaplan <[email-masked]>
Date: Mon, 16 Sep 2013 12:07:25 -0400

On Sep 11, 2013, at 12:49 PM, Paul Kyzivat <[email-masked]> wrote:

> It seemed like a good idea initially. But as we talk about it, coming up with good criteria for choosing 205 rather than 200 seems quite hard.

I'm fine with that too.  I do think sending a different 2xx for "you didn't reach the target you asked for" would have been useful for more than just traceroute, but it would take a very long time to get such a thing adopted+deployed in the real world.

-hadriel

---

From: Victor Pascual Avila <[email-masked]>
Date: Wed, 18 Sep 2013 10:30:41 +0200

> I'm fine with that too.  I do think sending a different 2xx for "you didn't reach the target you asked for" would have been useful for more than just traceroute, but it would take a very long time…

Then, I suggest we proceed accordingly.

-Victor