Subject: Re: [straw] I-D Action: draft-ietf-straw-b2bua-stun-02.txt

From: Lorenzo Miniero <[email-masked]>
Date: Mon, 2 Mar 2015 12:15:22 +0100

Hi all,

I just reviewed the latest version of this document. I'm personally
quite satisfied with its current stage, and only have a few comments
and nits on it.

Section 3.1 anticipates what is explained in better detail in the
following subsections. Anyway, credentials are not mentioned there,
e.g., when introducing passthrough mode. Although the management of all
ICE semantics, including credentials, is addressed in the related
subsection, I'd make this explicit in the intro as well, as it only
talks about forwarding candidates and may confuse the reader.

Typo in Section 4: s/dont/don't

I'd personally swap Sections 3 and 4, in order to first address
signalling-only B2BUAs and only then move to media-aware and
media-terminator: this would be more consistent with how the taxonomy
is referenced in the document, in Section 2.

Cheers,
Lorenzo

On Tue, 10 Feb 2015 05:04:51 +0000
"Ram Mohan R (rmohanr)" <[email-masked]> wrote:

> This version addresses some of the WGLC comments received in the
> mailing list. Thanks for the reviews/feedback so far.
> 
> Please let us know if you have any more comments on this draft.
> 
> Authors
> 
> -----Original Message-----
> From: "[email-masked]" <[email-masked]>
> Date: Tuesday, 10 February 2015 10:33 am
> To: "[email-masked]" <[email-masked]>
> Cc: "[email-masked]" <[email-masked]>
> Subject: [straw] I-D Action: draft-ietf-straw-b2bua-stun-02.txt
> 
> >
> >A New Internet-Draft is available from the on-line Internet-Drafts
> >directories.
> > This draft is a work item of the Sip Traversal Required for
> > Applications
> >to Work Working Group of the IETF.
> >
> >        Title           : Session Traversal Utilities for NAT (STUN)
> >Message Handling for Session Initiation Protocol (SIP) Back-to-Back
> >User Agents (B2BUAs)
> >        Authors         : Ram Mohan Ravindranath
> >                          Tirumaleswar Reddy
> >                          Gonzalo Salgueiro
> >	Filename        : draft-ietf-straw-b2bua-stun-02.txt
> >	Pages           : 14
> >	Date            : 2015-02-09
> >
> >Abstract:
> >   Session Initiation Protocol (SIP) Back-to-Back User Agents
> > (B2BUAs) are often designed to be on the media path, rather than
> > just intercepting signaling.  This means that B2BUAs often act on
> > the media path leading to separate media legs that the B2BUA
> > correlates and bridges together.  When acting on the media path,
> > B2BUAs are likely to receive Session Traversal Utilities for NAT
> > (STUN) packets as part of Interactive Connectivity Establishment
> > (ICE) processing. It is critical that B2BUAs handle these STUN
> > messages properly.
> >
> >   This document defines behavior for a B2BUA performing ICE
> > processing. The goal of this draft is to ensure that ICE used for
> > NAT and Firewall traversal of multimedia sessions works when there
> > are B2BUAs in place and the B2BUAs handle STUN messages properly.
> >
> >
> >The IETF datatracker status page for this draft is:
> >https://datatracker.ietf.org/doc/draft-ietf-straw-b2bua-stun/
> >
> >There's also a htmlized version available at:
> >http://tools.ietf.org/html/draft-ietf-straw-b2bua-stun-02
> >
> >A diff from the previous version is available at:
> >http://www.ietf.org/rfcdiff?url2=draft-ietf-straw-b2bua-stun-02
> >
> >
> >Please note that it may take a couple of minutes from the time of
> >submission
> >until the htmlized version and diff are available at tools.ietf.org.
> >
> >Internet-Drafts are also available by anonymous FTP at:
> >ftp://ftp.ietf.org/internet-drafts/
> >
> >_______________________________________________
> >straw mailing list
> >[email-masked]
> >https://www.ietf.org/mailman/listinfo/straw
> 
> _______________________________________________
> straw mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/straw

---

From: "Ram Mohan R (rmohanr)" <[email-masked]>
Date: Tue, 3 Mar 2015 07:02:10 +0000

Hi Lorenzo,

Thanks for your inputs. I will incorporate the below comments and also
swap section 3 and 4.

Ram