Subject: [straw] Coming up: WGLC draft-ietf-straw-b2bua-dtls-srtp

From: Christer Holmberg <[email-masked]>
Date: Thu, 13 Aug 2015 09:08:50 +0000

(As co-chair)

Hi,

We intend to initiate the WGLC for draft-ietf-straw-b2bua-dtls-srtp soon.

As always, anyone is welcome to review the document, but we'd like to ask for a couple of persons who are willing to commit.
https://datatracker.ietf.org/doc/draft-ietf-straw-b2bua-dtls-srtp/

Thanks!

Christer & Victor

---

From: Simon Perreault <[email-masked]>
Date: Thu, 13 Aug 2015 08:24:07 -0400

Le 2015-08-13 05:08, Christer Holmberg a écrit :
> As always, anyone is welcome to review the document, but we’d like to
> ask for a couple of persons who are willing to commit.

I've read the diff of every revision since my full review. IMHO the
document is ready.

Simon

---

From: "Schwarz, Albrecht (Albrecht)" <[email-masked]>
Date: Thu, 13 Aug 2015 13:09:46 +0000

Some comments from a rough review:

1) DTLS terminology
There's still a mix of "DTLS association" and "DTLS connection".
Proposal: replace "DTLS association" by "DTLS connection" for consistency reasons
Justification: draft-guballa-tls-terminology

2) Number of DTLS sessions/DTLS connections per SRTP/SRTCP flow components
The draft seems to be implicitly correct, but an explicit statement might be benefecial:
Proposal:
3.1.1
...
For each RTP or RTCP flow, the peers do a DTLS handshake on the same
   source and destination port pair to establish a DTLS association.  In
   this case, Bob, after he receives an INVITE, triggers a DTLS
   connection.  

Replaced by
For each RTP or RTCP flow, the peers do a DTLS handshake on the same
   source and destination port pair to establish a DTLS connection. Hence, there would be then two DTLS connections (if transport unmultiplexed) or a single DTLS connection (in case of transport multiplexing).  In
   this case, Bob, after he receives an INVITE, triggers a DTLS
   connection per L4 connection.

Furthermore: Figure 1 indicates just a single DTLS session in steps 7 to 10 ("there might be two")

Justification:  https://mailarchive.ietf.org/arch/search/?email_list=rtcweb  -> Re: [rtcweb] What the gateway draft should say about mux/non-mux

3) L4 protocol
Current draft mentions UDP only, but would be also valid for TCP-based RTP transport (such in case of WebRTC) in my understanding.
Proposal: indicate TCP option

4) Editorial - Figure 1:
Several notions for "IP transport address": "IP/port", "IP, port" and "address,port"
Proposal: just a single notion

5) Editorial - RFC 7092 terms:
RFC 7092: "media relay" and "media aware" roles, but not "media aware relay" role
Proposal: 3.1.2 title & body ... just "media aware"
Correct would be "media plane, media aware B2BUA" entity in my understanding.

Just some quick comments,
Albrecht

-----Original Message-----
From: straw [mailto:[email-masked]] On Behalf Of Simon Perreault
Sent: Donnerstag, 13. August 2015 14:24
To: Christer Holmberg; [email-masked]
Subject: Re: [straw] Coming up: WGLC draft-ietf-straw-b2bua-dtls-srtp

Le 2015-08-13 05:08, Christer Holmberg a écrit :
> As always, anyone is welcome to review the document, but we'd like to 

I've read the diff of every revision since my full review. IMHO the document is ready.

Simon

_______________________________________________
straw mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/straw

---

From: "Ram Mohan R (rmohanr)" <[email-masked]>
Date: Thu, 13 Aug 2015 13:39:36 +0000

Thanks Albrecht for your feedback.

I will address these in the next revision.

Ram

-----Original Message-----
From: straw <[email-masked]> on behalf of "Schwarz, Albrecht
(Albrecht)" <[email-masked]>
Date: Thursday, 13 August 2015 6:39 pm
To: Christer Holmberg <[email-masked]>, "[email-masked]"
<[email-masked]>
Cc: "GUBALLA, JENS (JENS)" <[email-masked]>
Subject: Re: [straw] Coming up: WGLC draft-ietf-straw-b2bua-dtls-srtp

>   source and destination port pair to establish a DTLS connection.
>Hence, there would be then two DTLS connections (if transport
>unmultiplexed) or a single DTLS connection (in case of transport
>multiplexing).  In
>Justification:  
>https://mailarchive.ietf.org/arch/search/?email_list=rtcweb  -> Re:
>[rtcweb] What the gateway draft should say about mux/non-mux
>
>3) L4 protocol
>Current draft mentions UDP only, but would be also valid for TCP-based
>RTP transport (such in case of WebRTC) in my understanding.

---

From: "GUBALLA, JENS (JENS)" <[email-masked]>
Date: Thu, 13 Aug 2015 13:21:56 +0000

One additional comment:

>    source and destination port pair to establish a DTLS connection. Hence,
> there would be then two DTLS connections (if transport unmultiplexed) or a
> single DTLS connection (in case of transport multiplexing).  In
[JG] ... triggers the establishment of a DTLS connection per L4 connection.

Jens

---

From: Christer Holmberg <[email-masked]>
Date: Thu, 13 Aug 2015 16:48:34 +0000

(As co-chair)

Thanks Simon!

Regards,

Christer

-----Original Message-----
From: Simon Perreault [mailto:[email-masked]] 
Sent: 13 August 2015 15:24
To: Christer Holmberg <[email-masked]>; [email-masked]
Subject: Re: [straw] Coming up: WGLC draft-ietf-straw-b2bua-dtls-srtp

Simon

---

From: "Ram Mohan R (rmohanr)" <[email-masked]>
Date: Mon, 17 Aug 2015 04:48:26 +0000

Here Jens and Albrecht,

Here is the updated draft diffs with some changes to address your
comments. Let me know if this takes care of your comments.

Regards,
Ram

-----Original Message-----
From: straw <[email-masked]> on behalf of "GUBALLA, JENS (JENS)"
<[email-masked]>
Date: Thursday, 13 August 2015 6:51 pm
To: "Schwarz, Albrecht (Albrecht)" <[email-masked]>,
Christer Holmberg <[email-masked]>, "[email-masked]"
<[email-masked]>
Subject: Re: [straw] Coming up: WGLC draft-ietf-straw-b2bua-dtls-srtp

>>Hence,

---

From: "GUBALLA, JENS (JENS)" <[email-masked]>
Date: Mon, 17 Aug 2015 09:12:03 +0000

Hi Ram,

Thanks for the update.

Could you just swap my last name and first name in the acknowledgement
section?

I have no more comments otherwise.

Best regards,
Jens
> From: Ram Mohan R (rmohanr) [mailto:[email-masked]]
> Sent: Montag, 17. August 2015 06:48
> To: GUBALLA, JENS (JENS); Schwarz, Albrecht (Albrecht); Christer Holmberg;
> [email-masked]
comments.
> Let me know if this takes care of your comments.
> 
> Regards,
> Ram
> 
> >> there would be then two DTLS connections (if transport unmultiplexed)
> >>or a  single DTLS connection (in case of transport multiplexing).  In

---

From: "Ram Mohan R (rmohanr)" <[email-masked]>
Date: Mon, 17 Aug 2015 10:18:49 +0000

Hi Jens,

Sure. Will do that.

Ram

-----Original Message-----
From: "GUBALLA, JENS (JENS)" <[email-masked]>
Date: Monday, 17 August 2015 2:42 pm
To: Cisco Employee <[email-masked]>, "Schwarz, Albrecht (Albrecht)"
<[email-masked]>, Christer Holmberg
<[email-masked]>, "[email-masked]" <[email-masked]>
Subject: RE: [straw] Coming up: WGLC draft-ietf-straw-b2bua-dtls-srtp