Subject: Re: [sunset4] new charter draft version

From: "George, Wes" <[email-masked]>
Date: Thu, 1 Nov 2012 08:04:53 -0400

The lack of any response to this is a bit disconcerting. I realize we have both IETF prep and storms taking people away from normal list traffic, but does anyone have comments? It's much easier to wordsmith a charter via email than in a room full of people. Please voice an opinion one way or the other.

Thanks
Wes George

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Marc Blanchet
> Sent: Monday, October 22, 2012 3:02 PM
> To: [email-masked]
> Subject: [sunset4] new charter draft version
>
> Hello,
>  a few individuals worked on a new version of the sunset4 charter after
> the last IETF.  It has been wordsmitted many times and hopefully would
> get support from the working group.
>
> It would be useful for us to see if you support this charter. If you
> disagree, it would be useful to get modified text.
>
> Marc and Wes.
>
> PS. Current charter is still at the normal place:
> https://datatracker.ietf.org/doc/charter-ietf-sunset4/
> PS2. this new charter has not got through IESG review yet.
>
> =======
> New sunset4 proposed charter
> 2012-10-22
>
> Global IPv4 addresses, once freely available, are an increasingly scarce
> resource for many who wish to connect to the Internet today. IPv6
> provides an abundance of freely available addresses, and while
> deployment alongside IPv4 has begun in earnest, much work remains.
>
> In order to fully transition the Internet to IPv6, individual
> applications, hosts, and networks that have enabled IPv6 must also be
> able to operate fully in the absence of IPv4. The Working Group will
> point out specific areas of concern, provide recommendations, and
> standardize protocols that facilitate the graceful "sunsetting" of the
> IPv4 Internet in areas where IPv6 has been deployed. This includes the
> act of shutting down IPv4 itself, as well as the ability of IPv6-only
> portions of the Internet to continue to connect with portions of the
> Internet that remain IPv4-only.
>
> While this work obviously spans multiple IETF areas including Internet,
> Operations, Transport, Applications, and Routing, this working group
> provides a single venue for the consideration of IPv4 sunsetting. Work
> in this group shall never impede the deployment of IPv6, will not
> duplicate functions and capabilities already available in existing
> technologies, and should demonstrate widespread operational need. Cross-
> area coordination and support is essential.
>
> Disabling IPv4 in applications, hosts, and networks is new territory for
> much of the Internet today, and it is expected that problems will be
> uncovered including those related to basic IPv4 functionality,
> interoperability, as well as potential security concerns. The working
> group will report on common issues, provide recommendations, and, when
> necessary, protocol extensions in order to facilitate disabling IPv4 in
> networks where IPv6 has been deployed.
>
> As a rule, deployment scenarios considered by the working group shall
> include IPv6-only nodes and networks. Work on technologies that involve
> increased sharing of global IPv4 addresses should be limited to what is
> necessary for communicating with endpoints or over networks that are
> IPv6-only.
>
> The initial work items are:
>  * NAT64 port allocation and address sharing methods involving scenarios
> where an IPv6-only node is present (and NAT44, as it overlaps NAT64
> address sharing and port
> use).
>  * Gap analysis of IPv4 features to facilitate IPv4 sunsetting
>  * Provisioning methods to signal a dual-stack host to disable or
> depreference the use of IPv4
>
>
> Goals and Milestones:
>  Mar 2013 - Submit gap analysis on IPv4 sunsetting to IESG for
> consideration as an Informational RFC
>  Jun 2013 - Submit NAT64 port allocation and address sharing methods to
> IESG for consideration as an Informational RFC
>  Sep 2013 - Submit provisioning methods to signal a dual-stack host to
> disable the use of IPv4 to IESG for consideration as Proposed Standard
> _______________________________________________
> sunset4 mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/sunset4

This E-mail and any of its attachments may contain Time Warner Cable proprietary information, which is privileged, confidential, or subject to copyright belonging to Time Warner Cable. This E-mail is intended solely for the use of the individual or entity to which it is addressed. If you are not the intended recipient of this E-mail, you are hereby notified that any dissemination, distribution, copying, or action taken in relation to the contents of and attachments to this E-mail is strictly prohibited and may be unlawful. If you have received this E-mail in error, please notify the sender immediately and permanently delete the original and any copy of this E-mail and any printout.

---

From: Simon Perreault <[email-masked]>
Date: Thu, 01 Nov 2012 14:02:24 +0100

Le 2012-11-01 13:04, George, Wes a écrit :
> The lack of any response to this is a bit disconcerting. I realize we
> have both IETF prep and storms taking people away from normal list
> traffic, but does anyone have comments? It's much easier to wordsmith
> a charter via email than in a room full of people. Please voice an
> opinion one way or the other.

One question I have is where will the CGN stuff go?

One instance of "CGN stuff": In BEHAVE we had to split off the CGN part 
of the NAT MIB. We were told that it would go in sunset4. It's not clear 
to me just by reading the charter that this advice is still valid.

There's a ton of other CGN-related drafts floating around. Is the plan 
just to let them die? If so, I fear they'll keep coming back to haunt us...

Simon
-- 
DTN made easy, lean, and smart --> http://postellation.viagenie.ca
NAT64/DNS64 open-source        --> http://ecdysis.viagenie.ca
STUN/TURN server               --> http://numb.viagenie.ca