Subject: [sunset4] Call for comments regarding NAT64 port allocation

From: GangChen <[email-masked]>
Date: Tue, 5 Nov 2013 05:44:56 +0800

Wg,

We have some preliminary thoughts for converging those three drafts.
Please kindly check the attached for your reference.
Thank Tom for drafting the slides.
We would like to take the slides as the starting point to prepare the draft.
There are also a couple of questions to the wg in order to guide
authors to write draft.

a) Should we recommend a particular solution in the draft to allocate
nat64 port?
b) Or, should we describe all the known solutions neutrally and
evaluate pros/cons?

Your comments on the slides or above questions are appreciated.

Many thanks

Gang

2013/10/29, GangChen <[email-masked]>:
> I guess it's better to open this message to wg and get comments.
> Actually, there are several drafts on the table regarding the NAT64
> port allocation.
> For example, draft-chen-sunset4-cgn-port-allocation,
> draft-tsou-behave-natx4-log-reduction and
> draft-donley-behave-deterministic-cgn
> The authors would like to work together and meet the current charter item:
> Submit NAT64 portallocation and address sharing methods to IESG
> forconsideration as an Informational RFC
>
> We would like to make a joint presentation in the meeting. If there is
> any comments/suggestions for this convergence, we would be much
> appreciated.
>
> Best Regards
>
> Gang
>
> 2013/10/29, GangChen <[email-masked]>:
>> Dear chairs,
>>
>> We intend to the make a joint presentation in Sunset4 for a converged
>> draft of NAT64-port allocation.
>> The new draft is not available at this time. We are trying to upload
>> when there is a clear thought how to combine different drafts.
>> The presentation in this meeting would like to propose some ideas for
>> the converged items.
>> We expect to receive the feedback from wg for the next step.
>>
>> Best Regards
>>
>> Gang
>>
>

---

From: Ted Lemon <[email-masked]>
Date: Tue, 5 Nov 2013 00:11:32 +0000

Why not just use PCP?

---

From: GangChen <[email-masked]>
Date: Tue, 5 Nov 2013 08:36:29 +0800

I guess PCP could a way to allocate the port. My thought was port
allocation with PCP is the behavior of PCP client+NAT64+PCP server. We
may not expect each NAT64 is capable of PCP server.

BRs

Gang

---

From: Marc Blanchet <[email-masked]>
Date: Mon, 4 Nov 2013 16:38:42 -0800

Le 2013-11-04 à 16:36, GangChen <[email-masked]> a écrit :

cut all cc:. please use the sunset4 ml further.

> may not expect each NAT64 is capable of PCP server.

then it is a question of tradeoffs. Needs to be ironed out and discussed.

Marc.

---

From: Tom Taylor <[email-masked]>
Date: Mon, 04 Nov 2013 19:44:30 -0500

This is about how and why you use PCP.

---

From: GangChen <[email-masked]>
Date: Tue, 5 Nov 2013 08:47:05 +0800

> then it is a question of tradeoffs. Needs to be ironed out and discussed.

Yes. It should be discussed.
BTW, there is an analysis draft for PCP, it may provide some
information help to discuss
http://www.ietf.org/id/draft-chen-pcp-mobile-deployment-04.txt

BRs

Gang

---

From: "Reinaldo Penno (repenno)" <[email-masked]>
Date: Tue, 5 Nov 2013 20:36:32 +0000

Port or group of ports. There is draft from quite a few folks on the
mechanism to do so.

http://tools.ietf.org/html/draft-ietf-pcp-port-set-03

This draft is in WGLC.

On 11/4/13 4:36 PM, "GangChen" <[email-masked]> wrote:

>_______________________________________________
>sunset4 mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/sunset4