Subject: [sunset4] Fwd: New Version Notification for draft-fan-sunset4-router-id-00.txt

From: "Fan, Peng" <[email-masked]>
Date: Fri, 20 Jun 2014 16:34:27 +0800

Hi all,

The following draft is about problems of managing router IDs in an
IPv6 only network as well as some solution ideas. It is an effort
based on the feedback during the last IETF meeting. Your review and
comments are appreciated.

Best regards,
Peng

---------- Forwarded message ----------
From: [email-masked]
Date: Fri, 20 Jun 2014 00:50:46 -0700
Subject: New Version Notification for draft-fan-sunset4-router-id-00.txt
To: Peng Fan <[email-masked]>

A new version of I-D, draft-fan-sunset4-router-id-00.txt
has been successfully submitted by Peng Fan and posted to the
IETF repository.

Name:		draft-fan-sunset4-router-id
Revision:	00
Title:		Managing Router Identifiers during IPv4 Sunset
Document date:	2014-06-20
Group:		Individual Submission
Pages:		3
URL:
http://www.ietf.org/internet-drafts/draft-fan-sunset4-router-id-00.txt
Status:         https://datatracker.ietf.org/doc/draft-fan-sunset4-router-id/
Htmlized:       http://tools.ietf.org/html/draft-fan-sunset4-router-id-00

Abstract:
   This document describes problems of managing protocol identifiers
   when turning off IPv4 and migrating to IPv6 only network, with some
   potential solutions discussed.

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

---

From: Karsten Thomann <[email-masked]>
Date: Thu, 26 Jun 2014 23:26:13 +0200

Hi,

I think the solution area should be extended by another possibility to embed 
IPv4 addresses in v6, as the /96 version has to use the hex version of the ID, 
the use of a /80 could be used to store them in a format like 
2001:db8::1921:6825:5001 or 2001:db8::0102:5525:0001.
If you like to use an even better readable approach you can also use a /64 for 
addresses like 2001:db8::192:168:255:1.

Regards
Karsten

Am Freitag, 20. Juni 2014, 16:34:27 schrieb Fan, Peng:
> Status:        
> https://datatracker.ietf.org/doc/draft-fan-sunset4-router-id/ Htmlized:    
>   http://tools.ietf.org/html/draft-fan-sunset4-router-id-00
> 
> 
> Abstract:
> _______________________________________________
> sunset4 mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/sunset4

---

From: "Fan, Peng" <[email-masked]>
Date: Fri, 27 Jun 2014 16:43:27 +0800

Hi Karsten,

Thanks for the comment, please see reply inline [FP].

> IPv4 addresses in v6, as the /96 version has to use the hex version of the
ID,
[FP] Perhaps we can use the mixed notation, e.g. 2001:db8::192.168.255.1?

> addresses like 2001:db8::192:168:255:1.
[FP] Yes these approaches are quite human-friendly, thanks.
[FP] We can also consider if there is another solution besides address
mapping and other ideas in the draft.

Best regards,
Peng

---

From: Karsten Thomann <[email-masked]>
Date: Fri, 27 Jun 2014 11:24:21 +0200

Hi,

The mixed notation can't be used, as it is converted to the hex version 
automatically and is stored as the /96 case in hex.
ping 2001:db8::192.168.0.1
Pinging 2001:db8::c0a8:1 with 32 bytes of data:

At least im not aware of a device which stores the IPv6 address in mixed 
notation, they accept it and convert it to the hex notation in /96, afaik.

Regards
Karsten

---

From: "Fan, Peng" <[email-masked]>
Date: Fri, 27 Jun 2014 23:00:44 +0800

Hi Karsten,

Okay so it is inconvenient at least when we want to get the value of router
id from an address.

This discussion does remind me of a saying that mixed notation is not
suggested... http://www.ietf.org/mail-archive/web/idr/current/msg12901.html

Best regards,
Peng

> -----Original Message-----
> From: sunset4 [mailto:[email-masked]] On Behalf Of Karsten
> Thomann
> Sent: Friday, June 27, 2014 5:24 PM
> To: Fan, Peng
> Cc: [email-masked]
> Subject: Re: [sunset4] Fwd: New Version Notification for
draft-fan-sunset4-
> router-id-00.txt
> >> I think the solution area should be extended by another possibility
> >> to
> > embed
> >> IPv4 addresses in v6, as the /96 version has to use the hex version
> >> of the
> > ID,
> >> If you like to use an even better readable approach you can also use
> >> a /64
> > for