Subject: Re: [sunset4] Fwd: New Version Notification for draft-song-sunset4-ipv6only-dns-00.txt

From: "George, Wes" <[email-masked]>
Date: Wed, 14 Jan 2015 13:05:24 -0500

Hi -

I gave this draft a quick review in preparation for identifying what we might discuss in our next meeting in Dallas.

It is unclear to me what the relationship is between draft-song-sunset4 and draft-davey-sunset4, and I think they should probably be integrated into one draft. Or does the newer draft supersede the other? If the one supersedes the other, I can send mail to the secretariat so that the metadata reflects that.

Either way, there are additional things to discuss in this space, such as the interaction between the DNS server, IPv4 transition/life extension technologies, address selection, and happy eyeballs. Some of it is covered in draft-ietf-dhc-conn-status-00, but I'm not certain what the status of that draft is.

The problem statement we discussed at a DHC/Sunset4 joint meeting was as follows:
•Many networks will have both IPv4 and IPv6, but with varying transition technologies affecting the quality of those stacks
–“real” IPv4 (no CGN)
–CGN IPv4 (potentially broken for some apps)
–NAT64/DNS64 (also potentially breaks things)
–IPv6 (only)
•How do you tell dual-stack hosts which to use/avoid?
–For which destinations?
–With which protocol(s)?
–Happy Eyeballs helps, but can be non-deterministic

Thanks,

Wes

From: Davey Song <[email-masked]<mailto:[email-masked]>>
Date: Monday, October 27, 2014 at 9:00 PM
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: [sunset4] Fwd: New Version Notification for draft-song-sunset4-ipv6only-dns-00.txt

Hi folks, I have just post a new draft on IPv6-only DNS development. Comments are welcome!!

A new version of I-D, draft-song-sunset4-ipv6only-dns-00.txt
has been successfully submitted by Linjian Song and posted to the
IETF repository.

Name:           draft-song-sunset4-ipv6only-dns
Revision:       00
Title:          Considerations on IPv6-only DNS Development
Document date:  2014-10-27
Group:          Individual Submission
Pages:          8
URL:            http://www.ietf.org/internet-drafts/draft-song-sunset4-ipv6only-dns-00.txt
Status:         https://datatracker.ietf.org/doc/draft-song-sunset4-ipv6only-dns/
Htmlized:       http://tools.ietf.org/html/draft-song-sunset4-ipv6only-dns-00

Abstract:
   Deployment of IPv6-only networks are impacted by assumptions of
   IPv4-only or dual-stack transition scenarios.  For example, these
   assumptions are in the operations of DNS.  This memo is problem
   statement and hopes to eventually propose a mitigation technique.

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org<http://tools.ietf.org>.

The IETF Secretariat

________________________________
This E-mail and any of its attachments may contain Time Warner Cable proprietary information, which is privileged, confidential, or subject to copyright belonging to Time Warner Cable. This E-mail is intended solely for the use of the individual or entity to which it is addressed. If you are not the intended recipient of this E-mail, you are hereby notified that any dissemination, distribution, copying, or action taken in relation to the contents of and attachments to this E-mail is strictly prohibited and may be unlawful. If you have received this E-mail in error, please notify the sender immediately and permanently delete the original and any copy of this E-mail and any printout.

---

From: Davey Song <[email-masked]>
Date: Tue, 20 Jan 2015 11:56:09 +0800

Sorry for late response, George.

Yes,  newer draft supersede the older one. It's appreciated if you can help
me to connect them. In addition If there is meeting in Dallas, I would like
to apply for a time slot. Thank you.

regards,
Davey

On Thu, Jan 15, 2015 at 2:05 AM, George, Wes <[email-masked]>
wrote:

>   Hi -
>
>  I gave this draft a quick review in preparation for identifying what we
> might discuss in our next meeting in Dallas.
>
>  It is unclear to me what the relationship is between draft-song-sunset4
> and draft-davey-sunset4, and I think they should probably be integrated
> into one draft. Or does the newer draft supersede the other? If the one
> supersedes the other, I can send mail to the secretariat so that the
> metadata reflects that.
>
>  Either way, there are additional things to discuss in this space, such
> as the interaction between the DNS server, IPv4 transition/life extension
> technologies, address selection, and happy eyeballs. Some of it is covered
> in draft-ietf-dhc-conn-status-00, but I'm not certain what the status of
> that draft is.
>
>  •Many networks will have both IPv4 and IPv6, but with varying transition
> technologies affecting the quality of those stacks
>  –“real” IPv4 (no CGN)
>    From: Davey Song <[email-masked]>
> To: "[email-masked]" <[email-masked]>
> URL:
> http://www.ietf.org/internet-drafts/draft-song-sunset4-ipv6only-dns-00.txt
> Status:
> https://datatracker.ietf.org/doc/draft-song-sunset4-ipv6only-dns/
> Htmlized:
> http://tools.ietf.org/html/draft-song-sunset4-ipv6only-dns-00
>
>
> Abstract:
> until the htmlized version and diff are available at tools.ietf.org.
>
> The IETF Secretariat
>
>
>
> ------------------------------
> This E-mail and any of its attachments may contain Time Warner Cable
> proprietary information, which is privileged, confidential, or subject to
> copyright belonging to Time Warner Cable. This E-mail is intended solely
> for the use of the individual or entity to which it is addressed. If you
> are not the intended recipient of this E-mail, you are hereby notified that
> any dissemination, distribution, copying, or action taken in relation to
> the contents of and attachments to this E-mail is strictly prohibited and
> may be unlawful. If you have received this E-mail in error, please notify
> the sender immediately and permanently delete the original and any copy of
> this E-mail and any printout.
>