Subject: Re: [sunset4] Discussion: IPv4 as a Service

From: "Fred Baker (fred)" <[email-masked]>
Date: Sun, 29 Mar 2015 01:36:03 +0000

I sent this the other day to v6ops; most of you are on that list and no doubt received it. However, since Wes showed the question to sunset4, I’d like to invite sunset4 to comment on the set of questions we are collecting.

https://docs.google.com/document/d/1ifDEkoypW43lgZJqh2paUDcMAwoUWdz6psyEb456c3A/edit?usp=sharing

I’d appreciate any comments you have on this being edited into the file or in a reply to the list or to the chairs.

> On Mar 25, 2015, at 6:48 PM, Fred Baker <[email-masked]> wrote:
> 
> Lee and I opened a discussion in the v6ops meeting today on a topic that I believe that the IETF, in cooperation with the *NOGs, needs to address. My slide is at https://www.ietf.org/proceedings/92/slides/slides-92-v6ops-9.pptx. Sunset4 and softwire chairs, please feel free to forward this to your mailing lists.
> 
> In short, we are starting to see the deployment of IPv6-only networks. In most cases, these are existing IPv4 networks that have become dual stack, and are somewhere in the process of shutting IPv4 down. These include Facebook, which (regardless of whether you view it as an enterprise or a content network) has been public about the fact, several mobile networks that treat IPv6-capable telephones as an IPv6-only network and use 464xlat as an operational methodology dealing with that, and some research networks, notably CERNET2, which has been running IPv6-only for ten years now. We also see green-field networks, such as Reliance JIO Infocomm Ltd; Suprita Sah presented on that topic today.
> 
> I am of the opinion, and there seemed to be agreement in the room, that the Internet community would be well served if we collected deployment experience with these technologies, and the considered advice of deploying operators. We have tried to guide the deployment of IPv6, and gathered experience and mitigations for that. Now, as IPv4 begins to fade, we need to take a leadership role in that.
> 
> I have opened a document on Google Docs, and given folks the ability to view it. That is at https://docs.google.com/document/d/1ifDEkoypW43lgZJqh2paUDcMAwoUWdz6psyEb456c3A. I have included an initial list of relevant technologies, and an initial list of the questions that we would want discussed in experience documents. I guarantee that there is an important question not asked, and while I hope otherwise, there may be some technology I have overlooked. So I invite discussion to flesh out that initial phase.

---

From: "Fred Baker (fred)" <[email-masked]>
Date: Mon, 30 Mar 2015 19:54:16 +0000

Over the weekend, we crowd-sourced a number of pretty good questions. I took the liberty, this morning, of reorganizing the text a bit. The "list of technologies" and "list of questions" remain, but I have added "possible (classes of) documents to be developed" and a first cut at a proposed outline, with the questions from above pulled in to make it clear what I might hope the section might comment on.

Collecting comments and thoughts. I guarantee there is something we haven’t thought of (as I was reorganizing, several points popped out, and I’m sure I’m not that smart).