Subject: Re: [sunset4] Fwd: New Version Notification for draft-chen-sunset4-cgn-port-allocation-05.txt

From: "George, Wes" <[email-masked]>
Date: Thu, 2 Apr 2015 11:45:02 -0400

Authors -

Based on the discussion during the meeting in Dallas, please publish a new
version of this with a slightly different name. We will not link the two
in "replaces", and this will clear the existing IPR encumbrance.

Separately, will the cable Labs folks confirm that the new draft does not
have any of your IPR in it?

Once this is completed, we will call for WG adoption. Sorry for the Texas
two-step, but this was the recommended way to address the IPR concerns.

Thanks,

Wes

On 9/29/14, 12:04 PM, "Tom Taylor" <[email-masked]> wrote:

>Draft has been posted. Detailed changes as described in the response to
>Lee Howard's review, plus deletion of the section on deterministic CGN
>as agreed in Toronto.
>
>Tom Taylor
>
>-------- Original Message --------
>Subject: New Version Notification for
>draft-chen-sunset4-cgn-port-allocation-05.txt
>Date: Mon, 29 Sep 2014 08:55:31 -0700
>From: [email-masked]
>To: Tom Taylor <[email-masked]>, Weibo Li
><[email-masked]>, James Huang <[email-masked]>, Gang Chen
><[email-masked]>, Weibo Li <[email-masked]>, Tina Tsou
><[email-masked]>, Jing Huang <[email-masked]>,
>Tina Tsou <[email-masked]>, Tom Taylor
><[email-masked]>, Gang Chen <[email-masked]>
>
>
>A new version of I-D, draft-chen-sunset4-cgn-port-allocation-05.txt
>has been successfully submitted by Tom Taylor and posted to the
>IETF repository.
>
>Name:          draft-chen-sunset4-cgn-port-allocation
>Revision:      05
>Title:         Analysis of NAT64 Port Allocation Methods for Shared IPv4
>Addresses
>Document date: 2014-09-29
>Group:         Individual Submission
>Pages:         19
>URL:
>http://www.ietf.org/internet-drafts/draft-chen-sunset4-cgn-port-allocation
>-05.txt
>Status:
>https://datatracker.ietf.org/doc/draft-chen-sunset4-cgn-port-allocation/
>Htmlized:
>http://tools.ietf.org/html/draft-chen-sunset4-cgn-port-allocation-05
>Diff:
>http://www.ietf.org/rfcdiff?url2=draft-chen-sunset4-cgn-port-allocation-05
>
>Abstract:
>    This document enumerates methods of port assignment in Carrier Grade
>    NATs (CGNs), focused particularly on NAT64 environments.  A
>    theoretical framework of different NAT port allocation methods is
>    described.  The memo is intended to clarify and focus the port
>    allocation discussion and propose an integrated view of the
>    considerations for selection of the port allocation mechanism in a
>    given deployment.
>
>
>
>
>
>Please note that it may take a couple of minutes from the time of
>submission
>until the htmlized version and diff are available at tools.ietf.org.
>
>The IETF Secretariat
>
>
>
>
>_______________________________________________
>sunset4 mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/sunset4

This E-mail and any of its attachments may contain Time Warner Cable proprietary information, which is privileged, confidential, or subject to copyright belonging to Time Warner Cable. This E-mail is intended solely for the use of the individual or entity to which it is addressed. If you are not the intended recipient of this E-mail, you are hereby notified that any dissemination, distribution, copying, or action taken in relation to the contents of and attachments to this E-mail is strictly prohibited and may be unlawful. If you have received this E-mail in error, please notify the sender immediately and permanently delete the original and any copy of this E-mail and any printout.

---

From: "Huangjing (A)" <[email-masked]>
Date: Tue, 14 Apr 2015 10:26:35 +0000

Hi, Chris,

Could you please help to confirm the IPR issue? Thanks a lot!

I am one of the co-authors.

Best Regards
James

> -----Original Message-----
> From: sunset4 [mailto:[email-masked]] On Behalf Of George, Wes
> Sent: Thursday, April 02, 2015 11:45 PM
> To: Tom Taylor; [email-masked]
> Cc: Donley, Chris (Cable Labs)
> Subject: Re: [sunset4] Fwd: New Version Notification for
> version of this with a slightly different name. We will not link the two in
> "replaces", and this will clear the existing IPR encumbrance.
> 
> Separately, will the cable Labs folks confirm that the new draft does not have
> any of your IPR in it?
> 
> >has been successfully submitted by Tom Taylor and posted to the IETF
> >repository.
> >
> >submission until the htmlized version and diff are available at
> >tools.ietf.org.
> >
> >The IETF Secretariat
> >
> >
> >
> >
> This E-mail and any of its attachments may contain Time Warner Cable
> proprietary information, which is privileged, confidential, or subject to
> copyright belonging to Time Warner Cable. This E-mail is intended solely for the
> use of the individual or entity to which it is addressed. If you are not the
> intended recipient of this E-mail, you are hereby notified that any dissemination,
> distribution, copying, or action taken in relation to the contents of and
> attachments to this E-mail is strictly prohibited and may be unlawful. If you
> have received this E-mail in error, please notify the sender immediately and
> permanently delete the original and any copy of this E-mail and any printout.

---

From: Chris Donley <[email-masked]>
Date: Tue, 14 Apr 2015 14:15:19 +0000

Confirmed - you have removed our IPR.  One note is that our deterministic
CGN document has been published as RFC 7422.  Would you please update the
reference in your next release?

Thanks,
Chris

---

From: "Huangjing (A)" <[email-masked]>
Date: Tue, 28 Apr 2015 09:12:52 +0000

Done, reference updated to RFC7422
https://tools.ietf.org/html/draft-chen-sunset4-nat64-port-allocation-00

James

-----Original Message-----
From: Chris Donley [mailto:[email-masked]] 
Sent: Tuesday, April 14, 2015 10:15 PM
To: Huangjing (A)
Cc: Tom Taylor; [email-masked]
Subject: Re: [sunset4] Fwd: New Version Notification for draft-chen-sunset4-cgn-port-allocation-05.txt

Confirmed - you have removed our IPR.  One note is that our deterministic CGN document has been published as RFC 7422.  Would you please update the reference in your next release?

Thanks,
Chris

On 4/14/15 4:26 AM, "Huangjing (A)" <[email-masked]> wrote:

>> Based on the discussion during the meeting in Dallas, please publish 
>>a new  version of this with a slightly different name. We will not 
>>link the two in  "replaces", and this will clear the existing IPR 
>>encumbrance.
>> 
>> Separately, will the cable Labs folks confirm that the new draft does 
>>not have  any of your IPR in it?
>> 
>> Once this is completed, we will call for WG adoption. Sorry for the 
>>Texas  two-step, but this was the recommended way to address the IPR 
>>concerns.
>> 
>> Thanks,
>> 
>> Wes
>> 
>> 
>> 
>> >Draft has been posted. Detailed changes as described in the response 
>> >to Lee Howard's review, plus deletion of the section on 
>> >deterministic CGN as agreed in Toronto.
>> >
>> >Tom Taylor
>> >
>> >http://www.ietf.org/internet-drafts/draft-chen-sunset4-cgn-port-allo
>> >cat
>> >ion
>> >-05.txt
>> >Status:
>> >https://datatracker.ietf.org/doc/draft-chen-sunset4-cgn-port-allocat
>> >ion
>> >/
>> >Htmlized:
>> >http://www.ietf.org/rfcdiff?url2=draft-chen-sunset4-cgn-port-allocat
>> >ion
>> >-05
>> >
>> >Abstract:
>>proprietary information, which is privileged, confidential, or subject 
>>to  copyright belonging to Time Warner Cable. This E-mail is intended 
>>solely for the  use of the individual or entity to which it is 
>>addressed. If you are not the  intended recipient of this E-mail, you 
>>are hereby notified that any dissemination,  distribution, copying, or 
>>action taken in relation to the contents of and  attachments to this 
>>E-mail is strictly prohibited and may be unlawful.
>>If you
>> have received this E-mail in error, please notify the sender 
>>immediately and  permanently delete the original and any copy of this 
>>E-mail and any printout.