Subject: Re: [sunset4] Declaring IPv4 Historic

From: Greg Skinner <[email-masked]>
Date: Tue, 22 Mar 2016 01:09:41 +0000 (GMT)

It occurred to me that there might be some people who have an active interest in updating the IPv4
standard in the not too distant future, such as those who want to use 240.0.0.0/4.

Has an Historic RFC ever been put back on the standards track?  Is there even a process for doing that?  (I couldn't find one offhand.)  If the IPv4 standard was reclassified as Historic, and there was some desire from an active group to update it, that could become a big mess.

Greg

On Mar 15, 2016, at 05:09 AM, Lee Howard <[email-masked]> wrote:

As noted below, I’ve posted a draft. I thought I’d start a thread for discussing it.

PLEASE Please please read the draft before commenting. It’s very short, less than 500 words, and I anticipate a lot of people having strong feelings about it. I would really rather not waste time arguing about things it doesn’t say.

To that end, I’ve also written a blog post, explaining in a level of detail I thought inappropriate for the draft: http://www.wleecoyote.com/blog/ipv4-historic.htm

Thank you,

Lee

From: sunset4 <[email-masked]> on behalf of Wesley George <[email-masked]>
Date: Monday, March 14, 2016 at 6:28 PM
To: "[email-masked]" <[email-masked]>
Subject: [sunset4] Agenda items?

As you can see, we have a meeting scheduled for BA. 
As of right now, we have a single agenda item:

https://tools.ietf.org/html/draft-howard-sunset4-v4historic-00

While I fully expect that this item can expand to fill all available time, if there are other things that the WG wishes to discuss, please respond ASAP to request agenda time. 

Thanks,
 
Wes
 
Anything below this line has been added by my company’s mail server, I have no control over it.
-----------

This E-mail and any of its attachments may contain Time Warner Cable proprietary information, which is privileged, confidential, or subject to copyright belonging to Time Warner Cable. This E-mail is intended solely for the use of the individual or entity to which it is addressed. If you are not the intended recipient of this E-mail, you are hereby notified that any dissemination, distribution, copying, or action taken in relation to the contents of and attachments to this E-mail is strictly prohibited and may be unlawful. If you have received this E-mail in error, please notify the sender immediately and permanently delete the original and any copy of this E-mail and any printout.
_______________________________________________ sunset4 mailing list [email-masked] https://www.ietf.org/mailman/listinfo/sunset4

---

From: "George, Wes" <[email-masked]>
Date: Tue, 22 Mar 2016 12:21:03 +0000

From: sunset4 <[email-masked]<mailto:[email-masked]>> on behalf of Greg Skinner <[email-masked]<mailto:[email-masked]>>
Date: Monday, March 21, 2016 at 9:09 PM

It occurred to me that there might be some people who have an active interest in updating the IPv4
standard in the not too distant future, such as those who want to use 240.0.0.0/4<http://www.gossamer-threads.com/lists/nanog/users/181046>.

WG] I'd argue that they've missed their window, repeatedly. This comes up [1] every [2] few [3] years [4]. It keeps failing to gain enough momentum to go anywhere, for one primary reason: a large number of IP stacks have hard-coded rules that disallow or otherwise treat 240/4 as invalid IP space, so interfaces can't be configured with it, or will drop packets they see with those addresses in the src/dst field. Even if we changed the records tomorrow, there would be significant code and configuration work necessary to enable it for any use on most platforms, punch holes in firewalls, martian lists, etc. The same reason that it's been difficult to get broader IPv6 deployment (it's expensive and time-consuming to update legacy hardware and software and get to ubiquitous enough deployment to make it broadly useful) is the same thing that limits doing anything with Class E space today. In other words, if people are willing to put in time to make changes to an IP stack, especially on older gear, that's time better spent enabling the current protocol version, rather than delaying the inevitable. The further out on the IPv6 deployment curve we get, the less sense doing something with 240/4 makes.

WG] There probably isn't one, because declaring a standards document historic is done via consensus just like declaring a document a standard. If there are groups that desire to update IPv4, their opportunity to express that desire is while this document is being discussed and gaining consensus to proceed. That's part of the reason this discussion is happening - it's looking for rough consensus from the IETF that we are done making changes to IPv4. If there are a few changes identified that need to be made prior to IPv4 being declared historic, I don't think that's necessarily a problem, but I think it's time for those to be identified and completed, rather than holding this out indefinitely on the change that someone might need to do something in the future.
Additionally, the IETF is not the protocol police; adhering to the standards that we generate is wholly voluntary. If a group, business, individual wishes to use 240/4 for an off–label use, and is able to convince the vendors in their particular implementation to modify the stack so that they can do so, IPv4 moving to historic status does not impact their ability to do this, any more than it impacts their ability to continue using the rest of IPv4 indefinitely.

Thanks,

Wes

[1] https://tools.ietf.org/html/draft-fuller-240space-02
[2] http://www.muada.com/drafts/draft-van-beijnum-v6ops-esiit-00.txt
[3] https://tools.ietf.org/html/draft-wilson-class-e-02
[4] http://packetlife.net/blog/2010/oct/14/ipv4-exhaustion-what-about-class-e-addresses/

________________________________