Subject: [sunset4] Fwd: New Version Notification for draft-bz-v4goawayflag-00.txt

From: "Bjoern A. Zeeb" <[email-masked]>
Date: Tue, 03 Apr 2018 15:15:20 +0000

Hi,

during the first sunset4 meeting I mentioned on jabber:
“[22:12:29] <[email-masked]> Have you guys concluded the WG yet? I 
thought the only reason to open it was to close it again immediately and 
be done with the stuff.”  [1]
Seems years after this hasn’t happened yet, so it’s time to get you 
there.

Despite the submission date, this wasn’t an April Fool Draft.
I am serious.

- timeline
- end node policy
- and technical implementation suggestion.

Trying to KISS.

Your clock is ticking..  humm.

/bz

[1] https://www.ietf.org/jabber/logs/sunset4/2012-07-30.html

Forwarded message:

> From: [email-masked]
> Subject: New Version Notification for draft-bz-v4goawayflag-00.txt
> Date: Sat, 31 Mar 2018 15:13:22 -0700
>
> A new version of I-D, draft-bz-v4goawayflag-00.txt
> has been successfully submitted by Bjoern A. Zeeb and posted to the
> IETF repository.
>
> Name:		draft-bz-v4goawayflag
> Revision:	00
> Title:		IPv6 Router Advertisement IPv4 GoAway Flag
> Document date:	2018-04-01
> Group:		Individual Submission
> Pages:		7
> URL:            
> https://www.ietf.org/internet-drafts/draft-bz-v4goawayflag-00.txt
> Status:         
> https://datatracker.ietf.org/doc/draft-bz-v4goawayflag/
> Htmlized:       https://tools.ietf.org/html/draft-bz-v4goawayflag-00
> Htmlized:       
> https://datatracker.ietf.org/doc/html/draft-bz-v4goawayflag
>
>
> Abstract:
>    This document specifies a Router Advertisement Flag to indicate to
>    end nodes that IPv4 support must be disabled on this link.  In
>    addition this document presents a policy and a timeline on how to
>    deal with this flag and the going-away of IPv4.  This document
>    updates RFC5175.
>
>
>
>
> Please note that it may take a couple of minutes from the time of 
> submission
> until the htmlized version and diff are available at tools.ietf.org.
>
> The IETF Secretariat

---

From: David Schinazi <[email-masked]>
Date: Tue, 03 Apr 2018 08:48:16 -0700

Hi Bjoern,

A few comments:

1) The draft keeps mentioning the end node "policy" but never defines it.
What does "disable IPv4 on this link" mean?

2) Unless you have a crystal ball that predicts the future, the timeline is not useful.
IPv4 will stop being supported when support costs outweigh user benefits, not on an arbitrary anniversary.

3) Do we really need two flags (IPv4 Unavailable vs IPv4 GoAway) for this purpose?

4) What problem is this trying to solve?

All in all, pretty good April Fool Draft, thank you.

David

> On Apr 3, 2018, at 08:15, Bjoern A. Zeeb <[email-masked]> wrote:
> 
> Hi,
> 
> “[22:12:29] <[email-masked]> Have you guys concluded the WG yet? I thought the only reason to open it was to close it again immediately and be done with the stuff.”  [1]
> Seems years after this hasn’t happened yet, so it’s time to get you there.
> 
>> URL:            https://www.ietf.org/internet-drafts/draft-bz-v4goawayflag-00.txt
>> Status:         https://datatracker.ietf.org/doc/draft-bz-v4goawayflag/
>> Htmlized:       https://datatracker.ietf.org/doc/html/draft-bz-v4goawayflag
>> 
>> 
>> Abstract:
>> Please note that it may take a couple of minutes from the time of submission
> _______________________________________________
> sunset4 mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/sunset4

---

From: "Bjoern A. Zeeb" <[email-masked]>
Date: Mon, 09 Apr 2018 23:10:09 +0000

On 3 Apr 2018, at 15:48, David Schinazi wrote:

Hi,

> 1) The draft keeps mentioning the end node "policy" but never defines 

    3.  End node policy . . . . . . . . . . . . . . . . . . . . . . .   
4
      3.1.  Mandatory end node rules  . . . . . . . . . . . . . . . .   
4

policy:  “a set of ideas … of what to do in particular situations 
…”
rule: “an accepted principle or instruction that states the way things 
are or should be done, and tells you what you are allowed or are not 
allowed to do”

> What does "disable IPv4 on this link" mean?

What does
“Usage: networksetup -setv4off <networkservice>
         Turn IPv4 off on <networkservice>.”
mean?

disable: “to stop something such as (part of) a machine, system, or .. 
from working”

> IPv4 will stop being supported when support costs outweigh user 
> benefits, not on an arbitrary anniversary.

Well, it is obvious at this point that agreeing on how to very 
gracefully getting anywhere is not working.
So the problem is not a priority or a problem at all.
If you do not have a deadline to work against, you won’t.
I give you this deadline.
Ans as we say “pick a number”;  I picked dates.

For me, the costs of supporting IPv4 started 8 years ago when I went 
ipv6-only to my edges.
Since shortly after that I have been paying extra to keep IPv4 alive for 
the people who still haven’t moved to even DS on basic infrastructure.
So don’t blame me for you not moving.
For the past years people have been telling the world that the costs for 
DS > for single stack.

> 3) Do we really need two flags (IPv4 Unavailable vs IPv4 GoAway) for 

Maybe?  One is for saving resources,  the other is for making something 
go away;  if you agree on the latter the former will be obsolete in a 
few years and  is just another extra graceful step towards the end.  If 
you’d prefer to have GoAway earlier and with that not need 
Unavailable, then (a) the GoAway draft gives you the opportunity, and 
(b) I can move the dates earlier for -01 to save you the work for 
Unavailable.   Even simpler.

> 4) What problem is this trying to solve?

What is the future you are avoiding to accept?

> All in all, pretty good April Fool Draft, thank you.

Thanks, just that it’s not.

/bz