Subject: [Supa] Discussion on SUPA draft chatter

From: "Jun Bi" <[email-masked]>
Date: Sun, 31 Aug 2014 02:42:05 +0800

Hi all,

I would like to trigger the discussion on SUPA charter.

The latest version of SUPA draft charter I received is below.

I would ask questions about items in milestones, may I ask,

    I-D 'Guidelines on mapping network service graphs into specific network

    management and controlling policies' as an Informational RFC.

What specific technologies the "mapping" here means ? Do we have an example
?

    I-D 'SUPA NETCONF/YANG (or RESTCONF/YANG) model and Protocol 

    Specification' Standards Track RFC.

What would be included into this protocol specification  ? 

Thanks,

Jun

SUPA (Shared Unified Policy Automation) charter

Target Area: 

Description of Working Group:

Today network operators are challenged to create an abstract view of their
network infrastructure and help service developers on using and programming
this abstraction rather than manipulating individual devices. An abstract
view of a network infrastructure and service function interdependencies can
be realized using a network service graph. A network service graph is a
graph specified by a Network Service Provider that defines how one or more
network services are applied to traffic flowing through a set of nodes of
the graph, which includes attributes such as:

o) network topology, based on I2RS, SFC based network topologies and
represented by a graph of links and nodes

o) service functions (e.g., policing function, NAT, Firewall, DNS, DHCP) and
their interdependencies

o) mapping between service function (and their service function
interdependencies) and network topology (similar to ALTO mapping)

o) application based policies (actions and access policies) generated by
network service systems to map the network service graph instance into
specific network management policies, i.e., into device level configuration
models. Such application based demands are:

   *) Configuration types:

       o) request to dynamically configure a node

       o) request to place a service function on a network 

          function 

   *) Data plane types:

       o) request to steer a traffic flow

       o) request prioritize a traffic flow

       o) request to encapsulate/de-capsulate a traffic flow

       o) request block or admit a traffic flow

   *) Control plane / Routing plane types:

       o) request to change the routing state on a network 

          function

Network services are enhanced Operational Support System (OSS) services that
help a communication service provider to monitor, control, analyze and
manage a communication network. In this context, network services can be
used to provide the required configuration and application programming
interfaces to network service developers. Subsequently, a network service
can use the service based demands and possibly update its associated network
service graph.

The main goal of SUPA is to provide application based policies and means to
model and program the abstract view of network infrastructure and service
function interdependencies in order to support and feed network management
and controlling policies (e.g., dynamic network configuration, I2RS routing
strategies). 

This can be realized by:

(1) modeling the network service graph, which among others include
application based policies, using YANG, 

(2) applying NETCONF (or RESTCONF) to enable dissemination of up to date
(fresh) network service graphs in a secure and efficient manner between
network service systems and network management and controlling systems, 

(3) providing guidelines on mapping attributes of network service graphs
provided by network service systems into specific network management and
controlling policies.

Work items related to SUPA include:

o) specify the network service graph based on YANG models

o) specify and standardize how NETCONF/YANG (or RESTCONF/YANG) can be used
to securely and efficiently distribute up to date (fresh) network service
graphs between network service systems and network management and
controlling systems

o) provide guidelines for mechanisms that can dynamically map attributes,
including application based policies, of network service graphs into
specific network management and controlling policies, such as dynamic
network configuration, I2RS routing strategies

o) document how to use NETCONF (or RESTCONF) authentication and
authorization mechanisms to achieve protection and isolation

The following items are out of the SUPA scope:

o) specification of the network management and controlling policies and
their associated device configuration models

Milestones:

    I-D 'Problem Statement and Use Cases' as an Informational RFC.

    I-D 'Guidelines on mapping network service graphs into specific network

    management and controlling policies' as an Informational RFC.

    I-D 'Guidelines on using NETCONF (or RESTCONF) authentication and 

    authorization mechanisms to achieve security protection and isolation' 

    as an Informational RFC.

    I-D 'SUPA NETCONF/YANG (or RESTCONF/YANG) model and Protocol 

    Specification' Standards Track RFC.

---

From: <[email-masked]>
Date: Sun, 31 Aug 2014 07:17:46 +0000

Hi Jun,

Thank you very much for your email!

Please note that we are working on providing preliminary versions of drafts that are providing the information associated with these milestones.

Please also note that in order to show why the SUPA activity is useful for the IETF community we are also working on a state of the art/gap analysis.

Best regards,

Georgios

________________________________
Van: Supa <[email-masked]> namens Jun Bi <[email-masked]>
Verzonden: zaterdag 30 augustus 2014 20:42
Aan: [email-masked]
Onderwerp: [Supa] Discussion on SUPA draft chatter

Hi all,

What specific technologies the “mapping” here means ? Do we have an example ?

Thanks,
Jun

Target Area:

Today network operators are challenged to create an abstract view of their network infrastructure and help service developers on using and programming this abstraction rather than manipulating individual devices. An abstract view of a network infrastructure and service function interdependencies can be realized using a network service graph. A network service graph is a graph specified by a Network Service Provider that defines how one or more network services are applied to traffic flowing through a set of nodes of the graph, which includes attributes such as:

o) network topology, based on I2RS, SFC based network topologies and represented by a graph of links and nodes

o) service functions (e.g., policing function, NAT, Firewall, DNS, DHCP) and their interdependencies

o) mapping between service function (and their service function interdependencies) and network topology (similar to ALTO mapping)

o) application based policies (actions and access policies) generated by network service systems to map the network service graph instance into specific network management policies, i.e., into device level configuration models. Such application based demands are:
   *) Configuration types:
Network services are enhanced Operational Support System (OSS) services that help a communication service provider to monitor, control, analyze and manage a communication network. In this context, network services can be used to provide the required configuration and application programming interfaces to network service developers. Subsequently, a network service can use the service based demands and possibly update its associated network service graph.

The main goal of SUPA is to provide application based policies and means to model and program the abstract view of network infrastructure and service function interdependencies in order to support and feed network management and controlling policies (e.g., dynamic network configuration, I2RS routing strategies).
This can be realized by:

(1) modeling the network service graph, which among others include application based policies, using YANG,

(2) applying NETCONF (or RESTCONF) to enable dissemination of up to date (fresh) network service graphs in a secure and efficient manner between network service systems and network management and controlling systems,

(3) providing guidelines on mapping attributes of network service graphs provided by network service systems into specific network management and controlling policies.

o) specify and standardize how NETCONF/YANG (or RESTCONF/YANG) can be used to securely and efficiently distribute up to date (fresh) network service graphs between network service systems and network management and controlling systems

o) provide guidelines for mechanisms that can dynamically map attributes, including application based policies, of network service graphs into specific network management and controlling policies, such as dynamic network configuration, I2RS routing strategies

o) document how to use NETCONF (or RESTCONF) authentication and authorization mechanisms to achieve protection and isolation

o) specification of the network management and controlling policies and their associated device configuration models

Milestones: