Subject: [Supa] Cloud SLA YANG Model --> incorporating Peer Mount Semantics

From: "Eric Voit (evoit)" <[email-masked]>
Date: Mon, 27 Oct 2014 16:27:41 +0000

Below is a new draft which hits elements of the proposed YMCA/SUPA charter.  It is a Domain Abstracted YANG model which incorporates Mount Semantics proposed into Netmod:  
http://www.ietf.org/internet-drafts/draft-tripathy-cloud-sla-yang-model-00.txt

The goal of this YANG model is to expose both Global and Device config in order to simplify application design for a new class of service offerings.

The services the YANG models support are described in 
http://www.ietf.org/internet-drafts/draft-voit-netmod-peer-mount-requirements-01.txt 
which I also updated last Friday.

Thanks,
Eric

Eric Voit
Principal Engineer
Core Software Group (CSG)

---

From: Tina TSOU <[email-masked]>
Date: Fri, 31 Oct 2014 08:26:30 +0000

Dear Eric,

The scenario and architecture of draft-tripath, can be used in SUPA architecture. The service specific abstractions can be applied to the same scenario of cloud SLA model.

" This model would reside in a controller or a network element filling the role of a controller.  This document does not define the corresponding YANG models for each of the controlled devices. "

The SUPA use case does not include cloud SLA yet.

It seems that you are happy about the current charter text.
You may think about how to update the architecture which Parviz is heavily working on. And perhaps also the use case? The cloud SLA yang model could be a standalone one?

Thank you,
Tina

On Oct 27, 2014, at 5:28 PM, Eric Voit (evoit) <[email-masked]<mailto:[email-masked]>> wrote:

Thanks,
Eric

Eric Voit
Principal Engineer

_______________________________________________
Supa mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/supa