Subject: [Supa] proposal to incorporate Eric's contribution in SUPA activities

From: Georgios Karagiannis <[email-masked]>
Date: Fri, 10 Oct 2014 07:31:41 +0000

Dear all,

Based on the discussions that I have had with Eric Voit, I think that it makes sense to incorporate the work items (or a subset of them) proposed by Eric into the SUPA activities.

The main goal of SUPA could become:

====================
The main goal of SUPA is to provide YANG models of service specific abstractions e.g. Inter-DCs traffic engineering, that allow applications to request network services from single or multiple controllers to be quickly and dynamically created/deleted/modified. This can be realized by:

  o) model service specific abstractions using the combination of policies and network graphs
  o) model the relationships between service specific abstractions models and network topology and configuration models
  o) specify how single or multiple controllers can push and pull configuration information to/from local or remote NEs
  o) specify how NEs can mount and push configuration information to local or remote controllers

===============

Please comment on the above!

Best regards,
Georgios

---

From: "Eric Voit (evoit)" <[email-masked]>
Date: Fri, 10 Oct 2014 13:46:54 +0000

I am very glad that SUPA is considering my suggestions important :-).    For more information about the objectives, see the presentation I just gave at a Netmod interim meeting on Wednesday:  Click here for the slides<http://www.voit.org/Peer-Mount-Netconf-WG-Oct2014.pdf> .   Also of note is that in Tuesday, a new version of the Mount technology draft<https://tools.ietf.org/html/draft-clemm-netmod-mount-02> was posted.  There are active discussions in the Netmod WG right now.  Please feel free to chime in!

In the end, I am completely ok if the drafts progress in either Netmod or in SUPA should it get chartered.  The technology space here is going to be significant. And the need for multi-device abstraction and convergence will likely span multiple WGs.

So count me in for helping with the charter's refinement.   Discussions in multiple places are needed to bring the needed brain-power to this problem space.

Eric

From: Georgios Karagiannis, October 10, 2014 3:32 AM

Dear all,

====================

===============

Best regards,
Georgios