Subject: [Supa] SUPA - I2RS - topology and data models

From: Benoit Claise <[email-masked]>
Date: Sat, 11 Oct 2014 14:27:36 +0200

Dear all,

Following our conf. call yesterday, I had the action item to check with 
the routing ADs regarding I2RS topology and data model.
It's true that the I2RS charter specifies:

    The working group is not currently chartered to develop protocols,
    encoding languages, or data models. The objective of this work
    effort is
    to arrive at common standards for these items, but these items are
    dependent on the progress of the topics listed above. Work for these
    items will be conducted in this working group only after a re-charter,
    and/or may be carried out in another working group with specific
    responsibility for the protocol or encoding language

In my discussion with Alia, it became clear that the I2RS charter has 
information models, not data models, because I2RS hadn't selected a data 
modeling language when the charter was written and because they wanted 
to try and have the higher level discussion about what information 
should be in each model. Alia is expecting to recharter I2RS to do the 
necessary data-models. Not sure if this is a month or 6 months, but the 
key message (from Alia) is that the topology data model development 
should take place in I2RS.

Regards, Benoit

---

From: Georgios Karagiannis <[email-masked]>
Date: Wed, 15 Oct 2014 08:52:25 +0000

Dear all,

In the attachment you can find the slides that have been presented during the telco of Friday (10 October 2014).
These slides helped the people that were attending the telco to more clearly understand the main goal of SUPA.

Please note that currently we are trying to translate the semantics of these slides into a charter text.
Other actions that we would like to complete before the IETF meeting in Honolulu are:

1)      Discuss the updated charter on the SUPA mailing list

2)      Select two use cases that will be used as the driving force for SUPA activities

3)      Organize a bar BOF during the IETF in Honolulu.

Best regards,
Georgios

From: Supa [mailto:[email-masked]] On Behalf Of Benoit Claise
Sent: Saturday, October 11, 2014 2:28 PM
To: [email-masked]
Cc: [email-masked]
Subject: [Supa] SUPA - I2RS - topology and data models

Dear all,

Following our conf. call yesterday, I had the action item to check with the routing ADs regarding I2RS topology and data model.
It's true that the I2RS charter specifies:
The working group is not currently chartered to develop protocols,
encoding languages, or data models. The objective of this work effort is
to arrive at common standards for these items, but these items are
dependent on the progress of the topics listed above. Work for these
items will be conducted in this working group only after a re-charter,
and/or may be carried out in another working group with specific
responsibility for the protocol or encoding language
In my discussion with Alia, it became clear that the I2RS charter has information models, not data models, because I2RS hadn't selected a data modeling language when the charter was written and because they wanted to try and have the higher level discussion about what information should be in each model. Alia is expecting to recharter I2RS to do the necessary data-models. Not sure if this is a month or 6 months, but the key message (from Alia) is that the topology data model development should take place in I2RS.

Regards, Benoit