Subject: [Supa] Charter discussion

From: Tina TSOU <[email-masked]>
Date: Fri, 9 Jan 2015 15:33:17 +0000

Dear all,

Here is the current charter for discussion, great thanks to Diego, John, Juergen, Marie-Jose, Scott et al.

Description of Working Group:
Version: 00
Date: UTC 2015.01.09 

The rapid increase in the amount and type of traffic and the increasing complexity of network architectures make it significantly more challenging for operations and management applications (OAMA) to manage networks and to deploy new services. Programmatic ways to configure and operate these networks, which are often called software-defined networks, are one means that could be used by network operators to provide significant benefits in design and deployment agility.

The purpose of the SUPA (Shared Unified Policy Automation) working group is to develop a set of generic YANG-based data models to enable management and automation of network services within an administrative domain. The service data models will be derived from a single information model, ensuring that they can be shared and reusedas managed objects. Similarly, a policy model will then be derived from the same information model to help manage and automate the generation and deployment of services. Policy rules will be used to define the operational aspects of both the "southbound" (e.g., controller to device) and "northbound" (e.g., controller to application) portions of the service environment. The first example that the working group will focus on will be VPN management.

This WG introduces the concepts of multi-level and multi-technology network abstractions to address the current separation between development and deployment operations. Business agility, along with OpEx reduction, cannot be obtained unless it becomes possible to deploy changes as products. Policy-based management is one way to help do this, but we need better abstractions of network resources and services to achieve these goals. The WG plans to create three types of YANG models: (1) a general network topology model, (2) a model of network service configuration, and (3) a model for representing policy rules. The combination of these three models will enable OAMA to request information that they need, such as topology information, as well as to define policy rules to configure network services. As a result, standardized models between OAMA and network controllers of all types can be established while supporting automatic and programmable configuration. This may beneficially improve the experience of operators in configuration and management of network services by allowing OAMA to request these network services from single or multiple network controllers. The combination of standardized policy and data models will enable network services to be quickly and dynamically created, deleted, and modified.

Work items for this WG include:
1) A set of Yang models focused on VPN management within a single administrative domain, but which will later be expanded to accommodate multiple administrative domains. These models may include, for example, a generic network topology model for requesting network services as well as generic policy models for controlling the communication of status and configuration information.

2) A set of Yang models defined in 1) to map Yang models of network services to network element configurations.

3) A set of Yang models that specify how network elements can interact with local or 
remote network controllers (e.g., exchange configuration and status information).

Thank you,
Tina

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Mon, 12 Jan 2015 11:21:24 +0100

Hi,

I am somewhat confused how much focus is on the 'generic' part and how
much focus is on the 'specific' part. Reading the textual description,
it all sounds top-down designing generic information models that lead
to generic data models (topology, network service config, policy
representation). Looking at the work items part, it all sounds VPN
management specific with a 'may include also generic components'.
Work item 3) is somewhat unclear to me - it seems to be about a
northbound API for not more specifically defined network controllers.

If I take all this together, I am wondering whether this rather wide
scope will be manageable since the charter seem to favour some
top-down work, some botton-up work, some work sideways for yet to be
defined specific controllers.

Perhaps it can help if contributors can indicate what the relative
importance of all these work items are for them.

/js

On Fri, Jan 09, 2015 at 03:33:17PM +0000, Tina TSOU wrote:
> This WG introduces the concepts of multi-level and multi-technology network abstractions to address the current separation between development and deployment operations. Business agility, along with OpEx reduction, cannot be obtained unless it becomes possible to deploy changes as products. Policy-based management is one way to help do this, but we need better abstractions of network resources and services to achieve these goals. The WG plans to create three types of YANG models: (1) a general network topology model, (2) a model of network service configuration, and (3) a model for representing policy rules. The combination of these three models will enable OAMA to request information that they need, such as topology information, as well as to define policy rules to configure network services. As a result, standardized models between OAMA and network controllers of all types can be established while supporting automatic and programmable configuration. This may beneficially improve th
>  e experience of operators in configuration and management of network services by allowing OAMA to request these network services from single or multiple network controllers. The combination of standardized policy and data models will enable network services to be quickly and dynamically created, deleted, and modified.
> 
> 
> _______________________________________________
> Supa mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/supa

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1, 28759 Bremen, Germany
Fax:   +49 421 200 3103         <http://www.jacobs-university.de/>

---

From: Tina TSOU <[email-masked]>
Date: Mon, 12 Jan 2015 12:19:50 +0000

Dear Juergen,

Thank you for your prompt reply.

Your are right by saying "it all sounds VPN management specific with a 'may include also generic components'.", because the also generic components which belong to generic overlay model, not the VPN management, are still being baked.
The current data model currently discussed between you and Ying did not fully contain cases from Harvard, Telefonica, China Telecom, China Mobile, Google and Tencent yet.

Work item 3) is about Pub/Sub and Peer Mount.

IMHO, the relative priority from high to low is work item 1) --> 2) --> 3).

Thank you,
Tina

On Jan 12, 2015, at 5:21 AM, Juergen Schoenwaelder <[email-masked]<mailto:[email-masked]>> wrote:

Hi,

/js

Thank you,
Tina
_______________________________________________
Supa mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/supa

---

From: John Strassner <[email-masked]>
Date: Mon, 12 Jan 2015 23:54:39 +0000

Hi Jürgen,

As you know, there are a lot of Yang models out there, and more are being built everyday. This (proposed) WG is different, in that it is focusing on how these different models can be related to each other and used to achieve a common set of goals. In this light, the "generic" Yang models are applied to a specific area in order to demonstrate the feasibility of the approach.

Work item 3 addresses the need to standardize the management of network models.

regards,
John

Dr. John Strassner, Ph.D.
CTO, Software Laboratory, CRD

Futurewei Technologies
US R&D Center
2330 Central Expressway
Building A, office A2-2143
Santa Clara, California   95050

  Office:  +1.408.330.4923
  Email:   [email-masked]

From: Supa [mailto:[email-masked]] On Behalf Of Tina TSOU
Sent: Monday, January 12, 2015 4:20 AM
To: Juergen Schoenwaelder
Cc: [email-masked]
Subject: Re: [Supa] Charter discussion

Dear Juergen,

Thank you,
Tina

/js

Dear all,

Thank you,
Tina

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Tue, 13 Jan 2015 08:48:45 +0100

> Work item 3 addresses the need to standardize the management of network models.

John,

the charter needs to be consistent in both the description and the
work items. I do not see that the current text aligns well with the
work items listed. And my limited experiences with the definition of
core (generic) YANG data models in NETMOD is that it is not a trivial
procedure. So either SUPA works on generic policy mgmt infrastructure
and then later applies it to say VPNs or it works from concrete use
cases and solves VPN related problems, potentially generalizing the
approach in a second phase. Right now, the text seems to say one thing
and the work items seem to say a different thing.

/js

---

From: Tina TSOU <[email-masked]>
Date: Tue, 13 Jan 2015 09:53:50 +0000

Dear Juergen,

I'd say it works from concrete use cases and solves VPN related problems (is enterprise interconnection provided by carriers, not only VPN), potentially generalizing the approach in a second phase.  

Anyone volunteers to edit the charter?

Thank you,
Tina

-----Original Message-----
From: Supa [mailto:[email-masked]] On Behalf Of Juergen Schoenwaelder
Sent: Tuesday, January 13, 2015 3:49 PM
To: John Strassner
Cc: [email-masked]; Tina TSOU
Subject: Re: [Supa] Charter discussion

John,

the charter needs to be consistent in both the description and the work items. I do not see that the current text aligns well with the work items listed. And my limited experiences with the definition of core (generic) YANG data models in NETMOD is that it is not a trivial procedure. So either SUPA works on generic policy mgmt infrastructure and then later applies it to say VPNs or it works from concrete use cases and solves VPN related problems, potentially generalizing the approach in a second phase. Right now, the text seems to say one thing and the work items seem to say a different thing.

/js

---

From: John Strassner <[email-masked]>
Date: Tue, 13 Jan 2015 19:52:55 +0000

As recorded in this morning's meeting, I'll take a shot at addressing Juergen's concerns...

regards,
John

Futurewei Technologies
US R&D Center
2330 Central Expressway

-----Original Message-----
From: Tina TSOU 
Sent: Tuesday, January 13, 2015 1:54 AM
To: Juergen Schoenwaelder; John Strassner
Cc: [email-masked]
Subject: RE: [Supa] Charter discussion

Dear Juergen,

Thank you,
Tina

-----Original Message-----
From: Supa [mailto:[email-masked]] On Behalf Of Juergen Schoenwaelder
Sent: Tuesday, January 13, 2015 3:49 PM
To: John Strassner
Cc: [email-masked]; Tina TSOU
Subject: Re: [Supa] Charter discussion

John,

/js