Subject: [Supa] [[email-masked]: I-D Action: draft-wang-netmod-yang-policy-dm-00.txt]

From: Juergen Schoenwaelder <[email-masked]>
Date: Mon, 26 Jan 2015 10:13:40 +0100

Hi,

is this the kind of policy work the supa charter in the making is
talking about?

/js

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1, 28759 Bremen, Germany
Fax:   +49 421 200 3103         <http://www.jacobs-university.de/>

Subject: I-D Action: draft-wang-netmod-yang-policy-dm-00.txt
From: <[email-masked]>
To: <[email-masked]>
Date: Mon, 26 Jan 2015 00:58:53 -0800
List-Id: Internet Draft Announcements only <i-d-announce.ietf.org>

A New Internet-Draft is available from the on-line Internet-Drafts directories.

        Title           : Network Policy YANG Data Model
        Authors         : Zitao Wang
                          Linda Dunbar
                          Qin Wu
	Filename        : draft-wang-netmod-yang-policy-dm-00.txt
	Pages           : 19
	Date            : 2015-01-26

Abstract:
   This document describes a common core YANG data model for network
   policies.  The common core model can be augmented by additional YANG
   modules defining data models for policy related protocols and
   functions to support various different network applications (such as
   Constraint based Routing, Network QoS, Traffic engineering, network
   management etc).  The core policy data model provides common building
   blocks for such extensions - policy information bases, policy related
   protocols.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-wang-netmod-yang-policy-dm/

There's also a htmlized version available at:
http://tools.ietf.org/html/draft-wang-netmod-yang-policy-dm-00

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

_______________________________________________
I-D-Announce mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/i-d-announce
Internet-Draft directories: http://www.ietf.org/shadow.html
or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

---

From: Tina TSOU <[email-masked]>
Date: Tue, 27 Jan 2015 09:58:17 +0000

Dear Juergen,

Thank you for the pointer.

I'm yet to go through that in detail, but in my opinion there is some overlap with this work (based on my understanding of the scope of SUPA). Maybe we could refer this work and extend on it.

Authors, would you like to explain it?

Thank you,
Tina

-----Original Message-----
From: Supa [mailto:[email-masked]] On Behalf Of Juergen Schoenwaelder
Sent: Monday, January 26, 2015 5:14 PM
To: [email-masked]
Subject: [Supa] [[email-masked]: I-D Action: draft-wang-netmod-yang-policy-dm-00.txt]

Hi,

is this the kind of policy work the supa charter in the making is talking about?

/js

---

From: wangzitao <[email-masked]>
Date: Wed, 28 Jan 2015 02:07:04 +0000

This work is separated from I2RS and carved out based on I2RS Policy IM draft. I am not sure whether it can fit into supa charter.
But I am happy if supa thinks it useful or benefits from it.

-Michael
-----邮件原件-----
发件人: Tina TSOU [mailto:[email-masked]] 
发送时间: 2015年1月27日 17:58
收件人: Juergen Schoenwaelder; [email-masked]
抄送: [email-masked]
主题: RE: [Supa] [[email-masked]: I-D Action: draft-wang-netmod-yang-policy-dm-00.txt]

Dear Juergen,

Thank you,
Tina

-----Original Message-----
From: Supa [mailto:[email-masked]] On Behalf Of Juergen Schoenwaelder
Sent: Monday, January 26, 2015 5:14 PM
To: [email-masked]
Subject: [Supa] [[email-masked]: I-D Action: draft-wang-netmod-yang-policy-dm-00.txt]

Hi,

/js

---

From: Tina TSOU <[email-masked]>
Date: Wed, 28 Jan 2015 02:14:06 +0000

Dear Michael,

Thank you for getting back to us.

Would you illustrate this policy information model or data model a little bit more technically?

Is there any service template to define the policy pattern?

Thank you,
Tina

> On Jan 28, 2015, at 10:07 AM, wangzitao <[email-masked]> wrote:
>

---

From: wangzitao <[email-masked]>
Date: Wed, 28 Jan 2015 08:00:54 +0000

Hi Tina,

It just describes policy rule format itself. 
For more details, you can refer to something that was discussed in I2RS(http://tools.ietf.org/agenda/90/slides/slides-90-i2rs-2.pdf).

Best Regards!
-Micheal
-----邮件原件-----
发件人: Tina TSOU 
发送时间: 2015年1月28日 10:14
收件人: wangzitao
抄送: Juergen Schoenwaelder; [email-masked]
主题: Re: [Supa] [[email-masked]: I-D Action: draft-wang-netmod-yang-policy-dm-00.txt]

Dear Michael,

Thank you,
Tina

---

From: JF Tremblay <[email-masked]>
Date: Wed, 28 Jan 2015 10:18:35 -0500

> On Jan 28, 2015, at 3:00 AM, wangzitao <[email-masked]> wrote:
> 
> Hi Tina,
> 

Thanks for the pointer. Interesting slides. They could differentiate a bit more between control-plane policing and traffic policing, but the base is there and allows for various extensions, which is good.  

In my opinion, it makes more sense to put the policies in a separate datastore and keep them independent of the objects they manage, as this presentation and yang-policy-dm suggests. 

My understanding of supa’s current draft (such as supa-configuration-model) for example, is that everything is defined under a “service” umbrella that contains everything. It doesn’t seem to be the best approach. Any opinions on this? 

JF