Subject: Re: [Supa] Fwd: [L3sm] Some background on the L3VPN Service YANG Model work

From: "Dacheng Zhang" <[email-masked]>
Date: Thu, 05 Mar 2015 22:05:50 +0800

Hi，
 
Draft-l3vpn-service-yang designs for carrier operators scenarios, it may be
too complicated for enterprises. For example, for VPN site position, it
includes multiple fields like country, city etc. However for enterprises,
they may not care about these, more prefer Instant VPN, via some
authentication method, e.g. MAC, to provision VPN service, and can migrate.
 
Cheers
 
Dacheng

From: Supa [mailto:[email-masked]] On Behalf Of Tina TSOU
Sent: Wednesday, March 04, 2015 10:09 PM
To: Benoit Claise; [email-masked]
Subject: Re: [Supa] Fwd: [L3sm] Some background on the L3VPN Service YANG
Model work

Dear Benoit,
 
Thank you for forwarding it.
 
I almost thought this was the first service yang model from supa.
 
Have you seen 
draft-zaalouk-supa-vpn-service-management-model-01
<http://datatracker.ietf.org/doc/draft-zaalouk-supa-vpn-service-management-m
odel/> 
VPN Service Management YANG Data Model?
 
and the discussion about draft-zaalouk-supa-vpn-service-management-model-01
<http://datatracker.ietf.org/doc/draft-zaalouk-supa-vpn-service-management-m
odel/>  and http://datatracker.ietf.org/doc/draft-l3vpn-service-yang/
at
http://www.ietf.org/mail-archive/web/supa/current/msg00559.html
?

Thank you,
Tina

From: Supa [mailto:[email-masked]] On Behalf Of Benoit Claise
Sent: Wednesday, March 04, 2015 9:52 PM
To: [email-masked]
Subject: [Supa] Fwd: [L3sm] Some background on the L3VPN Service YANG Model
work
 
FYI.

Regards, Benoit

-------- Forwarded Message --------

Subject: [L3sm] Some background on the L3VPN Service YANG Model work
Date: Wed, 4 Mar 2015 14:40:52 +0100
From: Benoit Claise <[email-masked]> <mailto:[email-masked]>
To: [email-masked]

Dear all,

Let me give you some background on this new piece of work: The Layer Three
Virtual Private Network Service Model (L3SM)

Three months ago, Adrian Farrel and I set up a design team to create a L3VPN
service YANG model.
It needs to be clearly understood that this L3VPN service model is not an
L3VPN configuration model. That is, it does not provide details for
configuring network elements or protocols. Instead it contains the
characteristics of the service, as discussed between the operators and their
customers.  Therefore, that design team was composed of operators only.

That design team created a first draft:
http://datatracker.ietf.org/doc/draft-l3vpn-service-yang/
Now that the draft has been posted, the work and discussion should continue
in a public forum, i.e. this [email-masked] mailing list.

Next step? we're busy trying to create a new short-lived WG, focusing solely
on this L3VPN service YANG model.
See the proposal at https://datatracker.ietf.org/doc/charter-ietf-l3sm/
If this WG is created (This proposal is on the IESG telechat this week for
external review approval), this would be a good test for the IETF community:
are we ready to standardize a first service YANG model? Personally, I
believe we are. 
IMO, the advantage/driver for this work is explained in the charter
proposal:
The deliverable from this working group will provide information to evaluate
the
set of YANG models that have already been developed or are under
development,
and will help identify any missing models or details.  The deliverable can
be
viewed as driving requirements for protocol configuration model so that the
service parameters can be mapped into inputs used by the protocol models.
Don't hesitate to forward this email.
    List address: [email-masked]
    Archive: http://www.ietf.org/mail-archive/web/l3sm/
    To subscribe: https://www.ietf.org/mailman/listinfo/l3sm

Regards, Benoit

---

From: Benoit Claise <[email-masked]>
Date: Mon, 09 Mar 2015 14:42:26 +0100

Hi Dacheng, all,

Can you please discus Draft-l3vpn-service-yang on the [email-masked] 
mailing list.

Regards, Benoit

> Hi，
>
> Draft-l3vpn-service-yang designs for carrier operators scenarios, it 
> may be too complicated for enterprises. For example, for VPN site 
> position, it includes multiple fields like country, city etc. However 
> for enterprises, they may not care about these, more prefer Instant 
> VPN, via some authentication method, e.g. MAC, to provision VPN 
> service, and can migrate.
>
> Cheers
>
> Dacheng
>
> *From:*Supa [mailto:[email-masked]] *On Behalf Of *Tina TSOU
> *Sent:* Wednesday, March 04, 2015 10:09 PM
> *To:* Benoit Claise; [email-masked] <mailto:[email-masked]>
> *Subject:* Re: [Supa] Fwd: [L3sm] Some background on the L3VPN Service 
> YANG Model work
>
> Dear Benoit,
>
> <http://datatracker.ietf.org/doc/draft-zaalouk-supa-vpn-service-management-model/>
>
> and the discussion about 
> <http://datatracker.ietf.org/doc/draft-zaalouk-supa-vpn-service-management-model/> 
> and http://datatracker.ietf.org/doc/draft-l3vpn-service-yang/
>
> at
>
> *From:*Supa [mailto:[email-masked]] *On Behalf Of *Benoit Claise
> *Sent:* Wednesday, March 04, 2015 9:52 PM
> *To:* [email-masked] <mailto:[email-masked]>
> *Subject:* [Supa] Fwd: [L3sm] Some background on the L3VPN Service 
> YANG Model work
>
> FYI.
>
> Regards, Benoit
>
>
>
> *Subject: *
> [L3sm] Some background on the L3VPN Service YANG Model work
>
> *Date: *
>
> 	
>
> Wed, 4 Mar 2015 14:40:52 +0100
>
> *From: *
>
> 	
>
> Benoit Claise <[email-masked]> <mailto:[email-masked]>
>
> *To: *
>
> 	
>
> [email-masked] <mailto:[email-masked]>
>
>
>
> Dear all,
>
> Let me give you some background on this new piece of work: The Layer 
> Three Virtual Private Network Service Model (L3SM)
>
> Three months ago, Adrian Farrel and I set up a design team to create a 
> L3VPN _service _YANG model.
> It needs to be clearly understood that this L3VPN _service _model is 
> not an L3VPN configuration model. That is, it does not provide details 
> for configuring network elements or protocols. Instead it contains the 
> characteristics of the service, as discussed between the operators and 
> their customers. Therefore, that design team was composed of operators 
> only.
>
> Now that the draft has been posted, the work and discussion should 
> continue in a public forum, i.e. this [email-masked] 
> <mailto:[email-masked]> mailing list.
>
> Next step? we're busy trying to create a new short-lived WG, focusing 
> solely on this L3VPN service YANG model.
> If this WG is created (This proposal is on the IESG telechat this week 
> for external review approval), this would be a good test for the IETF 
> community: are we ready to standardize a first service YANG model? 
> Personally, I believe we are.
> The deliverable from this working group will provide information to evaluate the
> set of YANG models that have already been developed or are under development,
> and will help identify any missing models or details.  The deliverable can be
>     List address: [email-masked] <mailto:[email-masked]>
> _______________________________________________
> Supa mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/supa

---

From: Tina TSOU <[email-masked]>
Date: Tue, 10 Mar 2015 09:40:37 +0000

Dear Benoit,

Thank you for your email.

I guess Dacheng meant to illustrate the relationship of his service management data model draft to the L3VPN service management draft. I saw a new version posted: http://tools.ietf.org/id/draft-zaalouk-supa-vpn-service-management-model-02.txt
The authors are also operators (Alibaba and China Unicom), and people from EICT (I don’t think it is vendor).

We were waiting for each other. You were waiting for us. We were waiting for you to pick a service between DDC and L3VPN. Then we found no need to pick, because model “Ietf-supa-l3vpn” and model “ietf-supa-ddc” are loose coupling, is UML aggregation (different life cycle), not composition (same life cycle). These two models are described in draft-zaalouk-supa-vpn-service-management-model.

Regarding Ietf-supa-l3vpn and Ietf-l3vpn-svc, put together my previous comments at the list and Dacheng’s comments, it is like this. Sorry for repeat some earlier comments. Some of them were sent to the l3vpn list and the authors.

Both draft-l3vpn-service-yang and draft-zaalouk-supa-vpn-service-management-model are aimed to abstract the Layer 3 IP VPN YANG model on top of the management system.

The YANG Model architecture in these two drafts are the same, including the vpn-service global parameters and access-sites parameters, and the key parameters for a VPN service are nearly have the same definition. But draft-l3vpn-service-yang have more definition details besides the main VPN YANG model arthiceture, for example, the protection mode, QOS requirments, IP address allocation, VPN policy definition and some templates definition. These definitions should be added to supa vpn service management model. By the way, draft-l3vpn-service-yang has described the management system action in detail after recieving a VPN service requirement using this vpn service yang model, and these are also the same as supa idea.

For these reasons above, draft-zaalouk-supa-vpn-service-management-model could make a combination with this draft-l3vpn-service-yang.

But supa-vpn-service-management-model has a big difference from the l3vpn-service-yang, that is how to get the physical access position of an exact access site. In l3vpn-service-yang, some parameters and constrains like location and site-diversity are defined to help the management system to select appropriate PE or POP for the exact access site. To achive this purpose，the management system should maintain the PE or POP pools. This deployment will restrict the access site movement requirement, which is the main highlight of supa design. Supa allows the user access sites to access to the network anywhere and the VPN
configuration for network element can be created and deleted dynamically, which can shortest the service deployment period.

Draft-l3vpn-service-yang designs for carrier operators scenarios, it may be too complicated for enterprises. For example, for VPN site position, it includes multiple fields like country, city etc. However for enterprises, they may not care about these, more prefer Instant VPN, via some authentication method, e.g. MAC, to provision VPN service, and can migrate.

Thank you,
Tina

From: Benoit Claise [mailto:[email-masked]]
Sent: Monday, March 09, 2015 9:42 PM
To: Dacheng Zhang; Tina TSOU
Cc: [email-masked]<mailto:[email-masked]>
Subject: Re: [Supa] Fwd: [L3sm] Some background on the L3VPN Service YANG Model work

Hi Dacheng, all,

Can you please discus Draft-l3vpn-service-yang on the [email-masked]<mailto:[email-masked]> mailing list.

Regards, Benoit

Hi，

Draft-l3vpn-service-yang designs for carrier operators scenarios, it may be too complicated for enterprises. For example, for VPN site position, it includes multiple fields like country, city etc. However for enterprises, they may not care about these, more prefer Instant VPN, via some authentication method, e.g. MAC, to provision VPN service, and can migrate.

Cheers

Dacheng

From: Supa [mailto:[email-masked]] On Behalf Of Tina TSOU
Sent: Wednesday, March 04, 2015 10:09 PM
To: Benoit Claise; [email-masked]<mailto:[email-masked]>
Subject: Re: [Supa] Fwd: [L3sm] Some background on the L3VPN Service YANG Model work

Dear Benoit,

Have you seen
draft-zaalouk-supa-vpn-service-management-model-01<http://datatracker.ietf.org/doc/draft-zaalouk-supa-vpn-service-management-model/>
VPN Service Management YANG Data Model?

and the discussion about draft-zaalouk-supa-vpn-service-management-model-01<http://datatracker.ietf.org/doc/draft-zaalouk-supa-vpn-service-management-model/> and http://datatracker.ietf.org/doc/draft-l3vpn-service-yang/
at
http://www.ietf.org/mail-archive/web/supa/current/msg00559.html
?

Thank you,
Tina

From: Supa [mailto:[email-masked]] On Behalf Of Benoit Claise
Sent: Wednesday, March 04, 2015 9:52 PM
To: [email-masked]<mailto:[email-masked]>
Subject: [Supa] Fwd: [L3sm] Some background on the L3VPN Service YANG Model work

FYI.

Regards, Benoit

-------- Forwarded Message --------
Subject:

Date:

From:

Benoit Claise <[email-masked]><mailto:[email-masked]>

To:

[email-masked]<mailto:[email-masked]>

Dear all,

Let me give you some background on this new piece of work: The Layer Three Virtual Private Network Service Model (L3SM)

Three months ago, Adrian Farrel and I set up a design team to create a L3VPN service YANG model.
It needs to be clearly understood that this L3VPN service model is not an L3VPN configuration model. That is, it does not provide details for configuring network elements or protocols. Instead it contains the characteristics of the service, as discussed between the operators and their customers.  Therefore, that design team was composed of operators only.

That design team created a first draft: http://datatracker.ietf.org/doc/draft-l3vpn-service-yang/
Now that the draft has been posted, the work and discussion should continue in a public forum, i.e. this [email-masked]<mailto:[email-masked]> mailing list.

Next step? we're busy trying to create a new short-lived WG, focusing solely on this L3VPN service YANG model.
See the proposal at https://datatracker.ietf.org/doc/charter-ietf-l3sm/
If this WG is created (This proposal is on the IESG telechat this week for external review approval), this would be a good test for the IETF community: are we ready to standardize a first service YANG model? Personally, I believe we are.
IMO, the advantage/driver for this work is explained in the charter proposal:

    List address: [email-masked]<mailto:[email-masked]>

Regards, Benoit

Supa mailing list

[email-masked]<mailto:[email-masked]>