Subject: [Supa] v2 of PBSM

From: John Strassner <[email-masked]>
Date: Tue, 17 Mar 2015 23:28:15 -0700

First, thanks for the comments from everyone. Attached please find v2 of
the PBSM slides, with Fukushima-san's slides merged into mine. Here's a
change log:

Slide 1: added Fukushima-san as a presenter
Slide 2:  no change
Slide 3: replaced "platform" and "intelligent container" per Juergen's
comments
Slide 4: almost took this one out, but I think it is worth the 10-15
seconds I'm planning to spend on it
Slide 5: change from Motivation and Purpose to Types and Uses of Policy
Rules
Slide 6: added clarification per Bob's comments
Slide 7: deleted my pretty picture per Juergen's suggestion; will mention
context from here on out (alternatively, put it in backup)
Slide 8: deleted (combined into slide 5)
Slide 9 (now 7): simplified animation; pointed out that SUPA will consider
two types of policy rules
Slide 10: deleted (less intro, more policy service)
Slide 11: deleted (less intro, more policy service)
Slide 12 (now 8): no change
Slide 13 (now 9): no change
Slide 14: deleted (simpler to deal with 2 types of policies per Juergen)
Slide 15: deleted (simpler to deal with 2 types of policies per Juergen)
Slide 15 (deleted, combined into previous section)
Slide 16 (now 10): no change
Slide 17 (now 11): major rework to try and address Juergen's comments; will
take
Slide Bob's advice and emphasize importance of continuum
Slide 18 (now 12): no change, talk about Dan's points here
Slide 19: deleted since we haven't really discussed DSLs and translation in
detail
Slide 20 (now 13): changed title; this is where I integrate Fukushima-san's
slides
Everything else now refers to Fukushima-san's slides
NEW SLIDE 14: Took Fukushima-san's first slide and showed where deliverable
3 is. Showed that there is in general an m:n mapping between goal and ECA
policies, and that BOTH can be described using a continuum

NEW SLIDE 15: Reformatted to match current PPT style; corrected typos
ADDED the following point as a new sub-bullet under Integration
*Here I have a question. Right now, the service management model is
completely independent of policy. In fact, other than the abstract the
definition of what SUPA stands for, there is no mention of policy in the
draft. I therefore have no idea how policy relates to vpn service
management.*
*There is more of a link to policy in the policy model slides, but even
there, I don't recognize either a goal or an ECA policy in the policy model
definition.*
*This is one reason why I didn't think that these two contributions could
be merged...*

NEW SLIDE 16: Reformatted to suit current PPT style
*I have no idea what the last sub-bullet *("") *means. AFAIK, you cannot
implement a UML aggregation in Yang. Furthermore, this is not shown in the
model snippet. In addition, you said "model" (twice), where I think you
mean "module".*
*Finally, I am **guessing** that you are trying to describe how the two
modules interact, but again, I don't see how they implement a UML
aggregation. Please explain.*

NEW SLIDE 17:
s/servic-type/service-type
*I am missing how these two **modules** relate to each other, and how
policy rules are used with both of them.*

NEW SLIDE 18: I assumed that this was to be deleted, so I deleted it.

regards,
John

---

From: Georgios Karagiannis <[email-masked]>
Date: Wed, 18 Mar 2015 08:08:48 +0000

Hi John,

The slides are good and I saw that you have worked out most of the provided comments.
IMHO, the introductory part of this presentation needs to explain clearly how this policy work fits together with the network service related work in SUPA.
Actually slide 14, presents a part of that.
Is it possible to include an introductory part the beginning of this presentation, move slide 14 and provide more details, that describes:
o) what are the concepts of generic service abstraction, generic policy abstraction, and what is their relation to SUPA.
Moreover, is it possible to clearly emphasize what is the relation of the work that is being done in TMF and what we can do in IETF/SUPA. IMHO, you already described that during an email communication with Dan.

Best regards,
Georgios

From: Supa [mailto:[email-masked]] On Behalf Of John Strassner
Sent: 18 March 2015 07:28
To: Tina TSOU; Juergen Schoenwaelder; Natale, Bob; Romascanu, Dan (Dan); [email-masked]; John Strassner
Cc: [email-masked]
Subject: [Supa] v2 of PBSM

First, thanks for the comments from everyone. Attached please find v2 of the PBSM slides, with Fukushima-san's slides merged into mine. Here's a change log:

Slide 1: added Fukushima-san as a presenter
Slide 2:  no change
Slide 3: replaced "platform" and "intelligent container" per Juergen's comments
Slide 4: almost took this one out, but I think it is worth the 10-15 seconds I'm planning to spend on it
Slide 5: change from Motivation and Purpose to Types and Uses of Policy Rules
Slide 6: added clarification per Bob's comments
Slide 7: deleted my pretty picture per Juergen's suggestion; will mention context from here on out (alternatively, put it in backup)
Slide 8: deleted (combined into slide 5)
Slide 9 (now 7): simplified animation; pointed out that SUPA will consider two types of policy rules
Slide 10: deleted (less intro, more policy service)
Slide 11: deleted (less intro, more policy service)
Slide 12 (now 8): no change
Slide 13 (now 9): no change
Slide 14: deleted (simpler to deal with 2 types of policies per Juergen)
Slide 15: deleted (simpler to deal with 2 types of policies per Juergen)
Slide 15 (deleted, combined into previous section)
Slide 16 (now 10): no change
Slide 17 (now 11): major rework to try and address Juergen's comments; will take
Slide Bob's advice and emphasize importance of continuum
Slide 18 (now 12): no change, talk about Dan's points here
Slide 19: deleted since we haven't really discussed DSLs and translation in detail
Slide 20 (now 13): changed title; this is where I integrate Fukushima-san's slides
Everything else now refers to Fukushima-san's slides
NEW SLIDE 14: Took Fukushima-san's first slide and showed where deliverable 3 is. Showed that there is in general an m:n mapping between goal and ECA policies, and that BOTH can be described using a continuum

NEW SLIDE 15: Reformatted to match current PPT style; corrected typos
ADDED the following point as a new sub-bullet under Integration
Here I have a question. Right now, the service management model is completely independent of policy. In fact, other than the abstract the definition of what SUPA stands for, there is no mention of policy in the draft. I therefore have no idea how policy relates to vpn service management.
There is more of a link to policy in the policy model slides, but even there, I don't recognize either a goal or an ECA policy in the policy model definition.
This is one reason why I didn't think that these two contributions could be merged...

NEW SLIDE 16: Reformatted to suit current PPT style
I have no idea what the last sub-bullet ("") means. AFAIK, you cannot implement a UML aggregation in Yang. Furthermore, this is not shown in the model snippet. In addition, you said "model" (twice), where I think you mean "module".
Finally, I am **guessing** that you are trying to describe how the two modules interact, but again, I don't see how they implement a UML aggregation. Please explain.

NEW SLIDE 17:
s/servic-type/service-type
I am missing how these two **modules** relate to each other, and how policy rules are used with both of them.

regards,
John

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Wed, 18 Mar 2015 14:34:50 +0000

Hi John,

Thanks for the further and visible progress. I still have a few comments/questions. Numbering of slides is of the latest version.

-          Slide 3 – the definition of policy rule seems recursive as it includes ‘policy rule’

-          Slide 6 – the sentence in the last sub-bullet seems incomplete

-          Slide 12 – It is still not clear what are the expected borders of the work done by TM Forum, IETF at large and SUPA specifically – do you plan to add these (graphically or as speaker notes)?

Regards,

Dan

From: John Strassner [mailto:[email-masked]]
Sent: Wednesday, March 18, 2015 8:28 AM
To: Tina Tsou; Juergen Schoenwaelder; Natale, Bob; Romascanu, Dan (Dan); [email-masked]; John Strassner
Cc: [email-masked]
Subject: v2 of PBSM

NEW SLIDE 17:

regards,
John

---

From: John Strassner <[email-masked]>
Date: Wed, 18 Mar 2015 19:09:59 -0700

Attached is v3. This update addresses Dan's and Georgios' comments.
Tomorrow I will work on addressing the problems I identified in slides 17
and 18.

Change log:
(general note: added a new intro section and updated the agenda dividers in
the deck)

Slide 1:   no change
Slide 2:   new agenda slide
Slide 3:   was slide 14, moved per Georgios' comment above
Slide 4:   NEW SLIDE, addresses Georgios' comment above
Slide 5:   new agenda slide
Slide 6:   (was slide 3) updated policy rule definition per Dan's comment;
added metadata examples
Slide 7:   unchanged
Slide 8:   new agenda slide
Slide 9:   (was slide 6) Fixed last bullet and its sub-bullets
Slide 10: unchanged
Slide 11: unchanged
Slide 12: unchanged
Slide 13: new agenda slide
Slide 14: unchanged
Slide 15: (was slide 12) added text to partially address Dan's comment;
will talk about relationship orally (unless I hear word back officially)
Slide 16: new agenda slide
Slide 17: unchanged
Slide 18: unchanged
Slide 19: unchanged
Slide 20: unchanged

On Wed, Mar 18, 2015 at 1:08 AM, Georgios Karagiannis <
[email-masked]> wrote:

> IMHO, the introductory part of this presentation needs to explain clearly
> how this policy work fits together with the network service related work in
> SUPA.
>
> Is it possible to include an introductory part the beginning of this
> presentation, move slide 14 and provide more details, that describes:
>
> o) what are the concepts of generic service abstraction, generic policy
> abstraction, and what is their relation to SUPA.
>
> Moreover, is it possible to clearly emphasize what is the relation of the
> work that is being done in TMF and what we can do in IETF/SUPA. IMHO, you
> already described that during an email communication with Dan.
>
>
>
> Best regards,
>
> Georgios
>
>
>
>
>
>
>
>
>
>
>
> *From:* Supa [mailto:[email-masked]] *On Behalf Of *John Strassner
> *Sent:* 18 March 2015 07:28
> *To:* Tina TSOU; Juergen Schoenwaelder; Natale, Bob; Romascanu, Dan
> (Dan); [email-masked]; John Strassner
> *Cc:* [email-masked]
> *Subject:* [Supa] v2 of PBSM
>
>
>
> NEW SLIDE 14: Took Fukushima-san's first slide and showed where
> deliverable 3 is. Showed that there is in general an m:n mapping between
> goal and ECA policies, and that BOTH can be described using a continuum
>
>
>

-- 
regards,
John

---

From: John Strassner <[email-masked]>
Date: Thu, 19 Mar 2015 22:05:38 +0000

This is v4.

Change log: everything is unchanged EXCEPT for a new slide 18, which I added to address the red text in slide 17. I think that this also addresses the red text in slide 19 (conceptually, NOT in the strict sense of the phrase “UML aggregation”, but I don’t understand what is meant by that anyway).

regards,
John

Dr. John Strassner, Ph.D.
CTO, Software Laboratory, CRD

Futurewei Technologies
US R&D Center
2330 Central Expressway
Building A, office A2-2143
Santa Clara, California   95050

  Office:  +1.408.330.4923
  Email:   [email-masked]

From: Supa [mailto:[email-masked]] On Behalf Of John Strassner
Sent: Wednesday, March 18, 2015 7:10 PM
To: Georgios Karagiannis; Romascanu, Dan (Dan); John Strassner
Cc: [email-masked]
Subject: Re: [Supa] v2 of PBSM

Attached is v3. This update addresses Dan's and Georgios' comments.
Tomorrow I will work on addressing the problems I identified in slides 17 and 18.

Change log:
(general note: added a new intro section and updated the agenda dividers in the deck)

Slide 1:   no change
Slide 6:   (was slide 3) updated policy rule definition per Dan's comment; added metadata examples
Slide 15: (was slide 12) added text to partially address Dan's comment; will talk about relationship orally (unless I hear word back officially)

On Wed, Mar 18, 2015 at 1:08 AM, Georgios Karagiannis <[email-masked]<mailto:[email-masked]>> wrote:
Hi John,

Best regards,
Georgios

From: Supa [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of John Strassner
Sent: 18 March 2015 07:28
To: Tina TSOU; Juergen Schoenwaelder; Natale, Bob; Romascanu, Dan (Dan); [email-masked]<mailto:[email-masked]>; John Strassner
Cc: [email-masked]<mailto:[email-masked]>
Subject: [Supa] v2 of PBSM

NEW SLIDE 17:

regards,
John

--
regards,
John

---

From: John Strassner <[email-masked]>
Date: Sat, 21 Mar 2015 00:32:48 +0000

Final version unless someone screams. ☺
Note that I added in one slide to talk about the ALPS service profile draft.

regards,
John

Futurewei Technologies
US R&D Center
2330 Central Expressway

  Office:  +1.408.330.4923

From: John Strassner
Sent: Thursday, March 19, 2015 3:06 PM
To: John Strassner; Georgios Karagiannis; Romascanu, Dan (Dan); [email-masked]
Cc: [email-masked]
Subject: RE: [Supa] v2 of PBSM

This is v4.

regards,
John

Futurewei Technologies
US R&D Center
2330 Central Expressway

  Office:  +1.408.330.4923

Change log:

Slide 1:   no change

Best regards,
Georgios

NEW SLIDE 17:

regards,
John

--
regards,
John