Subject: Re: [Supa] v3 of PBSM slides, ONOS Intent Framework, and TMF Service Mgmt model

From: JF Tremblay <[email-masked]>
Date: Thu, 19 Mar 2015 08:58:25 -0400

Thanks for the pointers, Bob.
Any information on how far the ONOS people are with this?  Their wiki doesn’t say much (https://wiki.onosproject.org/display/ONOS/The+Intent+Framework <https://wiki.onosproject.org/display/ONOS/The+Intent+Framework>)

If you have an interest in intents, you might want to take a look at the OpenDaylight NIC project. It’s probably the intent-related project that has the furthest advancement at this moment. It has a running demo built by the HP team. https://wiki.opendaylight.org/view/Project_Proposals:Network_Intent_Composition <https://wiki.opendaylight.org/view/Project_Proposals:Network_Intent_Composition>

On the IETF side, the NEMO project folks had intended (pun!) to bring an intent-flavoured version of their work to the IETF in the ib-nemo group, but that has seen very little activity. I guess you already know this, as you are the last poster on that list (from Feb. 11th!) (http://www.ietf.org/mail-archive/web/ibnemo/current/maillist.html <http://www.ietf.org/mail-archive/web/ibnemo/current/maillist.html>). 

There’s definitely some overlap between intents and ECA-type policies (John and myself discussed it on the list). The big debate at this point is: is it worth working on both, and is the IETF the right forum to do it. I guess the supa bof will be the place to discuss these questions. 

JF

> On Mar 18, 2015, at 11:08 PM, Natale, Bob <[email-masked]> wrote:
> 
> Hi folks,
>  
> - The v3 PBSM deck looks very good to me, but I would support integrating Georgios’ suggestion, if John agrees and wants to take that on at this stage.
>  
> The next two points are hopefully helpful to some people on the list and not disruptive spam to others:
>  
> - Most of you are probably ahead of me on general related industry activities, but I recently learned of the (open source) Open Network Operating System (ONOS) project’s Intent Framework and wanted to be sure that everyone else was, in fact, aware of it. Would seem to provide a somewhat higher-order context for possible PBSM implementation based on Intents/Goals driving E-C-A rules. See http://onosproject.org/ <http://onosproject.org/>, and especially http://onos.wpengine.com/wp-content/uploads/2014/11/ONOS-Intent-Framework.pdf <http://onos.wpengine.com/wp-content/uploads/2014/11/ONOS-Intent-Framework.pdf>.
>  
> - Since the topic of the TM Forum service management model has come up several times, I thought I’d forward the following two diagrams from Annex G (informative): TM Forum SID service model of ETSI GS NFV-MAN 001 V1.1.1 (2014-12) for those who might not have seen them (or have forgotten them).
>  
> The first is the highest level view of the major model elements and relationships from the TM Forum Information Model (which used to be called the Shared Information and Data Model (SID)):
> 
>  
> The second shows the potential revisions to a portion of that model to accommodate the following aspects of Network Functions Virtualization -- the concepts of a VNF, Network Service, Network Service Descriptor (NSD) and VNF Graph need to be introduced in the Service Model above to provide the needed integration. A VNF is a type of SID LogicalResource. As a SID LogicalResource, VNF implements ResourceFacingServices (RFSs) that are required to provide CustomerFacingServices (CFSs):
> 
>  
> Avanti,
> BobN

---

From: "Natale, Bob" <[email-masked]>
Date: Fri, 20 Mar 2015 03:41:21 +0000

Hi JF,

I don’t have any inside info on how far the ONOS project is with its Intent Framework, but they just released ONOS v1.1.0 (Blackbird) and the release notes (https://wiki.onosproject.org/display/ONOS/Downloads)  highlight the following improvements in that area:

  *   Intent operation (submit/withdraw) throughput performance and scalability
  *   Intent reactive repair (path re-routing) latency
  *   Cleaner intent subsystem API

… so I suppose they did get some performance and usability feedback from implementers of Intents in previous releases.

I think the Intent level policy approach is best for SUPA since service management should start from the Business View (in practice and wrt the Policy Continuum) and E-C-A rules don’t work that well up the chain, esp. if the target implementers (i.e., those who will execute actions on the managed resources) of those policies are several hops down the chain (e.g., Network, Device, or Instance View) … i.e., practitioners at the Business View level _might_ be able to compose E-C-A rules for the System View, but not beyond that (IMHO). This highlights the fact that different types of policy expressions (Intent, Goal, Utility, E-C-A) might work best for given Views … more importantly, however, is an understanding of what it means for the Views within the poles of the Continuum, who typically need to understand one or more policy expression types on the Northbound (input) side and one more possibly different policy expression types on the Southbound (output) side.

I am aware of the ODL NIC project, but will take a closer look over the weekend. Roger on the IB-Nemo WG.

Avanti,
BobN

From: JF Tremblay [mailto:[email-masked]]
Sent: Thursday, March 19, 2015 8:58 AM
To: Natale, Bob
Cc: [email-masked]
Subject: Re: [Supa] v3 of PBSM slides, ONOS Intent Framework, and TMF Service Mgmt model
Importance: Low

Thanks for the pointers, Bob.
Any information on how far the ONOS people are with this?  Their wiki doesn’t say much (https://wiki.onosproject.org/display/ONOS/The+Intent+Framework)

If you have an interest in intents, you might want to take a look at the OpenDaylight NIC project. It’s probably the intent-related project that has the furthest advancement at this moment. It has a running demo built by the HP team. https://wiki.opendaylight.org/view/Project_Proposals:Network_Intent_Composition

On the IETF side, the NEMO project folks had intended (pun!) to bring an intent-flavoured version of their work to the IETF in the ib-nemo group, but that has seen very little activity. I guess you already know this, as you are the last poster on that list (from Feb. 11th!) (http://www.ietf.org/mail-archive/web/ibnemo/current/maillist.html).

JF

On Mar 18, 2015, at 11:08 PM, Natale, Bob <[email-masked]<mailto:[email-masked]>> wrote:

Hi folks,

- Most of you are probably ahead of me on general related industry activities, but I recently learned of the (open source) Open Network Operating System (ONOS) project’s Intent Framework and wanted to be sure that everyone else was, in fact, aware of it. Would seem to provide a somewhat higher-order context for possible PBSM implementation based on Intents/Goals driving E-C-A rules. See http://onosproject.org/, and especially http://onos.wpengine.com/wp-content/uploads/2014/11/ONOS-Intent-Framework.pdf.

Avanti,
BobN