Subject: Re: [Supa] draft-bi-supa-gap-analysis

From: John Strassner <[email-masked]>
Date: Sat, 28 Feb 2015 16:52:35 -0800

First, I agree with what Bob said. I do not think that Intent and policy
should be separated. The charter talks about policy rules, and we have been
talking about different forms of policy rules (e.g., CA, ECA, goal
(intent), etc.).

Second, Congress does not **enforce** policy (especially in the sense of a
PEP). Rather, Congress is a mechanism for expressing whether something is
in compliance or not. It could **trigger** enforcement.

Third, I agree with Bob, s/End User App/Applications.

Fourth, why is API a focus area of SUPA? I think that this should be
removed.

Fifth, I don't understand what "Ext[ension] module for Rich Controller" is
or why we should care in the first phase of SUPA. There's a huge difference
in the functionality of different Controllers, and eliminating this removes
Yet Another Possibility for Ratholing.

Sixth, s/Depoly/Deploy.

regards,
John

On Fri, Feb 27, 2015 at 11:59 PM, Natale, Bob <[email-masked]> wrote:

>   Hi Ying,
>
>
>
> Looks good to me with one possible refinement and a couple of nits:
>
>
>
> 1. I don’t fully understand the implied dichotomy between “Intent” and
> “Policy” … are you sure they are mutually exclusive categories that
> completely describe some higher-order category space?  E.g., to quote from
> Dave Lenrow’s introduction to the “Intent Based Network Summit 2015” (slide
> #13), “Intent” can be seen as a subset of “Policy”:
>
>
>
> “• Not all Policy based infrastructure or networking is Intent Based
>
>    • All Intent based networking could be said to be policy based”
>
>
>
> Maybe it should be something like “Intent-based Policy” and “Rules-based
> Policy” …?
>
>
>
> 2. Just a nit: “Supa Focus Area” should be “SUPA Focus Area”
>
>
>
> 3. The graphics might need some clean-up/normalization … e.g.:
>
> a. The “Network Services Deployment” label on the right side should be
> centered across the “Intent” and “Policy” arrows
>
> b. The “Network Services Deployment” label on the left side should be
> centered under the “Core API” arrows, and
>
> c. it probably should be “boxed” in a rectangle like the “Ext Module for
> Rich Controller” on the right side of the “Network Manager Controller” box
>
> d. “End User APP” seems a bit limiting … maybe just “Applications” would
> suffice, allowing for a broader range of using applications…?
>
>
>
> Avanti,
>
> BobN
>
>
>
> *From:* Ying Cheng [mailto:[email-masked]]
> *Sent:* Saturday, February 28, 2015 2:06 AM
> *To:* Dacheng Zhang; Tina TSOU; Romascanu, Dan (Dan)
> *Cc:* Jun Bi; Jean-François Tremblay; Marc Blanchet; Natale, Bob;
> [email-masked]
> *Subject:* Re: Re: [Supa] draft-bi-supa-gap-analysis
>
>
>
> Hi all,
>
>
>
> Based upon Dacheng's texts on SUPA scope, it is proposed to add the
> following figure as the starting point for our further discussion.
>
>
>
> Any comments are welcomed and appreciated.
>
>
>
> BR,
>
> Ying
>
>
>
>
>
>
>
> 2015-02-28
>  ------------------------------
>
> Ying CHENG  程莹
> China Unicom Network Technology Research Institute 中国联通网络技术研究院
> Tel: +86-10-68799999-7702
> Mobile: +86-18601102971
>   ------------------------------
>
> *发件人：* Dacheng Zhang
>
> *发送时间：* 2015-02-27  22:26:06
>
> *收件人：* Tina TSOU; Romascanu, Dan (Dan)
>
> *抄送：* Ying Cheng(联通集团联通网络技术研究院); Jun Bi; Jean-François Tremblay; Marc
> Blanchet; Natale, Bob; [email-masked]
>
> *主**题：* Re: [Supa] draft-bi-supa-gap-analysis
>
> SUPA Scope and Focus：
>
> SUPA will focus in the first phase on inter-datacenter traffic management
> in the use case of a distributed data center, including the automated
> provisioning of site-to-site virtual private networks of various types,
> including service configuratioin model ,generic topology model and generic
> network-level policy model. All of them describe network behaviors for a
> service. Specially, the existing WG charters do not specify which WG is in
> charge to provide a generic toplogy model and that SUPA is happy to work
> with any WG that might get chartered to provide the generic topology model.
>
>
>
> Relationship with I2RS:
>
> I2RS defines a collection of protocol-based control or management
>
> interfaces for route system；
>
> SUPA can leverage the exsiting protocol and models defined I2RS;
>
>
>
> Relationship with BESS:
>
> BESS defines, specifies and extends network services based on BGP and sets
> up VPNs by configurating BGP;
>
> SUPA doesn't care how to set up VPNs by some specific protocol;
>
> SUPA can leverage the exsiting protocol and models defined BESS;
>
>
>
> Relationship with OpenStack Congress:
>
> Congress is intended to be a general-purpose, high-level policy component
> of OpenStack.  To enforce the policies across compute, storage and
> networking, Congress would carve off subpolicies and send them to the
> appropriate enforcement point in the cloud, Supa could be one of them in
> the networking domain.
>
>
>
> Relationship with TEAS:
>
> TEAS is responsible for defining MPLS and GMPLS traffic engineering
> architecture, standardizing the RSVP-TE signaling protocol, and identifying
> required related control-protocol functions.
>
> SUPA is responsible for defining ECA policy model to implement TE.
>
>
>
> Relationship with I2nsf:
>
> The relation or intersection between the SUPA and I2NSF may be in the
> information and data model for policies. I2NSF does not have or care about
> topologies.
>
>
>
> *发件人**: *Tina TSOU <[email-masked]>
> *日期**: *2015年2月26日 星期四 下午11:18
> *至**: *"Romascanu, Dan (Dan)" <[email-masked]>
> *抄送**: *Ying Cheng <[email-masked]>, Jun Bi <
> [email-masked]>, Jean-François Tremblay <
> [email-masked]>, Marc Blanchet <
> [email-masked]>, "Natale, Bob" <[email-masked]>, "
> [email-masked]" <[email-masked]>
> *主**题**: *Re: [Supa] draft-bi-supa-gap-analysis
>
>
>
> Dear Dan et al,
>
>
>
> Good point.
>
>
>
> I would suggest the following template to facilitate gap analysis
> discussion? Proposals? Let's see who fills it quickly;)
>
> Ideally, there should be a figure.
>
> SUPA scope and focus: xxx
>
> Relationship with ir2s: xxx
>
> Relationship with teas: xxx
>
> Relationship with OpenStack Congress: xxx
>
> Relationship with ODL NIC: xxx
>
>
>
>
>
> Thank you,
>
> Tina
>
>
> On Feb 25, 2015, at 6:08 PM, Romascanu, Dan (Dan) <[email-masked]>
> wrote:
>
>  <!--[if mso 9]--> <!--[endif]-->
>
> I agree that for the purpose of the discussions at the BOF slides are
> useful. However, the IETF mode of work gives preference to Internet-Drafts,
> and when chartering will be considered ‘are there relevant
> Internet-Drafts?’ is one of the questions the IESG will ask. My experience
> is that the IESG prefers I-Ds to powerpoint. The current I-D on gaps
> analysis was not updated since last September and for somebody searching
> and reading I-Ds the reading of this document can be mis-leading about
> where the team is in the discussions.
>
>
>
> Regards,
>
>
>
> Dan
>
>
>
>
>
> *From:* Supa [mailto:[email-masked] <[email-masked]>] *On
> Behalf Of *Natale, Bob
> *Sent:* Wednesday, February 25, 2015 8:45 AM
> *To:* Ying Cheng; Marc Blanchet; Tina Tsou
> *Cc:* Jun Bi; Jean-François Tremblay; [email-masked]
> *Subject:* Re: [Supa] draft-bi-supa-gap-analysis
>
>
>
> +1 … should be relatively easy to represent visually and, once agreed
> upon, would form the basis of the corresponding I-D.
>
>
>
> Avanti,
>
> BobN
>
>
>
> *From:* Supa [mailto:[email-masked] <[email-masked]>] *On
> Behalf Of *Ying Cheng
> *Sent:* Wednesday, February 25, 2015 12:59 AM
> *To:* Marc Blanchet; Tina Tsou
> *Cc:* Jun Bi; Jean-François Tremblay; [email-masked]
> *Subject:* Re: [Supa] draft-bi-supa-gap-analysis
>
>
>
> Hi all,
>
>
>
> I agree with Marc's suggestion. Slides of gap analysis with figures are
> more helpful for discussion.
>
>
>
> BR,
>
> Ying
>
>
>
>
>
> 2015-02-25
>  ------------------------------
>
> Ying CHENG  程莹
> China Unicom Network Technology Research Institute 中国联通网络技术研究院
> Tel: +86-10-68799999-7702
> Mobile: +86-18601102971
>   ------------------------------
>
> *发件人：* Marc Blanchet
>
> *发送时间：* 2015-02-25  00:21:24
>
> *收件人：* Tina Tsou
>
> *抄送：* Jun Bi; Jean-François Tremblay; [email-masked]
>
> *主**题：* Re: [Supa] draft-bi-supa-gap-analysis
>
>
>
>  Le 2015-02-23 à 23:43, Tina TSOU <[email-masked]> a écrit :
>
>
>
> Dear Jun and JF,
>
>
>
> Per this Monday's meeting, the gap analysis draft is one of the drafts
> that must be updated by Mar 9.
>
>
>
> http://datatracker.ietf.org/doc/draft-bi-supa-gap-analysis/
> <https://urldefense.proofpoint.com/v2/url?u=http-3A__datatracker.ietf.org_doc_draft-2Dbi-2Dsupa-2Dgap-2Danalysis_&d=AwMGaQ&c=BFpWQw8bsuKpl1SgiZH64Q&r=I4dzGxR31OcNXCJfQzvlsiLQfucBXRucPvdrphpBsFA&m=75NnaKfHSnJEyTvLp9a5KStGqK_KqY0aUr8JpCuvi2A&s=d_YdL_lV5dqUgzvEw-Y8PvZYpUd4Q0aB-mAZj_0niGc&e=>
>
>
>
> Would you work on it?
>
>
>
> I remember you signed up to work on this draft. I may miss the other
> people who also signed up for this. Pls team up with Jun and JF.
>
>
>
> Dear Tina,
>
>
>
> I see two kind of gap analysis:
>
> a) a full blown internet draft with all the details of everything
>
> b) one slide or two that describes where each wg is shown and what is supa
> would be doing. I could even see some graphic representation.
>
>
>
> The overall goal is to  have a good discussion during the BOF.  From that
> perspective, I think we should work on b), not a).
>
>
>
> my 2 cents.
>
>
>
> Marc.
>
>
>
>
>
>
>
> Thank you,
>
> Tina
>
> _______________________________________________
> Supa mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/supa
> <https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_supa&d=AwMGaQ&c=BFpWQw8bsuKpl1SgiZH64Q&r=I4dzGxR31OcNXCJfQzvlsiLQfucBXRucPvdrphpBsFA&m=75NnaKfHSnJEyTvLp9a5KStGqK_KqY0aUr8JpCuvi2A&s=xtw8PCJw-uH3Na6nOv2ntoPkGf7N9UkqKDggiMM681s&e=>
>
>
>
> 如果您错误接收了该邮件，请通过电子邮件立即通知我们。[email-masked]
> ，即可以退订此邮件。我们将立即将您的信息从我们的发送目录中删除。 If you have received this email in error
> please notify us immediately by e-mail. Please reply to
> [email-masked] if you want to unsubscribe from this mail. We
> will immediately remove your information from our sending catalogue.
>
>  _______________________________________________ Supa mailing list
> [email-masked] https://www.ietf.org/mailman/listinfo/supa
>
> 如果您错误接收了该邮件，请通过电子邮件立即通知我们。[email-masked]，即可以退
> 订此邮件。我们将立即将您的信息从我们的发送目录中删除。 If you have received this email in error
> please notify us immediately by e-mail. Please reply to
> [email-masked] if you want to unsubscribe from this mail. We
> will immediately remove your information from our sending catalogue.
>
> _______________________________________________
> Supa mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/supa
>
>

-- 
regards,
John

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Mon, 2 Mar 2015 11:52:48 +0000

Questions (if there are references already some place else please show me where they are:

-          What ‘Intent’ means in the figure?

-          I assume the middle box network element (NE) is labelled Deploy and not Depoly. What is the difference between it and the other two similar boxes with labels ‘Active’?

-          What is the functionality of the Service Management box? Only service creation or more?
Thanks and Regards,
Dan

From: Supa [mailto:[email-masked]] On Behalf Of Ying Cheng
Sent: Saturday, February 28, 2015 9:06 AM
To: Dacheng Zhang; Tina TSOU; Romascanu, Dan (Dan)
Cc: Jun Bi; Jean-François Tremblay; Natale, Bob; [email-masked]; Marc Blanchet
Subject: Re: [Supa] draft-bi-supa-gap-analysis

Hi all,

Based upon Dacheng's texts on SUPA scope, it is proposed to add the following figure as the starting point for our further discussion.

BR,
Ying

2015-02-28
________________________________
Ying CHENG  程莹
China Unicom Network Technology Research Institute 中国联通网络技术研究院
Tel: +86-10-68799999-7702
Mobile: +86-18601102971
________________________________
发件人： Dacheng Zhang
发送时间： 2015-02-27  22:26:06
收件人： Tina TSOU; Romascanu, Dan (Dan)
抄送： Ying Cheng(联通集团联通网络技术研究院); Jun Bi; Jean-François Tremblay; Marc Blanchet; Natale, Bob; [email-masked]<mailto:[email-masked]>
主题： Re: [Supa] draft-bi-supa-gap-analysis
SUPA Scope and Focus：
SUPA will focus in the first phase on inter-datacenter traffic management in the use case of a distributed data center, including the automated provisioning of site-to-site virtual private networks of various types, including service configuratioin model ,generic topology model and generic network-level policy model. All of them describe network behaviors for a service. Specially, the existing WG charters do not specify which WG is in charge to provide a generic toplogy model and that SUPA is happy to work with any WG that might get chartered to provide the generic topology model.

Relationship with I2RS:

Relationship with BESS:
BESS defines, specifies and extends network services based on BGP and sets up VPNs by configurating BGP;
SUPA doesn't care how to set up VPNs by some specific protocol;
SUPA can leverage the exsiting protocol and models defined BESS;

Relationship with OpenStack Congress:
Congress is intended to be a general-purpose, high-level policy component of OpenStack.  To enforce the policies across compute, storage and networking, Congress would carve off subpolicies and send them to the appropriate enforcement point in the cloud, Supa could be one of them in the networking domain.

Relationship with TEAS:
TEAS is responsible for defining MPLS and GMPLS traffic engineering architecture, standardizing the RSVP-TE signaling protocol, and identifying required related control-protocol functions.
SUPA is responsible for defining ECA policy model to implement TE.

Relationship with I2nsf:
The relation or intersection between the SUPA and I2NSF may be in the information and data model for policies. I2NSF does not have or care about topologies.

发件人: Tina TSOU <[email-masked]<mailto:[email-masked]>>
日期: 2015年2月26日 星期四 下午11:18
至: "Romascanu, Dan (Dan)" <[email-masked]<mailto:[email-masked]>>
抄送: Ying Cheng <[email-masked]<mailto:[email-masked]>>, Jun Bi <[email-masked]<mailto:[email-masked]>>, Jean-François Tremblay <[email-masked]<mailto:[email-masked]>>, Marc Blanchet <[email-masked]<mailto:[email-masked]>>, "Natale, Bob" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
主题: Re: [Supa] draft-bi-supa-gap-analysis

Dear Dan et al,

Good point.

I would suggest the following template to facilitate gap analysis discussion? Proposals? Let's see who fills it quickly;)

Thank you,
Tina

On Feb 25, 2015, at 6:08 PM, Romascanu, Dan (Dan) <[email-masked]<mailto:[email-masked]>> wrote:
<!--[if mso 9]--> <!--[endif]-->
I agree that for the purpose of the discussions at the BOF slides are useful. However, the IETF mode of work gives preference to Internet-Drafts, and when chartering will be considered ‘are there relevant Internet-Drafts?’ is one of the questions the IESG will ask. My experience is that the IESG prefers I-Ds to powerpoint. The current I-D on gaps analysis was not updated since last September and for somebody searching and reading I-Ds the reading of this document can be mis-leading about where the team is in the discussions.

Regards,

Dan

From: Supa [mailto:[email-masked]] On Behalf Of Natale, Bob
Sent: Wednesday, February 25, 2015 8:45 AM
To: Ying Cheng; Marc Blanchet; Tina Tsou
Cc: Jun Bi; Jean-François Tremblay; [email-masked]<mailto:[email-masked]>
Subject: Re: [Supa] draft-bi-supa-gap-analysis

+1 … should be relatively easy to represent visually and, once agreed upon, would form the basis of the corresponding I-D.

Avanti,
BobN

From: Supa [mailto:[email-masked]] On Behalf Of Ying Cheng
Sent: Wednesday, February 25, 2015 12:59 AM
To: Marc Blanchet; Tina Tsou
Cc: Jun Bi; Jean-François Tremblay; [email-masked]<mailto:[email-masked]>
Subject: Re: [Supa] draft-bi-supa-gap-analysis

Hi all,

I agree with Marc's suggestion. Slides of gap analysis with figures are more helpful for discussion.

BR,
Ying

2015-02-25
________________________________
Ying CHENG  程莹
China Unicom Network Technology Research Institute 中国联通网络技术研究院
Tel: +86-10-68799999-7702
Mobile: +86-18601102971
________________________________
发件人： Marc Blanchet
发送时间： 2015-02-25  00:21:24
收件人： Tina Tsou
抄送： Jun Bi; Jean-François Tremblay; [email-masked]<mailto:[email-masked]>
主题： Re: [Supa] draft-bi-supa-gap-analysis

Le 2015-02-23 à 23:43, Tina TSOU <[email-masked]<mailto:[email-masked]>> a écrit :

Dear Jun and JF,

Per this Monday's meeting, the gap analysis draft is one of the drafts that must be updated by Mar 9.

http://datatracker.ietf.org/doc/draft-bi-supa-gap-analysis/<https://urldefense.proofpoint.com/v2/url?u=http-3A__datatracker.ietf.org_doc_draft-2Dbi-2Dsupa-2Dgap-2Danalysis_&d=AwMGaQ&c=BFpWQw8bsuKpl1SgiZH64Q&r=I4dzGxR31OcNXCJfQzvlsiLQfucBXRucPvdrphpBsFA&m=75NnaKfHSnJEyTvLp9a5KStGqK_KqY0aUr8JpCuvi2A&s=d_YdL_lV5dqUgzvEw-Y8PvZYpUd4Q0aB-mAZj_0niGc&e=>

Would you work on it?

I remember you signed up to work on this draft. I may miss the other people who also signed up for this. Pls team up with Jun and JF.

Dear Tina,

I see two kind of gap analysis:
a) a full blown internet draft with all the details of everything
b) one slide or two that describes where each wg is shown and what is supa would be doing. I could even see some graphic representation.

The overall goal is to  have a good discussion during the BOF.  From that perspective, I think we should work on b), not a).

my 2 cents.

Marc.

Thank you,
Tina
_______________________________________________
Supa mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/supa<https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_supa&d=AwMGaQ&c=BFpWQw8bsuKpl1SgiZH64Q&r=I4dzGxR31OcNXCJfQzvlsiLQfucBXRucPvdrphpBsFA&m=75NnaKfHSnJEyTvLp9a5KStGqK_KqY0aUr8JpCuvi2A&s=xtw8PCJw-uH3Na6nOv2ntoPkGf7N9UkqKDggiMM681s&e=>

如果您错误接收了该邮件，请通过电子邮件立即通知我们。[email-masked]，即可以退订此邮件。我们将立即将您的信息从我们的发送目录中删除<mailto:[email-masked]，即可以退订此邮件。我们将立即将您的信息从我们的发送目录中删除>。 If you have received this email in error please notify us immediately by e-mail. Please reply to [email-masked]<mailto:[email-masked]> if you want to unsubscribe from this mail. We will immediately remove your information from our sending catalogue.
_______________________________________________ Supa mailing list [email-masked]<mailto:[email-masked]> https://www.ietf.org/mailman/listinfo/supa<https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_supa&d=AwMGaQ&c=BFpWQw8bsuKpl1SgiZH64Q&r=I4dzGxR31OcNXCJfQzvlsiLQfucBXRucPvdrphpBsFA&m=8tlXfMBYiyXdl3QX_uaZEwaErzoCYOw1TwelXmRq-5M&s=hklOUyvfQM5mQ7KybkMJTKMVTlnu7lUcIuXQYHWTCgE&e=>

如果您错误接收了该邮件，请通过电子邮件立即通知我们。[email-masked]，即可以退订此邮件。我们将立即将您的信息从我们的发送目录中删除。 If you have received this email in error please notify us immediately by e-mail. Please reply to [email-masked]<mailto:[email-masked]> if you want to unsubscribe from this mail. We will immediately remove your information from our sending catalogue.

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Mon, 2 Mar 2015 12:43:06 +0000

One more thing that I am missing here is the topology input. As things look now we will import different layers of topology from places like I2RS or TEAS – we may need to represent these.

Regards,

Dan

From: Supa [mailto:[email-masked]] On Behalf Of Romascanu, Dan (Dan)
Sent: Monday, March 02, 2015 1:53 PM
To: Ying Cheng; Dacheng Zhang; Tina TSOU
Cc: Marc Blanchet; Jun Bi; Jean-Fran?ois Tremblay; [email-masked]; Natale, Bob
Subject: Re: [Supa] draft-bi-supa-gap-analysis

Cc: Jun Bi; Jean-François Tremblay; Natale, Bob; [email-masked]<mailto:[email-masked]>; Marc Blanchet

Hi all,

BR,
Ying

2015-02-28

Relationship with I2RS:

Relationship with BESS:

Relationship with TEAS:

Relationship with I2nsf:

Dear Dan et al,

Good point.

Thank you,
Tina

Regards,

Dan

Avanti,
BobN

Hi all,

BR,
Ying

2015-02-25

Dear Jun and JF,

Would you work on it?

Dear Tina,

my 2 cents.

Marc.

Thank you,
Tina

---

From: "Susan Hares" <[email-masked]>
Date: Mon, 2 Mar 2015 09:50:59 -0500

Dan, Ying, and Dacheng: 

This model seems to really mix many pieces of the work.  SUPA’s problem statement claims to look at the service level for the configuration.  If so, the work is either configuration (netmod/netconf)?  If it is dynamic, the protocol independent topologies and policy for services are being handled by the I2RS work.  

•   draft-chen-i2rs-topology-im-00.txt  (summary of PIT topologies including service topologies, pending)    <http://datatracker.ietf.org/doc/draft-clemm-i2rs-yang-network-topo/> 

•   draft-clemm-i2rs-yang-network-topo-02 <http://datatracker.ietf.org/doc/draft-clemm-i2rs-yang-network-topo/>  (generic model) 

•   Draft-dong-i2rs-inventory-00.txt    (generic model addition for resources, pending) 

•    draft-zhang-i2rs-l1-topo-yang-model-00 <http://datatracker.ietf.org/doc/draft-zhang-i2rs-l1-topo-yang-model/> 

•   draft-dong-i2rs-l2-network-topology-00 <http://datatracker.ietf.org/doc/draft-dong-i2rs-l2-network-topology/> 

•   draft-clemm-i2rs-yang-l3-topo-00 <http://datatracker.ietf.org/doc/draft-clemm-i2rs-yang-l3-topo/>   

•   draft-dong-i2rs-l2-network-topology-00 <http://datatracker.ietf.org/doc/draft-dong-i2rs-l2-network-topology/> 

•   Draft-wang-i2rs-service-topo-dm-00   <http://tools.ietf.org/html/draft-wang-i2rs-yang-service-topo-dm-00>  - exist, revision pending 

•   Draft-wang-i2rs-service-topo-sfc-dm-00 (service model) – exists , revision pending 

•   Draft-dunbar-i2rs-discover-traffic-rules-00 (policy models) - pending

If SUPA is dealing with intent, it is not covered in the problem statement or the use cases.  If you are adding intent at this late date, you should consider the intent-specific work in Nemo ([email-masked] work (www.nemo-project.org) and the service topology). 

Can you tell me why you are taking this approach to SUPA? This diagram changes the SUPA work to middle box area without providing any support for the topology? 

Sue 

From: Supa [mailto:[email-masked]] On Behalf Of Romascanu, Dan (Dan)
Sent: Monday, March 02, 2015 7:43 AM
To: Romascanu, Dan (Dan); Ying Cheng; Dacheng Zhang; Tina TSOU
Cc: Marc Blanchet; Jean-Fran?ois Tremblay; Natale, Bob; [email-masked]; Jun Bi
Subject: Re: [Supa] draft-bi-supa-gap-analysis

Regards,

Dan

Thanks and Regards,

Dan

Hi all,

BR,

Ying

2015-02-28 

  _____  

Ying CHENG  程莹

  _____  

发件人： Dacheng Zhang 

抄送： Ying Cheng(联通集团联通网络技术研究院); Jun Bi; Jean-François Tremblay; Marc Blanchet; Natale, Bob; [email-masked] 

SUPA Scope and Focus：

Relationship with I2RS:

Relationship with BESS:

Relationship with TEAS:

Relationship with I2nsf:

发件人: Tina TSOU <[email-masked]>
日期: 2015年2月26日 星期四 下午11:18
至: "Romascanu, Dan (Dan)" <[email-masked]>
抄送: Ying Cheng <[email-masked]>, Jun Bi <[email-masked]>, Jean-François Tremblay <[email-masked]>, Marc Blanchet <[email-masked]>, "Natale, Bob" <[email-masked]>, "[email-masked]" <[email-masked]>
主题: Re: [Supa] draft-bi-supa-gap-analysis

Dear Dan et al,

Good point.

 

Thank you,

Tina

On Feb 25, 2015, at 6:08 PM, Romascanu, Dan (Dan) <[email-masked]> wrote:

Regards,

Dan

Cc: Jun Bi; Jean-François Tremblay; [email-masked]

Avanti,

BobN

Cc: Jun Bi; Jean-François Tremblay; [email-masked]

Hi all,

BR,

Ying

2015-02-25 

  _____  

Ying CHENG  程莹

  _____  

发件人： Marc Blanchet 

收件人： Tina Tsou 

抄送： Jun Bi; Jean-François Tremblay; [email-masked] 

Dear Jun and JF, 

http://datatracker.ietf.org/doc/draft-bi-supa-gap-analysis/ <https://urldefense.proofpoint.com/v2/url?u=http-3A__datatracker.ietf.org_doc_draft-2Dbi-2Dsupa-2Dgap-2Danalysis_&d=AwMGaQ&c=BFpWQw8bsuKpl1SgiZH64Q&r=I4dzGxR31OcNXCJfQzvlsiLQfucBXRucPvdrphpBsFA&m=75NnaKfHSnJEyTvLp9a5KStGqK_KqY0aUr8JpCuvi2A&s=d_YdL_lV5dqUgzvEw-Y8PvZYpUd4Q0aB-mAZj_0niGc&e=> 

Would you work on it?

Dear Tina,

my 2 cents.

Marc.

Thank you,

Tina

_______________________________________________
Supa mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/supa <https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_supa&d=AwMGaQ&c=BFpWQw8bsuKpl1SgiZH64Q&r=I4dzGxR31OcNXCJfQzvlsiLQfucBXRucPvdrphpBsFA&m=75NnaKfHSnJEyTvLp9a5KStGqK_KqY0aUr8JpCuvi2A&s=xtw8PCJw-uH3Na6nOv2ntoPkGf7N9UkqKDggiMM681s&e=> 

如果您错误接收了该邮件，请通过电子邮件立即通知我们。请回复邮件到 <mailto:[email-masked]，即可以退订此邮件。我们将立即将您的信息从我们的发送目录中删除> [email-masked]，即可以退订此邮件。我们将立即将您的信息从我们的发送目录中删除。 If you have received this email in error please notify us immediately by e-mail. Please reply to [email-masked] if you want to unsubscribe from this mail. We will immediately remove your information from our sending catalogue.

_______________________________________________ Supa mailing list [email-masked] https://www.ietf.org/mailman/listinfo/supa <https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_supa&d=AwMGaQ&c=BFpWQw8bsuKpl1SgiZH64Q&r=I4dzGxR31OcNXCJfQzvlsiLQfucBXRucPvdrphpBsFA&m=8tlXfMBYiyXdl3QX_uaZEwaErzoCYOw1TwelXmRq-5M&s=hklOUyvfQM5mQ7KybkMJTKMVTlnu7lUcIuXQYHWTCgE&e=>  

如果您错误接收了该邮件，请通过电子邮件立即通知我们。[email-masked]，即可以退订此邮件。我们将立即将您的信息从我们的发送目录中删除。 If you have received this email in error please notify us immediately by e-mail. Please reply to [email-masked] if you want to unsubscribe from this mail. We will immediately remove your information from our sending catalogue.

---

From: JF Tremblay <[email-masked]>
Date: Mon, 2 Mar 2015 10:02:12 -0500

Sorry for sending an embedded image (below). Hope this can be seen by everyone. I had no time to put this in ascii… ;)

In my opinion, the IETF view of things has always be a protocol-centric “bottom-up” view (as John pointed out). 

If we lay the protocol view as seen in an IETF context on top of the diagram that has been sent recently, we see that each protocol wg also covers the model or API relating to each specific protocol. It’s in line with the IETF mindset that the best people to put together an API or model for a protocol are the protocol experts in the dedicated workgroup. 

In this context, I have trouble seeing where supa fits. The policy example we saw in the “mapping” draft are somewhat similar to intents, except that topology information is being explicitly manipulated. This could be handled  in intents though an explicit topology contraint. 

In a nutshell, if we are to figure out what supa is or isn’t, there’s a need to find out what policy work isn’t within the scope of intent and also isn’t in the scope of specific protocols. 

> On Mar 2, 2015, at 7:43 AM, Romascanu, Dan (Dan) <[email-masked]> wrote:
>

---

From: Tina TSOU <[email-masked]>
Date: Mon, 2 Mar 2015 15:07:55 +0000

Dear all,

Great discussion.

I edited a little bit on Ying’s figure as attached, for discussion purpose.

As discussed in this thread, at this point in time, the existing WG charters do not specify which WG is in charge to provide a generic toplogy model and that we are happy to work with any WG that might get chartered to provide the generic topology model.

Thank you,
Tina

From: Susan Hares [mailto:[email-masked]]
Sent: Monday, March 02, 2015 10:51 PM
To: 'Romascanu, Dan (Dan)'; 'Ying Cheng'; 'Dacheng Zhang'; Tina TSOU
Cc: 'Marc Blanchet'; 'Jean-Fran?ois Tremblay'; 'Natale, Bob'; [email-masked]; 'Jun Bi'
Subject: RE: [Supa] draft-bi-supa-gap-analysis

Dan, Ying, and Dacheng:

•   draft-chen-i2rs-topology-im-00.txt  (summary of PIT topologies including service topologies, pending)   <http://datatracker.ietf.org/doc/draft-clemm-i2rs-yang-network-topo/>
•   draft-clemm-i2rs-yang-network-topo-02<http://datatracker.ietf.org/doc/draft-clemm-i2rs-yang-network-topo/> (generic model)
•   Draft-dong-i2rs-inventory-00.txt    (generic model addition for resources, pending)
•    draft-zhang-i2rs-l1-topo-yang-model-00<http://datatracker.ietf.org/doc/draft-zhang-i2rs-l1-topo-yang-model/>
•   draft-dong-i2rs-l2-network-topology-00<http://datatracker.ietf.org/doc/draft-dong-i2rs-l2-network-topology/>
•   draft-clemm-i2rs-yang-l3-topo-00<http://datatracker.ietf.org/doc/draft-clemm-i2rs-yang-l3-topo/>
•   draft-dong-i2rs-l2-network-topology-00<http://datatracker.ietf.org/doc/draft-dong-i2rs-l2-network-topology/>
•   Draft-wang-i2rs-service-topo-dm-00  <http://tools.ietf.org/html/draft-wang-i2rs-yang-service-topo-dm-00>  - exist, revision pending
•   Draft-wang-i2rs-service-topo-sfc-dm-00 (service model) – exists , revision pending

If SUPA is dealing with intent, it is not covered in the problem statement or the use cases.  If you are adding intent at this late date, you should consider the intent-specific work in Nemo ([email-masked]<mailto:[email-masked]> work (www.nemo-project.org<http://www.nemo-project.org>) and the service topology).

Sue

Cc: Marc Blanchet; Jean-Fran?ois Tremblay; Natale, Bob; [email-masked]<mailto:[email-masked]>; Jun Bi

Regards,

Dan

Cc: Marc Blanchet; Jun Bi; Jean-Fran?ois Tremblay; [email-masked]<mailto:[email-masked]>; Natale, Bob

Hi all,

BR,
Ying

2015-02-28

Relationship with I2RS:

Relationship with BESS:

Relationship with TEAS:

Relationship with I2nsf:

Dear Dan et al,

Good point.

Thank you,
Tina

Regards,

Dan

Avanti,
BobN

Hi all,

BR,
Ying

2015-02-25

Dear Jun and JF,

Would you work on it?

Dear Tina,

my 2 cents.

Marc.

Thank you,
Tina

---

From: "Susan Hares" <[email-masked]>
Date: Mon, 2 Mar 2015 10:13:48 -0500

Tina:

Just to make sure I am clear.  The I2RS is chartered to provide dynamic (I2rs)  protocol independent models (E.g. RIB, topology, and PBR).  This includes a generic topology model for protocol independent models.

Sue 

From: Tina TSOU [mailto:[email-masked]] 
Sent: Monday, March 02, 2015 10:08 AM
To: Susan Hares; 'Romascanu, Dan (Dan)'; 'Ying Cheng'; 'Dacheng Zhang'
Cc: 'Marc Blanchet'; 'Jean-Fran?ois Tremblay'; 'Natale, Bob'; [email-masked]; 'Jun Bi'
Subject: RE: [Supa] draft-bi-supa-gap-analysis

Dear all,

Great discussion.

 

Thank you,

Tina

Dan, Ying, and Dacheng: 

•   draft-chen-i2rs-topology-im-00.txt <http://datatracker.ietf.org/doc/draft-clemm-i2rs-yang-network-topo/>   (summary of PIT topologies including service topologies, pending)   

Sue 

Regards,

Dan

Thanks and Regards,

Dan

Hi all,

BR,

Ying

2015-02-28 

  _____  

Ying CHENG  程莹

  _____  

发件人： Dacheng Zhang 

SUPA Scope and Focus：

Relationship with I2RS:

Relationship with BESS:

Relationship with TEAS:

Relationship with I2nsf:

Dear Dan et al,

Good point.

 

Thank you,

Tina

Regards,

Dan

Avanti,

BobN

Hi all,

BR,

Ying

2015-02-25 

  _____  

Ying CHENG  程莹

  _____  

发件人： Marc Blanchet 

收件人： Tina Tsou 

Dear Jun and JF, 

Would you work on it?

Dear Tina,

my 2 cents.

Marc.

Thank you,

Tina

如果您错误接收了该邮件，请通过电子邮件立即通知我们。 <mailto:[email-masked]，即可以退订此邮件。我们将立即将您的信息从我们的发送目录中删除> [email-masked]，即可以退订此邮件。我们将立即将您的信息从我们的发送目录中删除。 If you have received this email in error please notify us immediately by e-mail. Please reply to [email-masked] if you want to unsubscribe from this mail. We will immediately remove your information from our sending catalogue.

---

From: Ying Cheng <[email-masked]>
Date: Tue, 3 Mar 2015 14:17:16 +0800

Hi all,

Many thanks for your insightful comments and suggestions. Based on Tina's modification, the location of OpenStack Congress is noted in the updated figure as attached. In addition, the editable file is also provided for our further discussion. 

BR,
Ying

2015-03-03 

Ying CHENG  程莹

发件人： Tina TSOU 
发送时间： 2015-03-02  23:08:36 
收件人： Susan Hares; 'Romascanu, Dan (Dan)'; Ying Cheng(联通集团联通网络技术研究院); 'Dacheng Zhang' 
抄送： 'Marc Blanchet'; 'Jean-Fran?ois Tremblay'; 'Natale, Bob'; [email-masked]; 'Jun Bi' 
主题： RE: [Supa] draft-bi-supa-gap-analysis 
 
Dear all,
 
Great discussion.

Thank you,
Tina

Dan, Ying, and Dacheng: 

•   draft-chen-i2rs-topology-im-00.txt  (summary of PIT topologies including service topologies, pending)   
•   draft-clemm-i2rs-yang-network-topo-02 (generic model) 
•   Draft-dong-i2rs-inventory-00.txt    (generic model addition for resources, pending) 
•    draft-zhang-i2rs-l1-topo-yang-model-00
•   draft-dong-i2rs-l2-network-topology-00
•   draft-clemm-i2rs-yang-l3-topo-00  
•   draft-dong-i2rs-l2-network-topology-00
•   Draft-wang-i2rs-service-topo-dm-00   - exist, revision pending 
•   Draft-wang-i2rs-service-topo-sfc-dm-00 (service model) – exists , revision pending 
•   Draft-dunbar-i2rs-discover-traffic-rules-00 (policy models) - pending

 
Sue 

 
Regards,
 
Dan

 
Hi all,

 
BR,
Ying

 
2015-02-28 

Ying CHENG  程莹

发件人： Dacheng Zhang 
 
Relationship with I2RS:
 
Relationship with BESS:

Relationship with TEAS:
 
Relationship with I2nsf:

Dear Dan et al,
 
Good point.

Thank you,
Tina

Regards,
 
Dan

 
Avanti,
BobN

Hi all,

BR,
Ying

2015-02-25 

Ying CHENG  程莹

发件人： Marc Blanchet 

Dear Jun and JF, 

 
Would you work on it?

Dear Tina,

 
my 2 cents.
 
Marc.

Thank you,
Tina
 
如果您错误接收了该邮件，请通过电子邮件立即通知我们。[email-masked]，即可以退订此邮件。我们将立即将您的信息从我们的发送目录中删除。 If you have received this email in error please notify us immediately by e-mail. Please reply to [email-masked] if you want to unsubscribe from this mail. We will immediately remove your information from our sending catalogue.
_______________________________________________ Supa mailing list [email-masked] https://www.ietf.org/mailman/listinfo/supa 
如果您错误接收了该邮件，请通过电子邮件立即通知我们。[email-masked]，即可以退订此邮件。我们将立即将您的信息从我们的发送目录中删除。 If you have received this email in error please notify us immediately by e-mail. Please reply to [email-masked] if you want to unsubscribe from this mail. We will immediately remove your information from our sending catalogue.

如果您错误接收了该邮件，请通过电子邮件立即通知我们。[email-masked]，即可以退订此邮件。我们将立即将您的信息从我们的发送目录中删除。
If you have received this email in error please notify us immediately by e-mail. Please reply to [email-masked] if you want to unsubscribe from this mail. We will immediately remove your information from our sending catalogue.