Subject: [Supa] SUPA big picture RE: Update to Gap Analysis 5a version 6

From: "Jun Bi" <[email-masked]>
Date: Sun, 22 Mar 2015 20:31:03 -0500

Hi all,

Please find the version 6 of gap-analysis ppt.

It was updated after our BoF preparation meeting this evening.

Best Regards,

Jun Bi

From: [email-masked] [mailto:[email-masked]] On Behalf Of Jun Bi
Sent: Sunday, March 22, 2015 6:12 PM
To: 'Sue Hares'; 'John Strassner'; 'Tina TSOU'; [email-masked]
Subject: [Supa] SUPA big picture RE: Update to Gap Analysis 5a
Importance: High

Hi all,

Thanks to John and Sue.

I updated the big picture on page 2, in the attached version 5 of gap-analysis ppt.

Sounds good now ?

Best Regards,

Jun Bi

From: Sue Hares [mailto:[email-masked]] 
Sent: Sunday, March 22, 2015 2:21 PM
To: John Strassner
Cc: Jun Bi; [email-masked] <mailto:[email-masked]> 
Subject: Re: [Supa] Update to Gap Analysis 5a

Let us try this at  6pm.  I am still in transit from dfw airport.  I will arrive by 5pm cdt.

Sye

Sent via the Samsung GALAXY S®4, an AT&T 4G LTE smartphone

-------- Original message --------

From: John Strassner <[email-masked] <mailto:[email-masked]> > 

Date:03/22/2015 12:39 PM (GMT-05:00) 

To: Susan Hares <[email-masked] <mailto:[email-masked]> >, John Strassner <[email-masked] <mailto:[email-masked]> > 

Cc: Jun Bi <[email-masked] <mailto:[email-masked]> >, [email-masked] <mailto:[email-masked]>  

Subject: Re: [Supa] Update to Gap Analysis 5a 

Hi Sue,

Jun did the I2RS gap analysis.

However, I don't understand the diagram you included. I don't see anywhere in the I2RS charter where you are working on intent-based languages, and furthermore, this seems a bit out of place with low-level RIB work. Please explain.

regards,

John

On Sun, Mar 22, 2015 at 7:43 AM, Susan Hares <[email-masked] <mailto:[email-masked]> > wrote:

John:

You might want to read the current I2RS charter and adjust your Gap Analysis.  After my chat with Tina on Friday, I think we have a good idea of where SUPA, I2RS, and intent based networking works.  

I2RS charter covers: 

1)      Protocol independent RIB  (1 Info model approved, 1 Data Model pending)

2)      Protocol independent topology (generic, L1, L2, L3, Service topology) pending

3)      Filter-Based RIBs.  (drafts pending) 

4)      Specific protocol to do I2RS Work (presentation in Netconf) 

I’m working on slide for SUPA for I2RS, and I will send them before 6pm.  Here’s a diagram: 

Applications 

     |

     |Intent-based languages (E.g. Nemo, ODL NIC project) 

Services 

    |   

I2RS (RIB, FB-RIB, Protocol independent topologies – L1, L2, L3, Service Topologies)  

   | I2rs interface (restconf/netconf+) 

   | 

Devices 

Sue 

From: Supa [mailto:[email-masked] <mailto:[email-masked]> ] On Behalf Of John Strassner
Sent: Saturday, March 21, 2015 5:18 PM
To: Jun Bi; John Strassner; [email-masked] <mailto:[email-masked]> 
Subject: [Supa] Update to Gap Analysis 5a

I was asked to update slides 6 and 7 according to my comments. They are attached. Change log:

Slide 6

1.  ODL GBP pre-dates GBP in OpenStack, so I moved it forward one slide to slide 6 and deleted it from OpenStack

2. Updated GBP description to be more accurate

3. Updated NIC description to be more accurate (e.g., first bullet, which set that the models were "often closely relating to the actual configuration of devices") is incorrect. Intent should NEVER use the actual configuration of a device.

Slide 7

Rewrote all 3 bullets under the Congress section to correct them as described in my original email.

Inserted New Slide 8 on TM Forum Gaps

If desired, I can also update the draft later.

-- 

regards,

John

-- 

regards,

John

---

From: John Strassner <[email-masked]>
Date: Sun, 22 Mar 2015 20:30:06 -0700

I am getting more and more confused.

I thought that SUPA wanted to pursue intent-based policy rules. That's why
they are described in the PBSM draft. Now I look at slide 2, and to my
surprise, I see the bullet "Other organizations: Intent-based languages
(ODL, ONOS)." If we don't want to pursue this, I should edit the PBSM deck,
but I have no idea why we wouldn't pursue it.

Second, ODL is not good enough. That's like saying OpenStack. You really
mean ODL NIC (since ODL GBP is relational), and ODL NIC has not yet defined
a **language**.

Third, ONOS does not have a **language** either - just a set of
(incomplete) APIs.

On slide 4, what does "does not offer policing" mean? Do you mean policing
a flow, or policy based operations? I'm assuming the latter, but it doesn't
read correctly.

On slide 6, I do not think that we should add NEMO yet. It is an incomplete
model, not a language. We aren't adding the other proposals in ODL NIC, so
to be fair, I don't think that we should add NEMO either. See discussions
on nic-dev.

regards,
John

On Sun, Mar 22, 2015 at 6:31 PM, Jun Bi <[email-masked]> wrote:

> *From:* [email-masked] [mailto:[email-masked]] *On Behalf
> Of *Jun Bi
> *Sent:* Sunday, March 22, 2015 6:12 PM
> *To:* 'Sue Hares'; 'John Strassner'; 'Tina TSOU'; [email-masked]
> *Subject:* [Supa] SUPA big picture RE: Update to Gap Analysis 5a
> *Importance:* High
>
>
>
> Hi all,
>
>
>
> Thanks to John and Sue.
>
>
>
> *From:* Sue Hares [mailto:[email-masked] <[email-masked]>]
> *Sent:* Sunday, March 22, 2015 2:21 PM
> *To:* John Strassner
> *Cc:* Jun Bi; [email-masked]
> *Subject:* Re: [Supa] Update to Gap Analysis 5a
>
>
>
> From: John Strassner <[email-masked]>
>
> To: Susan Hares <[email-masked]>, John Strassner <[email-masked]>
>
> Cc: Jun Bi <[email-masked]>, [email-masked]
>
> However, I don't understand the diagram you included. I don't see anywhere
> in the I2RS charter where you are working on intent-based languages, and
> furthermore, this seems a bit out of place with low-level RIB work. Please
> explain.
>
>
>
> regards,
>
> John
>
>
>
> On Sun, Mar 22, 2015 at 7:43 AM, Susan Hares <[email-masked]> wrote:
>
> John:
>
>
>
> You might want to read the current I2RS charter and adjust your Gap
> Analysis.  After my chat with Tina on Friday, I think we have a good idea
> of where SUPA, I2RS, and intent based networking works.
>
>
>
> I2RS charter covers:
>
>
>
> *From:* Supa [mailto:[email-masked]] *On Behalf Of *John Strassner
> *Sent:* Saturday, March 21, 2015 5:18 PM
> *To:* Jun Bi; John Strassner; [email-masked]
> *Subject:* [Supa] Update to Gap Analysis 5a
>
>
>
> 3. Updated NIC description to be more accurate (e.g., first bullet, which
> set that the models were "often closely relating to the actual
> configuration of devices") is incorrect. Intent should NEVER use the actual
> configuration of a device.
>
>
>
> Slide 7
>
> _______________________________________________
> Supa mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/supa
>
>

-- 
regards,
John

---

From: Dan Martin <[email-masked]>
Date: Mon, 23 Mar 2015 03:47:00 +0000

I don’t think we can avoid doing the intent stuff.   I don’t know enough about the agenda / work plan to be able to say when we should start it.

A big part of what makes this stuff scalable is the topology abstraction and the ability to NOT send state about everything north.  In order to make that possible I have to deliver configuration to the things that know a lot about the topology under their control not as commands but as constraints.

It all comes back to configuring things, I need to have a work order telling me what to do, a network diagram with the topology on it, then I have to connect to the devices I’m going to do the work on to make sure they’re still there and not having problems, then I run some scripts, then I make sure the configuration changes worked by connecting to the devices again.

Is this intent stuff an absolutely critical part of this?  Almost all the things I own work just fine almost all the time.  At any point in time, 1% of all the connections I depend on are down.  I think an even greater number of things I own are having performance problems that would make it a bad idea to do something to them until whatever was wrong with them got fixed.

If I ignore intent I risk delivering a solution that works almost all the time, is that ok?

From: Supa [mailto:[email-masked]] On Behalf Of John Strassner
Sent: Monday, March 23, 2015 10:30 AM
To: Jun Bi; John Strassner
Cc: Romascanu, Dan (Dan); [email-masked]; Sue Hares; Tina TSOU
Subject: Re: [Supa] SUPA big picture RE: Update to Gap Analysis 5a version 6

I thought that SUPA wanted to pursue intent-based policy rules. That's why they are described in the PBSM draft. Now I look at slide 2, and to my surprise, I see the bullet "Other organizations: Intent-based languages (ODL, ONOS)." If we don't want to pursue this, I should edit the PBSM deck, but I have no idea why we wouldn't pursue it.

Second, ODL is not good enough. That's like saying OpenStack. You really mean ODL NIC (since ODL GBP is relational), and ODL NIC has not yet defined a **language**.

Third, ONOS does not have a **language** either - just a set of (incomplete) APIs.

On slide 4, what does "does not offer policing" mean? Do you mean policing a flow, or policy based operations? I'm assuming the latter, but it doesn't read correctly.

On slide 6, I do not think that we should add NEMO yet. It is an incomplete model, not a language. We aren't adding the other proposals in ODL NIC, so to be fair, I don't think that we should add NEMO either. See discussions on nic-dev.

regards,
John

On Sun, Mar 22, 2015 at 6:31 PM, Jun Bi <[email-masked]<mailto:[email-masked]>> wrote:
Hi all,

Best Regards,
Jun Bi

From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of Jun Bi
Sent: Sunday, March 22, 2015 6:12 PM
To: 'Sue Hares'; 'John Strassner'; 'Tina TSOU'; [email-masked]<mailto:[email-masked]>
Subject: [Supa] SUPA big picture RE: Update to Gap Analysis 5a
Importance: High

Hi all,

Thanks to John and Sue.

Best Regards,
Jun Bi

From: Sue Hares [mailto:[email-masked]]
Sent: Sunday, March 22, 2015 2:21 PM
To: John Strassner
Cc: Jun Bi; [email-masked]<mailto:[email-masked]>
Subject: Re: [Supa] Update to Gap Analysis 5a

Sye

-------- Original message --------
From: John Strassner <[email-masked]<mailto:[email-masked]>>
Date:03/22/2015 12:39 PM (GMT-05:00)
To: Susan Hares <[email-masked]<mailto:[email-masked]>>, John Strassner <[email-masked]<mailto:[email-masked]>>
Cc: Jun Bi <[email-masked]<mailto:[email-masked]>>, [email-masked]<mailto:[email-masked]>
Subject: Re: [Supa] Update to Gap Analysis 5a

Hi Sue,

regards,
John

On Sun, Mar 22, 2015 at 7:43 AM, Susan Hares <[email-masked]<mailto:[email-masked]>> wrote:
John:

I2RS charter covers:

Applications
     |

Sue

From: Supa [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of John Strassner
Sent: Saturday, March 21, 2015 5:18 PM
To: Jun Bi; John Strassner; [email-masked]<mailto:[email-masked]>
Subject: [Supa] Update to Gap Analysis 5a

Slide 6

Slide 7

--
regards,
John

--
regards,
John

_______________________________________________
Supa mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/supa

--
regards,
John

---

From: "Susan Hares" <[email-masked]>
Date: Mon, 23 Mar 2015 07:24:10 -0400

Dan and John and Jun:

Leaving the intent information out would be fine with me.  On the topology, please be careful to differentiate where you get the topology information (E.g I2RS or OSPF), and if you are going to create topology based on it.  I’ve attached I2RS slides.  

Sue 

From: Supa [mailto:[email-masked]] On Behalf Of Dan Martin
Sent: Sunday, March 22, 2015 11:47 PM
To: John Strassner; Jun Bi
Cc: Romascanu, Dan (Dan); Sue Hares; [email-masked]; Tina TSOU
Subject: Re: [Supa] SUPA big picture RE: Update to Gap Analysis 5a version 6

regards,

John

Hi all,

Best Regards,

Jun Bi

Hi all,

Thanks to John and Sue.

Sounds good now ?

Best Regards,

Jun Bi

From: Sue Hares [mailto:[email-masked]] 
Sent: Sunday, March 22, 2015 2:21 PM
To: John Strassner
Cc: Jun Bi; [email-masked]
Subject: Re: [Supa] Update to Gap Analysis 5a

Sye

-------- Original message --------

Hi Sue,

regards,

John

John:

I2RS charter covers: 

Applications 

     |

Services 

    |   

   | 

Devices 

Sue 

From: Supa [mailto:[email-masked]] On Behalf Of John Strassner
Sent: Saturday, March 21, 2015 5:18 PM
To: Jun Bi; John Strassner; [email-masked]
Subject: [Supa] Update to Gap Analysis 5a

Slide 6

Slide 7

-- 

regards,

John

-- 

regards,

John

-- 

regards,

John