Subject: [Supa] PBSM slides

From: John Strassner <[email-masked]>
Date: Mon, 16 Mar 2015 01:23:04 -0700

Hi all,

I can't call in at 2am tomorrow from Melbourne, but here is v1 (i.e.,
D-R-A-F-T) of some PBSM slides. Comments are very much appreciated!

I have added a few notes to speak on my behalf. Hopefully, the content is
obvious; if it isn't, I'll fix it...

Yes, there are a lot of slides (17 content slides). However, I can do this
under 15 minutes (assuming no questions). That being said, I would propose
skipping some slides. I'll leave it for your collective wisdom to figure
out which ones, but here's my recommendation:

  - Slides 3 and 4 should take 1 minute combined; leave.
  - Thinking back to Juergen's comment, I'm tempted to remove slide 6 (and
of course, update
     the agenda slides accordingly); it is there because sometimes I get
the feeling that people
     think that defining a policy rule is all that is needed. That is
**not** the case.
  - Happy to kill slide 7, I just like the picture ;-) More importantly, it
does talk about context-
    aware policy rules, which I've been discussing in ODL NIC.
  - Originally, I just had slides 12-15 for defining the different types of
policy rules. However, I
     think that slides 9-11 provide a nice visual of why more than one type
of rule is needed, and
     I note that we did spend several emails on this subject.
  - I like slide 17. Slide 18 is the Policy Continuum (I've written about
this in journal and
    conference papers).
  - Slide 19 gives a hint as to how a northbound DSL would look like vs. a
southbound protocol.
  - Slide 21 shows the current TMF ZOOM policy-based management
architecture. I think that
    we need these elements, and that other WGs do not have them all.

Happy to adjust the content according to your feedback.

best regards,
John

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Mon, 16 Mar 2015 10:09:24 +0000

Hi,

I miss the argumentation about ‘How SUPA Policy Management is Different’. Slide 21 is not self-explicit for me, and if TMF have already defined such a policy-based management architecture – why don’t they do it, or what is the specific value that the IETF can bring?

Thanks and Regards,

Dan

From: Supa [mailto:[email-masked]] On Behalf Of John Strassner
Sent: Monday, March 16, 2015 10:23 AM
To: [email-masked]
Subject: [Supa] PBSM slides

Hi all,

I can't call in at 2am tomorrow from Melbourne, but here is v1 (i.e., D-R-A-F-T) of some PBSM slides. Comments are very much appreciated!

I have added a few notes to speak on my behalf. Hopefully, the content is obvious; if it isn't, I'll fix it...

Yes, there are a lot of slides (17 content slides). However, I can do this under 15 minutes (assuming no questions). That being said, I would propose skipping some slides. I'll leave it for your collective wisdom to figure out which ones, but here's my recommendation:

  - Slides 3 and 4 should take 1 minute combined; leave.
  - Thinking back to Juergen's comment, I'm tempted to remove slide 6 (and of course, update
     the agenda slides accordingly); it is there because sometimes I get the feeling that people
     think that defining a policy rule is all that is needed. That is **not** the case.
  - Happy to kill slide 7, I just like the picture ;-) More importantly, it does talk about context-
    aware policy rules, which I've been discussing in ODL NIC.
  - Originally, I just had slides 12-15 for defining the different types of policy rules. However, I
     think that slides 9-11 provide a nice visual of why more than one type of rule is needed, and
     I note that we did spend several emails on this subject.
  - I like slide 17. Slide 18 is the Policy Continuum (I've written about this in journal and
    conference papers).
  - Slide 19 gives a hint as to how a northbound DSL would look like vs. a southbound protocol.
  - Slide 21 shows the current TMF ZOOM policy-based management architecture. I think that
    we need these elements, and that other WGs do not have them all.

best regards,
John

---

From: John Strassner <[email-masked]>
Date: Mon, 16 Mar 2015 05:00:09 -0700

Hi Dan,

fair enough, I'll script this slide tomorrow.

It's late here in Melbourne, but very simply, there are a number of
architectural entities shown in this slide that do not exist in any other
IETF WG. They also do not exist in any of the previous IETF work.

While the TMF is doing the architecture, the architecture requires a
protocol, or set of protocols, to exchange different types of information,
and as the co-chair of the TMF ZOOM group, I have recommended that the TMF
do **not** embark on any protocol work.

HTH,
John

On Mon, Mar 16, 2015 at 3:09 AM, Romascanu, Dan (Dan) <[email-masked]>
wrote:

>  Hi,
>
>
>
> I miss the argumentation about ‘How SUPA Policy Management is Different’.
> Slide 21 is not self-explicit for me, and if TMF have already defined such
> a policy-based management architecture – why don’t they do it, or what is
> the specific value that the IETF can bring?
>
>
>
> Thanks and Regards,
>
>
>
> Dan
>
>
>
>
>
> *From:* Supa [mailto:[email-masked]] *On Behalf Of *John Strassner
> *Sent:* Monday, March 16, 2015 10:23 AM
> *To:* [email-masked]
> *Subject:* [Supa] PBSM slides
>
>
>
> Hi all,
>
>
>

-- 
regards,
John

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Mon, 16 Mar 2015 12:03:33 +0000

Good, please detail. I like the division TMF (architecture) – IETF (protocol, DM). This is the most important slide IMO, all the rest is introduction to it ☺

Thanks and Regards,

Dan

From: John Strassner [mailto:[email-masked]]
Sent: Monday, March 16, 2015 2:00 PM
To: Romascanu, Dan (Dan)
Cc: [email-masked]
Subject: Re: [Supa] PBSM slides

Hi Dan,

It's late here in Melbourne, but very simply, there are a number of architectural entities shown in this slide that do not exist in any other IETF WG. They also do not exist in any of the previous IETF work.

While the TMF is doing the architecture, the architecture requires a protocol, or set of protocols, to exchange different types of information, and as the co-chair of the TMF ZOOM group, I have recommended that the TMF do **not** embark on any protocol work.

HTH,
John

On Mon, Mar 16, 2015 at 3:09 AM, Romascanu, Dan (Dan) <[email-masked]<mailto:[email-masked]>> wrote:
Hi,

Thanks and Regards,

Dan

From: Supa [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of John Strassner
Sent: Monday, March 16, 2015 10:23 AM
To: [email-masked]<mailto:[email-masked]>
Subject: [Supa] PBSM slides

Hi all,

best regards,
John

--
regards,
John

---

From: John Strassner <[email-masked]>
Date: Mon, 16 Mar 2015 05:06:24 -0700

Thanks Dan, that's great feedback. If you have suggestions on what to cut
and what to add, please don't be bashful. :-)

regards,
John

On Mon, Mar 16, 2015 at 5:03 AM, Romascanu, Dan (Dan) <[email-masked]>
wrote:

>  Good, please detail. I like the division TMF (architecture) – IETF
> (protocol, DM). This is the most important slide IMO, all the rest is
> introduction to it J
>
>
>
> Thanks and Regards,
>
>
>
> Dan
>
>
>
>
>
> *From:* John Strassner [mailto:[email-masked]]
> *Sent:* Monday, March 16, 2015 2:00 PM
> *To:* Romascanu, Dan (Dan)
> *Cc:* [email-masked]
> *Subject:* Re: [Supa] PBSM slides
>
>
>
> Hi Dan,
>
>
>

-- 
regards,
John

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Mon, 16 Mar 2015 12:17:04 +0000

Sure. One more question though – to split the work on this lines we need access to the architecture documents of the TMForum. How will this be achieved? I also notice that TMF ZOOM is not included today in the gap analysis (not in the I-D in any case).

Regards,

Dan

From: John Strassner [mailto:[email-masked]]
Sent: Monday, March 16, 2015 2:06 PM
To: Romascanu, Dan (Dan)
Cc: [email-masked]
Subject: Re: [Supa] PBSM slides

Thanks Dan, that's great feedback. If you have suggestions on what to cut and what to add, please don't be bashful. :-)

regards,
John

On Mon, Mar 16, 2015 at 5:03 AM, Romascanu, Dan (Dan) <[email-masked]<mailto:[email-masked]>> wrote:
Good, please detail. I like the division TMF (architecture) – IETF (protocol, DM). This is the most important slide IMO, all the rest is introduction to it ☺

Thanks and Regards,

Dan

From: John Strassner [mailto:[email-masked]<mailto:[email-masked]>]
Sent: Monday, March 16, 2015 2:00 PM
To: Romascanu, Dan (Dan)
Cc: [email-masked]<mailto:[email-masked]>
Subject: Re: [Supa] PBSM slides

Hi Dan,

HTH,
John

Thanks and Regards,

Dan

Hi all,

best regards,
John

--
regards,
John

--
regards,
John

---

From: Tina TSOU <[email-masked]>
Date: Mon, 16 Mar 2015 12:19:28 +0000

Dear Dan, John, Fukusima-san et al,

Attached are service management data model slides from the authors.

Hope it helps, as input to PBSM.

Thank you,
Tina

From: Supa [mailto:[email-masked]] On Behalf Of Romascanu, Dan (Dan)
Sent: Monday, March 16, 2015 1:17 PM
To: John Strassner
Cc: [email-masked]
Subject: Re: [Supa] PBSM slides

Regards,

Dan

regards,
John

Thanks and Regards,

Dan

Hi Dan,

HTH,
John

Thanks and Regards,

Dan

Hi all,

best regards,
John

--
regards,
John

--
regards,
John

---

From: "Natale, Bob" <[email-masked]>
Date: Mon, 16 Mar 2015 14:21:54 +0000

Hi John,

This (“Supa PBSM Strassner v1 20150315.pptx”) is a very informative and compelling set of slides, in my judgment.

- Concerning #6 (“Motivation for Policy Management”): I believe that you should reference the (essential) role of PBSM in “automation” (or, “governed autonomics”) … since it is clear that the operational environment envisioned for network service virtualization (NFV, SFC/SFP, SDN, NFVI-IaaS, etc.) cannot achieve the goals being set for it without a high level of coordinated/collaborative automation … and (IIUC) SUPA intends to play in that space…?

- The graphic on #7 is extremely helpful for people who might not have already thought through the relationship between “Context” (which, in real life, is critical for all three elements in E-C-A policy rule execution), “Knowledge Management”, “Policy”, and “Configuration”. Many readers on this list already have that understanding, but some might not and I’d vote for keeping this slide in on their behalf.

- The only two changes I’d recommend on that slide are:
   -- Make the “Business Goals” object more prominent visually … comes across as an afterthought visually at present, even though it is correctly placed as the raison d’etre.
   -- Change the left-side “Communications Networks” label at the bottom to “Information Networks” … loose analogy to Web over Internet kind of thing.

- Slide #18, “Policy Continuum” (and #19): Personally, I think this is critical. Whether or not the number and nomenclature of the perspectives in the continuum are correct or fixed is open to discussion (might need updating, or might not), my own experience is that many attempts at PBM have failed due to a mismatch between the specification of policy at one level and the expectation of interpretation/translation of that policy at another level … probably too convoluted to get into here, so I’ll table it.

Avanti,
BobN

From: Supa [mailto:[email-masked]] On Behalf Of John Strassner
Sent: Monday, March 16, 2015 4:23 AM
To: [email-masked]
Subject: [Supa] PBSM slides

Hi all,

best regards,
John

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Mon, 16 Mar 2015 17:19:49 +0100

> D-R-A-F-T) of some PBSM slides. Comments are very much appreciated!

- I am wondering what 'platform' means on slide #3.

- I am also not sure what an 'intelligent' container is - ideally a
  definition should not use other terms that do not have a clear
  meaning.

- Slide #7 is beyond anything I can understand in realtime. And these
  kind of slides are often not very welcome at IETF meetings.

- Slide #10: I guess you mean RT_G instead of RTG (left part)

- I am not sure about utility functions - they typically lead to
  optimization problems where you apply mathematical tools like linear
  programming to determine an optimal set of parameters.

- I am not sure about slide #15. I do understand Mark Burgess work on
  what he calls promise theory but I am not sure how this relates to
  the SUPA BOF - I would probably leave this out to stay focused.

- I may not understand slide 17. Is it trying to compare different
  policy approaches - is Action supposed to mean Rules? I think this
  picture is perhaps misleading. For example, I could envision that
  you use a first order logic approach to generate a (potentially
  large) set of correct solutions and then you apply utility functions
  and an optimization algorithm to find the (hopefully small) subset
  with the best gain. I guess I am simply not sure what this figure
  tries to tell me - what are these arrows, why is one dashed?

- Concerning slide 18, what would really help are examples that say
  follow slide 18 and show how say an SLA is broken down to a system
  view and then to a network view and finally to a device view.

/js  

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1 | 28759 Bremen | Germany
Fax:   +49 421 200 3103         <http://www.jacobs-university.de/>

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Mon, 16 Mar 2015 16:51:24 +0000

I have a few short comments about these slides.

·         Slide 2 – we should avoid talking about ‘charter’ as this is a non-chartering BOF

·         I believe that we should take out slides 3,4 as we already discuss the principal use case at a different point in the agenda

·         I like slides 5 and 6, but I suggest that we swap them. The reason is that the DDC is our principal (some say only) use case, while L3VPN is one instantiation of inter-DC network connections

As a matter of process, I encourage Fukusima-san and John to work together and consolidate their respective sets of slides into one presentation to be used to drive item #3 in the updated BOF agenda.

Thanks and Regards,

Dan

From: Supa [mailto:[email-masked]] On Behalf Of Tina TSOU
Sent: Monday, March 16, 2015 2:19 PM
To: Romascanu, Dan (Dan); John Strassner
Cc: [email-masked]; [email-masked]
Subject: Re: [Supa] PBSM slides

Thank you,
Tina

Regards,

Dan

regards,
John

Thanks and Regards,

Dan

Hi Dan,

HTH,
John

Thanks and Regards,

Dan

Hi all,

best regards,
John

--
regards,
John

--
regards,
John

---

From: "Natale, Bob" <[email-masked]>
Date: Mon, 16 Mar 2015 17:15:15 +0000

Hi John,

I’d like to add one more comment:
- #17 (“No Need to Choose Just One!”): I think the perspective is wrong on this diagram in that (given the content of the diagram) “Higher-level specs/Business Users/Utility Functions” should be driving “Lower-level specs/Network Admins/Actions” … in other words, given the rightward direction of the arrow, the order of the nodes should be reversed, from left to right. …?

Avanti,
BobN

From: Natale, Bob
Sent: Monday, March 16, 2015 10:22 AM
To: 'John Strassner'
Cc: [email-masked]
Subject: RE: [Supa] PBSM slides

Hi John,

Avanti,
BobN

Hi all,

best regards,
John

---

From: John Strassner <[email-masked]>
Date: Tue, 17 Mar 2015 07:12:48 +0000

Hi Tina and Dan,

Is the idea to combine these slides with the PBSM slides? I thought these were two different talks. Sorry, I’m confused…

regards,
John

Dr. John Strassner, Ph.D.
CTO, Software Laboratory, CRD

Futurewei Technologies
US R&D Center
2330 Central Expressway
Building A, office A2-2143
Santa Clara, California   95050

  Office:  +1.408.330.4923
  Email:   [email-masked]

Sent: Monday, March 16, 2015 5:19 AM

Thank you,
Tina

Regards,

Dan

regards,
John

Thanks and Regards,

Dan

Hi Dan,

HTH,
John

Thanks and Regards,

Dan

Hi all,

best regards,
John

--
regards,
John

--
regards,
John

---

From: John Strassner <[email-masked]>
Date: Tue, 17 Mar 2015 07:14:58 +0000

Hi Dan,

Yup, I’m working that. TR235 (which is the specific document that contains the policy architecture) was released last year, so there shouldn’t be a problem there. I’ve already asked the TMF powers-that-be about procedurally, how will this be done.

Good catch on the ID, it’s on my reading list but I haven’t gotten to it yet. Thanks for the heads up.

regards,
John

Futurewei Technologies
US R&D Center
2330 Central Expressway

  Office:  +1.408.330.4923

From: Supa [mailto:[email-masked]] On Behalf Of Romascanu, Dan (Dan)
Sent: Monday, March 16, 2015 5:17 AM
To: John Strassner
Cc: [email-masked]
Subject: Re: [Supa] PBSM slides

Regards,

Dan

regards,
John

Thanks and Regards,

Dan

Hi Dan,

HTH,
John

Thanks and Regards,

Dan

Hi all,

best regards,
John

--
regards,
John

--
regards,
John

---

From: Tina TSOU <[email-masked]>
Date: Tue, 17 Mar 2015 10:31:16 +0000

Dear John, Fukusima-San, et al,

Yes, if you read yesterday's meeting minutes, you will see the feedback that your slides are strong enough at policy aspects, but not strong enough at service management perspective. And this set of slides may of help as input.

We expect to see policy based service management as the title says.

Thank you,
Tina

On Mar 17, 2015, at 11:00 AM, Romascanu, Dan (Dan) <[email-masked]<mailto:[email-masked]>> wrote:

In my view it would be better for them to be combined, as both deal with the same topic. Eventually it’s up to the two of you, but the total time in the agenda needs to stay the same.

Regards,

Dan

From: John Strassner [mailto:[email-masked]]
Sent: Tuesday, March 17, 2015 9:13 AM
To: Tina TSOU; Romascanu, Dan (Dan); John Strassner
Cc: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: RE: [Supa] PBSM slides

Hi Tina and Dan,

regards,
John

Futurewei Technologies
US R&D Center
2330 Central Expressway

  Office:  +1.408.330.4923
  Email:   [email-masked]<mailto:[email-masked]>

Cc: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>

Thank you,
Tina

Regards,

Dan

regards,
John

On Mon, Mar 16, 2015 at 5:03 AM, Romascanu, Dan (Dan) <[email-masked]<mailto:[email-masked]>> wrote:
Good, please detail. I like the division TMF (architecture) – IETF (protocol, DM). This is the most important slide IMO, all the rest is introduction to it :)

Thanks and Regards,

Dan

Hi Dan,

HTH,
John

Thanks and Regards,

Dan

Hi all,

best regards,
John

--
regards,
John

--
regards,
John

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Tue, 17 Mar 2015 09:59:55 +0000

Regards,

Dan

Hi Tina and Dan,

regards,
John

Futurewei Technologies
US R&D Center
2330 Central Expressway

  Office:  +1.408.330.4923

Thank you,
Tina

Regards,

Dan

regards,
John

Thanks and Regards,

Dan

Hi Dan,

HTH,
John

Thanks and Regards,

Dan

Hi all,

best regards,
John

--
regards,
John

--
regards,
John