Subject: [Supa] SUPA Proposition slides

From: Maxim Klyus <[email-masked]>
Date: Fri, 10 Jul 2015 09:45:04 +0000

Hello SUPA,

The slides prepared by me and John.
Unfortunately John was not able to review the last version.
However I’m sending it to the public review.
Any comments appreciated.

Regards,
Max Klyus

From: Supa [mailto:[email-masked]] On Behalf Of Romascanu, Dan (Dan)
Sent: Friday, July 10, 2015 12:21 PM
To: Tina TSOU; [email-masked]
Subject: Re: [Supa] SUPA call: 7:30-8:30am, Monday, July 13, San Francisco time

Hi,

It would be very useful for the call on Monday that folks who own items on the agenda can prepare and submit for discussion a draft of their slide decks. It is understood that these would be only draft slides for discussion that will be updated after the call on Monday and before IETF 93.

Thanks and Regards,

Dan

From: Supa [mailto:[email-masked]] On Behalf Of Tina TSOU
Sent: Tuesday, July 07, 2015 2:05 AM
To: [email-masked]<mailto:[email-masked]>
Subject: [Supa] SUPA call: 7:30-8:30am, Monday, July 13, San Francisco time

Dear all,

Below is the draft agenda and logistics for next call during 7:30-8:30am, Monday, July 13, San Francisco time.

Look forward to talking to many of you at the meeting.

----------

1. Note Well, logistics, agenda bashing (chairs, 5 min)

2. Slides Preparation for the BoF (Times are the ones in the call next week – not the BOF)

2.1. Goals, Framework, Examples (Max, Oscar (Luis) et al, 10 minutes)

2.2. Relationship to other WGs (Scott/Sue et al, 5 minutes)

2.3. Information Model Overview (John et al, 5 minutes)

2.4. Data Model Overview (Andy et al, 5 minutes)

2.5. Charter presentation (Dan/Juergen et al, 10 minutes)

2.6. Discussion on whether the progress assessment implies going forward changes to the charter (all, 15 minutes)

2.7. Questions to the audience (chairs, 10 minutes)

-----------

Join WebEx meeting<https://ietf.webex.com/ietf/j.php?MTID=m23e113c8822a0970e0e779383ab09322<https://urldefense.proofpoint.com/v2/url?u=https-3A__ietf.webex.com_ietf_j.php-3FMTID-3Dm23e113c8822a0970e0e779383ab09322&d=AwMGaQ&c=BFpWQw8bsuKpl1SgiZH64Q&r=I4dzGxR31OcNXCJfQzvlsiLQfucBXRucPvdrphpBsFA&m=5o_Is2wUigC3ddd4rYeeX71W3SZ0iusenzX-7phZkJE&s=_zCzyFpRlFDUsruTlmLpVz6tH_QpuLrHuADg5H3rWV4&e=>>

Meeting number: 646 022 302

Meeting password:       2015

Join by phone

1-877-668-4493 Call-in toll free number (US/Canada)

1-650-479-3208 Call-in toll number (US/Canada)

Access code: 646 022 302

Toll-free calling restrictions<http://www.webex.com/pdf/tollfree_restrictions.pdf<https://urldefense.proofpoint.com/v2/url?u=http-3A__www.webex.com_pdf_tollfree-5Frestrictions.pdf&d=AwMGaQ&c=BFpWQw8bsuKpl1SgiZH64Q&r=I4dzGxR31OcNXCJfQzvlsiLQfucBXRucPvdrphpBsFA&m=5o_Is2wUigC3ddd4rYeeX71W3SZ0iusenzX-7phZkJE&s=nL8-teqG2Euv9I9n3SWRXhiYHxazMgQNp1fR2R72N2Q&e=>>

Can't join the meeting? Contact support.<https://ietf.webex.com/ietf/mc<https://urldefense.proofpoint.com/v2/url?u=https-3A__ietf.webex.com_ietf_mc&d=AwMGaQ&c=BFpWQw8bsuKpl1SgiZH64Q&r=I4dzGxR31OcNXCJfQzvlsiLQfucBXRucPvdrphpBsFA&m=5o_Is2wUigC3ddd4rYeeX71W3SZ0iusenzX-7phZkJE&s=pH8ALHAwVUPf8pRzxMQD30gn32p0oISnQSFwsf-9tOs&e=>>

IMPORTANT NOTICE: Please note that this WebEx service allows audio and other information sent during the session to be recorded, which may be discoverable in a legal matter. By joining this session, you automatically consent to such recordings. If you do not consent to being recorded, discuss your concerns with the host or do not join the session.

Thank you,

Dan & Tina

________________________________
The information transmitted herein is intended only for the person or entity to which it is addressed and may contain confidential, proprietary and/or privileged material. Any review, retransmission, dissemination or other use of, or taking of any action in reliance upon, this information by persons or entities other than the intended recipient is prohibited. If you received this in error, please contact the sender and delete the material from any computer.

---

From: "Natale, Bob" <[email-masked]>
Date: Fri, 10 Jul 2015 13:14:27 +0000

Very useful slide set … concise, clear, and well designed … some observations for your consideration:

#6/7:
- There is a logical mismatch between “Declarative” and “ECA” at the level shown on these slides … should be “Declarative” and “Imperative”.
- “Intention-based” is not the same as “Intent-based” (see http://www.learnersdictionary.com/qa/intent-and-intention) … should use the latter.
- Given those two points, your second level might pair “Intent-based” and “Rule-based” or “Procedure-based” … John will know better than me.

#8/9:
- I think I’d move these slides forward in the deck as a pair … maybe with what is now #9 coming before what is now #8 … the rest of the deck seems to explain in more detail the goals and benefits these two lay out … but I see the flow you are going for in the present order and it works too.

#3:
- I have a small concern about showing SUPA “Syntax” and “Data Models” at the same level as “SDN, NFV, Legacy” and “CLI, TL1, Scripts” … logically and in light of #4/5, which seem right to me … i.e., SUPA syntax and data models feed (so to speak) those implementation technologies in the SUPA framework, right…?
- Of course, I do understand that legacy management interfaces will still exist for some time (indefinitely) and even newer ones might appear, all of which will be deployed contemporaneously with SUPA implementations going forward, and maybe that’s what the voice track for this slide will convey…? (In which case #4/5 do a very good job of illustrating the SUPA approach.)

Avanti,
BobN

From: Supa [mailto:[email-masked]] On Behalf Of Maxim Klyus
Sent: Friday, July 10, 2015 5:45 AM
To: [email-masked]
Subject: [Supa] SUPA Proposition slides

Hello SUPA,

Regards,
Max Klyus

From: Supa [mailto:[email-masked]] On Behalf Of Romascanu, Dan (Dan)
Sent: Friday, July 10, 2015 12:21 PM
To: Tina TSOU; [email-masked]<mailto:[email-masked]>
Subject: Re: [Supa] SUPA call: 7:30-8:30am, Monday, July 13, San Francisco time

Hi,

Thanks and Regards,

Dan

Dear all,

----------

-----------

Meeting password:       2015

Join by phone

Access code: 646 022 302

Thank you,

Dan & Tina

---

From: Jon Saperia <[email-masked]>
Date: Fri, 10 Jul 2015 09:26:20 -0400

Hi,

The slides are very well done. Slide #2 is a good generic statement of the problem.  My concern after having read through SUPA materials over the past week is that I have a hard time reconciling the anticipated work with the statement of the problem.  

The disconnect is illustrated on slide #5.  What I do not see is how this would interact with large portions of environments that are not YANG based.  That is where the problem has existed for some time and remains.  Most of these environment are highly-unlikely to convert to YANG. 

If the WG is to be YANG centric, then it is a bit more difficult to understand the connection of slide 2 with the rest of the presentation.

Here are some options:
	1. Declare that the work is now and into the future YANG focused.
	2. Show how the work expands to solve the larger problem with even a rough plan for getting there.

/jon
> On Jul 10, 2015, at 5:45 AM, Maxim Klyus <[email-masked]> wrote:
> 
> Hello SUPA,
>  
> From: Supa [mailto:[email-masked] <mailto:[email-masked]>] On Behalf Of Romascanu, Dan (Dan)
> To: Tina TSOU; [email-masked] <mailto:[email-masked]>
> From: Supa [mailto:[email-masked] <mailto:[email-masked]>] On Behalf Of Tina TSOU
> To: [email-masked] <mailto:[email-masked]>
> Join WebEx meeting<https://ietf.webex.com/ietf/j.php?MTID=m23e113c8822a0970e0e779383ab09322 <https://urldefense.proofpoint.com/v2/url?u=https-3A__ietf.webex.com_ietf_j.php-3FMTID-3Dm23e113c8822a0970e0e779383ab09322&d=AwMGaQ&c=BFpWQw8bsuKpl1SgiZH64Q&r=I4dzGxR31OcNXCJfQzvlsiLQfucBXRucPvdrphpBsFA&m=5o_Is2wUigC3ddd4rYeeX71W3SZ0iusenzX-7phZkJE&s=_zCzyFpRlFDUsruTlmLpVz6tH_QpuLrHuADg5H3rWV4&e=>>
> Toll-free calling restrictions<http://www.webex.com/pdf/tollfree_restrictions.pdf <https://urldefense.proofpoint.com/v2/url?u=http-3A__www.webex.com_pdf_tollfree-5Frestrictions.pdf&d=AwMGaQ&c=BFpWQw8bsuKpl1SgiZH64Q&r=I4dzGxR31OcNXCJfQzvlsiLQfucBXRucPvdrphpBsFA&m=5o_Is2wUigC3ddd4rYeeX71W3SZ0iusenzX-7phZkJE&s=nL8-teqG2Euv9I9n3SWRXhiYHxazMgQNp1fR2R72N2Q&e=>>
>  
>  
>  
> Can't join the meeting? Contact support.<https://ietf.webex.com/ietf/mc <https://urldefense.proofpoint.com/v2/url?u=https-3A__ietf.webex.com_ietf_mc&d=AwMGaQ&c=BFpWQw8bsuKpl1SgiZH64Q&r=I4dzGxR31OcNXCJfQzvlsiLQfucBXRucPvdrphpBsFA&m=5o_Is2wUigC3ddd4rYeeX71W3SZ0iusenzX-7phZkJE&s=pH8ALHAwVUPf8pRzxMQD30gn32p0oISnQSFwsf-9tOs&e=>>
>  
> <SUPA Proposition Slides v6.pptx>_______________________________________________
> Supa mailing list
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/supa <https://www.ietf.org/mailman/listinfo/supa>

---

From: "Narasimha Rao Vadrevu" <[email-masked]>
Date: Fri, 10 Jul 2015 07:08:36 -0700

Deck is good. 

Slides #4 and 5: Technology Specific YANG Data Models,   IETF YANG Data Models (Technology or Vendor Specific)

When they relate to WI  # 3 of Charter proposal - A set of YANG data models that express the concepts defined in the   generic policy information model in concrete data models. These

   models will be designed to be generic and extensible.

This is not matching.  They match in terms of SUPA flow and capability wise, my question is with respect to ‘Charter Scope’

Thanks,

Narasimha

From: Supa [mailto:[email-masked]] On Behalf Of Maxim Klyus
Sent: Friday, July 10, 2015 2:45 AM
To: [email-masked]
Subject: [Supa] SUPA Proposition slides

Hello SUPA,

Regards,

Max Klyus

Hi,

Thanks and Regards,

Dan

Dear all,

 
----------

 
-----------

Join WebEx meeting< <https://urldefense.proofpoint.com/v2/url?u=https-3A__ietf.webex.com_ietf_j.php-3FMTID-3Dm23e113c8822a0970e0e779383ab09322&d=AwMGaQ&c=BFpWQw8bsuKpl1SgiZH64Q&r=I4dzGxR31OcNXCJfQzvlsiLQfucBXRucPvdrphpBsFA&m=5o_Is2wUigC3ddd4rYeeX71W3SZ0iusenzX-7phZkJE&s=_zCzyFpRlFDUsruTlmLpVz6tH_QpuLrHuADg5H3rWV4&e=> https://ietf.webex.com/ietf/j.php?MTID=m23e113c8822a0970e0e779383ab09322>
Meeting number: 646 022 302
Meeting password:       2015

Join by phone
1-877-668-4493 Call-in toll free number (US/Canada)
1-650-479-3208 Call-in toll number (US/Canada)
Access code: 646 022 302
Toll-free calling restrictions< <https://urldefense.proofpoint.com/v2/url?u=http-3A__www.webex.com_pdf_tollfree-5Frestrictions.pdf&d=AwMGaQ&c=BFpWQw8bsuKpl1SgiZH64Q&r=I4dzGxR31OcNXCJfQzvlsiLQfucBXRucPvdrphpBsFA&m=5o_Is2wUigC3ddd4rYeeX71W3SZ0iusenzX-7phZkJE&s=nL8-teqG2Euv9I9n3SWRXhiYHxazMgQNp1fR2R72N2Q&e=> http://www.webex.com/pdf/tollfree_restrictions.pdf>

Can't join the meeting? Contact support.< <https://urldefense.proofpoint.com/v2/url?u=https-3A__ietf.webex.com_ietf_mc&d=AwMGaQ&c=BFpWQw8bsuKpl1SgiZH64Q&r=I4dzGxR31OcNXCJfQzvlsiLQfucBXRucPvdrphpBsFA&m=5o_Is2wUigC3ddd4rYeeX71W3SZ0iusenzX-7phZkJE&s=pH8ALHAwVUPf8pRzxMQD30gn32p0oISnQSFwsf-9tOs&e=> https://ietf.webex.com/ietf/mc>

Thank you,
Dan & Tina 

  _____

---

From: Andy Bierman <[email-masked]>
Date: Fri, 10 Jul 2015 10:12:19 -0700

Hi,

I am confused a bit by slide 4 and 5.
The charter talks about SUPA GPIM and creating
a data model  from this info model.

But under that box is "Policy Interface" and "Technology Specific
YANG Models" as the 3rd layer in the SUPA framework.
This layer feeds into the 4th layer -- SUPA Translation Function,
which generates layer 5 Configuration Snippets.

Layers 3 - 5 are where all the magic and hand-waving are located.
It would be good if the BoF explained the Policy Interface
and Translation Function.

The slides seem to imply that SUPA will allow a generic policy
like "disable incoming SNMP traffic" and generate vendor-specific
configuration snippets  (assume that means a different snippet
for vendor X and vendor Y are possible).

Andy

On Fri, Jul 10, 2015 at 2:45 AM, Maxim Klyus <[email-masked]> wrote:

> *From:* Supa [mailto:[email-masked]] *On Behalf Of *Romascanu, Dan
> (Dan)
> *Sent:* Friday, July 10, 2015 12:21 PM
> *To:* Tina TSOU; [email-masked]
> *Subject:* Re: [Supa] SUPA call: 7:30-8:30am, Monday, July 13, San
> Francisco time
>
>
>
> Hi,
>
>
>
> It would be very useful for the call on Monday that folks who own items on
> the agenda can prepare and submit for discussion a draft of their slide
> decks. It is understood that these would be only draft slides for
> discussion that will be updated after the call on Monday and before IETF
> 93.
>
>
>
> Thanks and Regards,
>
>
>
> Dan
>
>
>
>
>
> *From:* Supa [mailto:[email-masked] <[email-masked]>] *On
> Behalf Of *Tina TSOU
> *Sent:* Tuesday, July 07, 2015 2:05 AM
> *To:* [email-masked]
> *Subject:* [Supa] SUPA call: 7:30-8:30am, Monday, July 13, San Francisco
> time
>
>
>
> Dear all,
>
>
>
>  ------------------------------
> The information transmitted herein is intended only for the person or
> entity to which it is addressed and may contain confidential, proprietary
> and/or privileged material. Any review, retransmission, dissemination or
> other use of, or taking of any action in reliance upon, this information by
> persons or entities other than the intended recipient is prohibited. If you
> received this in error, please contact the sender and delete the material
> from any computer.
>
>
> _______________________________________________
> Supa mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/supa
>
>

---

From: John Strassner <[email-masked]>
Date: Sun, 12 Jul 2015 22:34:24 -0700

Hi Bob,

thank you for a thorough review. I have made the following changes:

Slide 6
  - changed ECA to Imperative
  - changed "Intention-based" to "Intent-based"
  - changed Imperative (first bullet under what was ECA) to "Rule-based"
  - changed "Logic-based" to "Logic clauses" (now clauses are used
consistently)
  - changed "Reactive network..." on left to "Goal-based", as declarative
doesn't "react" per se, it defines a goal to be achieved

Slide 7
  - Changed ECA to Imperative
  - first rounded rectangle under Declarative: changed "Create/Edit/Delete
properties" to "Define behavioral goals"; fixed typos
  - first rounded rectangle under ECA: changed "Edit" to
"Create/Edit/Delete/Read"; fixed typos; uncovered remainder of bullet by
lengthening rectangle

I haven't changed slide 3. You are of course correct - syntax and data
models are not at the level of abstraction as SDN or NFV, which are not at
the same layer of abstraction as CLI or TL1. We were trying to give
examples of the problems, and then show that SUPA is solving the first two
now, with at least the last being done once more of the overall solution
has matured (in slides 4/5). That's why the left 2 (syntax and data models)
are yellow, with the right two being brown.

regards,
John

On Fri, Jul 10, 2015 at 6:14 AM, Natale, Bob <[email-masked]> wrote:

> - There is a logical mismatch between “Declarative” and “ECA” at the level
> shown on these slides … should be “Declarative” and “Imperative”.
>
> - “Intention-based” is not the same as “Intent-based” (see
> http://www.learnersdictionary.com/qa/intent-and-intention) … should use
> the latter.
>
> - Given those two points, your second level might pair “Intent-based” and
> “Rule-based” or “Procedure-based” … John will know better than me.
>
>
>
> #8/9:
>
> - I think I’d move these slides forward in the deck as a pair … maybe with
> what is now #9 coming before what is now #8 … the rest of the deck seems to
> explain in more detail the goals and benefits these two lay out … but I see
> the flow you are going for in the present order and it works too.
>
>
>
> #3:
>
> - I have a small concern about showing SUPA “Syntax” and “Data Models” at
> the same level as “SDN, NFV, Legacy” and “CLI, TL1, Scripts” … logically
> and in light of #4/5, which seem right to me … i.e., SUPA syntax and data
> models feed (so to speak) those implementation technologies in the SUPA
> framework, right…?
>
> - Of course, I do understand that legacy management interfaces will still
> exist for some time (indefinitely) and even newer ones might appear, all of
> which will be deployed contemporaneously with SUPA implementations going
> forward, and maybe that’s what the voice track for this slide will convey…?
> (In which case #4/5 do a very good job of illustrating the SUPA approach.)
>
>
>
> Avanti,
>
> BobN
>
>
>
> *From:* Supa [mailto:[email-masked]] *On Behalf Of *Maxim Klyus
> *Sent:* Friday, July 10, 2015 5:45 AM
> *To:* [email-masked]
> *Subject:* [Supa] SUPA Proposition slides
>
>
>
> Hello SUPA,
>
>
>
> Behalf Of *Romascanu, Dan (Dan)

-- 
regards,
John

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Mon, 13 Jul 2015 16:06:42 +0200

> Very useful slide set … concise, clear, and well designed … some observations for your consideration:

I find the slides neither concise, nor clear; in fact they cause
confusion on my side rather than explaining what the SUPA value
proposition is. Remember that you target engineers, not business
people. Reduce color, remove arrows without a well defined meaning,
provide concrete examples instead of high-level claims.

- s2: I have no clue what all the colors and the arrows mean.

- s3: I do not think SUPA is providing a complete replacement for the
      box shown on slide s2. By overstating what SUPA does, you loose
      credibility.

- s4: I am lost in the 'middle'. Again, I do not understand the
      semantics of the arrows. I also believe we are better off with
      having a single framework figure instead of multiple.

- s5: I am lost here. Most down to earth engineers will be lost here.

- s6: This is pretty much OK. I am not sure why things have to be
      classified as reactive. I am also not sure why one is lifecycle
      oriented and the other not. My proposal would be to remove those
      bullets and instead add an example that engineers understand.

- s7: Still wondering what GPYDM stands for. To please engineers,
      avoid acronyms that are difficult to memorize after a couple of
      days at an IETF meeting. And yes, show real world down to earth
      examples.

- s8: Marketing slide without much content. Better explain why SUPA is
      an incremental and natural addition to what the IETF has been
      working on during the last yew years (namely YANG configuration
      data models) and why it is now the time to try (again) to make
      policy-driven networks a common vendor neutral solution.

- s9: Finally GPYDM (or GPYMD) is explained. But I am missing a clear
      distinction between the models and the instantiation of the
      models. Right box, what is this Policy Interface?? And the text
      reads as if data models are translated. I think it is policies
      written against the data models that are translated.

/js

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1 | 28759 Bremen | Germany
Fax:   +49 421 200 3103         <http://www.jacobs-university.de/>

---

From: Maxim Klyus <[email-masked]>
Date: Tue, 14 Jul 2015 11:13:53 +0000

Hi Juergen,

New slides version attached, you can see my comments inline.

Any comments from other people appreciated.

Best Regards,
Maxim Klyus

-----Original Message-----
From: Juergen Schoenwaelder [mailto:[email-masked]]
Sent: Monday, July 13, 2015 5:07 PM
To: Natale, Bob
Cc: Maxim Klyus; John Strassner; [email-masked]
Subject: Re: [Supa] SUPA Proposition slides

> Very useful slide set … concise, clear, and well designed … some observations for your consideration:

I find the slides neither concise, nor clear; in fact they cause confusion on my side rather than explaining what the SUPA value proposition is. Remember that you target engineers, not business people. Reduce color, remove arrows without a well defined meaning, provide concrete examples instead of high-level claims.

[MK] Fixed

[MK] The purpose of the slide is not to show complete replacement. It just says SUPA can help to solve those problems.

- s4: I am lost in the 'middle'. Again, I do not understand the
      semantics of the arrows. I also believe we are better off with
      having a single framework figure instead of multiple

[MK] Fixed

[MK] Simplified as much as possible
[MK] Adopted for engineers including implementations examples ( very close to the earth)

[MK] I would like to explain it.
[MK] Declarative changes obviously can manage some new network service deployment.
[MK] But I don't know any example when network service or function can be deployed based on current network situation or event.
[MK] If your service already deployed you can only modify it based on network event. You can install new configuration based on network event, but it seems to be your service already installed anyway.

[MK] Since GPYMD brings a lot of confusion I decided to remove it in total from the slides and current framework description.
[MK] Everything simplified as much as possible.

[MK] Fixed with slide which reflects only facts regarding your comments

[MK] Fixed

/js

---

From: John Strassner <[email-masked]>
Date: Wed, 15 Jul 2015 10:22:40 -0700

Good job Max, and thanks Juergen for the detailed feedback.

I would **recommend** the following minor changes, but feel free to ignore
them.

1. Slide 3
People may not notice that Policy was inserted; I added to dashed rounded
rectangles to focus on these changes.

2. Slide 4
In the top right box, delete "BY usual SQL" since 1) other languages could
be used and 2) the syntax isn't standard SQL :-)

3. Slide 5
I think dropping the text inside the parentheses in both the declarative
and the imperative boxes is better. The real difference is that imperative
ECA policies always implement a fixed response when they are triggered,
whereas goal-based algorithms do not. But I'm not sure that this subtlety
is appropriate for the audience.

4. Slide 6
  - Simplified the declarative example in the third row (you shouldn't have
to say "aggregation interfaces")
  - Minor grammatical fixes

5. Slide 7
Changed the sense of the first bullet (The network policy... should NOT
bring complexity, right?)
Same for second bullet
Minor changes in next two bullets

regards,
John

On Tue, Jul 14, 2015 at 4:13 AM, Maxim Klyus <[email-masked]> wrote:

> I find the slides neither concise, nor clear; in fact they cause confusion
> on my side rather than explaining what the SUPA value proposition is.
> Remember that you target engineers, not business people. Reduce color,
> remove arrows without a well defined meaning, provide concrete examples
> instead of high-level claims.
>
> [MK] The purpose of the slide is not to show complete replacement. It just
> says SUPA can help to solve those problems.
>
> [MK] But I don't know any example when network service or function can be
> deployed based on current network situation or event.
> [MK] If your service already deployed you can only modify it based on
> network event. You can install new configuration based on network event,
> but it seems to be your service already installed anyway.
>
> [MK] Since GPYMD brings a lot of confusion I decided to remove it in total
> from the slides and current framework description.

-- 
regards,
John

---

From: Georgios Karagiannis <[email-masked]>
Date: Thu, 16 Jul 2015 07:09:05 +0000

Dear all,

The slides look good, but I have two comments:
=>Regarding slide 2, it is important to emphasize that you talk about challenges. You may add the word “Challenges” before the bullets.
=> Regarding slide 3, I agree with the addition of John. You may also want to show in the same slide that the red box (lines) refer to SUPA input on solving the listed challenges.

Best regards,
Georgios

From: Supa [mailto:[email-masked]] On Behalf Of John Strassner
Sent: 15 July 2015 19:23
To: Maxim Klyus
Cc: Natale, Bob; Juergen Schoenwaelder; [email-masked]
Subject: Re: [Supa] SUPA Proposition slides

I would **recommend** the following minor changes, but feel free to ignore them.

1. Slide 3
People may not notice that Policy was inserted; I added to dashed rounded rectangles to focus on these changes.

2. Slide 4
In the top right box, delete "BY usual SQL" since 1) other languages could be used and 2) the syntax isn't standard SQL :-)

3. Slide 5
I think dropping the text inside the parentheses in both the declarative and the imperative boxes is better. The real difference is that imperative ECA policies always implement a fixed response when they are triggered, whereas goal-based algorithms do not. But I'm not sure that this subtlety is appropriate for the audience.

4. Slide 6
  - Simplified the declarative example in the third row (you shouldn't have to say "aggregation interfaces")
  - Minor grammatical fixes

5. Slide 7
Changed the sense of the first bullet (The network policy... should NOT bring complexity, right?)
Same for second bullet
Minor changes in next two bullets

regards,
John

On Tue, Jul 14, 2015 at 4:13 AM, Maxim Klyus <[email-masked]<mailto:[email-masked]>> wrote:
Hi Juergen,

Best Regards,
Maxim Klyus

-----Original Message-----
From: Juergen Schoenwaelder [mailto:[email-masked]<mailto:[email-masked]>]
Sent: Monday, July 13, 2015 5:07 PM
To: Natale, Bob
Cc: Maxim Klyus; John Strassner; [email-masked]<mailto:[email-masked]>
Subject: Re: [Supa] SUPA Proposition slides

[MK] Fixed

[MK] Fixed

[MK] Fixed

/js

--
regards,
John

---

From: Maxim Klyus <[email-masked]>
Date: Thu, 16 Jul 2015 09:39:30 +0000

Dears,

I agreed with all changes provided by John.
I also made changes according Georgios comments.
Plus some minor changes slide 7, one sentence was added “The network functions and capacities can changes flexibly based on SP requirements and needs“.

Any other comments and objections appreciated.

Regards,
Max Klyus

From: Georgios Karagiannis [mailto:[email-masked]]
Sent: Thursday, July 16, 2015 10:09 AM
To: John Strassner; Maxim Klyus
Cc: Natale, Bob; Juergen Schoenwaelder; [email-masked]
Subject: RE: [Supa] SUPA Proposition slides

Dear all,

Best regards,
Georgios

From: Supa [mailto:[email-masked]] On Behalf Of John Strassner
Sent: 15 July 2015 19:23
To: Maxim Klyus
Cc: Natale, Bob; Juergen Schoenwaelder; [email-masked]<mailto:[email-masked]>
Subject: Re: [Supa] SUPA Proposition slides

1. Slide 3

2. Slide 4

3. Slide 5

4. Slide 6

5. Slide 7

regards,
John

Best Regards,
Maxim Klyus

-----Original Message-----
From: Juergen Schoenwaelder [mailto:[email-masked]<mailto:[email-masked]>]
Sent: Monday, July 13, 2015 5:07 PM
To: Natale, Bob
Cc: Maxim Klyus; John Strassner; [email-masked]<mailto:[email-masked]>
Subject: Re: [Supa] SUPA Proposition slides

[MK] Fixed

[MK] Fixed

[MK] Fixed

/js

--
regards,
John

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Thu, 16 Jul 2015 21:23:46 +0000

Thanks.

I will upload the updated version.

Regards,

Dan

From: Supa [mailto:[email-masked]] On Behalf Of Maxim Klyus
Sent: Thursday, July 16, 2015 12:40 PM
To: Georgios Karagiannis; John Strassner
Cc: Natale, Bob; Juergen Schoenwaelder; [email-masked]
Subject: Re: [Supa] SUPA Proposition slides

Dears,

Regards,
Max Klyus

Dear all,

Best regards,
Georgios

1. Slide 3

2. Slide 4

3. Slide 5

4. Slide 6

5. Slide 7

regards,
John

Best Regards,
Maxim Klyus

-----Original Message-----
From: Juergen Schoenwaelder [mailto:[email-masked]<mailto:[email-masked]>]
Sent: Monday, July 13, 2015 5:07 PM
To: Natale, Bob
Cc: Maxim Klyus; John Strassner; [email-masked]<mailto:[email-masked]>
Subject: Re: [Supa] SUPA Proposition slides

[MK] Fixed

[MK] Fixed

[MK] Fixed

/js

--
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1 | 28759 Bremen | Germany
Fax:   +49 421 200 3103         <http://www.jacobs-university.de/<https://urldefense.proofpoint.com/v2/url?u=http-3A__www.jacobs-2Duniversity.de_&d=AwMGaQ&c=BFpWQw8bsuKpl1SgiZH64Q&r=I4dzGxR31OcNXCJfQzvlsiLQfucBXRucPvdrphpBsFA&m=yvZGYRJvAhAnvdpu6N1_jFBpEIyu3x7VKpaEX15J18I&s=YE0nax-s6nH0eG3-ABaniDf8OEVeMxM8qbwzT0jjWDE&e=>>

--
regards,
John

---

From: John Strassner <[email-masked]>
Date: Thu, 16 Jul 2015 14:23:49 -0700

Thanks Max. A minor nit that people may not even notice: on slide 7, there
are two instances of "changes"; both should be "change". :-)

regards,
John

On Thu, Jul 16, 2015 at 2:39 AM, Maxim Klyus <[email-masked]> wrote:

> Plus some minor changes slide 7, one sentence was added “*The network
> functions and capacities can changes flexibly based on SP requirements and
> needs*“.
>
>
>
> *From:* Georgios Karagiannis [mailto:[email-masked]]
> *Sent:* Thursday, July 16, 2015 10:09 AM
> *To:* John Strassner; Maxim Klyus
> *Cc:* Natale, Bob; Juergen Schoenwaelder; [email-masked]
> *Subject:* RE: [Supa] SUPA Proposition slides
>
>
>
> Dear all,
>
>
>
> =>Regarding slide 2, it is important to emphasize that you talk about
> challenges. You may add the word “Challenges” before the bullets.
>
> => Regarding slide 3, I agree with the addition of John. You may also want
> to show in the same slide that the red box (lines) refer to SUPA input on
> solving the listed challenges.
>
>
>
> Best regards,
>
> Georgios
>
>
>
>
>
> Behalf Of *John Strassner
> *Sent:* 15 July 2015 19:23
> *To:* Maxim Klyus
> *Cc:* Natale, Bob; Juergen Schoenwaelder; [email-masked]
> *Subject:* Re: [Supa] SUPA Proposition slides
>
>
>

-- 
regards,
John

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Thu, 16 Jul 2015 21:25:01 +0000

I caught this.

Thanks and Regards,

Dan

From: Supa [mailto:[email-masked]] On Behalf Of John Strassner
Sent: Friday, July 17, 2015 12:24 AM
To: Maxim Klyus
Cc: Georgios Karagiannis; Natale, Bob; Juergen Schoenwaelder; [email-masked]
Subject: Re: [Supa] SUPA Proposition slides

Thanks Max. A minor nit that people may not even notice: on slide 7, there are two instances of "changes"; both should be "change". :-)

regards,
John

On Thu, Jul 16, 2015 at 2:39 AM, Maxim Klyus <[email-masked]<mailto:[email-masked]>> wrote:
Dears,

Regards,
Max Klyus

From: Georgios Karagiannis [mailto:[email-masked]<mailto:[email-masked]>]

Dear all,

Best regards,
Georgios

1. Slide 3

2. Slide 4

3. Slide 5

4. Slide 6

5. Slide 7

regards,
John

Best Regards,
Maxim Klyus

-----Original Message-----
From: Juergen Schoenwaelder [mailto:[email-masked]<mailto:[email-masked]>]
Sent: Monday, July 13, 2015 5:07 PM
To: Natale, Bob
Cc: Maxim Klyus; John Strassner; [email-masked]<mailto:[email-masked]>
Subject: Re: [Supa] SUPA Proposition slides

[MK] Fixed

[MK] Fixed

[MK] Fixed

/js

--
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587<tel:%2B49%20421%20200%203587>         Campus Ring 1 | 28759 Bremen | Germany
Fax:   +49 421 200 3103<tel:%2B49%20421%20200%203103>         <http://www.jacobs-university.de/<https://urldefense.proofpoint.com/v2/url?u=http-3A__www.jacobs-2Duniversity.de_&d=AwMFaQ&c=BFpWQw8bsuKpl1SgiZH64Q&r=I4dzGxR31OcNXCJfQzvlsiLQfucBXRucPvdrphpBsFA&m=2wnZ6qXR3P1ZL5yKvO5Pp1V6BDvM_qd_ZBUNTVdSjYg&s=tPZqdWuSSCbyyucmEeEpGy0uWCODW85pjGZtT0NoJgE&e=>>

--
regards,
John

--
regards,
John

---

From: Benoit Claise <[email-masked]>
Date: Fri, 17 Jul 2015 19:50:08 +0200

Dear all,

[going through all the SUPA slides. In the middle of it, sorry for any 
duplications]
I reviewed the proposition slides v10, which defines a SUPA framework, 
but does tell me much about the YANG models.

 From the charter at 
http://cnds.eecs.jacobs-university.de/users/schoenw/supa/supa-charter-2015-06-15.txt

    The GPIM
    will be translated into corresponding YANG data models to define
    interoperable implementations that can exchange and modify generic
    policies using protocols such as NETCONF/RESTCONF.

http://datatracker.ietf.org/doc/draft-klyus-supa-proposition/ contains 
the same sentence, and

    In the preferred approach, SUPA generic policy data models are
    then used to create vendor- and technology-specific data models.

      ...

    SUPA will translate the GPIM into concrete YANG data models that
    define how to manage and communicate policies between systems.

I wonder what we have in those YANG models? A translation of the 
information model? Policy concepts that could reused in data models?
Would someone have a sketch of those?

Regards, Benoit
> functions and capacities can changes flexibly based on SP requirements 
> and needs*“.
>
> *From:*Georgios Karagiannis [mailto:[email-masked]]
> => Regarding slide 3, I agree with the addition of John. You may also 
> want to show in the same slide that the red box (lines) refer to SUPA 
> input on solving the listed challenges.
>
> Best regards,
>
> Georgios
>
> *From:*Supa [mailto:[email-masked]] *On Behalf Of *John Strassner
> <mailto:[email-masked]>
> People may not notice that Policy was inserted; I added to dashed 
> rounded rectangles to focus on these changes.
>
> 2. Slide 4
>
> In the top right box, delete "BY usual SQL" since 1) other languages 
> could be used and 2) the syntax isn't standard SQL :-)
>
> 3. Slide 5
>
> I think dropping the text inside the parentheses in both the 
> declarative and the imperative boxes is better. The real difference is 
> that imperative ECA policies always implement a fixed response when 
> they are triggered, whereas goal-based algorithms do not. But I'm not 
> sure that this subtlety is appropriate for the audience.
>
> 4. Slide 6
>
> From: Juergen Schoenwaelder 
> [mailto:[email-masked] 
> <mailto:[email-masked]>]
> Cc: Maxim Klyus; John Strassner; [email-masked] <mailto:[email-masked]>
> [MK] The purpose of the slide is not to show complete replacement. It 
> just says SUPA can help to solve those problems.
>
> [MK] But I don't know any example when network service or function can 
> be deployed based on current network situation or event.
> network event. You can install new configuration based on network 
> event, but it seems to be your service already installed anyway.
>
> [MK] Since GPYMD brings a lot of confusion I decided to remove it in 
> total from the slides and current framework description.
> entity to which it is addressed and may contain confidential, 
> proprietary and/or privileged material. Any review, retransmission, 
> dissemination or other use of, or taking of any action in reliance 
> upon, this information by persons or entities other than the intended 
> recipient is prohibited. If you received this in error, please contact 
> the sender and delete the material from any computer.
>
>
>
>
> -- 
>
> regards,
>
> John
>
> ------------------------------------------------------------------------
> entity to which it is addressed and may contain confidential, 
> proprietary and/or privileged material. Any review, retransmission, 
> dissemination or other use of, or taking of any action in reliance 
> upon, this information by persons or entities other than the intended 
> recipient is prohibited. If you received this in error, please contact 
> the sender and delete the material from any computer.
>
>

---

From: John Strassner <[email-masked]>
Date: Fri, 17 Jul 2015 13:20:07 -0700

Hi Benoit,

The SUPA info model is of course technology-neutral. Hence, the SUPA
Generic Policy YANG data models translate the generic policy concepts and
structure defined in the information model into YANG data models. They are
then input into a Policy Engine, which uses those YANG data models to
provide a customizable operator interface. This could, for example, be a
web form, or a template to enter script parameters, or an applet. The
output of this is then translated to a form that can be consumed by network
elements or management systems. Please see section 2.1 of the proposition
I-D.

I will be building a slide deck, with help from others, to talk about this
in more detail. Others will talk about the data model as well. In the
meantime, if this didn't answer your question, please let us know where you
would like to see more detail.

regards,
John

On Fri, Jul 17, 2015 at 10:50 AM, Benoit Claise <[email-masked]> wrote:

> I reviewed the proposition slides v10, which defines a SUPA framework, but
> does tell me much about the YANG models.
>
> From the charter at
> *From:* Georgios Karagiannis [mailto:[email-masked]
> <[email-masked]>]
> Supa mailing [email-masked]://www.ietf.org/mailman/listinfo/supa
>
>
>

-- 
regards,
John