Subject: Re: [Supa] 06/22/15 SUPA Applicability

From: Ying Cheng <[email-masked]>
Date: Fri, 10 Jul 2015 13:18:14 +0800

Hi Narasimha,

Thanks for your explanation.  Please kindly see my comments in line.

BR,
Ying

2015-07-10 

Ying CHENG  程莹
China Unicom Network Technology Research Institute 中国联通网络技术研究院
Tel: +86-10-68799999-7702
Mobile: +86-18601102971

发件人： Narasimha Rao Vadrevu 
发送时间： 2015-06-29  22:11:00 
收件人： 'John Strassner' 
抄送： [email-masked] 
主题： Re: [Supa] 06/22/15 SUPA Applicability 
Hi John,
 
Thanks for the comments, Now  I got clarified on a few things. Thinking of a high level generic user flow as follows:
 
·         Legacy Data center operator with legacy SNMP based NMS
·         Operations grow in complexity. Need to be more agile and scale
·         Creates YANG modules by reading the MIBs from NEs
[Ying] Regarding the high level generic user flow,  it is needed for operators to create YANG models and then map and reflect them to the concrete device configuration.
 Usually, we don't create YANG model based on the device configuration. Therefore, the methodology is "top-down", but not "bottom-up". 

·         Creates a SGPIM which can be translated into YANG models
[Ying]Information model needs to be defined by SUPA in advance. But it is not translated into YANG data model. IMHO, information model is more like the guidance of data model development. Between SGPIM and data model, there are ECA Policy Rule Information Model (EPRIM) and SUPA Logic Statement Information Model (SLSIM). 

·         These YANG models can act on NEs using NETCONF for better operations. It’s all run time since it’s an XML parsing than an MIB compilation
 
My disconnect , I was thinking SGPIM as an YANG model and you clarified that.
 
Thanks,
Narasimha

From: John Strassner [mailto:[email-masked]] 
Sent: Sunday, June 28, 2015 7:18 PM
To: [email-masked]
Cc: [email-masked]
Subject: Re: [Supa] 06/22/15 SUPA Applicability
 
Hi Narasimha,
 
Thanks for the effort; my comments are meant to help explain.
 
The applicability statement is work item #4 on the 2015-06-09
version of the charter. It says":
 
4) An applicability document providing a number of examples that
   demonstrate how the generic policy models can be used to express
   policies that are relevant for network operators. The examples may
   tie into network service models developed by other working groups.
 
regards,
John
 
On Sat, Jun 27, 2015 at 10:15 AM, Narasimha Rao Vadrevu <[email-masked]> wrote:
Hi John,
 
Thanks for the detailed feedback (thrashing or bashing I need it).
 
·         Agree it is a quick and patchy job. Will try to rework
·         For this forum, I center my navigation through SUPA Wiki, as I was thinking that is where the current status of this group is. 
·         WiKI links to ‘Charter proposal’ but there is no link to ‘draft proposal’, is that how the WiKi supposed to be.   I was only referencing to charter and only saw the draft proposition after Andy’s email subsequent to this.
 
When I put together this, I was trying to address #4 in the charter proposal (An applicability document). My QUESTION is:
·         Is the Applicability document for an end user (Operator or Developer) delineating the high level possibilities for this charter and used for offline discussions in BOF? That’s what this doc was trying to address to, even though only 40% accurate
·         Or a low level document, in terms of protocol connectivity model?
 
I remember Dan mentioning we need people to write docs etc. Will try to re work based on the answer to the  above.
 
Regards,
Narasimha

From: John Strassner [mailto:[email-masked]] 
Sent: Friday, June 26, 2015 6:43 PM
To: [email-masked]; John Strassner
Cc: [email-masked]
Subject: Re: [Supa] 06/22/15 SUPA Applicability
 
Hi Narasimha,
 
In general, I don't understand how this is related to the proposition draft or the charter. You need to tie one or both to your points, and make your points clearer (at least for me, because I didn't understand what you are trying to say, sorry!).
 
slide 2 (bullet by bullet)
SUPA is not a template language. Actually, SUPA is not strictly a language at all - it is a set of models. While one could build a template language to interact with SUPA, that is not in our scope.
 
SUPA does not define SLAs, SLOs, or SLSs. However, it is a model fragment, and could be combined with other models or model fragments to do so. In that case, one could write policies that test various SLA parameters and take appropriate actions.
 
Sorry, I can't parse the third bullet.
 
What is "evolutionary network functionality"? Why couldn't you use SUPA with legacy systems?
 
The fifth bullet is not quite correct. The GPIM is NOT a YANG model; either is the EPRIM or SLSIM. The GPIM + EPRIM give you one YANG model, the GPIM + SLSIM give you a different YANG model. I wouldn't say that YANG is implemented using netconf.
 
In the sense that SUPA can create policy, and in the sense that an OSS, EMS, NMS, or BSS needs policy, then sure, it is an input. It could also be an output (direct, if the management entity understood SUPA; indirect, if a SUPA policy server needed to translate OSS output to a form that SUPA could build into a policy). But DIAMETER is **just** a protocol, and shouldn't be in this list.
 
slide 3 (comment on the slide, not bullet-by-bullet)
SUPA could be used with NFV, SDN, or legacy. I personally cannot envision a YANG model that instantiates a VNF. In an IT or cloud environment, people seem to use anything but YANG to instantiate compute and storage resources. NFV doesn't have a policy model or policy manager, and its APIs are not ready for prime time, and these are far greater problems than SUPA can solve.
 
slide 4 (comment on the slide, not bullet-by-bullet)
I see you are a fan of Light Reading :-)
 
Why couldn't SUPA instantiate a new vRouter?
SUPAPolicy Foo {
   event:  user login
   condition:  no user connectivity
   action: instantiate user-router
}
where the action is a script, as Andy suggested.
 
slide 5 (comment on the slide, not bullet-by-bullet)
Yes, this could be done, but I think that it is way out of scope. We're still dealing with simple policies, not deploying clouds. :-)
 
slide 6 (comment on the slide, not bullet-by-bullet)
If you mean something like
SUPAPolicy Bar {
   event: monitoredTime
   condition:  numWebRequests BETWEEN webRequestThreshold1 AND webRequestThreshold2
   action:  run app-scaling-policy Baz
}
sure, why not? In fact, this is where the majority of past deployments have been: the event is receiving an alarm, or data from a cron job, or some other temporal event; the condition is a variable-operator-value test; the action is either change a command, or run a script.
 
slide 7 (comment on the slide, not bullet-by-bullet)
I don't understand what you are trying to say here.
 
regards,
John
 
On Mon, Jun 22, 2015 at 8:41 AM, Narasimha Rao Vadrevu <[email-masked]> wrote:
Hi All,
 
I was to do a 10 minute presentation of this time permitting, but we overran, so I am sending this scross.
This is live and will evolve with the charter.
 
Regards,
Narasimha Rao Vadrevu
 
Principal, VN Telecom Consultancy
www.von20.com
+14087810490

_______________________________________________
Supa mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/supa

-- 
regards,
John

-- 
regards,
John

如果您错误接收了该邮件，请通过电子邮件立即通知我们。[email-masked]，即可以退订此邮件。我们将立即将您的信息从我们的发送目录中删除。
If you have received this email in error please notify us immediately by e-mail. Please reply to [email-masked] if you want to unsubscribe from this mail. We will immediately remove your information from our sending catalogue.

---

From: "Narasimha Rao Vadrevu" <[email-masked]>
Date: Fri, 10 Jul 2015 03:53:27 -0700

Hi Ying,

Comments in line. 

Anyways, this document is superseded by another version which is not posted yet.

Best

Narasimha

From: Supa [mailto:[email-masked]] On Behalf Of Ying Cheng
Sent: Thursday, July 9, 2015 10:18 PM
To: [email-masked]; 'John Strassner'
Cc: [email-masked]
Subject: Re: [Supa] 06/22/15 SUPA Applicability

Hi Narasimha,

BR,

Ying

2015-07-10 

  _____  

Ying CHENG  程莹

  _____  

收件人： 'John Strassner' 

抄送： [email-masked] <mailto:[email-masked]>  

Hi John,

*         Legacy Data center operator with legacy SNMP based NMS

*         Operations grow in complexity. Need to be more agile and scale

*         Creates YANG modules by reading the MIBs from NEs

[Narasimha Vadrevu] what if have to migrate a legacy system to a SUPA model, can this be a possibility.

*         Creates a SGPIM which can be translated into YANG models

[Narasimha Vadrevu] Agreed.

*         These YANG models can act on NEs using NETCONF for better operations. It’s all run time since it’s an XML parsing than an MIB compilation

Thanks,

Narasimha

From: John Strassner [mailto:[email-masked]] 
Sent: Sunday, June 28, 2015 7:18 PM
To: [email-masked] <mailto:[email-masked]> 
Cc: [email-masked] <mailto:[email-masked]> 
Subject: Re: [Supa] 06/22/15 SUPA Applicability

Hi Narasimha,

regards,

John

On Sat, Jun 27, 2015 at 10:15 AM, Narasimha Rao Vadrevu <[email-masked] <mailto:[email-masked]> > wrote:

Hi John,

*         Agree it is a quick and patchy job. Will try to rework

*         For this forum, I center my navigation through SUPA Wiki, as I was thinking that is where the current status of this group is. 

*         WiKI links to ‘Charter proposal’ but there is no link to ‘draft proposal’, is that how the WiKi supposed to be.   I was only referencing to charter and only saw the draft proposition after Andy’s email subsequent to this.

*         Is the Applicability document for an end user (Operator or Developer) delineating the high level possibilities for this charter and used for offline discussions in BOF? That’s what this doc was trying to address to, even though only 40% accurate

*         Or a low level document, in terms of protocol connectivity model?

Regards,

Narasimha

From: John Strassner [mailto:[email-masked] <mailto:[email-masked]> ] 
Sent: Friday, June 26, 2015 6:43 PM
To: [email-masked] <mailto:[email-masked]> ; John Strassner
Cc: [email-masked] <mailto:[email-masked]> 
Subject: Re: [Supa] 06/22/15 SUPA Applicability

Hi Narasimha,

SUPAPolicy Foo {

   event:  user login

}

SUPAPolicy Bar {

   event: monitoredTime

}

regards,

John

On Mon, Jun 22, 2015 at 8:41 AM, Narasimha Rao Vadrevu <[email-masked] <mailto:[email-masked]> > wrote:

Hi All,

Regards,

Narasimha Rao Vadrevu

 <http://www.von20.com> www.von20.com

+14087810490 <tel:%2B14087810490> 

_______________________________________________
Supa mailing list
[email-masked] <mailto:[email-masked]> 
https://www.ietf.org/mailman/listinfo/supa

-- 

regards,

John

-- 

regards,

John

如果您错误接收了该邮件，请通过电子邮件立即通知我们。请回复邮件到 <mailto:[email-masked]，即可以退订此邮件。我们将立即将您的信息从我们的发送目录中删除> [email-masked]，即可以退订此邮件。我们将立即将您的信息从我们的发送目录中删除。 If you have received this email in error please notify us immediately by e-mail. Please reply to [email-masked] <mailto:[email-masked]>  if you want to unsubscribe from this mail. We will immediately remove your information from our sending catalogue.