Subject: Re: [Supa] Fwd: I-D Action: draft-strassner-supa-generic-policy-info-model-04.txt

From: "jmh.direct" <[email-masked]>
Date: Mon, 29 Feb 2016 20:17:48 -0500

There are two aspecrs.
First, the class in this model need to be sub-classed to define syntaxes for enxoded, or details of events, conditions, and actions in the ECACOMPOSITE vranch.
Second, we are translating this information model into YANG.
Yours,Joel

Sent via the Samsung Galaxy S® 6, an AT&T 4G LTE smartphone-------- Original message --------From: Andy Bierman <[email-masked]> Date: 2/29/2016  7:16 PM  (GMT-05:00) To: Joel Halpern <[email-masked]> Cc: [email-masked] Subject: Re: [Supa] Fwd: I-D Action: draft-strassner-supa-generic-policy-info-model-04.txt 
Hi,
I read this draft and I am still confused how it is really used.It is not clear what is supposed to be implemented.
   Variable == Event.baz                                        (A)
     Condition BETWEEN VALUE1 and VALUE2                          (B)
     (Event.severity == 'Critical' AND
       (SLA.violation == TRUE OR User.class == 'Gold'))           (C)

Sec 4.3 suggests there is some policy syntax but there is no ABNF
to follow to construct the syntax.
Even if there was a syntax and some examples, I do not see how SUPA uses YANG.It appears that one would somehow create an info model in the SUPA enginewhich represents the policy.  YANG seems irrelevant if this is the case.If SUPA is supposed to work with YANG somehow, then it would be goodto explain how.

Andy

On Fri, Feb 12, 2016 at 1:26 PM, Joel Halpern <[email-masked]> wrote:
Below is the announcement of the revision of the Generic Information Model for the SUPA work.  John has done the heavy lifting on this, with help from Jason and myself.

Over the last several months, we have made a lot of changes to this model.

We really need working group review and comment on this.

We will be working with the team that produced the earlier YANG models to drive a new YANG model that reflects this information model.  So if we have made mistakes here, we need to know ASAP.

In the absence of significant concerns, once we have gotten a YANG model derived, we will also ask for WG adoption of this document.

So please, read it and comment.

Yours,

Joel

-------- Forwarded Message --------

Subject: I-D Action: draft-strassner-supa-generic-policy-info-model-04.txt

Date: Fri, 12 Feb 2016 11:09:50 -0800

From: [email-masked]

Reply-To: [email-masked]

To: [email-masked]

A New Internet-Draft is available from the on-line Internet-Drafts directories.

        Title           : Generic Policy Information Model for Simplified Use of Policy Abstractions (SUPA)

        Authors         : John Strassner

                          Joel Halpern

                          Jason Coleman

        Filename        : draft-strassner-supa-generic-policy-info-model-04.txt

        Pages           : 115

        Date            : 2016-02-12

Abstract:

   This document defines an information model for representing

   policies using a common extensible framework that is independent

   of language, protocol, repository. It is also independent of the

   level of abstraction of the content and meaning of a policy.

The IETF datatracker status page for this draft is:

https://datatracker.ietf.org/doc/draft-strassner-supa-generic-policy-info-model/

There's also a htmlized version available at:

https://tools.ietf.org/html/draft-strassner-supa-generic-policy-info-model-04

A diff from the previous version is available at:

https://www.ietf.org/rfcdiff?url2=draft-strassner-supa-generic-policy-info-model-04

Please note that it may take a couple of minutes from the time of submission

until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:

ftp://ftp.ietf.org/internet-drafts/

_______________________________________________

I-D-Announce mailing list

[email-masked]

https://www.ietf.org/mailman/listinfo/i-d-announce

Internet-Draft directories: http://www.ietf.org/shadow.html

or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

_______________________________________________

Supa mailing list

[email-masked]

https://www.ietf.org/mailman/listinfo/supa

---

From: Zhoutianran <[email-masked]>
Date: Tue, 1 Mar 2016 03:19:23 +0000

If we want to finally generate YANG data models here, why do we spend time working on this information model.

Why not focus on the ECA YANG data model directly as standard track?

Do you imply we will create any other data model in addition to YANG?

Tianran

From: Supa [mailto:[email-masked]] On Behalf Of jmh.direct
Sent: Tuesday, March 01, 2016 9:18 AM
To: Andy Bierman; Joel Halpern
Cc: [email-masked]
Subject: Re: [Supa] Fwd: I-D Action: draft-strassner-supa-generic-policy-info-model-04.txt

There are two aspecrs.

Yours,
Joel

Sent via the Samsung Galaxy S® 6, an AT&T 4G LTE smartphone
-------- Original message --------
From: Andy Bierman <[email-masked]<mailto:[email-masked]>>
Date: 2/29/2016 7:16 PM (GMT-05:00)
To: Joel Halpern <[email-masked]<mailto:[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]>
Subject: Re: [Supa] Fwd: I-D Action: draft-strassner-supa-generic-policy-info-model-04.txt

Hi,

I read this draft and I am still confused how it is really used.
It is not clear what is supposed to be implemented.

Even if there was a syntax and some examples, I do not see how SUPA uses YANG.
It appears that one would somehow create an info model in the SUPA engine
which represents the policy.  YANG seems irrelevant if this is the case.
If SUPA is supposed to work with YANG somehow, then it would be good
to explain how.

Andy

On Fri, Feb 12, 2016 at 1:26 PM, Joel Halpern <[email-masked]<mailto:[email-masked]>> wrote:
Below is the announcement of the revision of the Generic Information Model for the SUPA work.  John has done the heavy lifting on this, with help from Jason and myself.

Yours,
Joel

-------- Forwarded Message --------
Subject: I-D Action: draft-strassner-supa-generic-policy-info-model-04.txt
Date: Fri, 12 Feb 2016 11:09:50 -0800
From: [email-masked]<mailto:[email-masked]>
Reply-To: [email-masked]<mailto:[email-masked]>
To: [email-masked]<mailto:[email-masked]>

Abstract:

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org<http://tools.ietf.org>.

[email-masked]<mailto:[email-masked]>

_______________________________________________
Supa mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/supa