Subject: Re: [Supa] I-D Action: draft-ietf-supa-policy-based-management-framework-00.txt

From: Zhoutianran <[email-masked]>
Date: Tue, 13 Sep 2016 03:06:16 +0000

Hi Jonathan

Although I am not the author of this draft, I agree with most of your comments except those in line.

Best,
Tianran

From: Supa [mailto:[email-masked]] On Behalf Of Jonathan Hansford
Sent: Thursday, September 01, 2016 1:50 AM
To: [email-masked]
Subject: Re: [Supa] I-D Action: draft-ietf-supa-policy-based-management-framework-00.txt

Some review comments:

*         General

l  The phrase "the GPIM (or the combination of the GPIM and the EPRIM)" or its equivalent appears a number of times throughout this document so clearly it is important but, coming to SUPA cold, I failed to understand its importance. If there is a need to constantly repeat this phrase, could it not do with further explanation?

[ztr]: The draft has section 2.3 to describe the GPIM and the EPRIM. And there is section 2.4 describes the relationship between the IM and the DM, and the way to refine both. What else do you think this draft can clarify the value of the IM?

*         Page 2

o   1. Introduction

*  "the task of network operations and management applications and deploying new services" - is that one task and, if so, what is it? Should that read "the task of network operations and management applications and deploying new services"?

[ztr]: Here I think the draft was to say "the task of network operations and management, and new service deployment".

*         Page 3

o   1. Introduction

*  s/indepednent/independent

*  What is the term "snippet" intended to imply? Should it be defined somewhere?

o   2.1 Overview

*  "The GPIM, as well as the combination of the  GPIM and EPRIM, are converted to generic YANG data modules." Shouldn't that be either The GPIM, as well as the combination of the  GPIM and EPRIM, is converted ..." or "The GPIM and the combination of the  GPIM and EPRIM are converted ..."?

[ztr]: Here I think the draft was to say " Both GPIM and EPRIM are converted to generic YANG data modules"

*         Page 4

o   2.1 Overview

*  For consistency with capitalisation, either e.g. "SUPA Generic & ECA Policy YANG Data modules" or "SUPA generic policy YANG data modules"

*         Page 7

o   2.1 Overview

*  None of the arrows with Ds appear to be double-headed and not all of the arrows with Cs

[ztr]: I think derivation should only be single headed. Communication in the figure should be double headed.

*  Since lower down we have "ECA Policy Rule Information Data Model (EPRIM):" for consistency should we not also have "Generic Policy Information Model (GPIM):"?

[ztr]: And I think "ECA Policy Rule Information Data Model" should be  "ECA Policy Rule Information Model (EPRIM)"

*  "query, and implementation languages, and protocol" (appears twice) - should that be "query, and implementation languages, and protocol"?

*  "policy rules for that are" - should that be ""policy rules for that are"?

*  "dependent of" - should that be "independent of" or "dependent on"?

*  "policy rules derived from EPRIM, consist" - should that be "policy rules, derived from EPRIM, that consist"?

*         Page 8

o   2.1 Overview

*  "Relationship among Policy, Service and Resource" (appears twice) - should that be "Relationship between Policy, Service and Resource"?

*  Should the caption for Figure 3 end with "models"?

o   2.2 Operation

*  "the goals to achieve" - would "the goals to be achieved" be better?

*         Page 9

o   2.3 The GPIM and the EPRIM

*  The structure of this section feels a little odd. Item (1) appears to repeat a little of what is in the first two paragraphs and I wonder whether the section would be better structured if those two paragraphs were incorporated into item (1).

*         Page 10

o   2.4 Creation of Generic YANG Modules

*  "the addition of new, as well as editing of existing model elements" - should that be "the addition of new, as well as the editing of existing model elements"?

o   Pagination fails on the PDF version of this Internet-Draft. Is this page too long?

Jonathan

> -----Original Message-----

> From: Supa [mailto:[email-masked]] On Behalf Of internet-

> [email-masked]<mailto:[email-masked]>

> Sent: 30 August 2016 04:11

> To: [email-masked]<mailto:[email-masked]>

> Cc: [email-masked]<mailto:[email-masked]>

> Subject: [Supa] I-D Action: draft-ietf-supa-policy-based-management-

> framework-00.txt

> A New Internet-Draft is available from the on-line Internet-Drafts directories.

> This draft is a work item of the Simplified Use of Policy Abstractions of the

> IETF.

>         Title           : SUPA policy-based management framework

>         Authors         : Will(Shucheng) Liu

>                           John Strassner

>                           Georgios Karagiannis

>                           Maxim Klyus

>                           Jun Bi

>                           Chongfeng Xie

>             Filename        : draft-ietf-supa-policy-based-management-

> framework-00.txt

>             Pages           : 14

>             Date            : 2016-08-29

> Abstract:

>    Simplified Use of Policy Abstractions (SUPA) defines base YANG data

>    models to encode policy, which will point to device-, technology-,

>    and service-specific YANG models developed in other working groups.

>    Policy rules within an operator's environment can be used to express

>    high-level, possibly network-wide policies to a network management

>    function (within a controller, an orchestrator, or a network element).

>    The network management function can then control the configuration

>    and/or monitoring of network elements and services. This document

>    describes the SUPA basic framework, its elements and interfaces.

> The IETF datatracker status page for this draft is:

> https://datatracker.ietf.org/doc/draft-ietf-supa-policy-based-management-<https://datatracker.ietf.org/doc/draft-ietf-supa-policy-based-management-framework/>

> framework/<https://datatracker.ietf.org/doc/draft-ietf-supa-policy-based-management-framework/>

> There's also a htmlized version available at:

> https://tools.ietf.org/html/draft-ietf-supa-policy-based-management-<https://tools.ietf.org/html/draft-ietf-supa-policy-based-management-framework-00>

> framework-00<https://tools.ietf.org/html/draft-ietf-supa-policy-based-management-framework-00>

> Please note that it may take a couple of minutes from the time of submission

> until the htmlized version and diff are available at tools.ietf.org.

> Internet-Drafts are also available by anonymous FTP at:

> ftp://ftp.ietf.org/internet-drafts/

> _______________________________________________

> Supa mailing list

> [email-masked]<mailto:[email-masked]>

> https://www.ietf.org/mailman/listinfo/supa

---

From: "Liushucheng (Will)" <[email-masked]>
Date: Mon, 19 Sep 2016 04:07:13 +0000

Dear Dr. Xie,

Just FYI, I checked your email below was not posted here: https://www.ietf.org/mail-archive/web/supa/current/maillist.html

It seems that email server from CT still doesn’t work for IETF mailing list.

Regards,
Will (Shucheng LIU)

From: [email-masked] [mailto:[email-masked]]
Sent: Tuesday, September 13, 2016 5:53 PM
To: Jonathan Hansford; supa
Cc: Liushucheng (Will)
Subject: Re: Re: [Supa] I-D Action: draft-ietf-supa-policy-based-management-framework-00.txt

Hi， Jonathan，

        Thank you for your constructive comments,  we are revising the draft now and improvements will be made based on your comments.

        Best regards

Chongfeng Xie

________________________________
[email-masked]<mailto:[email-masked]>

From: Jonathan Hansford<mailto:[email-masked]>
Date: 2016-09-01 01:49
To: [email-masked]<mailto:[email-masked]>
Subject: Re: [Supa] I-D Action: draft-ietf-supa-policy-based-management-framework-00.txt

Some review comments:

•         General

o   The phrase “the GPIM (or the combination of the GPIM and the EPRIM)” or its equivalent appears a number of times throughout this document so clearly it is important but, coming to SUPA cold, I failed to understand its importance. If there is a need to constantly repeat this phrase, could it not do with further explanation?

•         Page 2

o   1. Introduction

•  “the task of network operations and management applications and deploying new services” – is that one task and, if so, what is it? Should that read “the task of network operations and management applications and deploying new services”?

•         Page 3

o   1. Introduction

•  s/indepednent/independent

•  What is the term “snippet” intended to imply? Should it be defined somewhere?

o   2.1 Overview

•  “The GPIM, as well as the combination of the  GPIM and EPRIM, are converted to generic YANG data modules.” Shouldn’t that be either The GPIM, as well as the combination of the  GPIM and EPRIM, is converted …” or “The GPIM and the combination of the  GPIM and EPRIM are converted …”?

•         Page 4

o   2.1 Overview

•  For consistency with capitalisation, either e.g. “SUPA Generic & ECA Policy YANG Data modules” or “SUPA generic policy YANG data modules”

•         Page 7

o   2.1 Overview

•  None of the arrows with Ds appear to be double-headed and not all of the arrows with Cs

•  Since lower down we have “ECA Policy Rule Information Data Model (EPRIM):” for consistency should we not also have “Generic Policy Information Model (GPIM):”?

•  “query, and implementation languages, and protocol” (appears twice) – should that be “query, and implementation languages, and protocol”?

•  “policy rules for that are” – should that be “”policy rules for that are”?

•  “dependent of” – should that be “independent of” or “dependent on”?

•  “policy rules derived from EPRIM, consist” – should that be “policy rules, derived from EPRIM, that consist”?

•         Page 8

o   2.1 Overview

•  “Relationship among Policy, Service and Resource” (appears twice) – should that be “Relationship between Policy, Service and Resource”?

•  Should the caption for Figure 3 end with “models”?

o   2.2 Operation

•  “the goals to achieve” – would “the goals to be achieved” be better?

•         Page 9

•  The structure of this section feels a little odd. Item (1) appears to repeat a little of what is in the first two paragraphs and I wonder whether the section would be better structured if those two paragraphs were incorporated into item (1).

•         Page 10

•  “the addition of new, as well as editing of existing model elements” – should that be “the addition of new, as well as the editing of existing model elements”?

Jonathan