Subject: [Supa] We need some good examples of what SUPA can do !

From: Nevil Brownlee <[email-masked]>
Date: Thu, 17 Nov 2016 22:31:50 +1300

Hi all:

Your SUPA chairs met this morning with some of the SUPA I-D
authors to consider "how can we get people working on some
simple examples to demonstrate how SUPA could be used."

One idea we considered was "we need a few good example uses,
with clear specs written for each - we could start with the
examples in our (draft) Applicability Statement.  That considers
five examples -

   4.1.  Use Case 1: Switched Ethernet services (SES)
   4.2.  Use Case 2: Virtualized Private Clouds (VPC)
   4.3.  Use Case 3: Traffic Manipulation cross DCs
   4.4.  Use Case 4: Virtual SP
   4.5.  Use Case 5: Instant VPN
   4.6.  Use Case 6: traffic optimization and Qos assurance on ISP DC

It would help SUPA a lot to have input, especially from network
operators, telling us "what do you actually want (SUPA to) do?"

Do please give this some thought, and send your 'wishes' text to
the SUPA list!

Cheers, Nevil

-- 
---------------------------------------------------------------------
  Nevil Brownlee                    Computer Science Department | ITS
  Phone: +64 9 373 7599 x88941             The University of Auckland
  FAX: +64 9 373 7453   Private Bag 92019, Auckland 1142, New Zealand

---

From: "Joel M. Halpern" <[email-masked]>
Date: Thu, 17 Nov 2016 04:55:05 -0500

What I would find particularly useful woulde be examples of policies or 
policy sets that we can show how to represent using the SUPA model.

Yours,
joel

---

From: John Strassner <[email-masked]>
Date: Thu, 17 Nov 2016 22:03:34 +0000

Hi Nevil and Dan,

One of my other roles is the Orchestration Area Co-Director of the MEF. We have the following uses of SUPA artifacts planned:

   1) we will use the SUPA IM and DM as-is, and then add to both, to
       represent policies to manage MEF Third Network Services;
   2) we will use the above SUPA models and extensions in the
       MEF policy-driven orchestration project
   3) we will use the above SUPA models and extensions in the
       MEF OpenLSO project to develop open source tools and
       open source policy systems

We will hopefully be able to share the open source work in a future IETF Hackathon once it is mature and stable.

Best,
John

-----Original Message-----
From: Supa [mailto:[email-masked]] On Behalf Of Nevil Brownlee
Sent: Thursday, November 17, 2016 1:32 AM
To: [email-masked]
Cc: SUPA list <[email-masked]>
Subject: [Supa] We need some good examples of what SUPA can do !

Hi all:

Your SUPA chairs met this morning with some of the SUPA I-D authors to consider "how can we get people working on some simple examples to demonstrate how SUPA could be used."

One idea we considered was "we need a few good example uses, with clear specs written for each - we could start with the examples in our (draft) Applicability Statement.  That considers five examples -

It would help SUPA a lot to have input, especially from network operators, telling us "what do you actually want (SUPA to) do?"

Do please give this some thought, and send your 'wishes' text to the SUPA list!

Cheers, Nevil

_______________________________________________
Supa mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/supa

---

From: "Bert Wijnen (IETF)" <[email-masked]>
Date: Fri, 18 Nov 2016 10:28:09 +0900

Could the proponets of the current (in my view still complex) IM and DM
work out how one would define/configure/populate the policies for:

      ensure that SNMP is blocked on ports at the edge
      of the administrative domain to prevent SNMP going
      out or coming in from outside the enterprise.

This should be simple, no?

Thanks, Bert

---

From: "Joel M. Halpern" <[email-masked]>
Date: Thu, 17 Nov 2016 20:44:45 -0500

Thank you Bert.  That is exactly the kind of request I am looking for.

No, I do not think it will be simple to answer your question.  But I do 
think that showing how to do so will show both what we have and what 
more we need.

Yours,
Joel

---

From: Georgios Karagiannis <[email-masked]>
Date: Wed, 23 Nov 2016 09:56:12 +0000

Hi Bert, 

Thanks for your input.
Please note that I agree with Joel that the input is useful. 
Can you please provide more details on what will be the Event Condition Action?

Best regards,
Georgios

-----Original Message-----
From: Supa [mailto:[email-masked]] On Behalf Of Joel M. Halpern
Sent: Friday, November 18, 2016 2:45 AM
To: Bert Wijnen (IETF); Nevil Brownlee; [email-masked]
Cc: SUPA list
Subject: Re: [Supa] We need some good examples of what SUPA can do !

No, I do not think it will be simple to answer your question.  But I do think that showing how to do so will show both what we have and what more we need.

Yours,
Joel

On 11/17/16 8:28 PM, Bert Wijnen (IETF) wrote:
> Could the proponets of the current (in my view still complex) IM and 
> DM work out how one would define/configure/populate the policies for:
>
>> Your SUPA chairs met this morning with some of the SUPA I-D authors 
>> to consider "how can we get people working on some simple examples to 
>> demonstrate how SUPA could be used."
>>
>> One idea we considered was "we need a few good example uses, with 
>> clear specs written for each - we could start with the examples in 
>> our (draft) Applicability Statement.  That considers five examples -
>>

---

From: "Bert Wijnen (IETF)" <[email-masked]>
Date: Wed, 23 Nov 2016 11:54:56 +0100

> Can you please provide more details on what will be the Event Condition Action?
well, is that not my exact question?

I am asking what ECA policies need to be setup/defined in order to achieve/effectuate a policy that

      ensures that SNMP is blocked on ports at the edge
      of the administrative domain to prevent SNMP going
      out or coming in from outside the enterprise.

Bert

---

From: Georgios Karagiannis <[email-masked]>
Date: Wed, 23 Nov 2016 10:58:20 +0000

Hi Bert,

Okay, I see your point.

Best regards,
Georgios

-----Original Message-----
From: Bert Wijnen (IETF) [mailto:[email-masked]] 
Sent: Wednesday, November 23, 2016 11:55 AM
To: Georgios Karagiannis; Joel M. Halpern; Nevil Brownlee; [email-masked]
Cc: SUPA list
Subject: Re: [Supa] We need some good examples of what SUPA can do !

Bert
>>> to consider "how can we get people working on some simple examples 
>>> to demonstrate how SUPA could be used."
>>>

---

From: "Joel M. Halpern" <[email-masked]>
Date: Wed, 23 Nov 2016 09:33:41 -0500

To some degree Bert, you are demonstrating the limitations of the 
directive from the AD that SUPA is to use only ECA policies, not 
declarative.  Modeling the policy goal would be much easier.

I do believe that with a few extra definitions, we can create a set of 
meaningful events to trigger.  Mostly the insertion of ports at the edge 
of the domain.  And then the actions will be to create the filter rules 
to block SNMP in both directions.

I will be working with John to work out the exact modeling.

Yours,
Joel

On 11/23/16 5:54 AM, Bert Wijnen (IETF) wrote:
>> No, I do not think it will be simple to answer your question.  But I
>> do think that showing how to do so will show both what we have and
>> what more we need.
>>
>> Yours,
>> Joel
>>