Subject: [T2TRG] Fwd: New Version Notification for draft-sarikaya-t2trg-sbootstrapping-03.txt

From: Mohit Sethi <[email-masked]>
Date: Wed, 1 Feb 2017 13:22:40 +0200

Dear all

We have now submitted the next version of the draft on secure 
bootstrapping of IoT devices. The draft is available here:
https://tools.ietf.org/html/draft-sarikaya-t2trg-sbootstrapping-03

The draft has undergone several changes based on the comments we 
received during IETF 96. Most importantly, we have added text on secure 
bootstrapping with Device Provisioning Protocol (DPP) proposed by the 
WiFi Alliance, as well as secure bootstrapping for devices following the 
Thread group specification. We have also added text to the security 
considerations section.

We would really appreciate your feedback and comments so that the 
document can move forward in the research group.

Thanks.
/--Mohit

-------- Forwarded Message --------
Subject: 	New Version Notification for 
draft-sarikaya-t2trg-sbootstrapping-03.txt
Date: 	Wed, 01 Feb 2017 03:20:01 -0800
From: 	[email-masked]
To: 	Behcet Sarikaya <[email-masked]>, Abdur Rashid Sangi 
<[email-masked]>, Mohit Sethi <[email-masked]>, Abdur Sangi 
<[email-masked]>

A new version of I-D, draft-sarikaya-t2trg-sbootstrapping-03.txt
has been successfully submitted by Mohit Sethi and posted to the
IETF repository.

Name:		draft-sarikaya-t2trg-sbootstrapping
Revision:	03
Title:		Secure IoT Bootstrapping: A Survey
Document date:	2017-02-01
Group:		Individual Submission
Pages:		19
URL:https://www.ietf.org/internet-drafts/draft-sarikaya-t2trg-sbootstrapping-03.txt
Status:https://datatracker.ietf.org/doc/draft-sarikaya-t2trg-sbootstrapping/
Htmlized:https://tools.ietf.org/html/draft-sarikaya-t2trg-sbootstrapping-03
Diff:https://www.ietf.org/rfcdiff?url2=draft-sarikaya-t2trg-sbootstrapping-03

Abstract:
    This document presents a survey of secure bootstrapping mechanisms
    available for smart objects that are part of an Internet of Things
    (IoT) network.  It aims to provide a structured classification of the
    available mechanisms.  The document does not prescribe any one secure
    bootstrapping mechanism and rather presents IoT developers with
    different options to choose from, depending on their use-case,
    security requirements and the user interface available on their smart
    objects.

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

---

From: Mohummed Alkathiri <[email-masked]>
Date: Wed, 15 Feb 2017 21:31:19 -0600

Hi Mohit and all,

The classification of IoT bootstrapping methods were very informative for
me but I'm unclear about which particular method is more suitable for IoT?

Do you intend to incorporate this sort of comparison?

*Best Regards,*
* Mohammed S. Alkatheiri **l** Lecturer and  **Senior Researcher*
Ph.D Student: Computer Science Dept. Texas Tech University, TX, USA
Employed:  king Abdulaziz university, Jeddah, Saudi Arbia
Email:  [email-masked]
<javascript:_e(%7B%7D,'cvml',[email-masked]');>,
[email-masked]
<javascript:_e(%7B%7D,'cvml',[email-masked]');>
web site:  http://www.depts.ttu.edu;  http://www.kau.edu.sa

> -----Original Message-----
> From: Mohit Sethi [mailto:[email-masked]
> <javascript:_e(%7B%7D,'cvml',[email-masked]');>]
> Sent: 2017年2月1日 19:23
> To: [email-masked] <javascript:_e(%7B%7D,'cvml',[email-masked]');>
> Cc: [email-masked] <javascript:_e(%7B%7D,'cvml',[email-masked]');>;
> AbdurRashidSangi
> Subject: [T2TRG] Fwd: New Version Notification for
> The draft has undergone several changes based on the comments we received
> during IETF 96. Most importantly, we have added text on secure
> bootstrapping with Device Provisioning Protocol (DPP) proposed by the WiFi
> Alliance, as well as secure bootstrapping for devices following the Thread
> group specification. We have also added text to the security considerations
> section.
>
> We would really appreciate your feedback and comments so that the document
> can move forward in the research group.
>
> Thanks.
> /--Mohit
>
>
>
> <javascript:_e(%7B%7D,'cvml',[email-masked]');>
> To:     Behcet Sarikaya <[email-masked]
> <javascript:_e(%7B%7D,'cvml',[email-masked]');>>, Abdur Rashid Sangi
> <[email-masked]
> <javascript:_e(%7B%7D,'cvml',[email-masked]');>>, Mohit Sethi <
> [email-masked] <javascript:_e(%7B%7D,'cvml',[email-masked]');>>, Abdur
> Sangi <[email-masked]
> <javascript:_e(%7B%7D,'cvml',[email-masked]');>>
>
>
>

-- 
*Best Regards,*

*Eng. Mohammed S. Alkathiri **l** Lecturer and  *Senior Researcher
king Abdulaziz university
King Saud University, KAI Team
Cell Phone (+966) 543337802 (+966) 595501372
phone : 0096626400000 EXT: 74208
Fax (+966)
P.O. Box : 80327
Zip Code : 21589
Email: [email-masked] , [email-masked] -
[email-masked]
King Abdulaziz University web site:  http://www.kau.edu.sa
King Saud University web site: http://www.ksu.edu.sa
<https://mail.ksu.edu.sa/OWA/redir.aspx?C=d5a6fe7ae5134b76b4e92dafa55930a2&URL=http://www.ksu.edu.sa/>