Subject: [T2TRG] Call for Comment: <draft-iab-iotsi-workshop-02> Report from the Internet of Things (IoT) Semantic Interoperability (IOTSI) Workshop 2016

From: William_J_G Overington <[email-masked]>
Date: Tue, 7 Aug 2018 11:14:43 +0100 (BST)

Hi

Suppose please that there are a number of things communicating each with the others, using encoded localizable sentences that are language-independent and manufacturer-independent.

Suppose that a particular thing, let us call it A, can measure the ambient temperature and reply.

Suppose that a particular thing, let us call it B, can measure the ambient air pressure and reply.

Suppose that a particular thing, let us call it E, asks A for the temperature at its location.

E sends A the following.

∫③②③⑨⑥①

(The English localization is as follows.

What is the temperature at your location please?)

A recognises the sentence and measures the temperature.

A then replies to E as follows, using several localizable sentences and some data. The data is the data at the time, so could be different from the value used in this example.

∫①②⑦ ∫③②③⑨⑥① ∫⑨⑧③ ∫③②③⑨⑥② 21.3

(The English localization is as follows.

The following question has been asked.

What is the temperature at your location please?

My answer is as follows.

The temperature at my location in degrees Celsius is as follows. 21.3

)

Suppose now that E sends B the following.

∫③②③⑨⑥①

(The English localization is as follows.

What is the temperature at your location please?)

B can measure ambient air pressure, but not temperature.

B does not recognise the ∫③②③⑨⑥① as B has a list of localizable sentences relevant to its own functions, but does not have a list of every available localizable sentence that is in the standardized list.

However, B is able to use the following localizable sentence.

∫③②③⑨⑦②

(The English localization is as follows.

I do not have the capability to carry out that request.)

So, whenever B does not recognise a localizable sentence that it receives, B simply copies that localizable sentence from its input buffer and includes it in a message together with a ∫③②③⑨⑦② code.

In this particular case that is as follows.

∫①②⑦ ∫③②③⑨⑥① ∫⑨⑧③ ∫③②③⑨⑦② 

(The English localization is as follows.

The following question has been asked.

What is the temperature at your location please?

My answer is as follows.

I do not have the capability to carry out that request.

)

Thus if localizable sentences were to become used for communication between things and also so that they could also be localized so that a human can monitor what is happening in a language of his or her choice, it would not be necessary for each thing on the Internet of Things to be able to recognise and decode every localizable sentence in the standardization document list of localizable sentences. Only the number of localizable sentences needed to carry out its functions would need to be recognised by any particular thing.

However, a monitoring system that could decode any message encoded using any of all of the localizable sentence in the standardization document list would need to be capable of recognizing every localizable sentence in the standardization document list of localizable sentences.

William Overington

Tuesday 7 August 2018

---

From: William_J_G Overington <[email-masked]>
Date: Sat, 11 Aug 2018 16:33:01 +0100 (BST)

Hi

Further to my various comments, please find attached a copy of the document that I wrote explaining the encoding space that I have designed for localizable sentences.

This document was linked from an earlier comment but is posted here as an attachment so that the availability of the document is permanent and not dependent upon the continued existence of the webspace where it is published.

The web address of where the document is published is as follows.

http://www.users.globalnet.co.uk/~ngo/An_encoding_space_designed_for_application_in_encoding_localizable_sentences.pdf

William Overington

Saturday 11 August 2018

----Original message----
>From : [email-masked]
Date : 2018/08/07 - 11:14 (GMTDT)
To : [email-masked], [email-masked], [email-masked]
Subject : Call for Comment: &lt;draft-iab-iotsi-workshop-02&gt; Report from the Internet of Things (IoT) Semantic Interoperability (IOTSI) Workshop 2016

Hi

E sends A the following.

∫③②③⑨⑥①

My answer is as follows.

)

∫③②③⑨⑥①

∫③②③⑨⑦②

My answer is as follows.

)

William Overington

Tuesday 7 August 2018

---

From: William_J_G Overington <[email-masked]>
Date: Sat, 11 Aug 2018 16:56:18 +0100 (BST)

Hi

Further to the original message.

I began researching into communication through the language barrier using encoded localizable sentences some years ago.

The research, at that time, was for human to human communication.

More recently I have added the concept of using localizable sentences for device to device ("thing to thing") communication within the context of The Internet of Things to my research. There is also the concept of using localizable sentences for "human to thing" and for "thing to human" communication, as well as for a human to be able to monitor "thing to thing" communication.

I write to mention that for some time, since before extending the concept to The Internet of Things, I have regarded the collection of encoded localizable sentences available for use as being language Y as that enables diagrams with notes such as

English to Y

and

Y to French

being possible.

I have also used x-y as the code for language Y and although that code is a Private Use code such a Private Use code is allowed.

As a language, language Y is rather unusual in that the atomic concept units of language Y are whole, grammatically stand-alone sentences.

The use of the term language Y and the code x-y can be useful for clarity of explanation in some contexts.

William Overington

Saturday 11 August 2018

----Original message----

Hi

E sends A the following.

∫③②③⑨⑥①

My answer is as follows.

)

∫③②③⑨⑥①

∫③②③⑨⑦②

My answer is as follows.

)

William Overington

Tuesday 7 August 2018

---

From: William_J_G Overington <[email-masked]>
Date: Thu, 30 Aug 2018 10:25:46 +0100 (BST)

Having sent in some comments I am wondering what happens now.

Nobody has thus far responded to my comments and I am wondering what is the process please.

Will something be published some time?

Can anyone supply any information on the process please?

William Overington

Thursday 30 August 2018

---

From: Robert Sparks <[email-masked]>
Date: Thu, 30 Aug 2018 08:05:42 -0500

draft-iab-iotsi-workshop is a report on what was discussed at the 2016 
workshop. The IAB has approved it for publication, and it is now in the 
RFC Editor's hands. It will be published as an RFC in a few weeks.

Your comments have not about the workshop itself, but rather have been 
an attempt to continue or start a different discussion ostensibly on the 
same topic.

For background on this part of the process, you could start with RFC4844 
(and RFC4845 for the IAB stream specifically).

RjS

On 8/30/18 4:25 AM, William_J_G Overington wrote:
> _______________________________________________
> Architecture-discuss mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/architecture-discuss

---

From: William_J_G Overington <[email-masked]>
Date: Thu, 30 Aug 2018 14:57:33 +0100 (BST)

Hi

Thank you for your reply.

Best regards,

William Overington

Thursday 30 August 2018

----Original message----
>From : [email-masked]
Date : 2018/08/30 - 14:05 (GMTDT)
To : [email-masked], [email-masked], [email-masked], [email-masked]
Subject : Re: [T2TRG] [arch-d] Call for Comment: &lt;draft-iab-iotsi-workshop-02&gt; Report from the Internet of Things (IoT) Semantic Interoperability (IOTSI) Workshop 2016

RjS

_______________________________________________
T2TRG mailing list
[email-masked]
https://www.irtf.org/mailman/listinfo/t2trg

---

From: William_J_G Overington <[email-masked]>
Date: Thu, 30 Aug 2018 15:08:22 +0100 (BST)

Hi

In view of the reply, shall we discuss the possible uses of localizable sentences for thing to thing communication in the T2TRg forum?

This message is also being sent to [email-masked] and [email-masked] in case anyone there is interested in joining in a discussion, but please post for the discussion just to the [email-masked] mailing list.

William Overington

Thursday 30 August 2018

----Original message----
>From : wjgo_10009=[email-masked]
Date : 2018/08/30 - 14:57 (GMTDT)
To : [email-masked], [email-masked], [email-masked], [email-masked]
Subject : Re: [arch-d] [T2TRG] Call for Comment: &lt;draft-iab-iotsi-workshop-02&gt; Report from the Internet of Things (IoT) Semantic Interoperability (IOTSI) Workshop 2016

Hi

Best regards,

William Overington

Thursday 30 August 2018

----Original message----

RjS

---

From: Ari Keränen <[email-masked]>
Date: Thu, 30 Aug 2018 14:58:23 +0000

Hi William,

If there is interest in the topic in the RG, we can certainly discuss it here.

I haven't had a chance to look in detail in your work, but based on a quick look I was wondering how it relates to the work already done at the IETF and various other organizations? 

As Thorsten pointed out earlier, CoAP [1] with JSON [2] or CBOR [3] provides a generic solution for (also constrained) IoT communication. For more specific use cases, e.g., sensor data, IETF has specified data models such as SenML [4] with more defined semantics. For semantics and vocabularies for a variety of use cases there are standardization activities such as iot.schema.org [5] ongoing. Examples of how these technologies can work together in a full system can be found e.g., from W3C WoT, OCF, and OMA SpecWorks LwM2M.

Cheers,
Ari

[1] https://tools.ietf.org/html/rfc7252
 (see also https://datatracker.ietf.org/wg/core/documents/)
[2] https://tools.ietf.org/html/rfc8259
[3] https://tools.ietf.org/html/rfc7049
 (see also https://datatracker.ietf.org/wg/cbor/documents/)
[4] https://tools.ietf.org/html/draft-ietf-core-senml-16
[5] http://iotschema.org/

> On 30 Aug 2018, at 17.08, William_J_G Overington <wjgo_10009=[email-masked]> wrote:
> 
> Hi
>

---

From: William_J_G Overington <[email-masked]>
Date: Thu, 30 Aug 2018 17:06:39 +0100 (BST)

Hi

Thank you for replying.

> I haven't had a chance to look in detail in your work, but based on a quick look I was wondering how it relates to the work already done at the IETF and various other organizations? 

Well, the fact of the matter is that I do not know. The call for comments seemed to me to be discussing interoperability issues between devices made by various manufacturers. That seemed to me to be a similar problem to people who speak different languages trying to communicate. So I made the suggestion.

I devised localizable sentences in 2009 for human to human communication through the language barrier: the idea is not to encode every possible sentence and the idea is not intended to be able to do everything, or even a lot, but that it could be very useful in some specific circumstances. For example, when trying to find out information about relatives and friends after a disaster in a foreign land where a different language is spoken.

The following might be helpful to understand the concepts, though the first one is from some years ago and there have been some detail changes later yet the overall concept is still the same.

http://www.users.globalnet.co.uk/~ngo/locse027_four_simulations.pdf

http://www.users.globalnet.co.uk/~ngo/localizable_sentences_the_novel_chapter_042.pdf

Some time ago I wondered whether localizable sentences could be used for human to device communication, device to device communication, device to human communication. Each human and each device would communicate with the Internet of Things using localizable sentences all to a common standard and each human would himself or herself use their own language themselves otherwise  and each device would use its own software format itself otherwise.

Encoding a message by a human would be from a cascading menu in his or her own language.

Encoding a message by a device would be within its software.

> As Thorsten pointed out earlier, CoAP [1] with JSON [2] or CBOR [3] provides a generic solution for (also constrained) IoT communication. For more specific use cases, e.g., sensor data, IETF has sp…

I know almost nothing about the Internet of Things. Maybe what I am suggesting is of no use whatsoever in relation to the Internet of Things. Yet maybe it could be of some usefulness. I just do not know. So that is why I am seeking a discussion.

For example, I am thinking that localizable sentences could be used with email enquiries to devices and email responses from devices. Would that be helpful in some circumstances for people to use?

Best regards,

William Overington

Thursday 30 August 2018

----Original message----
>From : [email-masked]
Date : 2018/08/30 - 15:58 (GMTDT)
To : [email-masked]
Cc : [email-masked]
Subject : Re: [T2TRG] Localizable sentences for thing to thing communication

Hi William,

Cheers,
Ari

---

From: William_J_G Overington <[email-masked]>
Date: Fri, 31 Aug 2018 10:24:34 +0100 (BST)

I have found this rather nice diagrammatic presentation of JSON.

http://json.org/

William Overington

Friday 31 August 2018