Subject: [T2TRG] T2TRG @ IETF103

From: Ari Keränen <[email-masked]>
Date: Fri, 24 Aug 2018 14:39:26 +0000

IETF103 in Bangkok is coming up.  With respect to T2TRG activities there, we are currently looking at:

* Another WISHI hackathon on Sat/Sun before the IETF week
* A summary meeting during the week

We are also looking at scheduling some "work time".  The agenda experiment that will run in Bangkok might make it possible to schedule the Friday morning (09:30 to 13:30) for that.  Is that something that we should pursue?

Potential agenda items could include:

* What exactly is it that IoT applications are going to do with semantic information?  This might reflect in semantic APIs.  Can you interact based on semantic descriptors only (not requiring hardwired application knowledge)?  How do semantics enter the developer lifecycle, and where in the development/deployment lifecycle do you reference semantics (including via W3C WoT Thing Descriptions (TDs))?
* Attaching semantics to models / instances of descriptive data (sometimes called "semantic styles").
* Way forward on resource directory, web linking, data hubs; mapping between these, mapping between these and other formats such as W3C WoT TD; vocabulary issues between ecosystems.

and two more down-to-earth ones:

* Extracting information from binary strings: Description at model level, translation to JSON/CBOR (should be motivated by specific examples from existing standards such as Modbus, KNX, etc.)
* Infrastructure support for experiments, e.g.:
 * Setting up security information to be used in interop
 * Test descriptions and what exactly would that be for the work we are doing now

We’ll need to make a selection based on what people can bring to the table, so please speak up if you think you will have a contribution to discuss about any of these subjects (or one that we missed) by Bangkok.  We also will want to start discussing some of these issues at the (soon to be resumed after vacation time) regular WISHI call; again, speak up if you have input for one of those.

Thanks,
Carsten & Ari

---

From: Jungha Hong <[email-masked]>
Date: Wed, 29 Aug 2018 06:45:49 +0000

Dear T2TRG chairs,

We submitted a draft on IoT Edge Computing (draft-hong-iot-edge-computing) in July and tried to present it at IETF 102.
But, as you know, we did not make it since there was no time and the security session was only held in the last Montreal meeting.
Although we could not present it, we had some discussion on the mailing list.
We would like to continue the discussion on IoT Edge Computing and present the updated draft at IETF 103 if possible.

So, we are wondering what T2TRG at IETF 103 is planning on IoT Edge Computing session which was mentioned by chairs at IETF 102.

Thanks,

Jungha Hong

________________________________
보낸 사람 : "Ari Keränen" <[email-masked]>
보낸 날짜 : 2018-08-24 23:39:52 ( +09:00 )
받는 사람 : [email-masked] <[email-masked]>
참조 : Carsten Bormann <[email-masked]>
제목 : [T2TRG] T2TRG @ IETF103

Thanks,

Carsten & Ari

_______________________________________________

T2TRG mailing list

[email-masked]

https://www.irtf.org/mailman/listinfo/t2trg