Subject: Re: [T2TRG] Localizable sentences for thing to thing communication

From: William_J_G Overington <[email-masked]>
Date: Fri, 31 Aug 2018 13:55:40 +0100 (BST)

Hi

I am looking at the definitions in the http://json.org/ web page.

I refer to my post of 2018-08-07 that is in the https://mailarchive.ietf.org/arch/browse/t2trg/ archive.

> Suppose that a particular thing, let us call it A, can measure the ambient temperature and reply.

> Suppose that a particular thing, let us call it E, asks A for the temperature at its location.

> E sends A the following.

> ∫③②③⑨⑥①

> (The English localization is as follows.

> What is the temperature at your location please?)

I am wondering how to JSONize the ∫③②③⑨⑥① string so that it could be used with established Internet of Things protocols.

----

Would it be as follows?

{"LOCSE":"∫③②③⑨⑥①"}

where LOCSE would be used to designate that the object is a message encoded using one or more localizable sentences, each localizable sentence being either a coded string on its own or a coded string that is the first value of an array of values, a value in the JSON sense of the word value.

Thus, for example, when E replies to A,

{"LOCSE":["∫③②③⑨⑥②",21.3]}

so as to convey the message, which localizes into English as follows.

The temperature at my location in degrees Celsius is as follows. 21.3

Thus a longer message, such as in the earlier post to which I referred,

> ∫①②⑦ ∫③②③⑨⑥① ∫⑨⑧③ ∫③②③⑨⑥② 21.3

> (The English localization is as follows.

> The following question has been asked.

> What is the temperature at your location please?

> My answer is as follows.

> The temperature at my location in degrees Celsius is as follows. 21.3

)

would be JSONized as follows.

{"LOCSE":["∫①②⑦","∫③②③⑨⑥①","∫⑨⑧③","∫③②③⑨⑥②",21.3]}

----
 
or what please?
 
----

How would the appropriate object be sent so as to comply with the established protocols of the Internet of Things please?

William Overington

Friday 31 August 2018

----Original message----
>From : wjgo_10009=[email-masked]
Date : 2018/08/31 - 10:24 (GMTDT)
To : [email-masked]
Cc : [email-masked]
Subject : Re: [T2TRG] Localizable sentences for thing to thing communication

I have found this rather nice diagrammatic presentation of JSON.

http://json.org/

William Overington

Friday 31 August 2018

_______________________________________________
T2TRG mailing list
[email-masked]
https://www.irtf.org/mailman/listinfo/t2trg

---

From: William_J_G Overington <[email-masked]>
Date: Fri, 31 Aug 2018 14:08:19 +0100 (BST)

Hi

My apologies, in my previous post I wrote as follows.

> Thus, for example, when E replies to A, 

That should have been as follows:

Thus, for example, when A replies to E,

William Overington

Friday 31 August 2018

----Original message----
>From : wjgo_10009=[email-masked]
Date : 2018/08/31 - 13:55 (GMTDT)
To : [email-masked]
Subject : Re: [T2TRG] Localizable sentences for thing to thing communication

Hi

----

Would it be as follows?

{"LOCSE":"∫③②③⑨⑥①"}

)

----
 
or what please?
 
----

William Overington

Friday 31 August 2018

----Original message----

http://json.org/

William Overington

Friday 31 August 2018