Subject: [tap] Bikeshed: TAP document vs. TAP stream

From: Salve J Nilsen <[email-masked]>
Date: Tue, 2 Mar 2010 16:52:34 +0100 (CET)

Hey folks

Just did a quick "Google ranking" of the use of "document" vs. 
"stream":

   http://www.google.com/search?q=Perl+%22TAP+document%22
   http://www.google.com/search?q=Perl+%22TAP+stream%22

"Document" gives 110-ish hits and "stream" about 370 hits. Should we 
try to standardize on "stream" in the TAP spec?

I'm just raising this issue because I think "TAP document" sounds a 
litte weird to say after having looked at the output of "make test" 
enough times. It always seemed to me like a stream of data than a 
fixed document. "Stream" is also closer to the "protocol" paradigm 
than "document", IMO.

Sorry about the bikeshedding, but clarity and consistency is also 
nice to have. :)

So, what do people think? Should the TAP spec use "stream" instead of 
"document" where "document" is used now?

stream++

- Salve

-- 
#!/usr/bin/perl
sub AUTOLOAD{$AUTOLOAD=~/.*::(\d+)/;seek(DATA,$1,0);print#  Salve Joshua Nilsen
getc DATA}$"="'};&{'";@_=unpack("C*",unpack("u*",':4@,$'.#     <[email-masked]>
'2!--"5-(50P%$PL,!0X354UC-PP%/0\`'."\n"));eval "&{'@_'}";   __END__ is near! :)

---

From: Ovid <[email-masked]>
Date: Tue, 2 Mar 2010 07:56:48 -0800 (PST)

--- On Tue, 2/3/10, Salve J Nilsen <[email-masked]> wrote:

> From: Salve J Nilsen <[email-masked]>

> "Document" gives 110-ish hits and "stream" about 370 hits.
> Should we try to standardize on "stream" in the TAP spec?

It should say "stream".  One problem with many XML test formats is that you must have the entire document to analyze results.  This is not needed for a TAP stream.

Cheers,
Ovid
--
Buy the book         - http://www.oreilly.com/catalog/perlhks/
Tech blog            - http://use.perl.org/~Ovid/journal/
Twitter              - http://twitter.com/OvidPerl
Official Perl 6 Wiki - http://www.perlfoundation.org/perl6

---

From: Andy Armstrong <[email-masked]>
Date: Tue, 2 Mar 2010 21:26:15 +0000

On 2 Mar 2010, at 15:52, Salve J Nilsen wrote:
> So, what do people think? Should the TAP spec use "stream" instead of "document" where "document" is used now?

stream++

Maybe there'd be a context in which one would want to refer to a TAP document but stream should be the default I think.

-- 
Andy Armstrong, Hexten

---

From: Shlomi Fish <[email-masked]>
Date: Wed, 3 Mar 2010 00:26:47 +0200

On Tuesday 02 Mar 2010 23:26:15 Andy Armstrong wrote:
> Maybe there'd be a context in which one would want to refer to a TAP
> document but stream should be the default I think.

+1 to stream++ too.

Regards,

	Shlomi Fish

-- 
-----------------------------------------------------------------
Shlomi Fish       http://www.shlomifish.org/
List of Portability Libraries - http://shlom.in/port-libs

Deletionists delete Wikipedia articles that they consider lame.
Chuck Norris deletes deletionists whom he considers lame.

Please reply to list if it's a mailing list post - http://shlom.in/reply .

---

From: Salve J Nilsen <[email-masked]>
Date: Fri, 5 Mar 2010 16:19:03 +0100 (CET)

>> document but stream should be the default I think.

Ok, I've updated the wiki text with this now. :)

- Salve

---

From: Aristotle Pagaltzis <[email-masked]>
Date: Mon, 15 Mar 2010 13:33:06 +0100

* Salve J Nilsen <[email-masked]> [2010-03-02 16:45]:
> So, what do people think? Should the TAP spec use "stream"
> instead of "document" where "document" is used now?

Yes, or at least for the most part. The way I see it is that
a TAP document is an archived TAP stream. The stream angle is
more fundamental, but the document angle may be necessary in
describing some use cases.

Regards,
-- 
Aristotle Pagaltzis // <http://plasmasturm.org/>