Subject: Re: [Taps] I-D Action: draft-ietf-taps-transports-03.txt

From: Karen Elisabeth Egede Nielsen <[email-masked]>
Date: Mon, 16 Mar 2015 23:54:13 +0100

HI,

Please accept the following "minor" comments/questions to the TCP protocol
components:

#1:
The list include both of the followings:

*ordered delivery for each byte stream
* stream-oriented delivery in a single stream

Wouldn't it be more fair to combine these two and say:

*ordered delivery in a single stream

"Each stream" seems a little too much for TCP, I think.

#2:
Segmentation and bundling is listed as separate components, even if
bundling, for TCP, is part of the segmentation process.
I suppose that is as it should be, but when speaking "Bundling" then I
actually think that "Bundling delay" is a better term. Especially for TCP.

To put in context:
For SCTP it is actually relevant to discuss bundling and bundling delay
separately  as two different components.
Meaning that SCTP WILL bundle PDUs up to PMTU size (and I would call that
bundling), but it CAN (depending on no_delay setting) implement bundling
delay or not.

BR, Karen

>-----Original Message-----
>From: Taps [mailto:[email-masked]] On Behalf Of internet-
>[email-masked]
>Sent: Friday, February 27, 2015 1:52 PM
>To: [email-masked]
>Cc: [email-masked]
>Subject: [Taps] I-D Action: draft-ietf-taps-transports-03.txt
>
>
>A New Internet-Draft is available from the on-line Internet-Drafts
directories.
> This draft is a work item of the Transport Services Working Group of the
IETF.
>
>        Title           : Services provided by IETF transport protocols
and congestion
>control mechanisms
>        Authors         : Godred Fairhurst
>                          Brian Trammell
>                          Mirja Kuehlewind
>	Filename        : draft-ietf-taps-transports-03.txt
>	Pages           : 25
>	Date            : 2015-02-27
>
>Abstract:
>   This document describes services provided by existing IETF protocols
>   and congestion control mechanisms.  It is designed to help
>   application and network stack programmers and to inform the work of
>   the IETF TAPS Working Group.
>
>
>The IETF datatracker status page for this draft is:
>https://datatracker.ietf.org/doc/draft-ietf-taps-transports/
>
>There's also a htmlized version available at:
>http://tools.ietf.org/html/draft-ietf-taps-transports-03
>
>A diff from the previous version is available at:
>http://www.ietf.org/rfcdiff?url2=draft-ietf-taps-transports-03
>
>
>Please note that it may take a couple of minutes from the time of
submission
>until the htmlized version and diff are available at tools.ietf.org.
>
>Internet-Drafts are also available by anonymous FTP at:
>ftp://ftp.ietf.org/internet-drafts/
>
>_______________________________________________
>Taps mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/taps

---

From: Michael Welzl <[email-masked]>
Date: Tue, 17 Mar 2015 10:09:19 +0000

Hi,

> On 16 Mar 2015, at 23:54, Karen Elisabeth Egede Nielsen <[email-masked]> wrote:
> 
> HI,
> 

So how does bundling without delaying work?

Cheers,
Michael

---

From: Karen Elisabeth Egede Nielsen <[email-masked]>
Date: Tue, 17 Mar 2015 12:26:14 +0100

Hi,

>From: Michael Welzl [mailto:[email-masked]]
>Sent: Tuesday, March 17, 2015 11:09 AM
>To: Karen Elisabeth Egede Nielsen
>Cc: [email-masked]
>Subject: Re: [Taps] I-D Action: draft-ietf-taps-transports-03.txt
>
>Hi,
>
>
>> For SCTP it is actually relevant to discuss bundling and bundling
>> delay separately  as two different components.
>> Meaning that SCTP WILL bundle PDUs up to PMTU size (and I would call
>> that bundling), but it CAN (depending on no_delay setting) implement
>> bundling delay or not.
>
[Karen ]
If there are multiple messages available for transmittal in the SND
buffer. E.g.,
2 messages of 600 bytes would be bundled into the same SCTP packet.
This of course is only in situations where there has been congestion or
receiver window blocking.

For TCP this "bundling" of data bytes is part of the basic segment
partitioning of the data byte stream.

BR, Karen

---

From: Michael Welzl <[email-masked]>
Date: Tue, 17 Mar 2015 12:01:28 +0000

> On 17 Mar 2015, at 12:26, Karen Elisabeth Egede Nielsen <[email-masked]> wrote:
> 
> Hi,
> 

Ok, thanks...  yes this is indeed different from "Nagle'ing"...

Cheers,
Michael

---

From: Michael Tuexen <[email-masked]>
Date: Tue, 17 Mar 2015 13:47:04 +0100

> On 17 Mar 2015, at 11:09, Michael Welzl <[email-masked]> wrote:
> 
> Hi,
> 
> 
cwnd doesn't allow you to send, a_rwnd doesn't allow you to send, you have
a send() call which allows to provide multiple user messages, ...

Best regards
Michael