Subject: Re: [Taps] I-D Action: draft-ietf-taps-transports-02.txt

From: Karen Elisabeth Egede Nielsen <[email-masked]>
Date: Mon, 16 Mar 2015 22:09:50 +0100

Hi,

Do we actually know what we mean by
"Mode" and by the terms "dgram" and "stream"  in this respect ?
 I personally lost track of what this meant exactly when we moved beyond
TCP and UDP.

Some more comments to the table - I think that the following features are
missing:

* reliable unordered delivery

 * unreliable unordered delivery

BR, Karen

>-----Original Message-----
>From: Taps [mailto:[email-masked]] On Behalf Of Michael Tuexen
>Sent: Tuesday, February 10, 2015 8:06 PM
>To: Gorry Fairhurst
>Cc: taps WG
>Subject: Re: [Taps] I-D Action: draft-ietf-taps-transports-02.txt
>
>> On 09 Feb 2015, at 17:48, Gorry Fairhurst <[email-masked]> wrote:
>>
>>
>>
>> This version includes my first go at a table, in section 4.1, I'm
hoping this will
>stimulate some input/corrections, or even perhaps alternate list of what
to
>see here. Please discuss, or send comments via the TAPS list.
>Hi Gorry,
>
>maybe I didn't understand the table entries correctly, but I think the
following
>changes improve the description of SCTP:
>https://github.com/britram/taps-transports/pull/1
>
>* SCTP is message oriented, so Dgram seems to be more appropriate than
>Stream.
>* Bundling of DATA chunks and the Nagle algorithm is supported, so
multiple
>  user messages can fit into a single IP packet.
>* ECN support needs to be clarified.
>
>Best regards
>Michael
>>
>> gorry
>>
>>
>>
>> straw On 07/02/2015 12:41, Brian Trammell wrote:
>>> Greetings, all,
>>>
>>> We've submitted the -02 rev of the transports document, addressing
>comments to date and including additional content for some of the
transport
>protocols.
>>>
>>> Markdown (kramdown-rfc2629) source and toolchain is available at
>https://github.com/britram/taps-transports. Subsection authors: feel free
to
>send pull requests against either the markdown or XML source (we'll
convert
>the latter back to the former) or text to the editors via email. We'd
like to get
>at least one more rev of the document out before Dallas.
>>>
>>> Not-yet-subsection-authors who would like to contribute: there are a
>couple of sections we'd like to have (HTTP(S) as a pseudotransport, and
>WebSockets which removes some of the "pseudo" therefrom) that don't yet
>have contributors associated; additionally, if there are transport (or
transport-
>like) protocols we're missing here, please send text and we'll get it
integrated.
>>>
>>> Many thanks, best regards,
>>>
>>> Brian (for the editors of taps-transports).
>>>
>>>> Begin forwarded message:
>>>>
>>>> From: [email-masked]
>>>> To: <[email-masked]>
>>>> Date: 7 Feb 2015 13:07:02 CET
>>>> Cc: [email-masked]
>>>> Subject: [Taps] I-D Action: draft-ietf-taps-transports-02.txt
>>>>
>>>>
>>>> A New Internet-Draft is available from the on-line Internet-Drafts
>directories.
>>>> This draft is a work item of the Transport Services Working Group of
the
>IETF.
>>>>
>>>>        Title           : Services provided by IETF transport
protocols and
>congestion control mechanisms
>>>>        Authors         : Godred Fairhurst
>>>>                          Brian Trammell
>>>>                          Mirja Kuehlewind
>>>> 	Filename        : draft-ietf-taps-transports-02.txt
>>>> 	Pages           : 20
>>>> 	Date            : 2015-02-07
>>>>
>>>> Abstract:
>>>>   This document describes services provided by existing IETF
protocols
>>>>   and congestion control mechanisms.  It is designed to help
>>>>   application and network stack programmers and to inform the work of
>>>>   the IETF TAPS Working Group.
>>>>
>>>>
>>>> The IETF datatracker status page for this draft is:
>>>> https://datatracker.ietf.org/doc/draft-ietf-taps-transports/
>>>>
>>>> There's also a htmlized version available at:
>>>> http://tools.ietf.org/html/draft-ietf-taps-transports-02
>>>>
>>>> A diff from the previous version is available at:
>>>> http://www.ietf.org/rfcdiff?url2=draft-ietf-taps-transports-02
>>>>
>>>>
>>>> Please note that it may take a couple of minutes from the time of
>>>> submission until the htmlized version and diff are available at
>tools.ietf.org.
>>>>
>>>> Internet-Drafts are also available by anonymous FTP at:
>>>> ftp://ftp.ietf.org/internet-drafts/
>>>>
>>>> _______________________________________________
>>>> Taps mailing list
>>>> [email-masked]
>>>> https://www.ietf.org/mailman/listinfo/taps
>>>
>>>
>>>
>>> _______________________________________________
>>> Taps mailing list
>>> [email-masked]
>>> https://www.ietf.org/mailman/listinfo/taps
>>>
>>
>> _______________________________________________
>> Taps mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/taps
>>
>
>_______________________________________________
>Taps mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/taps

---

From: Salvatore Loreto <[email-masked]>
Date: Sat, 21 Mar 2015 12:39:47 +0000

Hi there

in 03 is still not assigned
so if you have not got any volunteer yet for WebSocket section
I can volunteer for it!

br
/Salvatore

> On 07 Feb 2015, at 12:41, Brian Trammell <[email-masked]> wrote:
> 
> Not-yet-subsection-authors who would like to contribute: there are a couple of sections we'd like to have (HTTP(S) as a pseudotransport, and WebSockets which removes some of the "pseudo" therefrom) that don't yet have contributors associated; additionally, if there are transport (or transport-like) protocols we're missing here, please send text and we'll get it integrated.

---

From: Mirja Kühlewind <[email-masked]>
Date: Mon, 23 Mar 2015 13:22:51 -0500

Hi Salvatore,

not sure Brian ever answered to this mail. We already have Dragana Damjanovic who volunteered to help with Websocket. However, as you just might have seen on the slides we’ve put your name down for Websockets as well. Please coordinate with Dragana.

Thanks!
Mirja

> Am 21.03.2015 um 07:39 schrieb Salvatore Loreto <[email-masked]>:
> 
> Hi there
>