Subject: [Taps] What about draft-moncaster-tsvwg-transport-services ?

From: Michael Welzl <[email-masked]>
Date: Sat, 30 Jan 2016 09:40:35 +0100

Hi everyone,

Looking at the current charter items, when TAPS is over, folks will see RFCs describing services of transports, an overview of what a TAPS system should provide, and how it could be implemented - but they do lack background unless they read stuff elsewhere: why is a TAPS system even needed? What is so important about it? What are its benefits, compared to simply building your own protocol?

I think it makes sense to provide these answers in an RFC. As part of the effort to motivate the need for TAPS, such text was written up in draft-moncaster-tsvwg-transport-services
https://tools.ietf.org/html/draft-moncaster-tsvwg-transport-services-01 <https://tools.ietf.org/html/draft-moncaster-tsvwg-transport-services-01>

Is this group interested in taking this document further? What do y’all think?

Cheers,
Michael

---

From: Joe Touch <[email-masked]>
Date: Sat, 30 Jan 2016 20:12:43 -0800

This might be a useful document, but it seems like it overlooks a few
"elephants in the room":

1) lots of services use TCP or UDP because they want to work through NATs

2) lots of services do just fine with the services provided by TCP or UDP

It would be useful to address those issues head-on. Otherwise, this
really looks like a group that's looking under its own lamppost for
solutions.

Joe

On 1/30/2016 12:40 AM, Michael Welzl wrote:
> Hi everyone,
> 
> Looking at the current charter items, when TAPS is over, folks will see
> RFCs describing services of transports, an overview of what a TAPS
> system should provide, and how it could be implemented - but they do
> lack background unless they read stuff elsewhere: why is a TAPS system
> even needed? What is so important about it? What are its benefits,
> compared to simply building your own protocol?
> 
> I think it makes sense to provide these answers in an RFC. As part of
> the effort to motivate the need for TAPS, such text was written up in
> draft-moncaster-tsvwg-transport-services
> https://tools.ietf.org/html/draft-moncaster-tsvwg-transport-services-01
> 
> _______________________________________________
> Taps mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/taps
>

---

From: Michael Welzl <[email-masked]>
Date: Sun, 31 Jan 2016 08:59:49 +0100

Perfectly fine by me to incorporate that!
The main question on the table is: provided that we'll incorporate such comments, should this be a product of the WG?
You say “this might be a useful document”, so I take that as a “yes” from you…

Cheers,
Michael

> On 31. jan. 2016, at 05.12, Joe Touch <[email-masked]> wrote:
>

---

From: [email-masked]
Date: Sun, 31 Jan 2016 15:05:33 -0000

I think documents that describe how the IETF got to decisions can be
useful, providing useful insights to why things emerged.

However, I think they are more usefully published as an RFC when the WG
heads towards the end of the design process - when its can be clearer what
they need to contain - an ID can exist and evolve to capture the inputs as
the WG heads towards its milestones.

Gorry

> The main question on the table is: provided that we'll incorporate such
> comments, should this be a product of the WG?

---

From: Michael Welzl <[email-masked]>
Date: Sun, 31 Jan 2016 18:07:25 +0100

this makes a lot of sense to me

Sent from my iPhone

> On 31. jan. 2016, at 16.05, [email-masked] wrote:
>