Subject: [Taps] plans for draft-welzl-taps-transports?

From: Aaron Falk <[email-masked]>
Date: Wed, 6 Jan 2016 17:13:59 -0500

Hi Michael, et al-

Now that we've settled the first doc, what is the plan for completing your
proposed approach (which I'll refer to as doc 1b)?  As a strawman, let me
suggest that you extend the 1b draft to include the additional protocols to
be included and the authors of the analogous sections from doc 1 perform
the 3 pass analysis, perhaps with some assistance from you and your
co-authors.  I'm open to alternative proposals but would like to figure out
where we are going while the year is still fresh and uncluttered. :)

An initial step is to submit the draft as a wg doc.  Since just
substituting "ietf' for "welzl" will cause the draftstring to collide with
doc 1, I suggest something like draft-ietf-taps-3pass.

--aaron

---

From: Michael Welzl <[email-masked]>
Date: Thu, 7 Jan 2016 11:55:11 +0100

Aaron, all,

In fact we've been working on an update, which I should be able to post VERY soon - sorry for keeping you in the dark while this takes a little longer than expected!
More below:

> On 06 Jan 2016, at 23:13, Aaron Falk <[email-masked]> wrote:
> 
> Hi Michael, et al-
> 
> Now that we've settled the first doc, what is the plan for completing your proposed approach (which I'll refer to as doc 1b)?  As a strawman, let me suggest that you extend the 1b draft to include the additional protocols to be included and the authors of the analogous sections from doc 1 perform the 3 pass analysis, perhaps with some assistance from you and your co-authors.  I'm open to alternative proposals but would like to figure out where we are going while the year is still fresh and uncluttered. :)

I agree about involving the folks from doc 1 if they're willing - but I don't think we need to be strict about this mapping: whoever volunteers should be welcome, I think. That's because the workload is probably much higher for most protocols, and overall it's quite a different task, so let's see...

The update that I'll post soon is almost ready now, it contains:

> >>> - addressing the many comments by Gorry
> >>> - addressing the comments by Karen on the TAPS list
> >>> - fixing the language chaos, to make use of one terminology that's in line with the other TAPS document
> >>> - an appendix explaining how to contribute
> >>> - many other fixes

For the version following this, we have Gorry up for UDP and Christoph Paasch has already volunteered for MPTCP.

> An initial step is to submit the draft as a wg doc.  Since just substituting "ietf' for "welzl" will cause the draftstring to collide with doc 1, I suggest something like draft-ietf-taps-3pass.

I like how Stein put it in his presentation in Yokohama: draft-ietf-taps-transports explains what transport service features exist, whereas draft-welzl-taps-transports explains how to use them.
Hence I suggest: draft-ietf-taps-transport-usage

... and this will already be the updated version, coming VERY soon (maybe even today or tomorrow). Ok?

Cheers,
Michael

---

From: Aaron Falk <[email-masked]>
Date: Thu, 7 Jan 2016 14:50:48 -0500

On Thu, Jan 7, 2016 at 5:55 AM, Michael Welzl <[email-masked]> wrote:

> In fact we've been working on an update, which I should be able to post
> VERY soon - sorry for keeping you in the dark while this takes a little
> longer than expected!
>

Great!

> I like how Stein put it in his presentation in Yokohama:
> draft-ietf-taps-transports explains what transport service features exist,
> whereas draft-welzl-taps-transports explains how to use them.
Works for me.

> even today or tomorrow). Ok?

Terrific!

--aaron