Subject: [Taps] extending the meeting a few minutes to accommodate another talk

From: Aaron Falk <[email-masked]>
Date: Sun, 17 Jul 2016 13:22:45 +0200

Hi Folks-

Yesterday there was an interesting talk at the IRTF/ACM Applied Networking Research Workshop that is relevant to TAPS.  Since our slot is only an hour and our agenda already full, I would like to propose extending the meeting 10 minutes to accommodate it.  We’ll be eating into the free time before the Bits-and-Bytes social so I don’t think anyone will miss any scheduled activities but I am aware that folks sometimes schedule meetings during the breaks.  I hope this doesn’t inconvenience anyone.  

Here is the abstract of the ANRW talk and the updated agenda:

Implementing Real-Time Transport Services over an Ossified Network

Stephen McQuistin (University of Glasgow), Colin Perkins (University of Glasgow), and Marwan Fayed (University of Stirling)

Real-time applications require a set of transport services not currently provided by widely-deployed transport protocols. Ossification prevents the deployment of novel protocols, restricting solutions to protocols using either TCP or UDP as a substrate. We describe the transport services required by real-time applications. We show that, in the short-term (i.e., while UDP is blocked at current levels), TCP offers a feasible substrate for providing these services. Over the longer term, protocols using UDP may reduce the number of networks blocking UDP, enabling a shift towards its use as a demultiplexing layer for novel transport protocols.  

https://irtf.org/anrw/2016/anrw16-final25.pdf 

Updated TAPS agenda:

1. Chairs update - 5min

2. Update on draft-ietf-taps-transports-usage - 10 min (Naeem Khademi ) – updated draft promised by the authors. 

3. Update on draft-fairhurst-taps-transports-usage-udp - 5 min (Gorry Fairhurst) – already updated.

4. Update on draft-gjessing-taps-minset - 10 min (Michael Welzl) - updated draft promised by the authors. 

5. Investigation on the use on happy eyeballs for transport protocol selection - 10 min (Anna Brunström)

6. Post socket - 10 min (Brian Trammell)

7. Socket intents - 5 min (Philipp Tiesel) 

8. Implementing Real-Time Transport Services over an Ossified Network - 10 miin (Stephen McQuistin)

See you Thursday, 

—aaron

---

From: Brian Trammell <[email-masked]>
Date: Sun, 17 Jul 2016 13:27:02 +0200

hi Aaron,

> On 17 Jul 2016, at 13:22, Aaron Falk <[email-masked]> wrote:
> 
> Hi Folks-
> 

I can do these as a lightning talk to make this go faster. So, s/10 min/5 min/..

Cheers,

Brian

> _______________________________________________
> Taps mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/taps

---

From: Aaron Falk <[email-masked]>
Date: Sun, 17 Jul 2016 13:28:59 +0200

OK but information is lost with excessive compression.  So, no heroics.  :)

—aaron

> On Jul 17, 2016, at 1:27 PM, Brian Trammell <[email-masked]> wrote:
> 
> hi Aaron,
> 
>> [email-masked] <mailto:[email-masked]>
>> https://www.ietf.org/mailman/listinfo/taps <https://www.ietf.org/mailman/listinfo/taps>
> 
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/taps <https://www.ietf.org/mailman/listinfo/taps>

---

From: Brian Trammell <[email-masked]>
Date: Sun, 17 Jul 2016 13:31:11 +0200

> On 17 Jul 2016, at 13:28, Aaron Falk <[email-masked]> wrote:
> 

It'll be a lightning talk in the sense of "it's an ad to read the rest of the slides, and come talk to us if you have questions".

Cheers,

Brian

---

From: Spencer Dawkins at IETF <[email-masked]>
Date: Sun, 17 Jul 2016 13:55:22 +0200

Hi, Aaron,

On Sun, Jul 17, 2016 at 1:31 PM, Brian Trammell <[email-masked]> wrote:

> It'll be a lightning talk in the sense of "it's an ad to read the rest of
> the slides, and come talk to us if you have questions".
>
> Cheers,
>
> Brian
>
> >
> > —aaron
> >
> >>> Yesterday there was an interesting talk at the IRTF/ACM Applied
> Networking Research Workshop that is relevant to TAPS.  Since our slot is
> only an hour and our agenda already full, I would like to propose extending
> the meeting 10 minutes to accommodate it.  We’ll be eating into the free
> time before the Bits-and-Bytes social so I don’t think anyone will miss any
> scheduled activities but I am aware that folks sometimes schedule meetings
> during the breaks. I hope this doesn’t inconvenience anyone.
>

Could you chat with the folks at MEETECHO and ask them not to cut off
recording when your slot ends on the agenda?

Thanks,

Spencer

> >>> Stephen McQuistin (University of Glasgow), Colin Perkins (University
> of Glasgow), and Marwan Fayed (University of Stirling)
> >>>
> >>> Real-time applications require a set of transport services not
> currently provided by widely-deployed transport protocols. Ossification
> prevents the deployment of novel protocols, restricting solutions to
> protocols using either TCP or UDP as a substrate. We describe the transport
> services required by real-time applications. We show that, in the
> short-term (i.e., while UDP is blocked at current levels), TCP offers a
> feasible substrate for providing these services. Over the longer term,
> protocols using UDP may reduce the number of networks blocking UDP,
> enabling a shift towards its use as a demultiplexing layer for novel
> transport protocols.
> >>>
> >>> 2. Update on draft-ietf-taps-transports-usage - 10 min (Naeem Khademi
> ) – updated draft promised by the authors.
> >>>