Subject: [Taps] new (arch, interface, impl)-01 drafts

From: "Brian Trammell (IETF)" <[email-masked]>
Date: Mon, 2 Jul 2018 10:08:08 +0200

Greetings, all,

We've submitted -01 versions of the -arch, -interface, and -impl documents.

To some extent, these are basically pre-Montreal snapshots of the state of the documents as they continue being developed; the open issues we know about are at https://github.com/taps-api/drafts/issues.

Of note:

- arch-01 has some editorial changes, and a new section explicitly defining a method to determine whether two stacks are equivalent and can therefore be safely raced.

- interface-01 has been largely reorganized to try and keep relevant properties together; indeed, due to this reorganization the diffs are largely useless, and we apologize for that. We (the authors and editors) are pretty sure the new macro-organization of the document is better, but we are also not yet sure the specific micro-organization of each property is correct. We should probably discuss this in person at the WG meeting in Montreal.

Cheers,

Brian

> Begin forwarded message:
> 
> From: [email-masked]
> Subject: New Version Notification for draft-ietf-taps-interface-01.txt
> Date: 2 July 2018 at 09:58:42 CEST
> To: "Michael Welzl" <[email-masked]>, "Theresa Enghardt" <[email-masked]>, "Christopher Wood" <[email-masked]>, "Philipp S. Tiesel" <[email-masked]>, "Colin Perkins" <[email-masked]>, "Brian Trammell" <[email-masked]>, "Gorry Fairhurst" <[email-masked]>, "Mirja Kuehlewind" <[email-masked]>, "Philipp Tiesel" <[email-masked]>, "Godred Fairhurst" <[email-masked]>, "Chris Wood" <[email-masked]>
> 
> 
> A new version of I-D, draft-ietf-taps-interface-01.txt
> has been successfully submitted by Brian Trammell and posted to the
> IETF repository.
> 
> Name:		draft-ietf-taps-interface
> Revision:	01
> Title:		An Abstract Application Layer Interface to Transport Services
> Document date:	2018-07-02
> Group:		taps
> Pages:		53
> URL:            https://www.ietf.org/internet-drafts/draft-ietf-taps-interface-01.txt
> Status:         https://datatracker.ietf.org/doc/draft-ietf-taps-interface/
> Htmlized:       https://tools.ietf.org/html/draft-ietf-taps-interface-01
> Htmlized:       https://datatracker.ietf.org/doc/html/draft-ietf-taps-interface
> Diff:           https://www.ietf.org/rfcdiff?url2=draft-ietf-taps-interface-01
> 
> Abstract:
>   This document describes an abstract programming interface to the
>   transport layer, following the Transport Services Architecture.  It
>   supports the asynchronous, atomic transmission of messages over
>   transport protocols and network paths dynamically selected at
>   runtime.  It is intended to replace the traditional BSD sockets API
>   as the lowest common denominator interface to the transport layer, in
>   an environment where endpoints have multiple interfaces and potential
>   transport protocols to select from.
> 
> 
> 
> 
> Please note that it may take a couple of minutes from the time of submission
> until the htmlized version and diff are available at tools.ietf.org.
> 
> The IETF Secretariat
>

---

From: Zaheduzzaman Sarker <[email-masked]>
Date: Thu, 5 Jul 2018 17:18:58 +0000

Hi Brian and rest of the authors,

Thanks for the updates. 

For the meeting agenda, could you please mention who will be presenting the updates per drafts?

BR
Zahed

On 2018-07-02, 10:08, "Taps on behalf of Brian Trammell (IETF)" <[email-masked] on behalf of [email-masked]> wrote:

    Greetings, all,

    
    Of note:

    
    Cheers,
    
    Brian