Subject: Re: [Taps] Transport Services (taps) WG Virtual Meeting: 2018-09-12

From: "Aaron Falk" <[email-masked]>
Date: Mon, 10 Sep 2018 09:48:25 -0400

Just a reminder that we have an interim meeting scheduled for this Weds. 
  Key questions to the group:

1. Are the topics below still relevant for discussion?
2. Any additional topics we should add?
3. Who's going to lead each topic?

A mea culpa: I had a critical calendar fail and have a personal 
appointment I cannot move at the time of the meeting so Zahed will be 
chairing the call.

--aaron

On 3 Aug 2018, at 17:20, IESG Secretary wrote:

> The Transport Services (taps) Working Group will hold
> a virtual interim meeting on 2018-09-12 from 11:00 to 13:00 
> America/New_York.
>
> Agenda:
> Draft agenda:
> 1. Partial Send/Receive
> 2. 0-RTT
> 3. Implementation & testing
>
> Information about remote participation:
> https://ietf.webex.com/meet/taps  | 316 448 940 Join by phone 
> 1-650-479-3208 Call-in toll number (US/Canada) Access code:  316 448 
> 940

---

From: Tommy Pauly <[email-masked]>
Date: Mon, 10 Sep 2018 11:08:54 -0700

Hi Aaron,

1. I think those discussion points are still relevant, as they've had continuing discussion on the open GitHub issues.

2. Based on discussion, I think it would be helpful to add a conversation to review Connection and Message Properties (https://github.com/taps-api/drafts/issues/218), and go over which buckets things need to be in, and standardizing how we talk about them.

I'd like to also share and briefly discuss a document I just posted to explore possible QUIC mappings onto a TAPS-style interface: https://tools.ietf.org/html/draft-pauly-quic-interface-00.

3. I'm happy to lead the discussion on Partial Sends and Receives, as I wrote the change for that (https://github.com/taps-api/drafts/pull/200).
I would nominate Brian to discuss the 0-RTT topic based on https://github.com/taps-api/drafts/pull/214

Sorry we'll miss you on Wednesday, Aaron!

Thanks,
Tommy

> On Sep 10, 2018, at 6:48 AM, Aaron Falk <[email-masked]> wrote:
> 
> Just a reminder that we have an interim meeting scheduled for this Weds. Key questions to the group:
> 
> Are the topics below still relevant for discussion?
> Any additional topics we should add?
> Who's going to lead each topic?
> A mea culpa: I had a critical calendar fail and have a personal appointment I cannot move at the time of the meeting so Zahed will be chairing the call.
> 
> --aaron
> 
> a virtual interim meeting on 2018-09-12 from 11:00 to 13:00 America/New_York.
> 
> Agenda:
> Draft agenda:
> 1. Partial Send/Receive
> 2. 0-RTT
> https://ietf.webex.com/meet/taps <https://ietf.webex.com/meet/taps> | 316 448 940 Join by phone 1-650-479-3208 Call-in toll number (US/Canada) Access code: 316 448 940
> 
> _______________________________________________
> Taps mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/taps

---

From: Michael Welzl <[email-masked]>
Date: Mon, 10 Sep 2018 22:07:08 +0200

+1 on these suggestions

Sent from my iPhone

> On 10 Sep 2018, at 20:08, Tommy Pauly <[email-masked]> wrote:
> 
> Hi Aaron,
> 
>> https://ietf.webex.com/meet/taps | 316 448 940 Join by phone 1-650-479-3208 Call-in toll number (US/Canada) Access code: 316 448 940
>>

---

From: "Aaron Falk" <[email-masked]>
Date: Mon, 10 Sep 2018 17:30:58 -0400

Here's an updated agenda.  Who will lead the discussion on Connection & 
Message Properties?

--aaron

AGENDA
1. Partial Send/Receive, Tommy
2. 0-RTT, Brian (to be confirmed)
3. Connection & Message Properties, ???
4. draft-pauly-quic-interface-00.txt, Tommy
5. Implementation & testing, (Zahed, can you lead this?)

On 10 Sep 2018, at 16:07, Michael Welzl wrote:

>> 1. I think those discussion points are still relevant, as they've had 
>> continuing discussion on the open GitHub issues.
>>
>> 2. Based on discussion, I think it would be helpful to add a 
>> conversation to review Connection and Message Properties 
>> (https://github.com/taps-api/drafts/issues/218), and go over which 
>> buckets things need to be in, and standardizing how we talk about 
>> them.
>>
>> I'd like to also share and briefly discuss a document I just posted 
>> to explore possible QUIC mappings onto a TAPS-style interface: 
>> https://tools.ietf.org/html/draft-pauly-quic-interface-00.
>>
>> 3. I'm happy to lead the discussion on Partial Sends and Receives, as 
>> I wrote the change for that 
>> (https://github.com/taps-api/drafts/pull/200).
>> I would nominate Brian to discuss the 0-RTT topic based on 
>> https://github.com/taps-api/drafts/pull/214
>>
>>> appointment I cannot move at the time of the meeting so Zahed will 
>>> be chairing the call.
>>>
>>> --aaron
>>>

---

From: Michael Welzl <[email-masked]>
Date: Tue, 11 Sep 2018 07:21:23 +0200

I can do that.

Cheers, Michael

Sent from my iPhone

> On 10 Sep 2018, at 23:30, Aaron Falk <[email-masked]> wrote:
> 
> Here's an updated agenda. Who will lead the discussion on Connection & Message Properties?
> 
> --aaron
> 
> AGENDA

---

From: Zaheduzzaman Sarker <[email-masked]>
Date: Tue, 11 Sep 2018 07:43:49 +0000

Good!!
Updated agenda-

AGENDA
1. Partial Send/Receive, Tommy
2. 0-RTT, Brian (to be confirmed)
3. Connection & Message Properties, Michael Welzl
4. draft-pauly-quic-interface-00.txt, Tommy
5. Implementation & testing, Chair

On 2018-09-11, 07:21, "Michael Welzl" <[email-masked]<mailto:[email-masked]>> wrote:

I can do that.

Cheers, Michael

Sent from my iPhone

On 10 Sep 2018, at 23:30, Aaron Falk <[email-masked]<mailto:[email-masked]>> wrote:

--aaron

AGENDA

On 10 Sep 2018, at 20:08, Tommy Pauly <[email-masked]<mailto:[email-masked]>> wrote:
Hi Aaron,

Thanks,
Tommy

On Sep 10, 2018, at 6:48 AM, Aaron Falk <[email-masked]<mailto:[email-masked]>> wrote:

[email-masked]<mailto:[email-masked]>

_______________________________________________
Taps mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/taps

---

From: "Brian Trammell (IETF)" <[email-masked]>
Date: Wed, 12 Sep 2018 11:03:24 +0200

> On 11 Sep 2018, at 09:43, Zaheduzzaman Sarker <[email-masked]> wrote:
> 
> Good!!
> Updated agenda-
> AGENDA

confirmed

cheers,

Brian

> On 2018-09-11, 07:21, "Michael Welzl" <[email-masked]> wrote:
> 
> I can do that.
> 
> Cheers, Michael
> 
> 
> Sent from my iPhone
>

---

From: "Philipp S. Tiesel" <[email-masked]>
Date: Wed, 12 Sep 2018 13:02:00 +0200

Hi,

going over the github issues again, we might also want to discuss “Fragmentation Prohibited"

> On 11. Sep 2018, at 09:43, Zaheduzzaman Sarker <[email-masked]> wrote:
> 
> Good!!
> Updated agenda- 
> AGENDA
> On 2018-09-11, 07:21, "Michael Welzl" <[email-masked] <mailto:[email-masked]>> wrote:
>  
> I can do that. 
>  
> Cheers, Michael
> 
> 
> Sent from my iPhone
> 
> On 10 Sep 2018, at 23:30, Aaron Falk <[email-masked] <mailto:[email-masked]>> wrote:
> 
>>> On 10 Sep 2018, at 20:08, Tommy Pauly <[email-masked] <mailto:[email-masked]>> wrote:
>>> 
>>>> Hi Aaron,
>>>>  
>>>> 2. Based on discussion, I think it would be helpful to add a conversation to review Connection and Message Properties (https://github.com/taps-api/drafts/issues/218 <https://github.com/taps-api/drafts/issues/218>), and go over which buckets things need to be in, and standardizing how we talk about them.
>>>>  
>>>> I'd like to also share and briefly discuss a document I just posted to explore possible QUIC mappings onto a TAPS-style interface: https://tools.ietf.org/html/draft-pauly-quic-interface-00 <https://tools.ietf.org/html/draft-pauly-quic-interface-00>.
>>>>  
>>>> 3. I'm happy to lead the discussion on Partial Sends and Receives, as I wrote the change for that (https://github.com/taps-api/drafts/pull/200 <https://github.com/taps-api/drafts/pull/200>).
>>>> I would nominate Brian to discuss the 0-RTT topic based on https://github.com/taps-api/drafts/pull/214 <https://github.com/taps-api/drafts/pull/214>
>>>>  
>>>>> On Sep 10, 2018, at 6:48 AM, Aaron Falk <[email-masked] <mailto:[email-masked]>> wrote:
>>>>>  
>>>>> [email-masked] <mailto:[email-masked]>
>>>>> https://www.ietf.org/mailman/listinfo/taps <https://www.ietf.org/mailman/listinfo/taps>
>>>>  
>>>> [email-masked] <mailto:[email-masked]>
>>>> https://www.ietf.org/mailman/listinfo/taps <https://www.ietf.org/mailman/listinfo/taps>_______________________________________________
> Taps mailing list
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/taps <https://www.ietf.org/mailman/listinfo/taps>

AVE!
  Philipp S. Tiesel / phils…
-- 
   {phils}--->---([email-masked])--->---(http://phils.in-panik.de)----,
      wenn w eine   aube ist dn      man au dran dre en                   |
           o     Schr        an muss     hc         h   (Kurt Schwitters) |
:wq!  <----(phone: +49-179-6737439)---<---(jabber: [email-masked])----'

---

From: Michael Welzl <[email-masked]>
Date: Wed, 12 Sep 2018 16:29:48 +0200

Hi,

In case someone wants to take a look at these things before we start, or just have the URL's handy, here's my "sub-agenda" for item 3 - the list of things that I think we should discuss:

- Message Dependencies:
https://github.com/taps-api/drafts/issues/220

- Niceness (Connection) vs. Niceness (Message):
https://taps-api.github.io/drafts/draft-ietf-taps-interface.html#rfc.section.12.3.21
https://taps-api.github.io/drafts/draft-ietf-taps-interface.html#rfc.section.12.3.22

- Fragmentation Prohibited
https://github.com/taps-api/drafts/issues/226

- Timeouts:
Appendix A:
"Suggest a timeout to the Remote Endpoint"
https://github.com/taps-api/drafts/issues/109
(really a general timeout discussion)

Talk soon ...

Cheers,
Michael

---

From: Theresa Enghardt <[email-masked]>
Date: Thu, 13 Sep 2018 10:09:15 +0200

Hi,

I took notes in yesterday's interim, you can find them in this pad:

https://etherpad.tools.ietf.org/p/notes-ietf-taps-interim-2018-09-12

Please review, and, in some cases, complete.

Thanks!

Best,
Theresa

-- 
Theresa Enghardt
Wissenschaftliche Mitarbeiterin / Research Assistant
Phone: +49 30 314 78628
Office: MAR 4.032

FG / Group "Internet Network Architectures" (INET)
Technische Universität Berlin
Sekr. MAR 4-4, Marchstraße 23, 10587 Berlin

---

From: Erik Kline <[email-masked]>
Date: Thu, 13 Sep 2018 17:22:18 +0900

Thanks very much!

(the call was midnight to 2:30am Tokyo, iirc :-)
On Thu, 13 Sep 2018 at 17:10, Theresa Enghardt