Subject: [Taps] NEAT is dead... long live NEATPy !

From: Michael Welzl <[email-masked]>
Date: Fri, 5 Jun 2020 12:22:51 +0200

Dear all,

It’s my pleasure to announce NEATPy: a Python-based implementation of TAPS over NEAT.
https://github.com/theagilepadawan/NEATPy <https://github.com/theagilepadawan/NEATPy>

Most of you have probably heard of NEAT before - it was a European research project which implemented much of TAPS (and more: most notably perhaps, it has a policy manager). With the project ending in 2018, NEAT’s API is however somewhat different from what TAPS has now become.

NEATPy is an effort to bring NEAT up to date: it’s a Python shim layer that maps an up-to-date TAPS API  (implementing *almost* everything we currently have) to NEAT. This should hopefully also make NEAT more attractive for people to play around with.

NEATPy interestingly complements PyTAPS from the TU Berlin group: now you can make Python code run on PyTAPS, and get TCP (more efficient, as it goes directly over sockets), and then run it with only minimal changes on NEATPy, and get SCTP (more efficient if you’re using multiple connections in FreeBSD because you get multi-streaming). A true TAPS'ism!

This is the work of Michael Gundersen in his master thesis. We thank Andreas Fischer and Michael Tuexen for their help with some parts.

Cheers,
Michael

---

From: Tommy Pauly <[email-masked]>
Date: Mon, 08 Jun 2020 09:26:40 -0700

Thanks for sharing! That’s really cool (or should I say neat?) to see another API implementation, and one that is pretty complete.

Congrats to Michael Gundersen on this good work.

Best,
Tommy

> On Jun 5, 2020, at 3:22 AM, Michael Welzl <[email-masked]> wrote:
> 
> Dear all,
> 
> _______________________________________________
> Taps mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/taps