Subject: [Taps] WGLC for draft-ietf-taps-interface (to conclude 26-Apr-2021)

From: "Aaron Falk" <[email-masked]>
Date: Sun, 11 Apr 2021 10:13:50 -0400

Working group last call for the API draft starts now.  Please review the 
draft and send comments to the list (including ‘ready to publish’ 
affirmations) or post issues/PRs to 
[github](https://github.com/ietf-tapswg/api-drafts).  Thanks to the 
authors, editors, and reviewers who’ve helped bring the draft to this 
point!

Forwarded message:

> From: IETF Secretariat <[email-masked]>
> To: [email-masked], [email-masked]
> Subject: IETF WG state changed for draft-ietf-taps-interface
> Date: Sun, 11 Apr 2021 07:05:50 -0700
>
> The IETF WG state of draft-ietf-taps-interface has been changed to "In 
> WG
> Last Call" from "WG Document" by Aaron Falk:
>
> https://datatracker.ietf.org/doc/draft-ietf-taps-interface/

---

From: Gorry Fairhurst <[email-masked]>
Date: Mon, 12 Apr 2021 16:11:25 +0100

On 11/04/2021 15:13, Aaron Falk wrote:
>
> Working group last call for the API draft starts now. Please review 
> the draft and send comments to the list (including ‘ready to publish’ 
> affirmations) or post issues/PRs to github 
> <https://github.com/ietf-tapswg/api-drafts>. Thanks to the authors, 
> editors, and reviewers who’ve helped bring the draft to this point!
>
> Forwarded message:
>
>     From: IETF Secretariat [email-masked]
>     <mailto:[email-masked]>
>     To: [email-masked]
>     <mailto:[email-masked]>, [email-masked]
>     <mailto:[email-masked]>
>     The IETF WG state of draft-ietf-taps-interface has been changed to
>     "In WG
>     <https://datatracker.ietf.org/doc/draft-ietf-taps-interface/>
>
>
> _______________________________________________
> Taps mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/taps

I've just read this carefully, and it seems nearly ready to me.

I did notice a few issues, now in github:

Some of which relate to text from text I originally proposed (sorry):

No Segmentation  #782
More thoughts on network Fragmentation  #781
To me, Safely Replayable text seems unclear ( 7.1.3.4.)  #780

UDP-Lite and Zero UDP Checksum (sect 6.1.1 and 7.1.3.6)    #776

Editorial:

Priority property "represents a hierarchy of priorities"?   #779
Update ref to dplpmtud  #778
Editorial: is Constant-Rate Streaming a path characteristic or appl 
traffic?  #777
There could be more definitions@ API #775
What is "entangled"?  #774
Editorial API NiT #773
Is Appendix A actually implementation?  #772

Gorry

---

From: Mirja Kuehlewind <[email-masked]>
Date: Wed, 14 Apr 2021 11:10:23 +0000

Even though I’m an author I did another quite review of the doc. I opened a few small issues but otherwise I think this is ready to go!

From: Taps <[email-masked]> on behalf of Aaron Falk <[email-masked]>
Date: Sunday, 11. April 2021 at 16:14
To: taps WG <[email-masked]>
Cc: Theresa Enghardt <[email-masked]>, Zaheduzzaman Sarker <[email-masked]>
Subject: [Taps] WGLC for draft-ietf-taps-interface (to conclude 26-Apr-2021)

Working group last call for the API draft starts now. Please review the draft and send comments to the list (including ‘ready to publish’ affirmations) or post issues/PRs to github<https://protect2.fireeye.com/v1/url?k=882fbae3-d7b483a0-882ffa78-861fcb972bfc-cfd4ef90c1339a1e&q=1&e=02781440-5cca-4898-8f0b-502499a7eae9&u=https%3A%2F%2Fgithub.com%2Fietf-tapswg%2Fapi-drafts>. Thanks to the authors, editors, and reviewers who’ve helped bring the draft to this point!

Forwarded message:

From: IETF Secretariat [email-masked]<mailto:[email-masked]>
To: [email-masked]<mailto:[email-masked]>, [email-masked]<mailto:[email-masked]>
Subject: IETF WG state changed for draft-ietf-taps-interface
Date: Sun, 11 Apr 2021 07:05:50 -0700

The IETF WG state of draft-ietf-taps-interface has been changed to "In WG
Last Call" from "WG Document" by Aaron Falk:

---

From: "Aaron Falk" <[email-masked]>
Date: Sun, 25 Apr 2021 12:51:07 -0400

Wrapping up WGLC:

* Does anyone need more time to finish their review?

* Other than the issues logged in 
[github](https://github.com/ietf-tapswg/api-drafts/issues?q=is%3Aopen+is%3Aissue+label%3AAPI), 
are there any significant concerns that would discourage publishing this 
draft?

* Would anyone like to express support for publishing this draft who 
hasn’t?

--aaron

On 11 Apr 2021, at 10:13, Aaron Falk wrote:

> the draft and send comments to the list (including ‘ready to 
> publish’ affirmations) or post issues/PRs to 
> authors, editors, and reviewers who’ve helped bring the draft to 
> this point!
>
>
>
> Forwarded message:
>

---

From: Anna Brunström <[email-masked]>
Date: Sun, 25 Apr 2021 20:38:36 +0000

Hi Aaron,

I started reading earlier this week, but got sidetracked by something urgent that came up in my day job. I was still aiming to finish in time, i.e tomorrow, but one or two extra days could be helpful ☺

BR,
Anna

From: Taps <[email-masked]> On Behalf Of Aaron Falk
Sent: den 25 april 2021 18:51
To: taps WG <[email-masked]>
Cc: Theresa Enghardt <[email-masked]>; Zaheduzzaman Sarker <[email-masked]>
Subject: Re: [Taps] WGLC for draft-ietf-taps-interface (to conclude 26-Apr-2021)

Wrapping up WGLC:

·     Does anyone need more time to finish their review?

·     Other than the issues logged in github<https://github.com/ietf-tapswg/api-drafts/issues?q=is%3Aopen+is%3Aissue+label%3AAPI>, are there any significant concerns that would discourage publishing this draft?

·     Would anyone like to express support for publishing this draft who hasn’t?

--aaron

Working group last call for the API draft starts now. Please review the draft and send comments to the list (including ‘ready to publish’ affirmations) or post issues/PRs to github<https://github.com/ietf-tapswg/api-drafts>. Thanks to the authors, editors, and reviewers who’ve helped bring the draft to this point!

Forwarded message:

När du skickar e-post till Karlstads universitet behandlar vi dina personuppgifter<https://www.kau.se/gdpr>.
When you send an e-mail to Karlstad University, we will process your personal data<https://www.kau.se/en/gdpr>.

---

From: "Aaron Falk" <[email-masked]>
Date: Mon, 26 Apr 2021 09:10:21 -0400

Hi Anna-

Your review is more important than the specific date.  If you need a 
couple additional days, please take them.

--aaron

On 25 Apr 2021, at 16:38, Anna Brunström wrote:

> Hi Aaron,
>
> I started reading earlier this week, but got sidetracked by something 
> urgent that came up in my day job. I was still aiming to finish in 
> time, i.e tomorrow, but one or two extra days could be helpful ☺
>
> BR,
> Anna
>
> ·     Other than the issues logged in 
> github<https://github.com/ietf-tapswg/api-drafts/issues?q=is%3Aopen+is%3Aissue+label%3AAPI>, 
> are there any significant concerns that would discourage publishing 
> this draft?
>
> github<https://github.com/ietf-tapswg/api-drafts>. Thanks to the 
> From: IETF Secretariat 
> [email-masked]<mailto:[email-masked]>
> To: 
> [email-masked]<mailto:[email-masked]>, 
> [email-masked]<mailto:[email-masked]>
> När du skickar e-post till Karlstads universitet behandlar vi dina 
> personuppgifter<https://www.kau.se/gdpr>.
> When you send an e-mail to Karlstad University, we will process your 
> personal data<https://www.kau.se/en/gdpr>.

---

From: Anna Brunström <[email-masked]>
Date: Sat, 1 May 2021 00:26:47 +0000

Hi all,

I fell a bit behind, but have now finished up my review. Overall I think the document is in very good shape.

I have filed issues in github for a few smaller things to resolve and for a number of needed editorial fixes.

BR,
Anna

From: Aaron Falk <[email-masked]>
Sent: den 26 april 2021 15:10
To: Anna Brunström <[email-masked]>
Cc: taps WG <[email-masked]>; Theresa Enghardt <[email-masked]>; Zaheduzzaman Sarker <[email-masked]>
Subject: Re: [Taps] WGLC for draft-ietf-taps-interface (to conclude 26-Apr-2021)

Hi Anna-

Your review is more important than the specific date. If you need a couple additional days, please take them.

--aaron

Hi Aaron,

BR,

Anna

From: Taps <[email-masked]<mailto:[email-masked]>> On Behalf Of Aaron Falk
Sent: den 25 april 2021 18:51
To: taps WG <[email-masked]<mailto:[email-masked]>>
Cc: Theresa Enghardt <[email-masked]<mailto:[email-masked]>>; Zaheduzzaman Sarker <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Taps] WGLC for draft-ietf-taps-interface (to conclude 26-Apr-2021)

Wrapping up WGLC:

•     Does anyone need more time to finish their review?

•     Other than the issues logged in github<https://github.com/ietf-tapswg/api-drafts/issues?q=is%3Aopen+is%3Aissue+label%3AAPI>, are there any significant concerns that would discourage publishing this draft?

•     Would anyone like to express support for publishing this draft who hasn’t?

--aaron

Forwarded message: