Subject: [tcpinc] Conclusion call [was: Re: CORRECTION: Reminder: Ongoing Working Group Last Call about drafts to choose as WG item]

From: Mirja Kühlewind <[email-masked]>
Date: Mon, 3 Aug 2015 15:52:30 +0200

Hi all,

this call was running until last Friday and we have to conclude that we could not achieve rough consensus. There was a slight preference to adopt tcpyrypt but not enough to finally make a decision. Moreover, as the authors of the tcpcrypt draft have submitted an new doc and indicated that they will also revise the tcpcrypt doc, it is anyway not appropriate to adopt the current version now.

In more detail, we have seen 

- 6 people supporting TCP-TLS (option a) + one more after the deadline
- 11 people supporting tcpcrypt (option b)
- 5 people supporting adoption of both, where 2 indicated that either as a starting point would be fine and one indicated that (s)he would also support tcpcrypt as a starting point

Further just to make the statistics complete, there were 7 additional people supporting adoption of both docs in the call before the meeting that did not re-vote in the last call. Note that the call before the meeting had a slightly different question with only two options: adopt both or the AD will chose one. Further as another side info, 3 people that indicated in this first call to support adoption of both, re-decided in the second call to support tcpycryt (only). That might be an indication that also people that have indicated support for one approach, might be willing to adopt both approaches as wg items. However, I know that's only speculation. Please also note that adoption does not mean that the content will stay is it is, not that the doc will be published at all; it only mean that there is interest of the wg and the change control will go over to the working group.

I will send two additional emails next: 
1) a brief summery of arguments provided for and against the two approaches; I hope that further will help the discussion. 
2) more information on how to move forward: as there already has been quite a bit positive feedback on the new tcp-eno draft, it seems to be the right way forward to focus on this document first; I’m currently mailing with the authors to figure out their further plan. Stay tuned, I'll provide more information soon!

However, thanks for the lively discussion over the last days. I think that was still helpful and please go on!

Mirja

> Am 24.07.2015 um 11:16 schrieb Martin Stiemerling <[email-masked]>:
> 
> 
> Dear all,
> 
> **Please use this CORRECTED version, as one option to choose from below didn't make it into the original.****
> Thanks to Erik Rescola for pointing this out to me directly.
> 
> This point got lost on the mailing list, but it has been decided in the WG session here at IETF-93 that there will be a Last Call for consensus about which document of the below ones to take as starting point for the WG.
> 
> 
> Here are the two drafts:
> a) draft-rescorla-tcpinc-tls-option-03
> b) draft-bittau-tcpinc-tcpcrypt-03
> 
> Please respond to the tcpinc wg mailing list until
> 
>   July 31st, 2015
>   1pm CEST
> 
> on wether you prefer
> - either draft a) or b)
> - both drafts (a & b) as WG items
> - or none
> 
> to be accepted as WG item(s).
> 
> Please write also your brief reasoning on why you made your choice.
> 
> Please note that accepting a draft is not the end of working on the technical content of the draft, but it is actually the starting point when the WG has full change control about the content of the draft!
> 
> 
> Regards,
> 
>  Martin Stiemerling
>  Transport Area Director
> 
> _______________________________________________
> Tcpinc mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tcpinc

---

From: Stephen Kent <[email-masked]>
Date: Mon, 10 Aug 2015 12:04:46 -0400

I prefer that both drafts be accepted as WG items, so that we can
evaluate the evolution of both in the WG context.

Steve
>
> Dear all,
>
> **Please use this CORRECTED version, as one option to choose from 
> below didn't make it into the original.****
> This point got lost on the mailing list, but it has been decided in 
> the WG session here at IETF-93 that there will be a Last Call for 
> consensus about which document of the below ones to take as starting 
> point for the WG.
>
>
> Here are the two drafts:
> Please note that accepting a draft is not the end of working on the 
> technical content of the draft, but it is actually the starting point 
> when the WG has full change control about the content of the draft!
>
>
> Regards,
>
>   Martin Stiemerling
>   Transport Area Director
>