Subject: [tcpinc] Implementation status

From: Mirja Kühlewind <[email-masked]>
Date: Fri, 4 Mar 2016 11:46:42 +0100

Hi all,

at the last meeting, we also tried to figure out if there are potentially more people that would be interested/willing to implement the proposed schemes. The feedback at this time was that people don’t want to implement something that might potentially not be standardized. 

Now that we are heading towards the publication of tcpcrypt as the default mechanism, we like to  ask again and figure if anybody is currently implementing tcpcrypt/plans to implement it/is willing to implement it in the near future.

As there is also already an implementation by the authors, it shows that the proposed approach is feasible to implement. As such this is a good basis to move on. However, if we could get a second independent implementation, it would also show that the specification as described in the current draft is solid and comprehensive. This would be very helpful to ensure that we as a group did a good job!

Let us know what your plans are!

Mirja, Kyle and David

---

From: Andrea Bittau <[email-masked]>
Date: Fri, 4 Mar 2016 07:26:26 -0800

All - I'd encourage you to try out our current tcpcrypt version from:

http://tcpcrypt.org/download.php

We support OS X, Windows and Linux.  There're prebuilt OS X and Windows
binaries.  You can check the status of various people testing the product
on different platforms here:

http://tcpcrypt.org/fame.php

Please let us know if you encounter any issues.

Thanks

On Fri, Mar 4, 2016 at 2:46 AM, Mirja Kühlewind <
[email-masked]> wrote:

> Hi all,
>
> at the last meeting, we also tried to figure out if there are potentially
> more people that would be interested/willing to implement the proposed
> schemes. The feedback at this time was that people don’t want to implement
> something that might potentially not be standardized.
>
> Now that we are heading towards the publication of tcpcrypt as the default
> mechanism, we like to  ask again and figure if anybody is currently
> implementing tcpcrypt/plans to implement it/is willing to implement it in
> the near future.
>
> As there is also already an implementation by the authors, it shows that
> the proposed approach is feasible to implement. As such this is a good
> basis to move on. However, if we could get a second independent
> implementation, it would also show that the specification as described in
> the current draft is solid and comprehensive. This would be very helpful to
> ensure that we as a group did a good job!
>
> _______________________________________________
> Tcpinc mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tcpinc