Subject: [tcpinc] tcpcrypt - what's encrypted?

From: "Smith, Kevin, (R&D) Vodafone Group" <[email-masked]>
Date: Tue, 8 Mar 2016 11:05:22 +0000

Apologies if this is obvious and I've missed it in the docs - but please can someone confirm if the TCP protocol itself is encrypted as part of tcpcrypt, i.e. the ACKs, MSS, cwnd etc. etc. will not be visible to any middleboxes? A quick test shows them still visible to a packet capture...

Cheers
Kevin

---

From: "Black, David" <[email-masked]>
Date: Tue, 8 Mar 2016 14:16:42 +0000

That's correct - the TCP headers are not encrypted by any tcpinc security protocol (the
TLS profile is similar in this regard).  To encrypt TCP headers,  something like IPsec is
needed.

Thanks, --David

> -----Original Message-----
> From: Tcpinc [mailto:[email-masked]] On Behalf Of Smith, Kevin, (R&D)
> Vodafone Group
> Sent: Tuesday, March 08, 2016 6:05 AM
> To: tcpinc
> Subject: [tcpinc] tcpcrypt - what's encrypted?
> 
> Apologies if this is obvious and I've missed it in the docs - but please can someone
> confirm if the TCP protocol itself is encrypted as part of tcpcrypt, i.e. the ACKs,
> MSS, cwnd etc. etc. will not be visible to any middleboxes? A quick test shows
> them still visible to a packet capture...
> 
> Cheers
> Kevin
> 
> 
> 
> 
> _______________________________________________
> Tcpinc mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tcpinc

---

From: Mirja Kühlewind <[email-masked]>
Date: Tue, 8 Mar 2016 15:54:58 +0100

That was discussed early after starting of the working group and the group decided to not encrypt any header fields to increase deployability.

Mirja

> Am 08.03.2016 um 15:16 schrieb Black, David <[email-masked]>:
>

---

From: "Smith, Kevin, (R&D) Vodafone Group" <[email-masked]>
Date: Tue, 8 Mar 2016 15:14:20 +0000

Great, thanks both for the confirmation.

-------- Original Message --------

Subject: Re: [tcpinc] tcpcrypt - what's encrypted?

From: Mirja Kühlewind <[email-masked]>

Date: 8 Mar 2016 14:55

To: "Smith, Kevin, (R&D) Vodafone Group" <[email-masked]>

Mirja

---

From: Jana Iyengar <[email-masked]>
Date: Tue, 8 Mar 2016 10:01:37 -0800

I believe that the TCP header is not *authenticated* either, since
middleboxes may resegment TCP segments.

On Tue, Mar 8, 2016 at 7:14 AM, Smith, Kevin, (R&D) Vodafone Group <
[email-masked]> wrote:

> That was discussed early after starting of the working group and the group
> decided to not encrypt any header fields to increase deployability.
>
> Mirja
>
>
> >> From: Tcpinc [mailto:[email-masked] <[email-masked]>]
> On Behalf Of Smith, Kevin, (R&D)
> >> Vodafone Group

---

From: Kyle Rose <[email-masked]>
Date: Tue, 8 Mar 2016 14:00:29 -0500

That is also correct. There was evidently a long discussion about this
before I got involved, at least partly because tcpcrypt originally
relied on sender segment integrity instead of using a TLV
construction. Middleboxes unfortunately put a lot of constraints on
how protocols can be used, which (I'm guessing?) is part of the reason
QUIC encrypts as much data as possible.

Kyle

On Tue, Mar 8, 2016 at 1:01 PM, Jana Iyengar <[email-masked]> wrote:
> On Tue, Mar 8, 2016 at 7:14 AM, Smith, Kevin, (R&D) Vodafone Group
> <[email-masked]> wrote:
>>

---

From: Yoshifumi Nishida <[email-masked]>
Date: Tue, 8 Mar 2016 13:57:57 -0800

Hi,
I know it, but, I have a naive question here, although I'm not sure if it's
a proper question.
Let's say tcpcrypt is defined well and becomes successful, then after for a
while, we realize some needs for header protections in TCP level.
In this case, do we build new one from scratch or do we have other visions?

Thanks,
--
Yoshi

---

From: "Black, David" <[email-masked]>
Date: Tue, 8 Mar 2016 22:13:18 +0000

The TCP-ENO option can be used in the future to negotiate additional security protocols beyond the one(s) we define now.

Thanks, --David

From: Tcpinc [mailto:[email-masked]] On Behalf Of Yoshifumi Nishida
Sent: Tuesday, March 08, 2016 4:58 PM
To: Mirja Kühlewind
Cc: tcpinc; Smith, Kevin, (R&D) Vodafone Group; Black, David
Subject: Re: [tcpinc] tcpcrypt - what's encrypted?

Hi,
I know it, but, I have a naive question here, although I'm not sure if it's a proper question.
Let's say tcpcrypt is defined well and becomes successful, then after for a while, we realize some needs for header protections in TCP level.
In this case, do we build new one from scratch or do we have other visions?

Thanks,
--
Yoshi

On Tue, Mar 8, 2016 at 6:54 AM, Mirja Kühlewind <[email-masked]<mailto:[email-masked]>> wrote:
That was discussed early after starting of the working group and the group decided to not encrypt any header fields to increase deployability.

Mirja

> Am 08.03.2016 um 15:16 schrieb Black, David <[email-masked]<mailto:[email-masked]>>:
>
>> From: Tcpinc [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of Smith, Kevin, (R&D)
>> Vodafone Group
>> [email-masked]<mailto:[email-masked]>
> [email-masked]<mailto:[email-masked]>

_______________________________________________
Tcpinc mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/tcpinc