Subject: [tcpm] TCPM notes from IETF-94

From: Pasi Sarolahti <[email-masked]>
Date: Mon, 16 Nov 2015 22:23:36 +0200

Hi,

The minutes of the Yokohama TCPM meeting are available at https://www.ietf.org/proceedings/94/minutes/minutes-94-tcpm. Many thanks to Christoph and David for compiling them!

If you have corrections to make, please send them to list, or directly to chairs.

- Pasi

---

From: Michael Welzl <[email-masked]>
Date: Wed, 18 Nov 2015 09:48:09 +0100

Hi,

nit: s/what is write/what is right

Else: the transcription of what David Black said to Naeem Khademi on the mic is misleading - it misses key bits that make it seem like a different statement than it was:

The minutes say:
***
David Black: RFC3168 says: don't do anything that breaks the Internet. If there is a ECE, react to it the same way as with packet-loss.
***

... which makes it sound like this would be his advice and he would opposed to experimental alternatives. However, what he really said is (transcribed from Meetecho:
http://recs.conf.meetecho.com/Playout/watch.jsp?recording=IETF94_TCPM&chapter=chapter_1   at approx. 0:31):

***
As one of the authors of RFC 3168: I agree that encouraging Experimental for congestion control is a really good idea.
3168 was written for the broad internet, hence contains some very strict language that basically said don't do anything that would break things. We had people react to congestion if you CE-mark as if you're dropping a packet, we said: the only thing we know for certain is safe right now - this was a long time ago - was: react to it as you would react to a packet drop. I'm not opposed to interesting innovative things being done under the guise of experimentation, I wanna provide some history for why 3168 says what it does.
***

The last sentence matters - it's really quite a different thing.

Cheers,
Michael

> On 16 Nov 2015, at 21:23, Pasi Sarolahti <[email-masked]> wrote:
> 
> Hi,
> 
> _______________________________________________
> tcpm mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tcpm

---

From: Pasi Sarolahti <[email-masked]>
Date: Thu, 26 Nov 2015 21:27:53 +0200

Hi Michael,

Thanks for clarification. I will correct this part in the minutes, along with the nit and couple of other updates, and will upload a new version soon.

- Pasi