Subject: Asking for TCP/IP Spoofing Papers, References, etc

From: "fauzan-." <[email-masked]>
Date: Wed, 20 Jun 2001 13:07:20 +0700

Hi Everyone,

I'm Fauzan. I'm looking for references, papers, etc about
TCP/IP Spoofing to improve TCP performance over Satellite
links. Can anybody tell me where can I find it? Specially
papers or references about the techniques? Thanks. 

Regards,
-Fauzan-

---

From: Srinivas Bongoni <[email-masked]>
Date: Wed, 20 Jun 2001 09:37:26 -0700

Hi Fauzan,

I am also involved in the work related to TCP performance over satellite. May be, we can be of mutual help. Well about the information you are asking for, please look at the information below. The NS2 network simulator is a good tool to perform various test simulations. May be spend some time at the website: http://www.isi.edu/nsnam/ns/

there isn't yet a list of satellite-related research on:

http://www.isi.edu/nsnam/ns/ns-research.html

here's a list I know of to date/token bibliography of satellite

networking simulation work resulting from the ns satellite extensions.

(The satellite extensions were first included in ns 2.1b6a; use of the

satellite plot scripts at

http://www.ee.surrey.ac.uk/Personal/L.Wood/ns/sat-plot-scripts/ is

indicated with a [*]).

The ns satellite extensions are outlined in:

Tom Henderson and Randy Katz, "Network Simulation for LEO Satellite

Networks," 18th AIAA International Communications Satellite Systems

Conference (ICSSC), Oakland, CA, April 10-14, 2000. [*]

(and described in a chapter of the ns documentation which you

must have noticed) and were used to investigate geographic routing in:

Tom Henderson and Randy Katz, "On Distributed, Geographic-Based

Packet Routing for LEO Satellite Networks," Proceedings of IEEE

Globecom 2000, San Francisco, CA, Nov. 2000.

http://www.cs.berkeley.edu/~tomh/publications.html

This is presented in more detail in chapter 6 of:

Tom Henderson, "Networking over Next-Generation Satellite Systems",

PhD thesis, Dept of Electrical Engineering and Computer Science,

University of California at Berkeley, Fall 1999. [*]

http://www.cs.berkeley.edu/~tomh/thesis/

Some examination of TCP goodput across LEO satellite meshes was

carried out in:

Lloyd Wood, George Pavlou and Barry Evans, "Effects on TCP of routing

strategies in satellite constellations", Special issue on

Satellite-Based Internet Technology and Services, IEEE Communications

Magazine, vol. 39, no. 3, pp. 172-181, March 2001. [*]

(DV routing across a static mesh was used for the multipath 

comparison) and handover discrimination in the presence of diversity

was explored in:

Lloyd Wood, George Pavlou and Barry Evans, "Managing diversity with

handover to provide classes of service in satellite constellation

networks", in the proceedings of the AIAA International Communication

Satellite Systems Conference (ICSSC '01), vol. 3, session 35, no. 194,

Toulouse, France, 17-20 April 2001. [*]

http://www.ee.surrey.ac.uk/Personal/L.Wood/publications/

Those are written up in more detail in:

Lloyd Wood, "Internetworking with satellite constellations", PhD

thesis, Centre for Communication Systems Research, University of

Surrey, February 2001. [*]

http://www.ee.surrey.ac.uk/Personal/L.Wood/publications/PhD-thesis/

There's also:

Merkourios Karaliopoulos, Rahim Tafazolli and Barry Evans, "TCP

Performance on Split Connection GEO Satellite Links", in the 

proceedings of the 19th AIAA International Communications Satellite

Systems Conference (ICSSC '01), Toulouse, France, 17-20 April 2001.[*]

where TCP splitting and terrestrial links were implemented with the ns

satellite extensions (no personal webpage). That builds on work

described in:

Merkourios Karaliopoulos, Rahim Tafazolli and Barry Evans, 

Enhancing TCP's performance over GEO satellite links with split-

connections and link level retransmissions, London Communications

Symposium, London, UK, 14-15 September 2000.

http://www.ee.ucl.ac.uk/lcs/papers2000/content.html

which uses ns and snoop, but not the satellite extensions.

Please let me know if you  need any further information.

Best regards,

Srinivas

<bold><bigger>Srinivas G. Bongoni

</bigger></bold>System Level Design Group			PH: +1-650-584-5692

Synopsys Inc.					FX: +1-650-584-5055

700 E Middlefield Rd., # D2337W		Email:<<mailto:[email-masked]>

Mountain View, CA 94043-4033		URL:http://www.synopsys.com

<italic>

.....

Truth, purity, and unselfishness-wherever these are present, there is no
power below or above the sun to crush the possessor thereof. Equipped
with these, one individual is able to face the whole universe in
opposition.

</italic>

Swami Vivekananda

.....

---

From: Srinivas Bongoni <[email-masked]>
Date: Wed, 20 Jun 2001 09:37:26 -0700

Hi Fauzan,

indicated with a [*]).

carried out in:

was explored in:

There's also:

described in:

Best regards,

Srinivas

<italic>

.....

</italic>

Swami Vivekananda

.....

---

From: Lloyd Wood <[email-masked]>
Date: Wed, 20 Jun 2001 19:04:13 +0100 (BST)

On Wed, 20 Jun 2001, Srinivas Bongoni wrote some original text:

> I am also involved in the work related to TCP performance over
> satellite. May be, we can be of mutual help. Well about the
> information you are asking for, please look at the information
> below. The NS2 network simulator is a good tool to perform various
> test simulations. May be spend some time at the website:
> http://www.isi.edu/nsnam/ns/

> networking simulation work resulting from the ns satellite extensions.
[long, painstakingly assembled list of information snipped]

The latter 'I' in question being me. 

http://www.isi.edu/nsnam/archive/ns-users/webarch/current/msg02604.html
is the original. 

Providing an attribution or credit is considered a minimal
courtesy, and is de rigeur for academic work.

> Please let me know if you  need any further information.

and you'll - what? Ask ns-users for it, and forward any answers you
get under your own name?

L.

<[email-masked]>PGP<http://www.ee.surrey.ac.uk/Personal/L.Wood/>

> Truth, purity, and unselfishness-wherever these are present, there
> is no power below or above the sun to crush the possessor thereof.
> Equipped with these, one individual is able to face the whole
> universe in opposition.
> 
> Swami Vivekananda

This is my truth. Tell me yours. -- Manic Street Preachers

---

From: Srinivas Bongoni <[email-masked]>
Date: Wed, 20 Jun 2001 11:42:00 -0700

My deepest apologies to you (Lloyd Wood). I realized it is a big mistake, not to give credits to some original work. Believe me Sir, it is because of lack of awareness. I vow that never in my life, I would do such a thing. Please forgive for this act. 

Srinivas

><<[email-masked]>PGP<<http://www.ee.surrey.ac.uk/Personal/L.Wood/>

<italic>

.....

</italic>

Swami Vivekananda

.....

---

From: Srinivas Bongoni <[email-masked]>
Date: Wed, 20 Jun 2001 11:42:00 -0700

Srinivas

<italic>

.....

</italic>

Swami Vivekananda

.....