Subject: RE: Satellites running IP

From: [email-masked]
Date: Tue, 18 Jun 2002 13:29:33 -0700

Adrian, 
Excuse me for jumping in on this but I want to mention that Honeywell, as
well as others, are beginning to connect aircraft to ground networks using
geosynchronous satellites and TCP.  For example, we are using INMARSAT
Swift64 (64Kbps) circuit connections for this purpose right now.  We require
than airborne laptops be able to use their normal stacks though so for now
are using gateways to handle TCP issues.  The potential market is far
greater than space based hosts.  
Regards,
Brian Smith
Honeywell

> -----Original Message-----
> From:	Adrian J. Hooke [SMTP:[email-masked]]
> Sent:	Tuesday, June 18, 2002 10:05 AM
> To:	Daniel Shell
> Cc:	[email-masked]
> Subject:	Re: Satellites running IP
> 
> At 08:25 AM 6/18/2002 -0400, Daniel Shell wrote:
> >Is SCPS an IETF RFC on a standards track yet?
> 
> Dan:
> 
> Could you perhaps ask your question a bit more precisely? Which of the
> four 
> SCPS protocols would you suggest should be launched on an IETF standards
> track?
> 
> If you are talking about the SCPS flavor of TCP (TCP Tranquility), in what
> 
> context do you ask the question? TCP running between two ground end
> systems 
> over a satellite link, or TCP running from a ground end system to an end 
> system onboard a satellite?
> 
> If the latter, what would be the benefit to you of IETF standardization of
> 
> TCP Tranquility? If it was on a standards track, would CISCO Systems Gobal
> 
> [sic] Defense and Space Group then be interested in investing corporate 
> funds to build a bunch of COTS products to support space missions?
> 
> Best regards
> 
> Adrian J. Hooke
> Manager, DOD-NASA Space Communications Protocol Standards (SCPS) Project
> NASA Jet Propulsion Laboratory,
> Interplanetary Network Directorate
> M/S 303-400, 4800 Oak Grove Drive
> Pasadena, California 91109-8099, USA
> +1.818.354.3063 OFFICE
> +1.818.653.9553 MOBILE
> +1 818.354.6290 FAX
> http://www.scps.org

---

From: "Adrian J. Hooke" <[email-masked]>
Date: Tue, 18 Jun 2002 15:40:32 -0700

At 01:29 PM 6/18/2002 -0700, [email-masked] wrote:
>For example, we are using INMARSAT
>are using gateways to handle TCP issues.

Brian:

Yes, we're aware of these neat aircraft applications via our close work 
with Larry Freudinger at NASA Dryden Flight Research Center, and in 
particular with the use of intermediate PEP gateways. The question is 
whether (in order to use the gateway capabilities) you feel that their 
various internal flavors of TCP need to be put on an *IETF* standards 
track. Dan Shell apparently feels that they do; what about you? TCP 
Tranquility is a full International Standard within the space community; do 
you feel in any way inhibited from experimenting with its use?

Adrian Hooke

---

From: [email-masked]
Date: Wed, 19 Jun 2002 09:14:16 -0700

Adrian,
The niche for these gateways is so small that I don't see a driving need for
a standard.  However, better yet would be if there was a way for all common
stacks (read Windows, etc.) to "detect" a long latency link and tune
themselves appropriately, so gateways were not required.  Again, there
probably won't be enough of a user base to warrant this.
Regards,
Brian

> Sent:	Tuesday, June 18, 2002 3:41 PM
> To:	[email-masked]
> Cc:	[email-masked]; [email-masked]
> Subject:	RE: Satellites running IP
>

---

From: William Ivancic <[email-masked]>
Date: Wed, 19 Jun 2002 13:29:00 -0400

At 09:14 AM 6/19/02 -0700, [email-masked] wrote:
>themselves appropriately, so gateways were not required.

There is lots of research being done in this area, but nothing is yet 
proven and tested in the sufficiently open networks to then take these to 
standards.  Most are still very much research.  I expect this will come in 
the future - maybe 3 to 5 years.  However, it is not here today.

Will